Jump to content
Froxlor Forum
  • 0

Nginx PHP Download ...


maffi

Question

Hallo,

 

bis gestern lief mein NGIX System mit Froxlor perfekt. Habe gestern Froxlor geupdated und nun hab ich das Problem das jedes mal wenn ich eine PHP Datei ?ffne (z.B. nen Forum bzw. dort die index.php) das jedes mal der Browser praktisch die PHP Datei downloaden m?chte.

 

Ich habe schon alles m?gliche durchgeguckt, aber die Logdateien sagen nicht wirklich viel.

 

Fehlermeldung: Sie m?chten folgende Datei herunterladen: Vom Typ: application/octet-stream

oder wenn man gezielt die index.php datei eingibt kommt nur Sie m?chten folgende Datei herunterladen: index.php vom Typ PHP-Datei

 

Habt ihr ne Idee woran das liegen k?nnte? Also vor dem Update funktionierte definitiv noch alles einwandfrei.

 

Hier meine NGIX Config:

 

user www-data;
worker_processes  4;

pid /var/run/nginx.pid;

events {
   worker_connections  1024;
}

http {
   include       /etc/nginx/mime.types;
   default_type  application/octet-stream;

   access_log  /var/log/nginx/access.log;
   access_log  off;
   client_max_body_size 20M;
   sendfile        on;
   tcp_nodelay     on;

   keepalive_timeout  10;

   gzip  on;
   include /etc/nginx/conf.d/*.conf;
   include /etc/nginx/sites-enabled/*;

proxy_connect_timeout 180;
proxy_send_timeout 180;
proxy_read_timeout 180;

}

 

Mit freundlichen Gr??en

maffi

Link to post
Share on other sites

13 answers to this question

Recommended Posts

Nun hat es auch meinen zweiten NGIX Server erwischt. ... :S Ist leider genau das gleiche, nach dem Update m?chte er nur noch die PHP-Dateien mit Sourcecode downloaden. So wie es aussieht funktioniert das Froxlor-Interface selber ohne Probleme, es spinnt praktisch nur bei den Kunden ...

 

# 22_froxlor_normal_vhost_meine.net.conf
# Created 24.11.2011 15:55
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server {
       listen meineip:80;
       server_name    meine.net www.meine.net meine.net *.meine.net;
       access_log    /var/customers/logs/k50-access.log combined;
       error_log    /var/customers/logs/k50-error.log error;
       root     /var/customers/webs/k50/;
       location / {
               index    index.php index.html index.htm;
               try_files $uri $uri/ @rewrites;
       }

       location @rewrites {
rewrite ^ /index.php last;
}

       location ~ \.php$ {
               fastcgi_index index.php;
       }
}

Link to post
Share on other sites

M?chte echt nicht nerven aber ist wirklich dringend. Ich wei? einfach nicht was ich noch tun soll :( Es liegt definitiv an Froxlor, da diese Problem erst nach dem Update auftreten.

 

Ich wei? echt nicht mehr weiter :(

 

hier noch ein paar Configs, vllt. bringt euch das was:

 

/etc/nginx/sites-enabled/10_froxlor_ipandport_meineip.80.conf

# 10_froxlor_ipandport_meineip.80.conf

# Created 24.11.2011 18:15

# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

 

server {

listen meineip:80 default;

# Froxlor default vhost

server_name s12.meinebestimmedomain.com;

access_log /var/log/nginx/access.log;

root /var/www/froxlor/;

location / {

index index.php index.html index.htm;

}

location ~ \.php$ {

fastcgi_index index.php;

include /etc/nginx/fastcgi_params;

fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

fastcgi_pass 127.0.0.1:8888;

}

}

 

/etc/init.d/php-fcgi

#!/bin/bash

BIND=127.0.0.1:8888

USER=www-data

PHP_FCGI_CHILDREN=15

PHP_FCGI_MAX_REQUESTS=1000

 

PHP_CGI=/usr/bin/php-cgi

PHP_CGI_NAME=`basename $PHP_CGI`

PHP_CGI_ARGS="- USER=$USER PATH=/usr/bin PHP_FCGI_CHILDREN=$PHP_FCGI_CHILDREN PHP_FCGI_MAX_REQUESTS=$PHP_FCGI_MAX_REQUES$

RETVAL=0

 

start() {

echo -n "Starting PHP FastCGI: "

start-stop-daemon --quiet --start --background --chuid "$USER" --exec /usr/bin/env -- $PHP_CGI_ARGS

RETVAL=$?

echo "$PHP_CGI_NAME."

}

stop() {

echo -n "Stopping PHP FastCGI: "

killall -q -w -u $USER $PHP_CGI

RETVAL=$?

echo "$PHP_CGI_NAME."

}

 

case "$1" in

start)

start

;;

stop)

stop

;;

restart)

stop

start

;;

*)

echo "Usage: php-fastcgi {start|stop|restart}"

exit 1

;;

esac

exit $RETVAL

Link to post
Share on other sites

M?chte echt nicht nerven aber ist wirklich dringend. Ich wei? einfach nicht was ich noch tun soll :( Es liegt definitiv an Froxlor, da diese Problem erst nach dem Update auftreten.

 

Ich wei? echt nicht mehr weiter :(

 

hier noch ein paar Configs, vllt. bringt euch das was:

 

/etc/nginx/sites-enabled/10_froxlor_ipandport_meineip.80.conf

 

 

/etc/init.d/php-fcgi

Wenn das Problem dringend ist Versuche auch mal nach Hilfe im Chat zu fragen, das geht oftmals schneller als ?ber das Forum.

Hab dir gerade auch mal im Announcement Forum geschrieben, vllt. hilft dir das weiter.

 

Was mir an deinen Configs auff?llt ist das bei der Froxlor Domain das hier drin steht:

include /etc/nginx/fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_pass 127.0.0.1:8888;

 

Aber nicht bei der anderen Config, liegt es evtl. daran? Sorry hab absolut keine Ahnung ?ber nginx :( aber vllt hilft es ja :).

Link to post
Share on other sites

Wenn das Problem dringend ist Versuche auch mal nach Hilfe im Chat zu fragen, das geht oftmals schneller als ?ber das Forum.

Hab dir gerade auch mal im Announcement Forum geschrieben, vllt. hilft dir das weiter.

 

Was mir an deinen Configs auff?llt ist das bei der Froxlor Domain das hier drin steht:

include /etc/nginx/fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_pass 127.0.0.1:8888;

 

Aber nicht bei der anderen Config, liegt es evtl. daran? Sorry hab absolut keine Ahnung ?ber nginx :( aber vllt hilft es ja :).

 

K?nnte es nicht beschw?ren aber ich meine das kommt dort nicht rein :S .. Da mein Englisch nicht so dolle ist hier nochmal ;)

 

Habe nur Froxlor geupdatet, f?r nginx gab es kein Update. Ich wei? auch nicht was ich noch tun oder ?berpr?fen soll :S bin echt verzweifelt :S

 

Wo fidne ich denn den Chat?

Link to post
Share on other sites

Hast recht gehabt. Froxlor hat beim erstellen der Configs f?r die Domains nen Fehler gemacht.

 

Normalerweise sollte es so aussehen:

 

location ~ \.php$ {
               fastcgi_index index.php;
               include /etc/nginx/fastcgi_params;
               fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
               fastcgi_pass 127.0.0.1:8888;
       }

 

Froxlor erstellt seit dem Update die Configs aber so:

 

location ~ \.php$ {
               fastcgi_index index.php;
       }

 

Fehlt also was .. ;)

 

sollte schnellstm?glich gefixt werden ;)

 

Achja bein Nginx (nginx/0.6.32 - Debian Lenny) funktioniert try_files nicht. Try_files funktioniert nur wenn man ?ber die Backports Nginx (nginx/0.7.67) installiert!

Link to post
Share on other sites

Der Release f?r den Release Candidate von 0.9.26 wurde um eine Woche auf den 19.12.2011 verschoben, da wir einige, f?r .26 geplante aber noch ungel?ste Tickets unbedingt mit in den Release mit einbauen wollten und daher eine Woche Puffer frei gestellt haben.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...