Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
StefanKittel

webalizer kb in und out leer oder Monsterzahlen

Question

Hallo,

auf meinem System zeigt webalizer f?r kb in und out entweder Null oder Monsterzahlen an.

 

Debian Squeeze 64Bit, Apache2 mit FCGI.

 

Genauer gesagt ?berall 0.

Nnur bei "Top 30 of 782 Total Sites" und "Top 10 of 782 Total Sites By kB F" sind Monsterzahlen wie z.B.

31571804879974698722765122281615037979164400207766427399363685792795186611915098817084607975641279295853062310846358352558559473140584117639844151788390284525568

31066656001895111934460983574496315325231123488473194413205674303552917135538364709010488195561005710502218348539235096532413375911337114721765271286686943281152

126287219519898428670933680181621507963032580720243466465035131786752611282809569216916321608810806820002533607483566723037380712547888048318729730646591143936

 

Im Forum hatte ich gelesen, dass die Nuller erst mit Froxlor 1.0 mit Leben gef?llt werden sollen.

 

Wie kann ich diese Felder ausblenden und wie bekomme ich die Monsterzahlen weg?

 

Danke

 

Stefan

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

Hallo,

 

leider ist da nichts bei.

Es funktioniert ja auch alles.

 

Nur Null-Zahlen h?tte ich gerne weg, aber sehr unfreundliche sehen diese Monsterzahlen aus.

 

http://imageshack.us/photo/my-images/225/31700311.png

http://imageshack.us/photo/my-images/443/64010591.png

http://imageshack.us/photo/my-images/854/53327818.png

 

Stefan

Share this post


Link to post
Share on other sites

Also ich selber benutze AWstats. Bei mir liegen die Statistiken f?r jede Domain in der customers/logs Ebene.

 

Hast du die webalizer.conf schon mal genauer angeschaut? -> /etc/webalizer/webalizer.conf

 

Standardm?ssig wird die Apache Log ausgelesen.

W?sste also nicht warum die ohne weiteres verkehrt ausgelesen werden sollte.

H?chstens versteckter Traffic - also fehlgeschlagende Downloads oder so.

 

Wegen den Nullwerten schau mal in der .conf ob auch alles gez?hlt wird was gez?hlt werden soll.

Manchmal ist da doch eine # ?bersehen worden ;)

 

Wenn es wirklich an der .conf lag, kannst ja die Werte Nullen

Share this post


Link to post
Share on other sites

Hallo,

an dieser Habe ich nichts ver?ndert.

 

Hier die Eintr?ge die nicht auskommentiert sind.

 

Es tritt bei allen Servern auf.

 

Jemand eine Idee?

 

LogFile /var/log/apache/access.log.1
OutputDir /var/www/webalizer
ReportTitle Usage statistics for
HostName server06.domain.de
PageType	htm*
PageType	cgi
PageType	php3
PageType	php
HideURL		*.gif
HideURL		*.GIF
HideURL		*.jpg
HideURL		*.JPG
HideURL		*.png
HideURL		*.PNG
HideURL		*.ra
IgnoreSite	localhost
IgnoreReferrer	localhost
SearchEngine	ganz viele Eintr?ge

Share this post


Link to post
Share on other sites

Nu hab ich mal selber gegoogelt und ups gesagt.

Siehe dir mal folgenden Link zu Debian selbst an.

 

Bugreport

 

Etwas tiefer auch wegen deiner Monsterzahlen.

 

Hallo,

 

prima, das probier ich mal aus.

Ich habe eben mal ein debian mit froxlor neu aufgesetzt und es tritt auf. Scheint also ein Haus-Bug von Debian, Froxlor oder Webalizer zu sein.

Ich berichte Morgen mal.

 

Stefan

Share this post


Link to post
Share on other sites

Moin,

 

es ist jetzt anders.

 

Die Tages und Stundenstatistik enthalten nun die Datenmenge.

http://imageshack.us/photo/my-images/33/54041267.png

 

Bei den Top Seiten ist die Datenmenge nun immer fest "126287219519898428670933680181621507963032580720243466465035131786752611282809569216916321608810806820002533607483566723037380712547888048318729730646591143936" und danach steht immer "inf%".

http://imageshack.us/photo/my-images/573/45409970.png

 

Diese ist der Auszug aus der apache2.conf

#LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
#LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\" %I %O" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

 

Irgendwas habe ich doch ?bersehen, aber was?

Bitte schau da doch nochmal drauf.

 

Danke

 

Stefan

Share this post


Link to post
Share on other sites

In der 1ten Reihe Logformat war davon eigentlich keine Rede.

Nur von der zweiten Reihe.

 

Schau mal hier ...

mod_logio

Hast du mod_logio installiert und eingebunden ? (a2enmod mod_logio)

Schaust einfach mal unter /etc/apache2/mods_enabled nach.

 

Danach schaust du dir nochmal den ersten Link an.

Da steht noch etwas mit customlog ...

Share this post


Link to post
Share on other sites





×
×
  • Create New...