Jump to content
Froxlor Forum
  • 0

Debian Squeeze FCGI



Hi there,


First of all I'd like to thank all the developers for such a great job. I used to run syscp and I'm moving to froxlor now.


So far I managed to install froxlor on a new debian squeeze distribution. I also managed to create user accounts so that they can login in using ssh. Cool!


Now I wanted to run FCGI. I've been following the tutorial at:




I decided to use the "default suexec binary".

So far so good. The strange thing is that the last apache restart does not want to really start.


This is my error message:


Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration


However I made sure that I run "apt-get install libapache2-mod-fcgid" and also "a2enmod fcgid". And there are no errors in "/var/log/apache2/access.log"


I followed all steps one by one as stated in the tutorial. The only step that I'm not sure is the following one:


I cite:

"Do this by activating the option Include PHP via mod_fcgid/suexec in the control panel options."


Where is this option available? I could not find it. The only thing I activated in the Froxlor interface wat to "Enable FGCI". That's all.


I have no idea what to do now.


Many thanks in advance!



Thanks again

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Sorry to insist but this I'm completely lost.


If you want to setup FCGI you are directed to the mentioned tutorial Server->Settings->Overview->FCGI -> "This needs a special webserver configuration for Apache, see FCGI - handbook".

Then you go to the tutorial and it asks for some options that do not exist in Froxlor menus.


If you follow the tutorial step-by-step there are some parts that cannot be done and ends up breaking apache...


I'm afraid I don't know how to proceed. Should I use ubuntu instead? Could anyone help? I'd really appreciate it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...