Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
StefanKittel

[solved] Problem mit mcrypt mit phpmyadmin und FCGI

Question

Hallo,

 

ich habe gerade einen neuen Server installiert und sto?e bei phpmyadmin auf folgenden Fehler.

"Die Erweiterung mcrypt fehlt. Bitte die PHP Konfiguration ?berpr?fen."

 

Debian Squeeze 64Bit, Apache2, FCGI.

Alles andere geht und mcrypt ist auch installiert und wird als modul angezeigt.

 

php -i | grep mcrypt
/etc/php5/cli/conf.d/mcrypt.ini,
Registered Stream Filters => zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, mcrypt.*, mdecrypt.*
PHP Warning:  Unknown: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in Unknown on line 0
mcrypt
mcrypt support => enabled
mcrypt_filter support => enabled
mcrypt.algorithms_dir => no value => no value
mcrypt.modes_dir => no value => no value

 

Hat da bitte mal Jemand den richtigen Tipp f?r mich?

 

Danke

 

Stefan

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

Hi,

 

ist die mcrypt - extension auch in der cgi - variante von PHP geladen? Du hast ja die CLI gepr?ft. Zudem: Hast du nach der Installation von mcrypt den Webserver (und damit PHP) neugestartet?

 

So long,

Florian

Share this post


Link to post
Share on other sites

Moin

 

ist die mcrypt - extension auch in der cgi - variante von PHP geladen?

Wie pr?fe ich das?

 

Hast du nach der Installation von mcrypt den Webserver (und damit PHP) neugestartet?

sowohl apache2 als auch den ganzen Server.

 

Stefan

Share this post


Link to post
Share on other sites

hatte ich auch, habe dann atp-get install php5-mcrypt ausgef?hrt und den indianer neu geladen.

os ist bei mir debian squeeze

 

Hallo,

das hat nicht funktioniert, aber ich habs mal deinstalliert und dann neu installieren wollen.

Dabei kommt dies:

 

The following packages have unmet dependencies:

php5-mcrypt : Depends: php5-common (= 5.3.3-7+squeeze3) but 5.3.6-6~dotdeb.1 is to be installed

 

Installiert hatte ich es urspr?nglich nach dieser Anleitung http://wiki.froxlor.org/contrib/fcgid-handbook mit

apt-get install php5-cgi

 

Bins nochmal durchgegangen, geht aber immer noch nicht.

 

Zus?tzlich bekomme ich als email nun

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mcrypt.so' - /usr/lib/php5/20090626/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0

 

Hat da Jemand eine Idee zu?

 

Danke

 

Stefan

Share this post


Link to post
Share on other sites





×
×
  • Create New...