Jump to content
Froxlor Forum
  • 0

mailman Installation krieg ich nicht hin


feiaweng

Question

Hallo,

 

ich versuche mailman zum Laufen zu kriegen. Habe ein Debian Lenny 64 bit System.

Mit apt-get install mailman hab ich das Paket installiert, Version 2.1.11-11+lenny2.

Allerdings ist da ein vhost-config mit dabei, und das Problem f?ngt an.

Die mitgelieferte Apache-config sieht so aus:

# Sample configuration for Debian mailman with Apache

# We can find mailman here:
ScriptAlias /cgi-bin/mailman/ /usr/lib/cgi-bin/mailman/
# And the public archives:
Alias /pipermail/ /var/lib/mailman/archives/public/
# Logos:
Alias /images/mailman/ /usr/share/images/mailman/

# Use this if you don't want the "cgi-bin" component in your URL:
# In case you want to access mailman through a shorter URL you should enable
# this:
#ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
# In this case you need to set the DEFAULT_URL_PATTERN in
# /etc/mailman/mm_cfg.py to http://%s/mailman/ for the cookie
# authentication code to work.  Note that you need to change the base
# URL for all the already-created lists as well.

<Directory /usr/lib/cgi-bin/mailman/>
   AllowOverride None
   Options -Indexes ExecCGI -MultiViews +SymLinksIfOwnerMatch +FollowSymLinks
   AddHandler cgi-script .cgi .pl
   Order allow,deny
   Allow from all
</Directory>
<Directory /var/lib/mailman/archives/public/>
   Options Indexes FollowSymlinks
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>
<Directory /usr/share/images/mailman/>
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

 

Ich habe in Froxlor keine Option gefunden, dass ?ber die Oberfl?che einzutragen.

Lege ich einen vhost au?erhalb von Froxlor an, motzt Suexec dass Username usw. nicht stimmt.

Habt ihr eine Idee wie ich mailman zum Laufen kriege?

 

Danke schon mal f?r die Hilfe.

 

Gruss feiaweng

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Hi,

 

Hab mittlerweile was gefunden, unter den Domaineinsteungen. Hab jetzt die Einstellungen unter "eigene vhost Einstellungen" eingetragen. Ich kann auch ein perlskript im Orcner /cgi-bin/mailman ausf?hren. Wenn ich aber /cgi-bin/mailman/admin aufrufe im Browser, bietet er mir das file zum Download an. I

Suexec log steht, dad die uid/gid nicht passt. Also da wei? ich momentan Au h nicht weiter. Ich vermute das ganze hat was mit Suexec zu tun.

Link to comment
Share on other sites

So, ich bin einen Schritt weiter.

Ich habe eine Apache-config angelegt, nicht ?ber Froxlor. Darin wird auch kein Suexec ben?tigt.

Und ich sehe schon mal die mailman Oberfl?che.

An xocii:

In den Errorlogs stand, bzw. im suexec.log::

[2011-07-11 10:44:22]: target uid/gid (10006/10006) mismatch with directory (10006/10006) or program (33/33)

das hei?t, dass suexec den User ralf erwartet, mailman aber als mailman gestartet ist.

 

Eine andere Option w?re gewesen, ich lege eine neue Domain an, sodass in der Apache-config als Suexec-User www-data:www-data drinsteht, dann lie?e sich maiman auch ?berreden zu arbeiten.

DA es den User www-data aber schon gibt, (Apache) w?re das Plan C gewesen.

Aber so funktioniert es ganz gut.

Die Installation l?uft, und der Thread kann geschlossen werden.

Danke euch.

Link to comment
Share on other sites

So, ich bin einen Schritt weiter.

Ich habe eine Apache-config angelegt, nicht ?ber Froxlor. Darin wird auch kein Suexec ben?tigt.

Und ich sehe schon mal die mailman Oberfl?che.

An xocii:

In den Errorlogs stand, bzw. im suexec.log::

[2011-07-11 10:44:22]: target uid/gid (10006/10006) mismatch with directory (10006/10006) or program (33/33)

das hei?t, dass suexec den User ralf erwartet, mailman aber als mailman gestartet ist.

 

Eine andere Option w?re gewesen, ich lege eine neue Domain an, sodass in der Apache-config als Suexec-User www-data:www-data drinsteht, dann lie?e sich maiman auch ?berreden zu arbeiten.

DA es den User www-data aber schon gibt, (Apache) w?re das Plan C gewesen.

Aber so funktioniert es ganz gut.

Die Installation l?uft, und der Thread kann geschlossen werden.

Danke euch.

 

Sorry, ich dachte jetzt ich habe es, ist aber doch nicht so.

Wenn ich eine Apache-Konfiguration ausserhalb von froxlor erstelle, dass auf einen anderen nicht-froxlor-konfigurierten Host zeigt, dann klappt das.

Dummerweise ist es dann so:

Mailman-GUI http://domain2.de, die Listen werden aber auf domain1.de angelegt, der Mailhost ist ein anderer.

Nun wollte ich die Konfiguration so hinkriegen, dass ich mailman als mailman.domain1.de zum Laufen kriege.

Nun habe ich mailman compiliert mit --with-cgi-gid=suexec-user-von-domain1.

Nun habe ich das Problem, dass die Scripte zum Download angeboten werden, aber nicht ausgef?hrt wird.

F?hre ich ein perl-Script aus, was Hallo Welt produziert, sehe ich im suexec.log folgendes:

directory is writable by others: (/var/www/webs/kunde/domain1.de/mailing/mailman/cgi-bin)

Es ist aber nicht writable by others:

drwxrwsr-x 2 root list 4.0K 2011-07-13 14:41 cgi-bin

IN cgi-bin:

-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 admin
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 admindb
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 confirm
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 create
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 edithtml
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 listinfo
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 options
-rwxr-xr-x  1 root list  326 2011-07-13 14:41 perl.pl
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 private
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 rmlist
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 roster
-rwxr-xr-x  1 root list  23K 2011-07-13 14:10 subscrib

Hat jemand eine Idee, wie ich mailman zum Laufen kriege?

 

Danke und Gruss

feiaweng

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...