Jump to content
Froxlor Forum

Tealk

Members
  • Content Count

    177
  • Joined

  • Last visited

Posts posted by Tealk

  1. also dieses

    sh: 1: nscd: not found
    sh: 1: nscd: not found

    kommt aber immer noch wenn der cron ausgeführt wird. Aber nscd braucht man doch gar net wenn man libnss-extrausers nutzt oder?

     

    7 minutes ago, irisdina said:

    nur viele CMS Systeme (wenn man sowas benutzen will), haben noch viele probleme damit.

    ja gut das ist mir schon aufgefallen, bei mir läuft fast alles auf php7.4 ganz ganz selten das was auf php8 läuft

  2. Hi,

     

    ich weiß nicht warum aber ich laufe jetzt schon mehrmals in den selben Fehler. Ich habe Nginx mit php-fpm installiert; auch Froxlor lies sich problemlos installieren, dann habe ich die Einstellungen vorgenommen und die Konfiguration durch gemacht, sobald aber der Cronjob läuft erstellt er mir eine nginx config die keinen Pfad zum fpm hat:

    # 10_froxlor_ipandport_202.61.246.121.80.conf
    # Created 01.03.2021 23:36
    # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
    
    server { 
    	listen    202.61.246.121:80 default_server;
    	# Froxlor default vhost
    	server_name    DOMAIN;
    	access_log     /var/log/nginx/access.log combined;
    	root     /var/www/;
    	index    index.php index.html index.htm;
    
    	location / {
    	}
    	location ~ \.php {
    		fastcgi_split_path_info ^(.+?\.php)(/.*)$;
    		include /etc/nginx/fastcgi_params;
    		fastcgi_param SCRIPT_FILENAME $request_filename;
    		fastcgi_param PATH_INFO $fastcgi_path_info;
    		try_files $fastcgi_script_name =404;
    		fastcgi_pass 127.0.0.1:8888;
    		fastcgi_index index.php;
    	}
    }
    

    Und ich komm einfach nicht drauf warum das passiert

     

    ich bekomm auch komischerweise folgenden output:

    php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug
    [information] TasksCron: Searching for tasks to do
    [information] Task4 started - Rebuilding froxlor_bind.conf
    [information] Cleaning dns zone files from /etc/bind/domains/
    [information] No domains found for nameserver-config, skipping...
    [information] nginx::createIpPort: creating ip/port settings for  202.61.246.121:80
    [information] nginx::writeConfigs: rebuilding /etc/nginx/sites-enabled/
    [information] Froxlor\Cron\Http\NginxFcgi::reload: fpm config directory "/etc/php/8.0/fpm/pool.d/" is empty. Creating dummy.
    [information] Froxlor\Cron\Http\NginxFcgi::reload: running service php8.0-fpm restart
    [information] Froxlor\Cron\Http\NginxFcgi::reload: fpm config directory "/etc/php/7.4/fpm/pool.d/" is empty. Creating dummy.
    [information] Froxlor\Cron\Http\NginxFcgi::reload: running service php7.4-fpm restart
    [information] Froxlor\Cron\Http\NginxFcgi::reload: reloading Froxlor\Cron\Http\NginxFcgi
    sh: 1: nscd: not found
    sh: 1: nscd: not found
    [notice] Checking system's last guid

     

  3. Also ich hab aus spaß mal die installation angeworfen, bevor ich den install des "froxlor" Paketes angestoßen habe, habe ich

    • nginx
    • php7.4
    • php8.0
    • mariadb-server & client

    installiert.

    Folgendes führt er dann noch aus

    The following additional packages will be installed:
      bind9 bind9utils courier-authlib default-mysql-client default-mysql-server dns-root-data dovecot-core dovecot-imapd dovecot-mysql dovecot-pop3d expect
      libcourier-unicode4 libexttextcat-2.0-0 libexttextcat-data libhiredis0.14 libicu63 liblua5.3-0 libpq5 libsasl2-modules-sql libstemmer0d libtcl8.6 maildrop
      php php8.0 postfix postfix-mysql proftpd-basic proftpd-doc proftpd-mod-mysql python3-ply ssl-cert tcl-expect tcl8.6 webalizer
    Suggested packages:
      bind9-doc dnsutils resolvconf ufw dovecot-gssapi dovecot-ldap dovecot-lmtpd dovecot-lucene dovecot-managesieved dovecot-pgsql dovecot-sieve dovecot-solr
      dovecot-sqlite dovecot-submissiond ntp tk8.6 procmail postfix-pgsql postfix-ldap postfix-pcre postfix-lmdb postfix-sqlite postfix-cdb mail-reader
      postfix-doc openbsd-inetd | inet-superserver proftpd-mod-ldap proftpd-mod-odbc proftpd-mod-pgsql proftpd-mod-sqlite proftpd-mod-geoip proftpd-mod-snmp
      python-ply-doc openssl-blacklist tcl-tclreadline
    The following NEW packages will be installed:
      bind9 bind9utils courier-authlib default-mysql-client default-mysql-server dns-root-data dovecot-core dovecot-imapd dovecot-mysql dovecot-pop3d expect
      froxlor libcourier-unicode4 libexttextcat-2.0-0 libexttextcat-data libhiredis0.14 libicu63 liblua5.3-0 libpq5 libsasl2-modules-sql libstemmer0d libtcl8.6
      maildrop php php8.0 postfix postfix-mysql proftpd-basic proftpd-doc proftpd-mod-mysql python3-ply ssl-cert tcl-expect tcl8.6 webalizer

    sieht für mich soweit korrekt aus.

    Interessant find ich das der "default-mysql-client" nicht schon bei der MariaDB installation dabei ist.

  4. Hi,

    ich komm einfach nicht dahinter wo der Fehler liegt. Angefangen hat alles das ein Zertifikat abgelaufen war, da habe ich es manuell erneuern wollen, seit dem bekomme ich folgenden Fehler:

    nginx: [emerg] bind() to 5.9.187.34:443 failed (98: Address already in use)

    Leider finde ich nicht warum die Adresse schon belegt sein sollte, die letze Änderung die es an dem Server gab war das Froxlor update.

    ein netstat bringt kein Ergebnis:

    root@web:~# netstat -tulpn | grep :443
    root@web:~# 

    Ich hab auch schon alle vHosts rausgeworfen außer 10_froxlor_ipandport_5.9.187.34.80 und 10_froxlor_ipandport_5.9.187.34.443; ohne Besserung.

    Sobald ich aber die 10_froxlor_ipandport_5.9.187.34.443 entferne startet nginx

     

    //Edit

    irgendwie hat sich in die nginx.conf ein "include /etc/nginx/modules-enabled/*;" eingeschlichen.

    Dort gab es eine "60-jitsi-meet.conf" in der ein server Block enthalten ist...

  5. Hallo,

    gibt es eine möglichkeit für eine Domain folgendes einzutregen?

    upstream zammad-railsserver {
        server 127.0.0.1:3000;
    }
    
    upstream zammad-websocket {
        server 127.0.0.1:6042;
    }

    Das Problem dabei ist ja das es außerhalb des server tags stehen muss, leider fällt mir jetzt nicht ein wie ich das mit Froxlor handhaben könnte. Da ich sonst auch alles über Froxlor einstelle wäre das natürlich wunderbar wenn ich jetzt nicht einen zweiten Weg anfangen müsste.

    Vor allem da sich Froxlor ja auch um die SSL Zertifikate kümmert.

  6. Hi,

    mir ist gestern als ich eine neue Domain angelegt habe aufgefallen das der Cron immer wieder los läuft, wenn ich diesen als debug anstoße bekomme ich für jede Domain folgende Meldung:

    [information] Updating certificate for anzah.co
    [information] Adding SAN entry: anzah.co
    [information] Adding SAN entry: www.anzah.co
    [Tue 24 Mar 2020 05:52:01 AM CET] Lets find script dir.
    [Tue 24 Mar 2020 05:52:01 AM CET] _SCRIPT_='/root/.acme.sh/acme.sh'
    [Tue 24 Mar 2020 05:52:01 AM CET] _script='/root/.acme.sh/acme.sh'
    [Tue 24 Mar 2020 05:52:01 AM CET] _script_home='/root/.acme.sh'
    [Tue 24 Mar 2020 05:52:01 AM CET] Using default home:/root/.acme.sh
    [Tue 24 Mar 2020 05:52:01 AM CET] Using config home:/root/.acme.sh
    [Tue 24 Mar 2020 05:52:01 AM CET] Using server: https://acme-v02.api.letsencrypt.org/directory
    [Tue 24 Mar 2020 05:52:01 AM CET] Running cmd: renew
    [Tue 24 Mar 2020 05:52:01 AM CET] Using config home:/root/.acme.sh
    [Tue 24 Mar 2020 05:52:01 AM CET] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
    [Tue 24 Mar 2020 05:52:01 AM CET] DOMAIN_PATH='/root/.acme.sh/anzah.co'
    [debug] https://github.com/acmesh-official/acme.sh
    v2.8.6
    [Tue 24 Mar 2020 05:52:01 AM CET] The domain 'anzah.co' seems to have a ECC cert already, please add '--ecc' parameter if you want to use that cert.
    [Tue 24 Mar 2020 05:52:01 AM CET] Renew: 'anzah.co'
    [Tue 24 Mar 2020 05:52:01 AM CET] 'anzah.co' is not a issued domain, skip.
    [information] Updated Let's Encrypt certificate for anzah.co

    Einstellung:

    image.thumb.png.1c8ce8106cdf23e1df456ba2334fd328.png

    Kann es sein das das den loop verursacht?

×
×
  • Create New...