Jump to content
Froxlor Forum

Pro-Webs

Members
  • Content Count

    19
  • Joined

  • Last visited

Everything posted by Pro-Webs

  1. Pro-Webs

    FTP Pfade

    Ich versuche gerade einen FTP User anzulegen der in dem Home Ordner der Domain auf /VERZEICHNIS zu greifen kann ... leider ist das Pfad feld bei mir ein Dropdown wo nur "/" ausgewählt werden kann ... es sind natürlich Verzeichnise im Ordner vorhanden ich will aber nur das der User dieses spezielle Verzeichnis hat keine anderen ...
  2. Unser Problem war auch dabei, dass die Blöcke in für uns falscher Reihenfolge zusammengefasst wurden. Du meinst den Include bei vHost Eintrag im Froxlor oder wo setzt du diesen an?
  3. Hallo, ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten. Das ist jedoch relativ problematisch. Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain: location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /sho
  4. Hallo, ich versuche gerade den Upload auf 300 MB zustellen, leider bricht dieser aber weiterhin bei 100 MB ab. In PHP ist alles soweit korrekt, aber NGINX will nicht so recht. Ich habe bei der Domain in Froxlor bei vHost Einstellungen folgendes versucht: location / { client_max_body_size 300M; } Meine Log sagt leider aber: 2019/11/21 19:07:47 [error] 26369#26369: *3365 client intended to send too large body: 227169307 bytes, client: 2.201.238.226, server: xxx.de, request: "POST /typo3/index.php?ajaxID=%2Fajax%2Ffile%2Fprocess&ajaxToken=4ed2561cc4b8d0b6a31e708e
  5. Okay i deactivated it an set this code in vHost conf. if ($scheme = http) { return 301 https://www.$server_name$request_uri; } if ($host !~ ^www\.) { rewrite ^ https://www.$host$request_uri permanent; } Thanks
  6. Is it possible to prevent that i got now two 301 redirects on http://digitale-fotografien.com
  7. The alias was already set to www. so that's not the solution. http to https is working even when i doit via vhost config
  8. Nope. The http to https redirect works with the configuration above. I need also a solution to redirect to www from non-www including https. Look this site: https://www.digitale-fotografien.com/ You will be redirectet ever to https. But if you write https://digitale-fotografien.com/ You will be not redirectet to www.
  9. I'm using a nginx server, so .htaccess solutions won't work for me. I want that all requests will be rewrite to https://.www , i have only the vHosts in froxlor to use for it. http://domain.de -> https://www.domain.de http://www.domain.de -> https://www.domain.de https://domain.de -> https://www.domain.de www.domain.de -> https://www.domain.de
  10. Ich habe auf meinem Servre Nginx laufen, daher schon helfen mir .htaccess Lösungen leider nicht. Ich möchte, dass alle Aufrufe auf https://www.domain.de geleitet werden. Singemäß natürlich auch für die Unterseiten. Aktuell funktioniert bei mir nur die weiterheitung auf https mit folgender Konfiguration: location @php { fastcgi_pass unix:/run/php/php7.0-fpm.sock; } if ($scheme = http) { return 301 https://www.$server_name$request_uri; } location ~* \.(jpg|jpeg|png|gif|ico|css|js|svg|mp4|ttf|otf|woff|woff2|eot|swf|pdf)(\?ver=[0-9.]+)?$ { expires 30d; add_header Pragm
  11. Ich habe gerade das gleiche Problem nur ist bei mir die Lösung nicht "localhost". A database error occurred SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost' Gibt es sonst noch Lösungsansätze? Passwort stimmt natürlich und über die Konsole kann ich auf die DB als root damit zugreifen. <?php //automatically generated userdata.inc.php for Froxlor $sql['host']='127.0.0.1'; $sql['user']='froxlor'; $sql['password']='xxxxx1'; $sql['db']='froxlor'; $sql_root[0]['caption']='Default'; $sql_root[0]['host']='localhost'; $sql_root[0]['user']='root'; $sql_roo
  12. Schade ;( Wäre einfach übersichtlicher. Aber gut man kann mit leben. Dank Dir
  13. Gibt es eine Möglichkeit die Konfiguration die ich in Froxlor vHost eingebe so zu vereinfachen, dass ich dort nur eine Verweis ala "LINK ZU CONFIG DATEI" eingebe und in dieser Datei dann alle Änderungen vornehme? Diese sollte dann einfach nur über den LINK in den vHist eingebunden werden ... bei mir arteten die vHost Einstellungen gerade etwas aus, so das es langsam unübersichtlich wird diese in Froxlor direkt vorzunehmen. Danke
  14. Offenbar hatte ich einen völlig falschen Ansatz. Damit geht es nun mit Einschränkung, dass die "woff" immer noch kein expires hat ... woran das liegt ist mir noch unbekannt. location ~* \.(jpg|jpeg|png|gif|ico|css|js|svg|woff|mp4|ttf|otf|woff2|eot|swf|pdf))$ { expires 30d; add_header Pragma public; add_header Cache-Control "public"; } Vielleicht weiß einer woran das liegt mit der Font?
  15. Also ich habs jetzt mit dieser Konfig probiert. Klappt aber leider immer noch nicht # 35_froxlor_normal_vhost_hochzeitsfotografie-pajo.de.conf # Created 10.10.2017 10:25 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:80; server_name hochzeitsfotografie-pajo.de www.hochzeitsfotografie-pajo.de hochzeitsfotografen-pajo.de www.hochzeitsfotografen-pajo.de; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-hochzeitsfotografie-pajo.de-access.log combined; error_log /var/cu
  16. Ein weiteres Problem, welches ich bei der Konfiguration von Nginx mit Froxlor habe wäre: Wie leite ich direkt bei Aufruf der domain bspw. www.hochzeitsfotografie-pajo.de auf https um? Soweit ich es ergoogelt habe müsste ich weitere "server" blöcke einbauen, dass geht über die vHost Einstellungen in Froxlor jedoch nicht. Eine Verschachtelung ist ebenfalls nicht möglich. Was wäre hier also der richtige Ansatz? Das gefundene Snippet wäre wie folgt: server { listen 80; listen [::]:80; server_name www.example.com; return 301 https://$server_name$request
  17. Nein, dass wusste ich nicht. Fand die Syntax aber schon verdächtig. Hatte das so nur eben auch gegoogelt. Wie würde es denn dann korrekt aussehen bzw. wo in Froxlor müsste ich dies dann einfügen, damit es wie gewünscht funktioniert? Danke im Voraus
  18. Danke für die schnelle Antwort Du meinst also so: user www-data; worker_processes auto; pid /run/nginx.pid; include /etc/nginx/modules-enabled/*.conf; events { worker_connections 768; # multi_accept on; } http { ## # Basic Settings ## sendfile on; tcp_nopush on; tcp_nodelay on; keepalive_timeout 65; types_hash_max_size 2048; # server_tokens off; # server_names_hash_bucket_size 64; # server_name_in_redirect off; include /etc/nginx/mime.types; default_type application/octet-stream; ## # SSL Settings ##
  19. Ich habe Froxlor mit Ngnix laufen und wollte gerne die Expires Headers wie folgt setzen: # Expires map map $sent_http_content_type $expires { default off; text/html epoch; text/css max; application/javascript max; ~image/ max; } Soweit ich das jedoch sehe gibt es dabei kein "default" sondern von Froxlor generierte Dateien je Domain. Diese möchte ich natürlich nicht manuell ändern, da diese Froxlor jedes mal überschreiben dürfte, wenn ich dort eine Änderung vornehme. Insofern ist
×
×
  • Create New...