Jump to content
Froxlor Forum

hoschi

Members
  • Posts

    12
  • Joined

  • Last visited

Everything posted by hoschi

  1. Die aktuelle release ist ladbar, aber indexing scheint abgeschaltet zu sein. https://froxlor.de/download.php -> Release-Archiv ist damit platt.
  2. HM, in der Praxis ist das doch gegen die Wand gefahren, die Methode kann ich nicht empfehlen. Bleibt die Frage, wie man eine nicht von Froxlor verwaltet Domain zu acme.sh dazupackt? Einfach per /root/.acme.sh/acme.sh --issue -d domain.tld --webroot /pfad/zum/.wellknown und der cron richtet das dann automatisch?
  3. Ich hab noch gaaanz alte Systeme (+10 Jahre) am Start und wollte nicht auf dovecot umstellen. Falls jemand danach suchen sollte, die "alte" Kombination von Programmen ist weiter nutzbar, wenn angepasst (Debian 9+). Hintergrund: froxlor speichert in seiner DB die Passwörter nach konfiguration als password und password_enc ab, letzteres ist verschlüsselt. Der hash lässt erkennen, womit gearbeitet wurde - ein einfacher String ist ein Uralt-crypt-Passwort, aktuell sollte sowas wie $5$ am Anfang stehen, was auf SHA-256 verweisst. Werden die Klartextpasswörter gelöscht, ist die alte Konfiguration nicht mehr verwendbar. Wäre aber mal sinnvoll, die rauszuwerfen. Folgendes ist anzupassen: /etc/courier/authmysqlrc: MYSQL_USER_TABLE mail_users MYSQL_CRYPT_PWFIELD password_enc #MYSQL_CRYPT_PWFIELD crypt Damit wird courier angewiesen, für pop und imap verschlüsslte PW auszulesen. Die SHA-256 lib ist bei Debian inclusive. crypt fliegt raus. Fertig ist der Mailabruf. Tricky ist die Anpassung von postfix. Die dort benutzte Bibliothek für sasl hat Einschränkungen und ist der letztlich der Grund für Probleme. Lässt sich beheben mit folgender /etc/postfix/sasl/smtpd.conf: pwcheck_method: authdaemond authdaemond_path: /run/courier/authdaemon/socket mech_list: plain login In der Datei stand vorher pwcheck_method: auxprop mit sql plugin drin. Das Problem ist: auxprop kann nur Klartext. Aber dafür erlaubt auxprop die Verwendung von cram-md5 und digest-md5 zum hashen auf Clientseite, früher war daher die mech_list um diese beiden ergänzt. Bedeutet: der Client verbindet sich unverschlüsselt und ohne TLS, aber hasht noch auf dem Clientsystem das Passwort mit md5 und übermittelt dann nur den hash über den unverschlüsselten Kanal. Bei TLS kann man sich das sparen - erst wird der Kanal abgesichert, dann kann das PW unverschlüsselt geschickt werden und wird auf Serverseite gehasht und dann verglichen - das erledigt der authdaemond. auxprop kann das nicht. Die Mechlist wird dem Client übermittelt. Ganz alte Accounts haben evtl. noch Clienthashes und kein SSL eingeschaltet, die müssen dann umstellen auf STARTTLS mit Klartext - gilt aber nur für den Mailversand. Klartext bedeutet wie gesagt nur, das der Thunderbird/Outlook/etc. das Passwort ungehasht schickt, der authdaemond hasht das und vergleicht dann diesen hash mit dem in der froxlor Datenbank - da steht aber nix mehr im Klartext drin. Passwort-Wechsel ist für die User über Roundcube wie gewohnt möglich. In der DB könnt ihr sehen wie der Hash sich ändert.
  4. Ah cool. Damit wär die Frage auch geklärt, wie man die Domains aus dem Ordner rausbekommt: manuell vorher mit dieser Option installieren...falls jemand einen Feature Request draus machen will.
  5. Öhm, der Pfad stimmt ja. acme.sh ist schon in /root/.acme.sh installiert, und liegt auch da. Nur die Domains werden halt in /etc/acme abgeworfen, und nicht auch in dem Ordner.
  6. Ich will froxlor auf einem host einspielen, der bereits acme und eine die Domain sub.domain.tld nutzt. Nun ist acme aber mit ./acme.sh --install --config-home /etc/acme installiert worden, --cert-home ist automatisch gleich --config-home. Das Zertifikat für sub.domain.tld wurde mit --reloadcmd "meinskript" installiert, das alle Dienste neu startet und die Certs mit cat zusammenbastelt für den courier-imap. Certs und die config dafür liegen in /etc/acme. Lief alles lange einwandfrei mit cronjob für acme.sh. sub.domain.tld soll nun ausserhalb von froxlor bleiben (und ist froxlor host) - wenn ich froxlor installiere, wirft das automatisch alle Domains auch nach /etc/acme. Kann man das so lassen oder ist das Verzeichnis /root/.acme.sh/ zwingend nötig, weil hart codiert? Also klappen die renews und die Konfiguration zeigt an die richtige Stelle oder gibt das Ärger? Nicht das ein cronjob dann im falschen Ordner sucht, oder /etc/acme/sub.domain.tld löscht.
  7. I'm testing out Froxlor/Stretch right now, and this procedure worked for me for multiple PHP versions: - add Debian's/Ubuntu's PHP maintainer repository apt-get install apt-transport-https curl https://packages.sury.org/php/apt.gpg | apt-key add - echo 'deb https://packages.sury.org/php/ stretch main' > /etc/apt/sources.list.d/deb.sury.org.list apt-get update apt-get install php5.6-cgi php7.1-cgi You may change the default php with: update-alternatives --config php As i use fcgi+apache 2.4+suexec the rest is easy: remove the immutable from the fcgi-starter you wish to change to a different version, and edit the starter to use a different one: chatt -i /path/to/starter edit the starter and change exec /usr/bin/php-cgi -c /path/to/conf to exec /usr/bin/php-cgi5.6 -c /path/to/conf As Debian delivers 7.0, you should have the choice of 5.6, 7.0 and 7.1 binaries. It would be nice to have this as an option within froxlor, but right now you have to re-edit all non-default files when froxlor rebuilds them. BTW: libnss-mysql works in stretch (source build, maridb dev files required).
×
×
  • Create New...