Jump to content
Froxlor Forum

df8oe

Members
  • Posts

    124
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by df8oe

  1. There is someting going wrong. I do have libnss-extrausers installed and marked as "present" in Froxlor. /etc/nsswitch.conf is modified as mentioned here in the forum. /var/lib/extrausers exists and hs three files with well looking contents (passwd, group, shadow). But nscd throws some messages at start: Mai 02 17:53:21 myserver64 nscd[98342]: 98342 überwache das Verzeichnis »/etc« (2) Mai 02 17:53:21 myserver64 nscd[98342]: 98342 Die inotify-basierte Überwachung für die Datei »/etc/netgroup« deaktiviert: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 »stat« für die Datei »/etc/netgroup« ist fehlgeschlagen; weiterer Versuch folgt später: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 Die inotify-basierte Überwachung für die Datei »/var/db/passwd.db« deaktiviert: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 »stat« für die Datei »/var/db/passwd.db« ist fehlgeschlagen; weiterer Versuch folgt später: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 Die inotify-basierte Überwachung für die Datei »/var/db/group.db« deaktiviert: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 »stat« für die Datei »/var/db/group.db« ist fehlgeschlagen; weiterer Versuch folgt später: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 Die inotify-basierte Überwachung für die Datei »/var/db/services.db« deaktiviert: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 nscd[98342]: 98342 »stat« für die Datei »/var/db/services.db« ist fehlgeschlagen; weiterer Versuch folgt später: Datei oder Verzeichnis nicht gefunden Mai 02 17:53:21 myserver64 systemd[1]: Started Name Service Cache Daemon. Where is the path to /var/lib/extrausers published for usage?
  2. Interesting. Apache logs tell me [Sat May 02 17:21:55.743194 2020] [proxy_fcgi:error] [pid 92157] [client 192.168.0.202:55572] AH01079: failed to make connection to backend: httpd-UDS [Sat May 02 17:23:24.331392 2020] [proxy:error] [pid 92159] (13)Keine Berechtigung: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-anton-hullewulle.de-php-fpm.socket (*) failed But user/group in sites-enabled config of the domain and also in corresponding php-fpm config is identical. I can get php work if I set listen.mode to 666 in php-fpm config...
  3. OK - I see. It is generated by froxlor and froxlor defines and uses the ending. I have to dig deeper why my "hand-defined vhost" works with php and all froxlor vhosts do not.... All sockets are present for froxlor vhosts so it is mainly apache configuration / conflicts with existing base config from Arch (which is quite different from Debian).
  4. That solved it. Now all is set to my private IP and I can step forward.
  5. Here I will post everything that isn't self explaining and possibly is inside Froxlor... First I looked over the apache vhost files and noticed lines following: SetHandler proxy:unix:/var/lib/apache2/fastcgi/hullewulle-php-fpm.socket|fcgi://localhost This does not work in Arch because it must be like this: SetHandler proxy:unix:/var/lib/apache2/fastcgi/hullewulle-php-fpm.sock|fcgi://localhost Is there a settings possibility to change from "socket" to "sock"?
  6. Thanks - that helps it making easier !
  7. I will look at the setting in the database - I think it must reside there?
  8. I am surely not using the latest version because I must merge it to my repo where well-running dkim and spf support is implemented. So I do not pull every time if a new version is released because it will not work out-of-the-box because of missing dkim and spf stuff...
  9. Hi, I am migrating my server from Debian to Arch Linux. Froxlor is running on my Debian system and I want to port it of course, too. But not in a productive environment... So I have the installation running actually within my LAN and it has IP 192.168.x.y Mail with all its components (postfix, dovecot, amavis, spamassassin, dkim and spf) is already working and Froxlor handles it perfectly like on Debian. But for php I want to start a new way: not mod_php but php-fpm (different configurations, different php versions). So I need for testing to set the IP/Port to my local net but Froxlor does not accept this. How can I disable the ip-validation or overwrite existing setting manually?
  10. ? Schönen Abend - bis bald
  11. Völlig korrekt. Amavis oder Opendkim als Alternative, wählbar, sauber eingebunden. So wollte ich das machen. Nur eben mal kurz anfunken dass man eben doch Teile die vorhanden sind recyclen kann
  12. Ich denke nicht dass ich da etwas verwechsle. Die Config-Dateien für den dkim-filter werden in der class.DnsBase.php erzeugt und schwirren verwaist (default) im Ordner /etc/postfix/dkim rum. Die erzeugt Datei dkim-keys.conf diente doch nur zur Verwendung mit dkim-filter. Oder nicht? EDIT: Dass aktuell keine Verwendung für amavis vorgesehen ist - ist klar. Aber warum nicht die (nun sowieso sinnfreie) Datei dkim-keys.conf so umstrukturieren, dass sie das Format einer amavis-conf hat. Man kann sie entweder gleich im richtigen Ordner erzeugen lassen (/etc/amavis/conf.d/) oder vermutlich auch die im dkim-Schlüsselordner erzeugte Datei einfach dorthin symlinken - habe ich noch nicht ausprobiert. Wie gesagt: wird ein paar Tage dauern bis da was nutzbares rauskommt.
  13. Dass man alles was an DKIM Geschichten in Froxlor schon drin ist vergessen kann: kann ich so nicht sagen. Ich brauchte in der /scripts/class.DnsBase.php nur vor Erstellung der Schlüsseldateien eine Zeile einfügen: $dkimkeys = "use strict;\n\n"; Dann folgende Zeile ändern: $dkimkeys .= "*@" . $domain['domain'] . ":" . $domain['domain'] . ":" . $privkey_filename . "\n"; in $dkimkeys .= "dkim_key('".$domain['domain']."','main','".$privkey_filename."');\n"; und nach Abschluss der Schlüsseldatei diese Zeile einfügen: $dkimkeys .= "\n\n## this list was automatically created by Froxlor ##\n1; # ensure a defined return"; ...und schon wurde eine Amavis-konforme Liste erstellt. Kann man sofort so übernehmen. Da ist nicht allzuviel Arbeit nötig. glaube ich.
  14. Mache ich. Deine Arbeit ist echt klasse und ich habe schon ein Konstrukt im Kopf herumschwirren. Gib mir ein paar Tage dann kommen die ersten Ergebnisse.
  15. Ich schau mal ob ich Dir da etwas Arbeit abnehmen kann. Ich werde mir mal das Projekt von GitHub clonen und damit rumexperimentieren. Du hast sicher nichts gegen Pull-Requests?
  16. OK - das bringt Licht ins Dunkel - danke! Da in den Datenbanken von Froxlor ja schon private und öffentliche Schlüssel für jede Domain gepflegt werden hätte ich eine Idee, wie man das mit der Amavis-Technik (die ich übrigens sehr cool finde) vereinbaren könnte... Es werden doch schon per cron-job Dateien für den alten Indianer gepflegt. Im Prinzip bräuchte man diesen Automaten leicht abgewandelt nur für eine Datei /etc/amavis/conf.d/66-froxlor_dkim in der nach jeder Änderung einfach die Schlüsselzuordnungen neu geschrieben werden. Also Einträge genau der Form wie Du sie oben gepostet hast. Ich habe mal eine solche Datei angelegt, Amavis neu gestartet und alles läuft wie vorgesehen. Man könnte als "Goodie" in der Froxlor-Konfig noch auswählbar machen ob man für alle Domains ein gemeinsames Schlüsselpaar oder für jede Domain ein eigenes pflegt und dann wäre die Integration fertig. Kein zusätzliches DKIM-Paket nötig. LG DF8OE
  17. Hallo liebe Community, ich habe einen Server mit 40 Domains, verwaltet mit Froxlor. Ich habe vor DKIM einzuführen. Alle Domains senden über einen gemeinsamen Mailserver / eine gemeinsame Maildomain. Nennen wir den Server mail.abcd.de. Dies ist der Server wie er in den mx-Records und auch als reverse lookup eingetragen ist. So läuft das seit Jahren einwandfrei. Alle 30 Doamins mit ihren geschätzten 120 Mailadressen verwenden diesen Mailserver. SPF ist aktiviert und funktioniert. Ich möchte nun gerne die Mails zusätzlich per DKIM signieren. Dafür habe ich für die Domain abcd.de einen Schlüssel erstellt und den öffentlichen Teil im DNS-Record von abcd.de als txt eingetragen. Ein Versenden mit einer Emailadresse xyz@abcd.de funktioniert auch bereits DKIM-signiert. Wenn ich dieses Feature nun auch für alle anderen erlaubten Domains nutzen möchte: Muss ich dann für jede Domain einen eigenen Schlüssel erzeugen und bei der betreffenden Domain hinterlegen? Das wäre sehr aufwändig... Besser wäre es wenn ich für alle Domains den gleichen Schlüssel verwenden könnte. Und wenn ich den schon bei abcd.de im DNS eingetragen habe: reicht das nicht? Muss ich den bei jeder Domain einzeln eintragen? Wenn es so ist: ok, 10 Minuten c&p und alles geht. Nur: wie sage ich amavis dass es für alle Domains den gleichen Schlüssel nehmen soll? Bislang lehnt amavis kategorisch alles Domains außer abcd.de zum DKIM-signieren ab. Klar könnte ich für alle Domains einen Symlink auf den ersten Schlüssel legen - müsste dann aber auch für jede Domain einen eigenen Eintrag in /etc/amavis/conf.d/20-debian-defaults anlegen und pflegen. Das wäre doch sehr umständlich. Also der "Traumwunsch" wäre es: - einen Schlüssel für die Domain des Mailservers abcd.de - alle anderen Domains, denen erlaubt ist über diesen Server zu senden benutzen den gleichen Schlüssel (s.o.) - ich brauche die Domains nicht alle einzeln aufzuführen in irgendeiner Konfig In den DNS Records jeder Domain habe ich den Mailserver abcd.de ja bereits eingetragen. Geht das so?
  18. Maybe there is an understanding problem how dkim has to work. I will go to "German discussion" because that makes it easier for me
  19. Regarding port: there was a simple typo in postfix/master.cf in section "submission". Corrected now. Additional info after I have cranked up log levels. Now I see these two lines in amavis log which may declare - but I do not understnad: Aug 1 12:31:38 myserver amavis[31973]: (31973-01) dkim: candidate originators: From:<info@ballaballa.com> Aug 1 12:31:38 myserver amavis[31973]: (31973-01) dkim: not signing, empty signing domain, From: <info@ballaballa.com> Test if mail has to be signed is coming via port 10023. No other tests should be done. How can I disable domain based tests? I thought declaring a policy_bank is sufficient...
  20. I am little far now... It seems that the lines submission inet n - n - - smtpd -o cleanup_service_name=cleanup_submission (...snip...) -o content_filter=smtp-amavis:[127.0.0.1]:10023 are not sufficient that postfix transfers outgoing mails via port 10023 to amavis. There is no traffic on this port when I send a mail - but identification for amavis to sign dkim is incoming on port 10023. What can override my setting for postfix?
  21. I want to start dkim signing. I know that is not related to froxlor in secific but it may fail because of froxlor settings for postfix... I have followed instructions I found here: https://kb.kolabenterprise.com/guides/configure-dkim-signing-and-verification-using-amavis There is no error to see in the logs, but messages are not signed. I tried to increase log_level of amavis and I cannot see there is any try to sing messages. Related per package for DKIM is installed and shown up correctly when amavis starts. Any advice is highly welcome... Best regards df8oe
  22. Done. But I have choosen another way: - changing customer ids in froxlors database tables mail_users, mail_virtual, panel_databases and panel_domains - aligning informations in panel customers (number of databases, email, subdomains e.g.) - changing paths (replacing old customer name in paths by new one) - changing names of databases - moving mail folders to new position (no changing of owners and permissions neccessary) - moving webfolders to new position (ownership of files must be aligned to new owner) - aligning static paths in webcontent to new one (one bash line using 'sed') - aligning paths (e.g. for attachments) that are stored in CMS and forums databases of customer That all took 15 minutes. At last I changed one setting in froxlor domain panel so that froxlor initiates cron job - and after cron run everything was transferred to new customer. All pages are working, all old emails are swapped, everything is working as expected. I think it is possible to do all this by php instead of by hand - but I do not know if the function is important. Disclaimer: if you follow this way please make a backup before changing anything. I cannot guarantee if it works under all circumstances - for me it is doing the job.
  23. I have already reverted manually changings in froxlor database. Resources of customer are all set to infintely... I think it will be much easier to delete the domains and subdomains and add them at the right customer later.
  24. I have tried. First I have added new customer: successfully. Then I tried to add a NEW domain. New customer appears in the list of domain holders. Then I went to an existing domain and tried to move it to new customer: New customer does NOT appear in the dropdown list of possible domain holders??!! OK - strange. Very strange. Then I modified froxlor database manually and changed customer id in domain. Now the domains appear in customers froxlor panel - fine. But if I call them in admin frroxlor panel they are still displayed as owned by old customer - strange again. I have not seen where froxlor gets this information - it cannot be out of the panel_domains table. It seems so that the function for transferring domains to another customer are not working as expected...
  25. What about existing subdomains which already exist? Are they moved, too?
×
×
  • Create New...