Jump to content
Froxlor Forum

df8oe

Members
  • Posts

    124
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by df8oe

  1. Bei Arch Linux gibt es keine Ordner oder Dateien die mit"apache*" benannt sind. Die haben alle ein "http*" im Namen - ganz sicher. Es gibt weder einen Unterordner "apache" noch irgendwo Zertifikatsdateien die mit "apache" benannt sind.
  2. Hier die beiden relevanten Zeilen aus der erstellten ssl-Vhost-conf: SSLCertificateFile /etc/ssl/apache/apache.crt SSLCertificateKeyFile /etc/ssl/apache/apache.key Ich habe es vermieden die gesamte conf zu posten da das Unkenntlichmachen der 30 für dieses Problem absolut irrelevanten Stellen sinnlos Arbeit erzeugt. Der Knackpunkt wurde klar beschrieben: Es ist default "SSL aktivieren" ausgewählt. Es gibt kein systemweites oder IP-basiertes Zertifikat. Letsencrypt ist nicht angehakt. Dann erstellt Froxlor einen ssl-Vhost mit den oben aufgeführten Zeilen und startet den Webserver neu. Der Start des Webservers schlägt fehl weil die Zertifikatsdateien (oben aufgeführt) nicht exitieren - ein Zugriff via Web ist ab sofort nicht mehr möglich. Einzige Lösung ist den ssl-Vhost via Konsole zu löschen, dann den Webserver neu zu starten (dann startet er natürlich), dann via Froxlor die betreffende Domain zu bearbeiten und entweder den Haken bei "aktiviere SSL" rauszunehen ODER einen Haken bei "Letsencrypt" zu setzen.
  3. Leider wird der Vhost bei drei unterschiedlichen Server nicht deaktiviert. Es wird ein Vhost angelegt dessen Zertifikat in /etc/ssl/apache/apache.crt / /etc/ssl/apache/apache.key liegen soll. Da liegt aber keines (es gibt noch nicht mal den Ordner /etc/ssl/apache) und das wars dann mit dem Webserver...
  4. Das Neuanlegen einer Domain führt jetzt oft dazu, dass der Webserver nicht mehr startet. Wie kommt das zu Stande? Beim Neuanlegen einer Domain wird, wenn in den Webserver-Grundeinstellungen SSL enabled ist, in der Sektion "Webserver SSL-Einstellungen" bei "Aktiviere Nutzung von SSL:" generell ein Haken gesetzt. Bei "SSL Zertifikat erstellen (Let's Encrypt):" ist dagegen kein Haken gesetzt. Das führt dazu, dass beim nächsten Cron-Lauf die Konfiguration so geschrieben wird, dass von einem lokal vorhandenen Zertifikat ausgegangen wird. Das ist aber nicht vorhanden - und damit startet der Webserver nicht mehr. Dieses Verhalten war nicht immer so - erst seit einiger Zeit laufen mehr und mehr Nutzer in diese "Falle". Wer ein wenig Kenntnisse von der Konsole hat und einen ssh-Zugriff, kann sich leicht selbst helfen. Das hat aber nicht jeder... Lösungsvorschlag: - SSL wird nicht generell aktiviert. Ich glaube das war bis vor ??? auch der Default oder: Wenn SSL aktiviert wurde wird überprüft, ob der Haken bei Letsencrypt auch gesetzt ist ODER ein Zertifikat existiert. Wenn nicht, wird die Aktivierung von SSL nicht ausgeführt und eine Warnung angezeigt LG DF8OE
  5. Nein, funktioniert immer noch nicht. Ich habe vor der Entscheidung ein var_dump($renew_domains) eingefügt und dort wird mir nach wie vor die komplette Liste aller Domains incl. der Keys ausgegeben - auch nach dem Patch. Könnte hier dran liegen: private static function renewDomains($check = false) damit ist $check immer false und das Ergebnis immer so wie vorher - oder nicht?
  6. Das Problem entsteht in /var/www/froxlor/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php und zwar durch diese Zuweisung in Zeile 65: $renew_domains = self::renewDomains(); Da kommt hier true raus und deswegen sollen die Configs neu geschrieben werden. Wenn ich $renew_domains eine Zeile danach auf false setze wird kein false-renew der Config mehr gemacht. EDIT: Da kommt nicht true raus - da werden alle Domains mit letsencrypt als Array zurückgegeben. Und damit ist die nachfolgende Bedingung immer erfüllt - es sei denn, man hat keine Domains mit letsencrypt. Oder sehe ich da was falsch? Eigentlich kann das auf keiner denkbaren Installation laufen wie gedacht...
  7. Einen ssh-Zugang kann ich Dir aus DSGVO-Gründen bei keinem der Server geben. Aber ich kann forschen - auch ohne weitere Tipps. Vielleicht fällt Dir als der "Schöpfer von Froxlor" mit dem entsprechenden Überblick ja mit irgendeinem meiner Hinweise was ein. starte ich /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks aus der Konsole so ist im Admin-Panel immer zu finden, dass keine Cron-Aufgaben anstehen. Warte ich ab bis der Cronjob das tut dann steht nach Lauf des Cronjobs im Admin Panel, dass die Webserverconfig neu geschrieben werden muss. Ich kann das auch beschleunigen, wenn ich /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt auf der Konsole starte. Dann wird sofort im Panel engezeigt, dass die Webserverconfig neu geschrieben werden muss.
  8. Systeme: Arch Linux, Apache, php-fpm, postfix, dovecot, amavisd, proftpt. Nichts Subtropisches. Wenn Du an einem Debugging Interesse haben solltest sag was Du noch für Infos brauchst, was ich machen soll, welche Logs Du brauchst. Es ist definitiv mit der 18 in Ordnung und mit der 19 schreibt er alle 5 Minuten eine neue Webserverconfig. Ich denke, da schlummert ein Bug drin, der vielleicht nicht in jeder Konstellation auftaucht. Oder ich bin der erste dem augefallen ist dass da ein Bug ist. Nach meiner Erfahrung (und ich habe auch schon Erfahrung mit solchen Fehlern in meinen Softwareprojekten!) ist "...dann ist es halt so" keine optimale Lösung. Das kann eine gefährliche Zeitbombe werden bei der es später sehr viel schwieriger ist die Ursache zu finden als sofort...
  9. War auch bislang nicht - bei keinem der beiden Server. Jetzt wird es noch kurioser. Ich habe die Ausgabe im Admin-Panel mal öfter refresht. Da stand beim letzten Mal drin, dass es keine ausstehenden Aufgaben gibt und trotzdem ist der Zeitstempel der sites-enabled Dateien ein eindeutiger Beweis dafür, dass sie exakt zur Cronlaufzeit ausgetauscht wurden. EDIT: Sollte im Admin-Panel unter "Erstellen von Konfigurationsdateien:" der letzte Zeitstempel drin sein dann wird der beim Cron-Lauf nicht erneuert. EDITEDIT: Ob die Webserverkonfiguration neu geschrieben werden muss ist vom Luftdruck in Shanghai abhängig. Mal steht 10 Minuten lang drin, dass keine ausstehenden Cron-Aufgaben anstehen (es werden aber trotzdem alle 5 Minuten die Webserverconfigs neu geschrieben) - mal steht drin dass die Konfiguation neu geschrieben werden muss - es hat aber keiner was im Admin-Panel gemacht. EDITEDITEDIT: Kann ich gefahrlos ein Downgrade auf einem der Server auf die 0.10.18 machen? Ich würde gerne testen ob das was mit dem Update zu tun hat. Ich will aber die Datenbank nicht schrotten.
  10. # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null ...genau um hier zu debuggen warum das an zwei Servern passiert wollte ich ja wissen, was Froxlor da abprüft um zu entscheiden, ob eine neue Config geschrieben werden soll oder nicht. Ich finde es merkwürdig dass das bei zwei völlig unabhängigen Servern jetzt ist. Das war nicht immer so! Die Sache mit den falschen IP-Adressen und den resultierenden Fehlern von letsencrypt hatten nichts mit Froxlor zu tun. Da hat vermutlich der Inhaber des Servers im Admin-Panel etwas gelöscht, was er nicht verstanden hat. Aber der zweite Server ist mein eigener - und da kann nur ich was ändern. Und ich habe nichts geändert. Außer dass ich vor kurzem auf beiden Server ein Froxlor-Update auf die 0.10.19 vorgenommen habe. Übrigens führt der Lauf von php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug dazu dass im Admin-Panel bis zum nächsten Cron-Lauf bei "ausstehende Cron-Aufgaben" genau solange "Zur Zeit gibt es keine ausstehenden Aufgaben für Froxlor" steht, bis der nächste Cron-Lauf stattfindet. Bei dem werden keine neuen Configs erstellt - aber nach dem Lauf ist die Zeitbombe wieder scharf. Nach den Cronlauf steht bei "ausstehende Cron-Aufgaben" jetzt "Neuerstellung der Webserver-Konfiguration" und das erfolgt dann auch endlos.
  11. Danke. Der Tausch der IP-Adressen hat funktioniert. Auf dem Server sind jetzt auch ALLE Zertifikate erneuert worden - erfolgreich. Da waren ja auch nur 15 Domains drauf Jetzt ist auf beiden Servern der gleiche Stand: Alle Zertifikate länger als 1 Monat gültig, aber auf beiden Servern wird nach wie vor alle 5 Minuten die Webserver-Konfigurationsdatei neu erstellt. Daher hier von dem Server, wo alle Zertifikate neu sind die Ausgabe von php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug: (IP-Adressen customer und Domains sind gefaked) [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Checking for LetsEncrypt client upgrades before renewing certificates: [Sa 25. Jul 13:29:53 CEST 2020] Already uptodate! [Sa 25. Jul 13:29:53 CEST 2020] Upgrade success! [Sa 25. Jul 13:29:53 CEST 2020] Installing cron job 7 0 * * * "/root/.acme.sh"/acme.sh --cron --home "/root/.acme.sh" > /dev/null [information] Updated Let's Encrypt certificate for wergaerrgg [information] Updated Let's Encrypt certificate for qerrgadfgvadverq [information] Updated Let's Encrypt certificate for sdfEFf [information] Updated Let's Encrypt certificate for dvfaesfF [information] Updated Let's Encrypt certificate for FfeFEEf [information] Updated Let's Encrypt certificate for EFffeSdfsdf [information] Updated Let's Encrypt certificate for DfFEfeFE [information] Updated Let's Encrypt certificate for ADGADGAERGGA [information] Updated Let's Encrypt certificate for hgsrsbfdb [information] Updated Let's Encrypt certificate for adfgaerrgaergar [information] Updated Let's Encrypt certificate for dfaergvbdafvbdaf [information] Updated Let's Encrypt certificate for egeargga [information] Updated Let's Encrypt certificate for dfvagaegae [information] Updated Let's Encrypt certificate for dffvgaegvaegv [information] Let's Encrypt certificates have been updated [information] apache::createIpPort: creating ip/port settings for 10.0.10.4:80 [debug] 10.0.10.4:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 10.0.10.4:443 [information] apache::createIpPort: creating ip/port settings for 95.202.134.210:80 [debug] 195.202.142.210:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 95.202.134.210:443 [information] apache::createVirtualHosts: creating vhost container for domain 3, customer Psfbgbgfsbsf [information] apache::createVirtualHosts: creating vhost container for domain 32, customer bfgbsfbsfb [information] apache::createVirtualHosts: creating vhost container for domain 12, customer sfgbsfgbsbsfbsf [information] apache::createVirtualHosts: creating vhost container for domain 14, customer Psgbsfbsfbsfb [information] apache::createVirtualHosts: creating vhost container for domain 10, customer Pasfbsfbsfbsf [information] apache::createVirtualHosts: creating vhost container for domain 15, customer erqerfgerqegg [information] apache::createVirtualHosts: creating vhost container for domain 9, customer reqrgqerrgrre [information] apache::createVirtualHosts: creating vhost container for domain 21, customer qerrgqergqerge [information] apache::createVirtualHosts: creating vhost container for domain 7, customer nenenen [information] apache::createVirtualHosts: creating vhost container for domain 33, customer zhwhwhzwz [information] apache::createVirtualHosts: creating vhost container for domain 30, customer qergeqgqrgqqer [information] apache::createVirtualHosts: creating vhost container for domain 25, customer qegqegdfgvag [information] apache::createVirtualHosts: creating vhost container for domain 2, customer dafveqrgqerg [information] apache::createVirtualHosts: creating vhost container for domain 8, customer adffveqrefadfv [information] apache::createVirtualHosts: creating vhost container for domain 17, customer eafgefasdfvadsf [information] apache::writeConfigs: rebuilding /etc/httpd/conf/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/httpd/conf/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/httpd/conf/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: running systemctl restart php-fpm [information] Froxlor\Cron\Http\ApacheFcgi::reload: running systemctl restart php73-fpm [information] Froxlor\Cron\Http\ApacheFcgi::reload: running systemctl restart php72-fpm [information] Froxlor\Cron\Http\ApacheFcgi::reload: fpm config directory "/etc/php71/php-fpm.d/" is empty. Creating dummy. [information] Froxlor\Cron\Http\ApacheFcgi::reload: running systemctl restart php71-fpm [information] Froxlor\Cron\Http\ApacheFcgi::reload: running systemctl restart php70-fpm [information] Froxlor\Cron\Http\ApacheFcgi::reload: fpm config directory "/etc/php56/php-fpm.d/" is empty. Creating dummy. [information] Froxlor\Cron\Http\ApacheFcgi::reload: running systemctl restart php56-fpm [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 11 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 6 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 11 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid Das war um 13:31 Uhr, Um 13:35 wurde dann wieder eine neue Config geschrieben und das geht jetzt endlos weiter so.
  12. Das ist nur ein Platzhalter... Bin noch weiter. Aus Gründen die ich nicht nachvollziehen kann ist bei Froxlor in die IP/Port-Konfiguration die INTERNE IP des Rechners gerutscht. Da stand bislang immer die externe drin - kein Wunder dass das nicht mit den Zertifikaten klappt. Leider kann ich die Adresse nicht ändern - ich soll die "System-IP-Adresse ändern". Nur wo? Muss ich erst eine neue anlegen, dann die System-IP darauf hin ändern und dan kann ich die alte löschen?
  13. Hat sich überschnitten - ich habe jetzt eine greifbare Fehlermeldung auf dem Rechner wo die Ordner in /root/.acme.sh leer sind: [warning] Skipping Let's Encrypt generation for www.hullewulle.at due to no system known IP address via DNS check Allerdings ergibt ein Ping von einem externen Rechner und auch ein ping auf dem Server selbst auf hullewulle.at und www.hullewulle.at die korrekte IP-Adresse - das verstehe ich nicht. Du hast Recht - Hektik ist nicht zielführend. Wobei dummerweise auf dem Rechner auf dem die Ordner leer sind und ich die oben genannte Fehlermeldung bekomme die meisten Zertifikate heute um 13:55 ablaufen 🤐 Und deswegen möchte ich mit diesem Rechner anfangen.
  14. Wo schaut Froxlor nach ob sich was geändert hat? In einer Tabelle? Wenn ja: In welcher Tabelle und wie heißt die Variable in der das gespeichert wird? Oder wird irgendwo eine Datei erzeugt? Wenn ja: Wo, und wie heißt die?
  15. Habe ich auch schon gemacht - keine Änderung. Wie gesagt - das sind ZWEI Probleme: 1) acme kann auf Server 1 mit keiner Domain etwas machen (remove, renew etc.) - es kommt jedesmal "...is not a issued domain, skip". Woher weiß denn acme welche Domains es handlen soll? Kann ich acme sozusagen "from the scratch" starten? Es kann durchaus sein dass auch andere Ordner von acme nicht mehr so sind wie sie sein sollten auf Server 1. 2) es wird alle 5 Minuten die Webserverkonfig neu geschrieben. Ob das auch bei dem Server passieren würde wo Problem 1) da ist wenn das gelöst wurde - kann ich (noch) nicht sagen Zusatzinfo: Rufe ich den Froxlor-Mastercronjob auf Server 2 manuell auf, dann findet zum nächsten 5-minütigen Cron-Lauf KEIN Neuschreiben der Webserverkonfiguration statt - erst zum übernächsten wieder. Dann aber wieder alle 5 Minuten. Es läuft definitiv nur der eine Froxlor-Cronjob - kein zweiter mit force.
  16. acme.sh --remove -d hullewulle.at [Sa 25. Jul 10:04:29 CEST 2020] hullewulle.at is not a issued domain, skip. ...das ist das Resultat auf dem Server wo der Inhalt der Domain-Ordner in /root/.acme.sh/ gelöscht wurde. Wenn ich keine Sicherungen der Apache-Zertifikate erstellt hätte gäbe es jetzt ein größeres Problem acme.sh weigert sich bei leeren Ordnern neue Zertifikate zu holen. Bei dem anderen Server kann ich das erfolgreich machen, alle Zertifikate werden dann neu geholt und auch von Froxlor wieder dem Apachen untergeschoben. Alle Domains laufen wieder mit SSL, was bleibt ist dass alle 5 Minuten die Webserverkonfiguration neu geschrieben wird - nach wie vor.
  17. Hallo in die Runde, ich habe Froxlor 0.10.19 auf zwei Servern am Laufen. Bei beiden wird seit einiger Zeit - ich kann leider nicht genau sagen seit wann - alle 5 Minuten die Webserverkonfiguration neu geschrieben. Bei einem ist zusätzlich durch eigenen Fehler der Inhalt aller Domain-Ordner in /root/.acme.sh/name-der-domain/ gelöscht worden. Bei diesem Server erhalte ich bei einem force debug die folgende Ausgabe: [error] Could not find file 'hullewulle.at.cer' in '/root/.acme.sh/hullewulle.at/' [error] Could not find file 'ca.cer' in '/root/.acme.sh/hullewulle.at/' [error] Could not find file 'fullchain.cer' in '/root/.acme.sh/hullewulle.at/' [error] Could not find file 'hullewulle.at.csr' in '/root/.acme.sh/hullewulle.at/' [error] Could not get Let's Encrypt certificate for hullewulle.at: ...und das für alle Domains. Wie kann ich acme.sh dazu bringen, dass es einfach für alle Domains neue Zertifikate abholt? Damit sollte dann doch wieder alles im grünen Bereich sein - oder nicht? Ich habe es schon mit acme.sh -f -r -d hullewulle.at versucht, aber das ergibt nur ein [Sa 25. Jul 09:55:46 CEST 2020] Renew: 'hullewulle.at' [Sa 25. Jul 09:55:46 CEST 2020] 'hullewulle.at' is not a issued domain, skip. Damit dürfte aber das Problem dass alle 5 Minuten die Webserverkonfiguration neu geschrieben wird nicht gelöst sein. Ein force debug bringt bei diesem zweiten Server keine Auffälligkeit. Wo kann ich nachschauen was den Neubau der Webserverkonfiguration triggert?
  18. Hi to all, I do have a complete ready & running dkim / spf integration in Froxlor at my github: https://github.com/df8oe/Froxlor It is working now over 6 months and is doing a great job. But I do not have the time to finish it. There is missing the part how you have to configure opendkim or amavisd (I by myself prefer amavisd). Of course I can provide information what must be changed but I do not have the time to implement these instructions to Froxlor. That's a pity: it is working on 5 servers and all my friends need to get "my version" after a Froxlor update because everything vanishes of course... Is there anyone who can contribute on implementing the "configuration part"?
  19. Usage of /tmp was "grown" - but not mandatory. /var/customers/tmp is working out of the box. I will test the next weeks and if nothing else pops up migration is complete. Thank you for your support - excellent!
  20. I have got one leaving issue which I am unable to solve by myself. I think it is not related to Froxlor but to a configuration problem... Temporary directory /tmp/username does not work. I see "unable to locate session file" e.g. in logs. Folder was not created - so I created it giving it correct permissions and ownership. Does not work either. Path is included in openbasedir line of froxlor generated php-fpm conf for the domain. If I remove username in the config file at all places so that only /tmp is used it works (after restarting fpm process). But I cannot use folder within /tmp. What can be the problem? It looks like everything else related to Froxlor works under Arch as stable as under Debian. I can confirm that my implementation of DKIM works perfectly, too. The only part that must be paid attention: NEVER direct copy configuration files for Debian or any other distribution! See which changes are related to Froxlor and modify these specific lines in Arch manually. I have done that with every cofiguration file except one (nsswitch.conf) and Murphy pushes me into problems immediately
  21. Solved! The configuration was not correct. I took now the original nsswitch.conf which was shipped with Arch and added just "extrausers" at the end of the lines passwd, shadow and group. That fixed all. No error messages at start, php is running well. Thanks for pointing me to nsswitch.conf.
  22. I have nsswitch.conf adjusted as following: # Make sure that `passwd`, `group` and `shadow` have extrausers in their lines # You should place extrausers at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files
×
×
  • Create New...