Jump to content
Froxlor Forum

Max Amigo

Members
  • Posts

    38
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by Max Amigo

  1. 1 minute ago, d00p said:

    Can you open your-silly-somain-123.com:443 from the error message in your browser without errors?

    I don't know much about SSL stuff but everything was working perfectly. At first I had DNS set to my server, and I used Let's Encrypt on my domain - everything was fine.

    Then I switched to cloudflare for security issues, so nobody cad DDOS me. Again - everything seemed to be cool until I realised that after switching to cloudflare WP-Cron stoped to work.

    I believe it is because it is kind of WEB Cron?

    Here is more about it: https://www.journeybytes.com/wordpress-cron-error-503-by-cloudflare/

    ---

    Another option it manually call cron.php script from system cron.

    Trying to understand what is better for me.

     

  2. Hi guys!

    I have Froxlor server with Apache, Let's Encrypt and  PHP-FPM. I have a single WordPress site installed. My website is behind cloudflare.  I have a problem with WP-Cron service on Wordpress.

    In the error log I see:

    There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:
    
    stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages: error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert
    handshake failure stream_socket_client(): Failed to enable crypto stream_socket_client(): unable to connect to 
    ssl://your-silly-somain-123.com:443 (Unknown error)

     I could not find easily anything related to this issue in the google, so I am searching... I only saw something about Apache misconfiguration.

     

    Any ideas are welcome!

  3. So, subject says everything. I think it is permissions under which PHP script is running (editor1). Somehow it has not enough right?

    root@host1 /var/customers/webs/editor1 # ls -Al
    total 44
    drwxr-xr-x  2 editor1 editor1 4096 Oct 14 16:15 mydomain-1.com
    drwxr-xr-x  2 editor1 editor1 4096 Oct 14 16:15 mydomain-2.com
    drwxr-xr-x  2 editor1 editor1 4096 Oct 14 16:15 mydomain-3.com
    -rw-r--r--  1 editor1 editor1 6422 Aug 20 09:49 index.html
    
    root@host1 /var/customers/webs/editor1 # cd ./mydomain-1.com
    root@host1 /var/customers/webs/editor1/mydomain-1.com # ls -Al
    total 232
    -rw-r--r--  1 www-data www-data   665 Oct  8 17:08 .htaccess
    -rw-r--r--  1 www-data www-data 10918 Oct  8 17:08 index.html.bak
    -rw-r--r--  1 www-data www-data   405 Oct  8 17:08 index.php
    -rw-r--r--  1 www-data www-data 19915 Oct  8 17:08 license.txt
    -rw-r--r--  1 www-data www-data  7346 Oct  8 17:08 readme.html
    -rw-r--r--  1 www-data www-data  7165 Oct  8 17:08 wp-activate.php
    drwxr-xr-x  9 www-data www-data  4096 Oct  8 17:08 wp-admin
    -rw-r--r--  1 www-data www-data   351 Oct  8 17:08 wp-blog-header.php
    -rw-r--r--  1 www-data www-data  2328 Oct  8 17:08 wp-comments-post.php
    -rw-r--r--  1 www-data www-data  3004 Oct  8 17:08 wp-config-sample.php
    -rw-r--r--  1 www-data www-data  3207 Oct  8 17:08 wp-config.php
    drwxr-xr-x 10 www-data www-data  4096 Oct 14 10:01 wp-content
    -rw-r--r--  1 www-data www-data  3939 Oct  8 17:08 wp-cron.php
    drwxr-xr-x 25 www-data www-data 12288 Oct  8 17:08 wp-includes
    -rw-r--r--  1 www-data www-data  2496 Oct  8 17:08 wp-links-opml.php
    -rw-r--r--  1 www-data www-data  3900 Oct  8 17:08 wp-load.php
    -rw-r--r--  1 www-data www-data 45463 Oct  8 17:08 wp-login.php
    -rw-r--r--  1 www-data www-data  8509 Oct  8 17:08 wp-mail.php
    -rw-r--r--  1 www-data www-data 22297 Oct  8 17:08 wp-settings.php
    -rw-r--r--  1 www-data www-data 31693 Oct  8 17:08 wp-signup.php
    -rw-r--r--  1 www-data www-data  4747 Oct  8 17:08 wp-trackback.php
    -rw-r--r--  1 www-data www-data  3236 Oct  8 17:08 xmlrpc.php

    Any ideas how to host WordPress a better way? Or how to fix it?

  4. PHP-FPM is ok now:

    # service php7.4-fpm status
    ● php7.4-fpm.service - The PHP 7.4 FastCGI Process Manager
         Loaded: loaded (/lib/systemd/system/php7.4-fpm.service; enabled; vendor preset: enabled)
         Active: active (running) since Thu 2021-10-14 19:50:01 CEST; 1min 7s ago
           Docs: man:php-fpm7.4(8)
        Process: 221505 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install /run/php/php-fpm.sock /etc/php/7.4/fpm/pool.d/www.conf 74 (code=exited, status=0/SUCCESS)
       Main PID: 221485 (php-fpm7.4)
         Status: "Processes active: 0, idle: 16, Requests: 0, slow: 0, Traffic: 0req/sec"
          Tasks: 17 (limit: 76846)
         Memory: 20.2M
         CGroup: /system.slice/php7.4-fpm.service
                 ├─221485 php-fpm: master process (/etc/php/7.4/fpm/php-fpm.conf)
                 ├─221489 php-fpm: pool mydomain12345.com
                 ├─221490 php-fpm: pool mydomain12345.com

     

    But in server admin I still see:

    Server API: Apache 2.0 Handler

    Any ideas why?

  5. @d00p I just revalidated libnss-extrausers setup.

    Everything is done according to the instruction from froxlor. The only thing is /etc/nsswitch.conf file:

    # Make sure that `passwd`, `group` and `shadow` have extrausers in their lines
    # You should place extrausers at the end, so that it is queried after the other mechanisams
    #
    passwd:         files systemd compat extrausers
    group:          files systemd compat extrausers
    shadow:         files compat extrausers
    gshadow:        files
    
    hosts:       files dns
    networks:    files dns
    
    protocols:   db files
    services:    db files
    ethers:      db files
    rpc:         db files
    
    netmasks:    files
    netgroup:    files
    bootparams:  files
    
    automount:   files
    aliases:     files

    Is it correct file?

     

    Also files in /var/lib/extrausers all have root as owner and they are empty.

    root@host1 /var/lib/extrausers # ls -Al
    total 0
    -rw-r--r-- 1 root root 0 Oct 14 17:34 group
    -rw-r--r-- 1 root root 0 Oct 14 17:34 passwd
    -rw-r--r-- 1 root root 0 Oct 14 17:34 shadow
    root@host1 /var/lib/extrausers # cat group
    root@host1 /var/lib/extrausers # cat passwd
    root@host1 /var/lib/extrausers # cat shadow
    root@host1 /var/lib/extrausers #

     

    Any idea?

  6. I was carefully following the instructions but...

    Somehow I came to this:

    # php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
    sh: 1: /etc/init.d/bind9: not found
    [error] Error while running `/etc/init.d/bind9 reload`: exit code (127) - please check your system logs
    Job for php7.4-fpm.service failed because the control process exited with error code.
    See "systemctl status php7.4-fpm.service" and "journalctl -xe" for details.
    sh: 1: nscd: not found
    sh: 1: nscd: not found

    Note: bind9 and nscd are missing because I do not use them. I didn't configure it at all. It is not related to PHP FPM.

    Then:

    # service php7.4-fpm status
    ● php7.4-fpm.service - The PHP 7.4 FastCGI Process Manager
         Loaded: loaded (/lib/systemd/system/php7.4-fpm.service; enabled; vendor preset: enabled)
         Active: failed (Result: exit-code) since Thu 2021-10-14 17:46:13 CEST; 9min ago
           Docs: man:php-fpm7.4(8)
        Process: 214347 ExecStart=/usr/sbin/php-fpm7.4 --nodaemonize --fpm-config /etc/php/7.4/fpm/php-fpm.conf (code=exited, status=78)
        Process: 214355 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/7.4/fpm/pool.d/www.conf 74 (code=exited, status=0/SUCCESS)
       Main PID: 214347 (code=exited, status=78)
    
    Oct 14 17:46:13 host1 systemd[1]: Starting The PHP 7.4 FastCGI Process Manager...
    Oct 14 17:46:13 host1 php-fpm7.4[214347]: [14-Oct-2021 17:46:13] ERROR: [pool mydomain123.com] cannot get uid for user 'editor1'
    Oct 14 17:46:13 host1 php-fpm7.4[214347]: [14-Oct-2021 17:46:13] ERROR: FPM initialization failed
    Oct 14 17:46:13 host1 systemd[1]: php7.4-fpm.service: Main process exited, code=exited, status=78/CONFIG
    Oct 14 17:46:13 host1 systemd[1]: php7.4-fpm.service: Failed with result 'exit-code'.
    Oct 14 17:46:13 host1 systemd[1]: Failed to start The PHP 7.4 FastCGI Process Manager.

     

    In configs that Froxlor gave me I saw nothing about mysql. Maybe I missed something, but I think that PHP-FPM is missing link MySQL:

    Oct 14 17:46:13 host1 php-fpm7.4[214347]: [14-Oct-2021 17:46:13] ERROR: [pool mydomain123.com] cannot get uid for user 'editor1'
    Oct 14 17:46:13 host1 php-fpm7.4[214347]: [14-Oct-2021 17:46:13] ERROR: FPM initialization failed

     

    --------------------------------

     

    I can try to edit /etc/php/7.4/fpm/pool.d/mysomain123.com.conf

    and change this section:

    user = editor1
    group = editor1

    But it is hacking over froxlor. I believe I mixed something up...

    Any ideas?

     

  7. Hi guys,

    I have basic installation of froxlor with Apache2 and php on Ubuntu 20.04 as is.

    # php --version
    PHP 7.4.3 (cli) (built: Aug 13 2021 05:39:12) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
        with Zend OPcache v7.4.3, Copyright (c), by Zend Technologies

    I want to reconfigure it to Apache2 wit php-fpm for better performance.

    I came across this doc: https://github.com/Froxlor/Froxlor/wiki/apache2-with-php-fpm it is 5 yers old.

    I just wanted to know what is a best practice procedure for my task?

    What is a best way to approach it?

    Thank you in advance for your time.

    p.s.: I was thinking about switching to ngnix, but I think it is way too complicated. Or not?

  8. 6 minutes ago, d00p said:

    Can you explain???

    No reasonable explanation! No logic!

    Just want to extra protect my precious froxlor installation! :-) Didn't see such great software for a long while!!!

     

    6 minutes ago, d00p said:

    Yes, go to admin -> templates

    Thank you Sir! It is even better than I could expect!!!!

×
×
  • Create New...