Jump to content
Froxlor Forum

Typ01

Members
  • Posts

    36
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by Typ01

  1. vor 5 Stunden schrieb d00p:

    Na offenbar verwaltest du die DNS Einträge ja dort in irgendeinem Webinterface, oder woher kommt das bild? Wieso solltest du also auf dem Server selbst einen Nameserver betreiben? Das brauchen tatsächlich nur die allerwenigsten, und dafür sollte man wirklich wissen was man tut und das man das wirklich braucht. Ich verstehe auch nicht was das jetzt wieder mit der Mailconfig zu tun hat, das wird doch alles von Froxlor vorgegeben. Einfach nur Copy und Paste...funktioniert 1-A.

    In welcher Datei?

    also braucht weder dovecot noch sonst ein dienst in froxlor den NS ?

    was ich jetzt dazu gelesen habe könnte ich die NS als Slave konfigurieren, ist das aber nicht nötig, nehm ich die haken für eigenen NS bei den installierten domains raus und bin die Fehlermeldungen los.

    > "In welcher Datei?"
    in allen Config dateien in die das Kennwort für SQL im Klartext eingetragen wurde..   diese Sicherheitslücke wurde also nach wie vor nicht abgestellt :..  siehe Meldung der ct darüber.
     

  2. Zitat
    •  
    vor 2 Stunden schrieb Typ01:

    1. Froxlor legt die Verzeichnisse für die Mailboxen nicht an.

    Das macht auch nicht froxlor, das macht dovecot sobald die erste mail an die mailbox ankommt...

    vor 2 Stunden schrieb Typ01:

    dovecot[870]: auth-worker(8769): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES)

    Dann prüfe bitte die dovecot-sql config ob username und passwort auch wirklich korrekt sind

    vor 2 Stunden schrieb Typ01:

    Da aber in einer Anleitung hier im Forum steht, dass  das unix_socket-Plugin zu deaktivieren sei, steht für mich die Frage ob dass einer der Gründe ist.

    Nein, denn wie du siehst steht da das der Zugang für den user 'froxlor' fehlschlägt, nicht für 'root'. Dennoch ist diese Anpassung notwendig, da sonst froxlor via webinterface nicht als root auf die Datenbank darf, was nötig ist für das Erstellen von Datenbanken.

    vor 2 Stunden schrieb Typ01:

    Der Knackpunkt ist ich habe das jetzt mehr als einmal deaktiviert und komme danach nicht mehr ind froxlor und kann es auch nicht wieder aktivieren..

    Hö? Warum solltest du nicht mehr auf Froxlor kommen?

    jetzt hat es funktioniert mit der Deaktivierung des Plugins, muss also was anderes der Grund gewesen sein.

    Mir fehlt die Routine, das letze Mal hatte ich es vor vier Jahren eingerichtet noch mit Debian Lenny (v. Netcup)
    Ein Verständnisproblem habe ich noch, denn die DNS-Einstellungen meckern auch noch rum.  Unten habe ich ein Bild des externen DNS angehangen, das zeigt auf diese Server IP. Da der VServer aber eine Hostnamen hat der auf vmd...contaboserver.net lautet, habe ich noch nicht verstanden wie ich dovecot bzw Postfix genau einrichte..   an dem letzen hatte ich es denke   srv1. xxx.de als Hostmane vergeben, also den Vservername außen vorgelassen und den srv1.xxx.de in meine eigene domain eingebunden per DNS . Das ist für mich evtl auch der Grund warum ein eigener DNS gebraucht wird auf diesem server.

    der damalige lief auch unverschlüsselt, was heute so nicht mehr geht und da geht das nächste Problem los, letscrypt arbeitet nicht. warum ?

     

     

    DNS-SERVER.jpg

  3. nachdem ich nun noch 3 bis 4 Mal neu aufgesetzt hatte, läuft zwar der Webserver, im Froxlor selbst gibt es noch einige Ungereimtheiten.

    1. Froxlor legt die Verzeichnisse für die Mailboxen nicht an.
    dazu gibt es Fehlemeldungen.

     

    Zitat

     dovecot[870]: auth-worker(8769): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 5 seconds before retry

     

    ich kann mich aber mit phpmyadmin als froxlor anmelden .. dazu fallen mir die Erwähnungen zu MariaDB ein, welches ich nach dieser Anleitung installiert und konfiguriert habe. Insbesondere Punkt 9:

    Zitat

    9 Enable MySQL root Login for phpMyAdmin

    While you can log in as root user into MariaDB on the shell, the root login will not work in phpMyAdmin. To allow the root user to use phpMyAdmin as well, run the following command on the shell:

    
    echo "UPDATE mysql.user SET plugin = 'mysql_native_password' WHERE user = 'root' AND plugin = 'unix_socket';FLUSH PRIVILEGES;" | mysql -u root -p

    war dabei recht wichtig. Da aber in einer Anleitung hier im Forum steht, dass  das unix_socket-Plugin zu deaktivieren sei, steht für mich die Frage ob dass einer der Gründe ist. Der Knackpunkt ist ich habe das jetzt mehr als einmal deaktiviert und komme danach nicht mehr ind froxlor und kann es auch nicht wieder aktivieren..

     

  4. vor 2 Minuten schrieb d00p:

    aaaah netcup...patchen die da nicht selbst rum?

    Am besten löscht du da mal alles, machst ne SAUBERE debian installation und installierst das offizielle froxlor von der website 

    nee der hier ist nicht von netcup aber es sit nicht ausgeschlossen, dass der hoster auch selbst gepatcht hat.

    jetz läuft froxlor die Webseite die eingerichtet ist, ist erreichbar:

    cronjob: 13.12.2018 23:05
     

  5. E: Sub-process /usr/bin/dpkg returned an error code (1)
    100All services have been configured
     

    dovecot.service - Dovecot IMAP/POP3 email server
       Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2018-12-13 22:56:38 CET; 9ms ago
         Docs: man:dovecot(1)
               http://wiki2.dovecot.org/
      Process: 31440 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
     Main PID: 846 (code=exited, status=0/SUCCESS)

    Dec 13 22:56:38 v......1.c......server.net systemd[1]: Starting Dovecot IMAP/…..
    Dec 13 22:56:38 v......1.c......server.net dovecot[31440]: Fatal: Dovecot is …in
    Dec 13 22:56:38 v......1.c......server.net systemd[1]: dovecot.service: Contr…89
    Dec 13 22:56:38 v......1.c.....server.net systemd[1]: Failed to start Doveco…r.
    Dec 13 22:56:38 v......1.c......server.net systemd[1]: dovecot.service: Unit …e.
    Dec 13 22:56:38 v......1.c......server.net systemd[1]: dovecot.service: Faile…'.

     

     

  6. vor 2 Minuten schrieb d00p:

    du musst die GANZE zeile kopieren, du kannst nicht einfach irgendwo "conig-services.php" eintippen....du bist aber schon nen server-admin ja? denn dafür ist froxlor gemacht...nicht für leute die nicht wissen was sie auf einem server tun sollen....

    ich war schon wieder im verzeichnis wo die php steht.. jetzt geht es, aber die oben beschriebnen fehler (Dovecot fail) sind immer noch drin..

  7. vor 2 Minuten schrieb d00p:

    korrektur mit den pfeiltasten? What? Wtf machst du?

    Wenn dein froxlor in /var/www/html/froxlor installiert ist, dann führe folgendes aus:

    
    php /var/www/html/froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/html/froxlor --create

    liegt dein froxlor in /was/weiss/ich/froxlor dann führe folgendes aus:

    
    php /was/weiss/ich/froxlor/install/scripts/config-services.php --froxlor-dir=/was/weiss/ich/froxlor --create

     

    Das erste ist schon richtig... ich machs nochmal ...

    jetzt hats funzt... wer weiss verschreiben gehabt oder

     

  8. vor 6 Minuten schrieb d00p:

    Vllt solltest du einfach mal alles korrekt konfigurieren...lass dch mal folgendes laufen:

    
    php /var/www/froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/froxlor --create

    folge dem was da steht, da werden dir die dienste konfiguriert

    hierzu hatte ich vorhin gefragt ob es ein Problem darstellt, wenn froxlor im Verz. /html statt /www liegt, der Grund ist, im /www war froxlor nicht erreichbar.

     

  9. vor 1 Minute schrieb d00p:

    die ip der domain sollte sowieso auf den server zeigen, meinst du den Nameserver eintrag?

    ja die Nameservereinträge sind so eingetragen, dass der vserver den ich geradee konfiguriere darin steht.


    jetzt kommt das erste mal ein Fehler.. den ich nicht deuten kann.

    invoke-rc.d: initscript dovecot, action "restart" failed.
    ● dovecot.service - Dovecot IMAP/POP3 email server
       Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2018-12-13 21:52:20 CET; 30ms ago
         Docs: man:dovecot(1)
               http://wiki2.dovecot.org/
      Process: 3876 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
     Main PID: 846 (code=exited, status=0/SUCCESS)

    Dec 13 21:52:20 v.....1.c.....server.net systemd[1]: Starting Dovecot IMAP/POP3 email ser…r...
    Dec 13 21:52:20 v......1.c......server.net dovecot[3876]: Fatal: Dovecot is already running …id)
    Dec 13 21:52:20 v......1.c......server.net systemd[1]: dovecot.service: Control process exi…s=89
    Dec 13 21:52:20 v......1.c.......server.net systemd[1]: Failed to start Dovecot IMAP/POP3 em…ver.
    Dec 13 21:52:20 v......1.c.......server.net systemd[1]: dovecot.service: Unit entered failed…ate.
    Dec 13 21:52:20 v......1.c.......server.net systemd[1]: dovecot.service: Failed with result …de'.
    Hint: Some lines were ellipsized, use -l to show in full.
    dpkg: error processing package dovecot-core (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of dovecot-managesieved:
     dovecot-managesieved depends on dovecot-core (= 1:2.2.27-3+deb9u2); however:
      Package dovecot-core is not configured yet.

    dpkg: error processing package dovecot-managesieved (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of dovecot-sieve:
     dovecot-sieve depends on dovecot-core (= 1:2.2.27-3+deb9u2); however:
      Package dovecot-core is not configured yet.

    dpkg: error processing package dovecot-sieve (--configure):

    kann das daran liegen, dass ich im Postfix noch die root@vserver.....net  Emailadresse stehen habe ?

     

×
×
  • Create New...