Jump to content
Froxlor Forum
  • 0

FCGID & Debian 10/11 & nsswitch


mrairstone
 Share

Question

Guten Abend.

Ich nutze aktuell zwei Systeme Debian 10 und 11 und wollte nun auf dem System FCGI für PHP aktivieren.
Jedoch startet der Apache nicht mehr bzw. macht keinen Reload.

Die Fehlermeldung lautet wie folgt:

AH00543: apache2: bad user name customername

Der Apache findet also scheinbar die Benutzer von Froxlor nicht. Jedoch ist "extrausers" und der /etc/nsswitch.conf eingetragen.

Die Pakete ibnss-extrausers sowie nscd sind installiert.
Die Dateien group, passwd und shadow wurden unter /var/lib/extrausers/ angelegt, sind jedoch leer.

Kann man die Eintragungen in diese drei Dateien manuell anstoßen?

 

LG

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Ich hab's.

Unter "Einstellungen -> Systemeinstellungen" war der Haken bei "Verwende libnss-extrausers anstatt libnss-mysql" nicht gesetzt.
Daher wurden die Dateien auch nicht mit Daten gefüttert.

Ich hatte die Option irgendwie übersehen... Sorry.

LG

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...