Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
DoCraft

vHosts gehen nicht

Question

Hallo,

ich habe vor kurzem Froxlor installiert.

Und eine Domain angelegt, die DNS Eintr?ge werden auch auf den Sekund?ren DNS Server ?bertragen.

Wenn man die Domain aufruft leitet Apache die Domain nicht in den Angegebenen Ordner weiter sondern man kommt in /var/www an.

Wenn ich bei der vHost Datei statt der IP des Server(Externe IP) ein * setz funktionierts.

Aber sobald ich ja wieder eine Subdomain anleg wird das ja zur?ckgesetzt.

Habt ihr da eine Idee warum und was ich dagegen machen kann.

PS.: Apache startet ohne Fehlermeldungen falls ihr Configs braucht schreibt es drunter

Danke im Vorraus

LG.: Flo

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

Dann tippe ich mal darauf, dass es ein DNS-Aufl?sungsproblem ist. Oder der Server steht in einer DMZ, dann ist es evtl. ein Routing-Problem.

Sowas k?nnen wir aber nur anhand einer Domain ?berpr?fen.

 

huschi.

Share this post


Link to post
Share on other sites

Domain: docraft.de

IP: 92.104.49.157

Edit:

H?tte fast vergessen es laufen noch welche auf dem Server:

oberiey.ch

darkframe3dhometheater.ch

dracomiscendas.ch

---

Da wir erstmal unsere Seiten wieder online haben wollen, habe ich jetzt die IP durch * ersetzt, bis der Fehler weg ist werden wir keine Subdomain erstellen.

Habe es aber so gemacht das docraft.de weiterhin von dem Problem betroffen ist also dort die IP drin gelassen, die Subdomains von DoCraft.de gehen aber nru damit keiner verwirrt ist ;-)

Share this post


Link to post
Share on other sites

Welche "Listen"-Direktiven hast Du in Apache und welche "NameVirtualHost"?

grep -R Listen /etc/apache2/
grep -R NameVirtualHost /etc/apache2/

 

Zum Vergleich:

root@server4:/tmp# grep -Ri Listen /etc/apache2/
/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:    Listen 443
root@server4:/tmp# grep -Ri NameVirtualHost /etc/apache2/
/etc/apache2/sites-enabled/10_froxlor_ipandport_xx.xx.xx.xx.80.conf:NameVirtualHost xx.xx.xx.xx:80
/etc/apache2/ports.conf:NameVirtualHost *:80

 

huschi.

Share this post


Link to post
Share on other sites

root@web:/etc/proftpd# grep -R Listen /etc/apache2/
/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:	Listen 443
/etc/apache2/ports.conf:	Listen 443

root@web:/etc/proftpd# grep -R NameVirtualHost /etc/apache2/
/etc/apache2/sites-enabled/10_froxlor_ipandport_192.168.1.102.80.conf:NameVirtualHost 192.168.1.102:80
/etc/apache2/sites-enabled/10_froxlor_ipandport_92.104.49.157.80.conf:NameVirtualHost 92.104.49.157:80
/etc/apache2/ports.conf:NameVirtualHost *:80
/etc/apache2/ports.conf:	# If you add NameVirtualHost *:443 here, you will also have to change

Edit: Die 192.168.1.102 die hatte ich ausversehentlich mal als IP gew?hlt hab aber danach die externe hinzugef?gt und als STandard Ip ge?ndert f?r Froxlor und f?r alle Domains

Share this post


Link to post
Share on other sites

So hab die Einstellungen so ge?ndert das es jetzt so aussieht:

root@web:/var/log/apache2# grep -Ri Listen /etc/apache2/
/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:	Listen 443
root@web:/var/log/apache2# grep -Ri NameVirtualHost /etc/apache2/
/etc/apache2/sites-enabled/10_froxlor_ipandport_92.104.49.157.80.conf:NameVirtualHost 92.104.49.157:80
/etc/apache2/ports.conf:NameVirtualHost *:80

Aber der leitet immer noch auf /var/www um und nicht auf /var/customers/webs/CUSTOMER/ -.-"

Edit: So wie ich es sehe kennt Apache die externe IP nicht sondern nur die interne des Server.

PS.: Es ist ein Virtueller Server ?ber OpenVZ der bei nem Kumpel daheim l?uft(Habt ihr ne idee wie ich die externe IP auf den irtuellen server bekomme?)

Share this post


Link to post
Share on other sites

So hab die Einstellungen so ge?ndert das es jetzt so aussieht:

root@web:/var/log/apache2# grep -Ri Listen /etc/apache2/
/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:	Listen 443
root@web:/var/log/apache2# grep -Ri NameVirtualHost /etc/apache2/
/etc/apache2/sites-enabled/10_froxlor_ipandport_92.104.49.157.80.conf:NameVirtualHost 92.104.49.157:80
/etc/apache2/ports.conf:NameVirtualHost *:80

 

Entferne oder kommentiere die NameVirtualHost Direktive in der /etc/apache2/ports.conf doch einfach aus. Wie du siehst, erstellt Froxlor jeweils pro IP (sofern nicht deaktiviert).

 

Aber der leitet immer noch auf /var/www um und nicht auf /var/customers/webs/CUSTOMER/"

Edit: So wie ich es sehe kennt Apache die externe IP nicht sondern nur die interne des Server.

PS.: Es ist ein Virtueller Server ?ber OpenVZ der bei nem Kumpel daheim l?uft(Habt ihr ne idee wie ich die externe IP auf den irtuellen server bekomme?)

 

Zeigt die externe IP nun auf deinen VPS oder nicht?! Bei letzterem: Das regelt dein physikalischer Host/ dein ISP/Admin.

Share this post


Link to post
Share on other sites

Entferne oder kommentiere die NameVirtualHost Direktive in der /etc/apache2/ports.conf doch einfach aus. Wie du siehst, erstellt Froxlor jeweils pro IP (sofern nicht deaktiviert).

Hab ich gemacht

Zeigt die externe IP nun auf deinen VPS oder nicht?! Bei letzterem: Das regelt dein physikalischer Host/ dein ISP/Admin.

Also die Ports werden auf den VPS vom Router her weitergeleitet aber wenn ich Apache starten will kommt:

(99)Cannot assign requested address: make_sock: could not bind to address 92.104.49.157:80
no listening sockets available, shutting down

Nein es l?uft nix auf Port 80

Share this post


Link to post
Share on other sites

So Apache l?uft jetzt ohne Fehlermeldungen habe ihm die externe IP bekannt gegeben.

Aber jetzt werden all meine Domain nicht von Apache entgegen genommen also es kommt Server nicht gefunden.

Aber ich kann den Server auf seiner IP anpingen und die Ports sind auch offen(80).

DNS Ist nat?rlich auch richtig.

Domain:

ns.docraft.de (Ist der einzigste Subdomain der auf den Server zurzeit weiterleitet, da ich die WEebsites zum laufen kriegen musste und die erstmal auf einem anderen Server sind.

Ja Apache hat nen vhost f?r ns.docraft.de wegen Froxlor weil er sonst diese ?berschreiben w?rde aus BIND.

oberiey.ch ist auch noch betroffen

Edit: Da Problem was ich habe ist glaube ich genau das was in diesem Bug ist: http://redmine.froxlor.org/issues/952 aber was aknn ich da jetzt machen ?

Ptoblem hat sich erledigt bei mir bin nun auf ispCP umgestiegen und es l?uft

Share this post


Link to post
Share on other sites

×
×
  • Create New...