Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

Warlock

[solved] 403 Forbidden - Problem that came with version 0.9.20 (fix 687)

Recommended Posts

Dear all,

 

I recently upgraded my froxlor installation from 0.9.18 to 0.9.21.

However, after installing the update, I got a 403 Forbidden error on all virtual hosts using the PHP fcgi.

After some search I discovered the problem:

 

http://git.froxlor.org/?p=froxlor.git;a=commitdiff;h=29665ff

 

Unfortunately, the bugfix 687 (that came with version 0.9.20, see link) changed the position of the following block from the <Directory> directive to

the <FilesMatch> directive causing to be not effective anymore.

Options +ExecCGI
Order allow,deny
allow from all

 

Some more explanation:

My configuration disables the access by default.

Then, the access is enabled for specific paths in the vhost configuration.

Moving the "Order allow..." into the <FilesMatch> block caused the server to take the "Order deny..." from the default settings.

 

This was certainly done by accident, was it?

 

Please give me some feedback, I changed it manually in my 0.9.21 version now.

 

Cheers,

Warlock

Share this post


Link to post
Share on other sites

Hey,

 

thank you for your bug report.

 

Eleras has created a patch which fixes this. Please open a ticket in redmine.froxlor.org or refer to a ticket #. I guess it's http://redmine.froxlor.org/issues/687 ?

 

Hi,

 

The funny thing is that everything was fine before the change (the fix of issue 687) but incorrect afterwards.

 

As I said, the solution is just to move the block

Options +ExecCGI
Order allow,deny
allow from all

outside the <FilesMatch> directive and back into the <Directory> directive.

I doubt this belongs to issue 687...

 

@arnoldB:

Did you experienced the same problem with your installation?

Share this post


Link to post
Share on other sites

Hi,

 

Thank you very much for the report, please see ticket #800 and commit 5b6acce8 for the fix.

 

So long,

Florian

Share this post


Link to post
Share on other sites

Hi,

 

Thank you very much for the report, please see ticket #800 and commit 5b6acce8 for the fix.

 

So long,

Florian

 

No worries...

 

(I liked helping you...I'm just wondering that nobody noticed the problem which existed for both versions 0.9.20 and 0.9.21)

 

Warlock

Share this post


Link to post
Share on other sites

×
×
  • Create New...