May 28, 201115 yr Guten Morgen , vorgestern installierte Ich zum ersten mal Froxlor auf meinem Webserver. Wenn ich ein Kunde anlege komme ich nicht auf die (Sub)Domains. Es wird immer nur das Login Panel von Froxlor angezeigt. Desweiteren funktioniert SMTP und IMAP nicht, h?ngt aber denke ich auch mit den Domains zusammen. Wo ligt das Problem? OS: Debian 6.0 "Squeeze" 64-Bit Serversoftware: Apache/2.2.16 (Debian) PHP-Version: 5.3.3-7+squeeze1 PHP-Memory-Limit: 128M MySQL Server Version: 5.1.49-3 MySQL Client Version: 5.1.49 Nameserver: Bind9 IMAP: Dovevot SMTP: Postfix/Dovecot Seit mir nicht b?se wenn ich irgendwas vergessen hab zu posten, ich bin in Froxlor noch Anf?nger
May 28, 201115 yr Guten Morgen , vorgestern installierte Ich zum ersten mal Froxlor auf meinem Webserver. OS ist Debian 6.0 und l?uft ?ber Apache2. Wenn ich ein Kunde anlege komme ich nicht auf die (Sub)Domains. Es wird immer nur das Login Panel von Froxlor angezeigt. Desweiteren funktioniert SMTP und IMAP nicht, h?ngt aber denke ich auch mit den Domains zusammen. Wo ligt das Problem? Seit mir nicht b?se wenn ich irgendwas vergessen hab zu posten, ich bin in Froxlor noch Anf?nger Hallo! Die Info's sind wirklich sp?rlich. Versuche aber mal ein paar Ideen: 1.Hast Du die Konfiguration aus dem Panel heraus ausgef?hrt? 2. Gab es bei mir ein Problem, dass die Cronjobs nicht automatisch gestartet wurden. Die L?sung dazu habe ich in einem anderen Forum gefunden: http://forum.netcup.de/showpost.php?p=34861&postcount=4 Gru? J?rn
May 28, 201115 yr Author 1. Alle Konfigurationen sind ausgef?hrt worden 2. Cronjobs funktionieren alle automatisch, also da kann das Problem schonmal nicht liegen Nameserver sowohl Bind9 als auch PowerDNS probiret, funzt beides nicht.
May 28, 201115 yr 1. Alle Konfigurationen sind ausgef?hrt worden 2. Cronjobs funktionieren alle automatisch, also da kann das Problem schonmal nicht liegen Nameserver sowohl Bind9 als auch PowerDNS probiret, funzt beides nicht. Ich vermute dass bei den Konfigurationen doch etwas schief gegangen ist. Hast Du auch ?berall Dein eigenes Mysql-Passwort eingetragen? Gehe doch nochmal die Konfigurationsdateien durch und vergleiche sie mit den Vorschl?gen aus dem Admin-Panel. Ich nutze Bind9 und esl?uft auf Anhieb.
May 28, 201115 yr Author Stimmt alles so wie aus dem Admin Panel von Proxlor, hab aber gleich alles aus Froxlor rauskopiert und in die conf datein eingef?gt. Stand ja man solls ersetzen.. MSQL Passwort wurde auch ?berall eingetragen. Kanns auch dran liegn das die Nameserver noch extern liegn?
May 28, 201115 yr Stimmt alles so wie aus dem Admin Panel von Proxlor, hab aber gleich alles aus Froxlor rauskopiert und in die conf datein eingef?gt. Stand ja man solls ersetzen.. MSQL Passwort wurde auch ?berall eingetragen. Kanns auch dran liegn das die Nameserver noch extern liegn? Ich bin leider auch nicht so der Fachmann ;-( Vielleicht m?sstes du erst einmal mehr ?ber dein System erz?hlen. Au?erdem solltest Du mal in den Log-Dateien nachsehen, welche Fehler angezeigt werden. Die betreffenden Fehlermeldungen hier mal posten. Dann werden sich auch eher die Fachleute zu schalten.
May 28, 201115 yr Wo find ich den die Logs? Was f?r Informationen braucht ihr? Mal ne dumme Frage: Kann es sein dass Du noch nie einen Server aufgesetzt hast? Also die Log-Dateien findest Du unter /var/log/ Falls Du noch nie einen Server betrieben hast, w?re es gut, du w?rdest erst einmal einen lokalen Server zum ?ben betreiben. Ich will jetzt nicht in das gleiche Horn sto?en wie einige in diesen Foren, aber es ist wirklich so, dass wenig Erfahrung ein gro?es Risiko sein kann. Nicht b?se gemeint. Schau, wie gesagt, in den Log Dateien nach Fehlermeldungen und poste sie hier. Nachtrag: Hier sind einige gute und hilfreiche Seiten angegeben ?ber die Verwaltung eines Servers: http://forum.netcup.de/showthread.php?t=2432 Edited May 28, 201115 yr by Eichjoernchen
May 28, 201115 yr Author Und welche brauch ich da genau, gibt ja mehr als genug da Hab oben mal die Systeminformationen reingepostet
May 28, 201115 yr Und welche brauch ich da genau, gibt ja mehr als genug da Hab oben mal die Systeminformationen reingepostet Ich habe einen V-Server bei Netcup gemietet. Dort habe ich Debian 6 (squeeze) als Grundsystem installiert. Dann habe ich gem?? der Anleitung im Wiki Froxlor installiert. Au?er dem Problem mit den Cronjobst lief es auf Anhieb. Manchmal ist es ein minimaler Fehler bei der ?bertragung der Konfigurationsdateien. Und schon geht gar nichts mehr. Vielleicht solltest Du noch mal mit einem nackten Grundsystem beginnen und dann nach der Anleitung aus dem Wiki vorgehen. Die sourceslist m?ssen nat?rlich angepasst werden.
May 28, 201115 yr Author Es geht ja alles au?er das bei den Kundendomains nicht der Inhalt sondern das Login Panel angezeigt werden... in /etc/bind in der Konfig sind die Domains auch eingetragen und m?sste eig. alles stimmen. Edit: was mir grad aufgefallen ist, jetzt l?sst sich Bind9 nichtmehr starten.. wenn ich "/etc/init.d/bind9 restart" eingebe kommt Stopping domain name service...: bind9rndc: connect failed: 127.0.0.1#953: connection refused . Starting domain name service...: bind9 failed!
May 28, 201115 yr Es geht ja alles au?er das bei den Kundendomains nicht der Inhalt sondern das Login Panel angezeigt werden... in /etc/bind in der Konfig sind die Domains auch eingetragen und m?sste eig. alles stimmen. Edit: was mir grad aufgefallen ist, jetzt l?sst sich Bind9 nichtmehr starten.. wenn ich "/etc/init.d/bind9 restart" eingebe kommt Stopping domain name service...: bind9rndc: connect failed: 127.0.0.1#953: connection refused . Starting domain name service...: bind9 failed! Vermutlicht werden die Virtualhosts nicht richtig angelegt (/etc/apache2/sites-enabled). Das l??t auf eine fehlerhafte Konfiguration schlie?en, oder der Cronjob wird nicht richtig ausgef?hrt. Da m??te aber irgendwas in den Apache-Logs zu finden sein Die Fehlermeldung, die Du nachtr?glich gepostet hast zeigt an, dass etwas mit der Konfiguration nicht stimmt. ?berpr?fe zuerst ob die Konfigurationsdateien wirklich so ?bernommen wurden, wie sie vorgeschlagen werden. Edited May 28, 201115 yr by Eichjoernchen
May 28, 201115 yr Author Hmm bei der Froxlor HTTP Apache2 Konfiguration steht allerdings nichts von sites-enabled kofigurieren, nur mods-enabled Im Konfigurations Men? muss man bei Bind9 keine Dateien bearbeiten, sondern nur bind9 ?ber SSH installieren usw. apt-get install bind9 echo "include \"/etc/bind/froxlor_bind.conf\";" >> /etc/bind/named.conf touch /etc/bind/froxlor_bind.conf chown root:bind /etc/bind/froxlor_bind.conf chmod 0644 /etc/bind/froxlor_bind.conf Mehr ist da nicht au?er noch Restart, und so hab ich auch alles ausgef?hrt.
May 28, 201115 yr Hmm bei der Froxlor HTTP Apache2 Konfiguration steht allerdings nichts von sites-enabled kofigurieren, nur mods-enabled Im Konfigurations Men? muss man bei Bind9 keine Dateien bearbeiten, sondern nur bind9 ?ber SSH installieren usw. apt-get install bind9 echo "include \"/etc/bind/froxlor_bind.conf\";" >> /etc/bind/named.conf touch /etc/bind/froxlor_bind.conf chown root:bind /etc/bind/froxlor_bind.conf chmod 0644 /etc/bind/froxlor_bind.conf Mehr ist da nicht au?er noch Restart, und so hab ich auch alles ausgef?hrt. Habe gerade was in einem anderen Forum zu diesem Problem gefunden: In der syslog steht nix von Bind drin. Und Bind l?uft derzeit auch nicht. L?sst sich auch nicht starten weil wie gesagt der Fehler auftritt.Ich hab jetzt mal mit aptitude purge bind9 Bind entfernt und mit aptitude install bind9 Bind neuinstalliert. Danach habe nach der Doku die Configfiles neu regeneriert. Bind l?uft wieder.
May 28, 201115 yr Author Danke, werd ich dann mal probieren. Erstmal hab ich aber auch rausgefunden das ich den Apache nichtmehr rebooten kann da es bei PHPmyAdmin ein Fehler gibt. Vielleicht h?ngt da alles zusammen.. Fehler gibts auch noch da: Syntax error on line 11 of /etc/apache2/sites-enabled/20_froxlor_normal_vhost_KUNDE1.DOMAIN.conf: Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed. # 20_froxlor_normal_vhost_KUNDE1.DOMAIN.conf # Created 28.05.2011 10:00 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 6 - CustomerID: 5 - CustomerLogin: KUNDE1 <VirtualHost 84.200.210.35:80> ServerName KUNDE1.DOMAIN ServerAlias *.KUNDE1.DOMAIN ServerAdmin test@domain.de DocumentRoot "/var/customers/webs/KUNDE1/" SuexecUserGroup "KUNDE1" "KUNDE1" FastCgiExternalServer /var/customers/webs/KUNDE1/fpm.external -socket /var/run/apache2/kunde1-kunde1.DOMAIN-php-fpm.socket -user KUNDE1 -group KUNDE1 <Directory "/var/customers/webs/kunde1/"> <FilesMatch "\.php$"> SetHandler php5-fastcgi Action php5-fastcgi /fastcgiphp Options +ExecCGI Order allow,deny allow from all </FilesMatch> </Directory> Alias /fastcgiphp /var/customers/webs/KUNDE1/fpm.external ErrorLog "/var/customers/logs/KUNDE1-error.log" CustomLog "/var/customers/logs/KUNDE1-access.log" combined </VirtualHost>
May 28, 201115 yr Danke, werd ich dann mal probieren. Erstmal hab ich aber auch rausgefunden das ich den Apache nichtmehr rebooten kann da es bei PHPmyAdmin ein Fehler gibt. Vielleicht h?ngt da alles zusammen.. Ich w?rde, solange noch keine Daten etc gespeichert wurden, den Server neu aufsetzen und alles noch mal von vorn konfigurieren, wie gesagt, es ensteht schnell ein minimaler Schreibfehler (vergessenes Symikolon etc.) der gro?e Auswirkungen hat.
May 28, 201115 yr Author Dann werd ich wohl das machen m?ssn :/ Hoffentlich bekomm ich das noch alles bis zum 1.Juni hin... Danke f?r deine Hilfe
May 28, 201115 yr Libnss einerichtet? => Distri => Others (system) => Libnss Dann werd ich wohl das machen m?ssn :/ Hoffentlich bekomm ich das noch alles bis zum 1.Juni hin Ansonsten beauftragst du einen Sys-Admin. *hust* Edit: Warum muss es eigentlich gleich ein (v)server sein? Webspace bei namhaften Anbietern gen?gt nicht?
May 28, 201115 yr Author Libnss einerichtet? Das kann nart?rlich sein das die nicht eingerichtet sind, da nach dem Tutorial die libnss nicht gefunden werden und ich es einfach ?bersprungen habe. Edit: Warum muss es eigentlich gleich ein (v)server sein? Webspace bei namhaften Anbietern gen?gt nicht? Weil auf dem Server noch mehr l?uft Sprich Teamspeak3 Ansonsten beauftragst du einen Sys-Admin. *hust* Preis? Edited May 28, 201115 yr by Philax
May 28, 201115 yr Libnss einerichtet? => Distri => Others (system) => Libnss Ansonsten beauftragst du einen Sys-Admin. *hust* Edit: Warum muss es eigentlich gleich ein (v)server sein? Webspace bei namhaften Anbietern gen?gt nicht? Das frage ich mich auch! Diese Anleitung w?re besser: http://redmine.froxlor.org/projects/froxlor/wiki/Installation_via_APT_(Debian) nur die sourceslist auf squeeze anpassen. Nach dieser Anleitung klappt es bei mir immer. Au?erdem wird dann Froxlor auch automatisch aktualisiert.
May 28, 201115 yr Das kann nart?rlich sein das die nicht eingerichtet sind, da nach dem Tutorial die libnss nicht gefunden werden und ich es einfach ?bersprungen habe. Weil auf dem Server noch mehr l?uft Sprich Teamspeak3 Preis? Dienste einzeln mieten ist g?nstiger als ein entsprechendes Gerichtsverfahren, wenn dein Server geknackt ist.
May 28, 201115 yr Wer keine Ahnung von Linux bzw. Unix besitzt sollte sich keinen Server aneignen. Tuts nachmachen kann jeder, aber den sinn versteht dann keiner. Hollt euch ein Managed Server, wenn ihr die grundlagen nicht kennt. Vielleicht w?re es mal klug, nicht nur Microsoft Windows zu benutzen. Sondern auch Linux - Ubuntu oder ?hnliches. [Man kann beides auf einem PC installieren, man kann also beides benutzen, siehe Oracles VM]. Aber nun gut. Back 2 Topic: W?re sch?n, Logs zur gesicht zu bekommen ^^. Und mehr Infos zu den Grundlagen von Linux unter - > info coreutils Edit: Rechtschreib Fehler , + Bl?den spruch ver?ndert :/. Edited May 28, 201115 yr by xocii
May 28, 201115 yr Wer keine Ahnung von Linux bzw. Unix besitzt sollte sich keinen Server aneignen. Tuts nachmachen kann jeder, aber den sinn versteht dann keiner. Hollt euch ein Managed Server, wenn ihr die grundlagen nicht kennt. Vielleicht w?re es mal klug, nicht nur Microsoft Windows zu benutzen. Sondern auch Linux - Ubuntu oder ?hnliches. [Man kann beides auf einem PC installieren, man kann also beides benutzen, siehe Oracles VM]. Aber nun gut. Back 2 Topic: W?re sch?n, Logs zur gesicht zu bekommen ^^. Und mehr Infos zu den Grundlagen von Linux unter - > info coreutils Edit: Rechtschreib Fehler , + Bl?den spruch ver?ndert :/. Ich kann dem nur beipflichten. Ich fand es auch nicht sehr sch?n, dass den Beitr?gen zus?tzliche Informationen zugef?gt wurden, nachdem ich geantwortet habe. Somit stimmen die Antworten nicht mehr unbedingt mit dem Kontext ?berein. Die Informationen kamen sp?rlich und St?ckweise. Dadurch war es schwer sich ein Bild zu machen. Letztlich mu? jeder selbst wissen was er tut. Er haftet ja schlie?lich selbst daf?r, wenn jemand seinen Server mi?braucht. Ich finde es eher sehr schade, dass durch diese Art der Information wertvolle Zeit des Helfenden sinnlos verbraucht wird.
May 28, 201115 yr Author Wenn euch die Zeit zu schade ist antwortet doch einfach nicht Und die h?lfte von den Off-Topic zu schreiben ich solle mir Webspace kaufen etc. w?ren auch nicht n?tig gewesen, wollte ich Webspace h?t ich Webspace gekauft. Aber nun gut. Back 2 Topic: W?re sch?n, Logs zur gesicht zu bekommen ^^. Und mehr Infos zu den Grundlagen von Linux unter - > info coreutils Wurde doch bereits gekl?rt, Habs nach der Einleitung von Eichjoernchen gemacht danach gings.. kann geclosed werden
Archived
This topic is now archived and is closed to further replies.