Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'php-fpm'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 19 results

  1. Mpi

    Error with php-fpm

    Good morning, after the restart of the vps I find the following problem: AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/10_froxlor_ipandport www1 apache2[2426]: Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration.
  2. Debian (9) Stretch 1. sudo apt install curl wget apt-transport-https dirmngr git 1a. Keys install wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && curl https://packages.sury.org/php/apt.gpg | apt-key add - 1b. Source List ( nano /etc/apt/source.list ) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2. MariaDB Install use sudo command for install MariaDB! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 3. nginx Install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 3c. service nginx restart 4. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 4a. service nginx restart service php7.1-fpm restart Ubuntu 17.10 (Artful) 1. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common python-software-properties 1b. Source List ( nano /etc/apt/source.list ) 1c. Key Install sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987) sudo add-apt-repository ppa:ondrej/nginx-mainline sudo add-apt-repository ppa:ondrej/php 2. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 3. MariaDB Install sudo apt install mariadb-server mariadb-client 3a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 4. nginx Install sudo apt install nginx 4a. nano /etc/nginx/nginx.conf 4b. service nginx restart 5. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 5a. service nginx restart service php7.1-fpm restart Froxlor Install Git version 1. vhost nano /etc/nginx/sites-enabled/frox 1a. service nginx restart 2. Change dir cd /usr/share/nginx/ 2a. Froxlor git Load sudo git clone https://github.com/Froxlor/Froxlor.git 2a. Folder Rename mv /usr/share/nginx/Froxlor /usr/share/nginx/your Folder Name 2b. User/Group Change for Froxlor Folder sudo chown -HR www-data:www-data Your Froxlor Folder 3. Browser Open http://your-SubDomain/your-Frolxor-Folder 3c. Change Your DB/User Name for Froxlor Install Froxlor finish 3d. Move userdata (Optional) mv /tmp/userdata.inc.php /usr/share/nginx/Your Froxlor Folder/lib/ 4. vhost delete rm /etc/nginx/site-enable/frox don't restart nginx! Froxlor Settings 1. cronjob nano /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /usr/share/nginx/your Froxlor Folder/scripts/froxlor_master_cronjob.php chmod 0640 "/etc/cron.d/froxlor" chown root:0 "/etc/cron.d/froxlor" service cron restart Froxlor Panel 1. Change your PHP-Backend Settings Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.1-fpm.sock 2. Make Folder and Change chmod mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /home/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp service nginx restart 2a. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home 2. libnss-extrausers install sudo apt install install nscd libnss-extrausers mkdir -p /var/lib/extrausers touch /var/lib/extrausers/{passwd,group,shadow} mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated: Change from NO to YES 3a. Settings > PHP-FPM > Settings Change > Configuration directory of php-fpm to /etc/php/7.1/fpm/pool.d/ Change > php-fpm restart command to /etc/init.d/php7.1-fpm restart or service php7.1-fpm restart 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. When you 502 error on Nginx have, use this command (Optional) (Thanks lino16 for this Note) sudo usermod -a -G www-data froxlorlocal SSL / Let's Encrypt activate 1. Create Folder on nginx mkdir /etc/nginx/ssl cd /etc/nginx/ssl 1a. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1b. create acme.conf nano /etc/nginx/acme.conf location /.well-known/acme-challenge { alias /usr/share/nginx/Your Froxlor Folder/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile insert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings Activate > Enable Let's Encrypt 2c. Activate on Settings > Froxlor VirtualHost settings - Enable Let's Encrypt for the froxlor vhost - Enable SSL-redirect for the froxlor vhost - HTTP Strict Transport Security (HSTS) - Include HSTS for any subdomain
  3. Hi, because I had some issues with HTTP2 and php via fcgid under Apache I tried to switch to php_fpm. While I was at it, I noticed a problem that I couldn't pinpoint and decided to try nginx. The issue stayed the same, basically these log entries: nginx: connect() to unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: xx.xx.xx.xx, server: domainname.de, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket:", host: "domainname.de", referrer: "https://domainname.de/" Apache: (13)Permission denied: [client xx.xx.xx.xx:63318] FastCGI: failed to connect to server "/var/www/php-fpm/web2/domainname.de/ssl-fpm.external": connect() failed The way I understand this problem: By design, php-fpm sockets created by Froxlor have permissions which only allow the vhost user to connect. But neither Apache nor nginx are told anywhere under which identity to connect to the socket. The SuExecUserGroup line in the vhost config file for Apache which does this for fcgid vanished when switching to php-fpm. I currently solved the problem by changing the line "listen.owner" inside the php-fpm pools to "www-data". That should not lower security, because php-fpm in itself takes care that the php process runs as the vhost user. Can someone tell me where I misunderstood the whole concept?
  4. Hi all, is it possible to use a shared php-fpm pool for a domain and its subdomains? I have a domain with ~80 subdomains for the local branches of a political party. I can't use a wildcard domain because we're using Let's Encrypt certificates, and an alias domain seems to not work either for the same reason. However, having 80+ php-fpm pools is a little high on the memory side. Do you have any advice for me? Best regards
  5. Hello! I have this error HTTP Error: Missing header/body separator, in my web app when PHP-FPM is enabled. When I disabled PHP-FPM the web app works fine. Any idea or additional config to php-fpm?? Thank you, Regards.
  6. davidoct14

    DataBase validation Fail

    Hi There, Anyone kwons How to solve froxlor-user in the customer groups (for FCGID/php-fpm) -- FAIL? In the database validation. I click in Fix problems automatically, but after the next cronjob run. It FAIL again. Regards,
  7. markus.heinze

    PHP-FPM mehrere Instanzen

    Moin moin, ich bereite gerade einen Migrationspfad für einen veralteten Server vor und möchte nat. viele Altlasten damit bereinigen. Ich möchte gern PHP-FPM mit Apache 2.4 nutzen. PHP soll per default in der Version 5.6.x laufen. Dies funktioniert auch alles prima. Nun ist es allerdings so, das es auch ältere WebApps gibt die nur mit PHP 5.3/4 laufen und auch Kunden, welche immer wieder nach PHP 7 fragen. Grundsätzlich ist es ja möglich verschiedene Instanzen aufzusetzen, hab hier PHP 5.4/5.6/7 laufen, natürlich von Hand konfiguriert. Das möchte nat. niemand auf Dauer machen;) Nun wäre es schön wenn es möglich wäre, verschiedene FPM Instanzen zu hinterlegen, so wie dies schon in den Einstellungen gemacht wird aber eben von 1-n und diese dann den vhosts zugewiesen werden könnte. Ja ich weiss das es dies noch nicht gibt und Feature Requests sind immer nervig weil man ja immer was anderes zu tun hat. Ich hätte kein Problem damit mich selbst dafür einzubringen , es wäre halt schön wenn man ein paar Tips bekäme wo anzusetzen ist, Programmier Konventionen etc. pp, sozusagen eine Schnellbesohlung, dann könnt man mal forken und schaun obs geht und ggf. hier zur Verfügung stellen (wenn gewünscht). Meine Deadline ist ende Juni für den Server daher muss ich bis dahin eine adäquateLösung haben, im Zweifel halt wieder Apache 2.2 mit fcgid aber wer will schon alte Kamellen wenn man die Sache grad anpackt, soll ja wieder eine Weile laufen und den Anforderungen genügen. Würde mich über Feedback freuen. lg max
  8. plusterkopp

    wiedermal fastcgi:error

    so, die allseits beliebte Fehlermeldung hat mich wieder erwischt: [Mon Apr 25 14:16:00.645665 2016] [fastcgi:error] [pid 991:tid 140379730966272] (13)Permission denied: [client 79.205.198.74:60848] FastCGI: failed to connect to server "/var/www/php-fpm/PKMD/pkmd.de/fpm.external": connect() failed [Mon Apr 25 14:16:00.645742 2016] [fastcgi:error] [pid 991:tid 140379730966272] [client 79.205.198.74:60848] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/PKMD/pkmd.de/fpm.external" Den Dateinamen gibt es zwar nicht, aber den Socket schon: srw-rw---- 1 PKMD PKMD 0 Apr 25 14:22 pkmd-pkmd.de-php-fpm.socket in /etc/php5/fpm/pool.d/pkmd.de.conf findet sich [pkmd.de] listen = /var/lib/apache2/fastcgi/pkmd-pkmd.de-php-fpm.socket listen.owner = PKMD listen.group = PKMD listen.mode = 0660 user = PKMD group = PKMD und das Ganze wird auch in /etc/php5/fpm/php-fpm.conf eingebunden: include=/etc/php5/fpm/pool.d/*.conf Das Froxlor-Panel (0.9.35.1-1+wheezy1) geht auch noch. Auch wenn das Debian 8 ist. Und der Dienst scheint zu laufen: ● php5-fpm.service - LSB: starts php5-fpm Loaded: loaded (/etc/init.d/php5-fpm) Active: active (running) since Mon 2016-04-25 14:22:02 CEST; 20min ago Process: 2225 ExecStop=/etc/init.d/php5-fpm stop (code=exited, status=0/SUCCESS) Process: 2233 ExecStart=/etc/init.d/php5-fpm start (code=exited, status=0/SUCCESS) CGroup: /system.slice/php5-fpm.service └─2245 php-fpm: master process (/etc/php5/fpm/php-fpm.conf) Wo muß ich sonst noch gucken? danke schonmal
  9. Hallihallo liebes Forum, ich muss nach einer langen Recherche aufgeben und mal nachfragen. Und zwar geht es konkret darum Froxlor Kunden-Domains mit SSL-Zertifikaten zu best?cken. Wie schon erw?hnt, habe ich mich umgehend umgeschaut und kam nicht wirklich zu einer L?sung des Problems durch Suchen und Ausprobieren. Mal vorweg das Problem: nginx liefert dem Browser das SSL-Zertifikat, was unter "IP and Ports" hinterlegt wurde, also quasi sowas wie das "Server-Fallback-Zertifikat" statt dem SSL-Zertifikat, was der Kunde angelegt hat. Das ist so nat?rlich nicht praktikabel und daher kann da ja nur etwas nicht stimmen. Zu den technischen Details: Der Server ist ein Debian 3.2.65-1+deb7u2 x86_64 Es l?uft Froxlor 0.9.33.1-1 Es l?uft nginx 1.6.2 (SNI-Support) sowie php5-fpm PHP 5.4.36-0+deb7u3 Ich benutze aktuelle Browser mit SNI-Support Die Kunden k?nnen erfolgreich als "virtuelle" UNIX User gemappt werden (also f?r PHP-Socket-Zugriff etc.) Die nginx Vhost Dateien: IP und Port SSL-Vhost: http://nopaste.linux-dev.org/?450919 Kunden SSL-Vhost: http://nopaste.linux-dev.org/?450920 Wie ich das sehe, sieht das korrekt aus, oder? Das Problem ist nun, dass ich statt dem Kunden SSL Zertifikat das der IP bekomme, also das unter /pfad/zum/server/cert.crt. Was ich schon gemacht habe: s?mtliche Einstellungen der IP ge?ndert (alle Checkboxen mal durchprobiert), also diese Vhost-Container ja/nein, Servername ja/nein, ? Domains gel?scht/neu hinzugef?gt Zertifikate gel?scht/neu hinzugef?gt Configs neu geschrieben Services neu gestartet Was sonst noch so passiert: L?sche ich das der IP hinterlegte SSL-Zertifikat, sagt nginx bei einer Anfrage auf die SSL-Kunden-Domain, dass kein SSL-Zertifikat angegeben wurde Vielleicht habe ich einige Daten, Fakten und Dinge, die ich schon probiert habe, vergessen zu erw?hnen. Fragt doch bitte, wenn was fehlt oder unklar ist. ?ber Denkanst??e w?re ich sehr dankbar, ich bin noch recht neu um Umgang mir Froxlor und wollte jetzt mal die SSL-Implementation testen? Ich gehe mal davon aus, dass mein Fehler recht trivial sein d?rfte.
  10. DYNASTIE

    502 bei Kunden nach Reboot

    Hi, OS: Ubuntu 15.04, Webserver: nginx, PHP-FPM aktiviert? Ja! Soweit funktioniert alles, Kunden werden angelegt und man kann problemlos auf deren Seite verbinden und sieht die index.html. Wenn ich jetzt aber die index.html in index.php umbenenne, erhalte ich einen 502 gateway timed out fehler. Errorlog vom Kunden: Das Gleiche passiert bei einem Reboot. Ein simples "service nginx reload" behebt den Fehler. Kunde ist in der Webservergruppe vorhanden. nscd etc. sind richtig konfiguriert, bin nach dem offiziellen Howto gegangen. Einstellungen sollten richtig sein: Die Sockets von PHP-FPM werden auch angelegt. vhost.conf vom Kunden: php-fpm.conf (/etc/php5/fpm): Den Fehler kann ich mit: "service nginx reload" wie erw?hnt beheben. Ein "chmod 666" auf den php-fpm.socket l?st das Problem nach dem Reboot ebenfalls, jedoch m?chte ich ungern an den Rechten rumschrauben. Ebenfalls wird das problem gel?st indem ich den Master-Cronjob ausf?hre. Wobei, wenn nginx restarted/reloaded wird, ?ndert der ja nichts an den Rechten vom php-fpm.socket - also kann es nicht die L?sung sein, die chmod-Rechte auf jeden socket zu erh?hen. Edit: Habe gerade mal das System neu gestartet und sehe in der syslog folgendes: Habe aber in der nscd in der Zeile bei required-start mysql eingetragen, also d?rfte es zu dem Fehler nicht kommen. Die Daten stimmen 100% ?berein, ein manuelles Einloggverfahren mit den gleichen Daten funktioniert problemlos.
  11. FM-Design

    Debian Wheezy, Froxlor + PHP-FPM

    Ich versuche verzweifelt o.g. Konfiguration zum Laufen zu bringen, scheitere aber bereits bei der Installation an den ersten Schritten. Ich hoffe, Ihr k?nnte mir helfen. Bei der Installation halte ich mich an dieser Anleitung FPM - handbook - Froxlor. Bei der Ausf?hrung des Befehls ?apt-get install libnss-mysql-bg nscd libapache2-mod-fastcgi apache2-suexec php5-fpm? kommt die Meldung ?Package libapache2-mod-fastcgi is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libapache2-mod-fastcgi' has no installation candidate? Ich habe die Source-Listen wie folgt angepasst: ftp.es.debian.org/debian stable main contrib non-freedeb-src ftp.es.debian.org/debian stable main contrib non-freedeb ftp.debian.org/debian/ wheezy-updates main contrib non-freedeb-src ftp.debian.org/debian/ wheezy-updates main contrib non-freedeb security.debian.org/ wheezy/updates main contrib non-freedeb-src security.debian.org/ wheezy/updates main contrib non-free Nach 'apt-get update' funktioniert auch die Installation. W?hrend der Installation folgt dann die Frage, wie mit dem Konfiguration File ?/etc/apache2/apche2.conf? umgegangen werden soll. Hier bin mir unschl?ssig. Ich habe die ?Install the package maintrainer?s version? versucht. Dann funktioniert Froxlor nicht mehr. Ich habe es auch mit der Beibehaltung der aktuellen Version versucht. Dann l?sst sich aber Apache nicht mehr starten. (?apache2: Syntax error on line 265 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/conf.d/: No such file or directory?). Leider finde ich dazu keine Hinweise oder Anleitungen. Hat von Euch jemand eine Idee?
  12. Hallo, ich habe gerade einen neuen Server aufgesetzt. Ubuntu 14.04 LTS, Apache2, Froxlor 0.9.33 mit PHP-FPM Leider haben alle Benutzer die selbe php.ini. Loaded Configuration File /etc/php5/fpm/php.ini Sonst funktioniert das mit den Benutzern alles korrekt. Ich habe auch mal Dein Youtube Video geschaut. Aber da ist am ende der gleiche Pfad. Im Forum hattest Du 2014 geschrieben, dass das Problem behoben w?re. Was kann ich tun? http://shoplive.server31.skyweb.hosting/phpinfo.php https://gist.github.com/cosmomill/4753944 https://forum.froxlor.org/index.php/topic/11662-merged-add-custom-phpini-files-for-php-fpm/ Viele Gr??e Stefan
  13. Hi, kurze Frage: Im Adminpanel von Froxlor bei den Settings von php-fpm kann man die Child Prozesse einstellen, wenn man das dort macht muss man nirgendwo anders mehr in .conf's etwas einstellen? Sind das alle relevanten Einstellungen und man kann Sie nutzen ANSTATT in der Shell zu arbeiten? Danke im Voraus. Andre
  14. Hallo ich habe meiner Meinung nach ein relativ merkw?rdiges Problem. Ich nutze Froxlor auf meinem debian jessie system. Als Webserver l?uft Nginx mit php-fpm. Das php-fpm funktioniert auch soweit. Mein Kunde f?hrt die php Dateien der domain.de unter seinem Benutzer selbst aus. Demzufolge reichen Rechte von 750 um Dateien im Kundenverzeichnis auszuf?hren. Dies funktioniert allerdings nicht f?r den Froxlor vhost selber. Die Option ist im froxlor Panel nat?rlich gesetzt, der user Froxlorlocal ist erstellt und es l?uft sogar ein fpm prozess unter diesem Nutzer. Trotzdem f?hrt der froxlorlocal Nutzer die Dateien in /var/www/froxlor nicht selber aus, sonder der fpm master prozess. Demzufolge braucht das Verzeichnis Rechte 755 um zu funktionieren. Woran kann das liegen? Das ganze ist nat?rlich nicht so tragisch, schlie?lich funktioniert es f?r die Kunden-vhosts. Aber dennoch ist es meiner Meinung nach komisch. Anhang: Wie man sieht, l?uft ein Prozess unter froxlorlocal wenn ich das froxlor panel ausrufe. Wenn ich dies nicht mache, l?uft kein Prozess wegen pm = ondemand. der Nutzer Alex f?hrt in diesem Fall die Anfragen auf die domain selber aus. root@s1:~# ps aux|grep php-fpm root 9371 0.3 0.2 454816 22348 ? Ss 11:44 0:00 php-fpm: master process (/etc/php5/fpm/php-fpm.conf) froxlorlocal 9374 0.8 0.2 456856 17296 ? S 11:44 0:00 php-fpm: pool s1.domain.de Alex 9376 3.0 0.2 463640 23632 ? S 11:44 0:00 php-fpm: pool domain.de Alex 9377 0.7 0.2 463360 20840 ? S 11:44 0:00 php-fpm: pool domain.de Alex 9378 0.9 0.3 691620 27772 ? S 11:44 0:00 php-fpm: pool domain.de hier die pool.conf datei vom froxlorhost ;PHP-FPM configuration for "s1.domain.de" created on 2014.07.06 11:44:09 [s1.domain.de] listen = /etc/nginx/fcgi/froxlor.panel-s1.domain.de-php-fpm.socket listen.owner = froxlorlocal listen.group = froxlorlocal listen.mode = 0666 user = froxlorlocal group = froxlorlocal pm = ondemand pm.max_children = 60 pm.start_servers = 20 pm.process_idle_timeout = 30 pm.max_requests = 0 ;chroot = /var/www/froxlor/ env[TMP] = /var/customers/tmp/froxlor.panel/ env[TMPDIR] = /var/customers/tmp/froxlor.panel/ env[TEMP] = /var/customers/tmp/froxlor.panel/ php_admin_value[session.save_path] = /var/customers/tmp/froxlor.panel/ php_admin_value[upload_tmp_dir] = /var/customers/tmp/froxlor.panel/ php_admin_flag[allow_call_time_pass_reference] = Off php_admin_flag[allow_url_fopen] = On php_flag[asp_tags] = Off php_admin_value[disable_functions] = exec,curl_multi_exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system php_flag[display_errors] = Off php_flag[display_startup_errors] = Off php_admin_flag[enable_dl] = Off php_value[error_reporting] = E_ALL & ~E_NOTICE php_admin_flag[expose_php] = Off php_admin_flag[file_uploads] = On php_admin_flag[cgi.force_redirect] = 1 php_admin_value[gpc_order] = "GPC" php_flag[html_errors] = Off php_admin_flag[ignore_repeated_errors] = Off php_admin_flag[ignore_repeated_source] = Off php_value[include_path] = ".:/usr/share/php/:/usr/share/php5/" php_flag[log_errors] = On php_value[log_errors_max_len] = 1024 php_flag[magic_quotes_gpc] = Off php_flag[magic_quotes_runtime] = Off php_flag[magic_quotes_sybase] = Off php_value[max_execution_time] = 60 php_admin_value[max_input_time] = 60 php_admin_value[memory_limit] = 16M php_admin_value[post_max_size] = 16M php_admin_value[precision] = 14 php_admin_flag[register_argc_argv] = Off php_admin_flag[report_memleaks] = On php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -f admin@domain.de" php_admin_value[session.gc_divisor] = 1000 php_admin_value[session.gc_probability] = 1 php_flag[short_open_tag] = On php_flag[track_errors] = Off php_value[upload_max_filesize] = 32M php_admin_value[variables_order] = "GPCS" Der Socket in /etc/nginx/fcgi existiert auch. drwxr-xr-x 2 root root 4096 Jul 6 11:44 . drwxr-xr-x 7 root root 4096 Jul 3 12:11 .. srw-rw-rw- 1 Alex Alex 0 Jul 6 11:44 Alex-domain.de-php-fpm.socket srw-rw-rw- 1 froxlorlocal froxlorlocal 0 Jul 6 11:44 froxlor.panel-s1.domain.de-php-fpm.socket hier noch der nginx vhost f?r die ip:80 # 10_froxlor_ipandport_ip.80.conf # Created 06.07.2014 11:44 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen ip:80 default; # Froxlor default vhost server_name s1.domain.de; access_log /var/log/nginx/access.log; root /var/www/; location / { index index.php index.html index.htm; } location ~ \.php$ { if (!-f $request_filename) { return 404; } fastcgi_index index.php; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_pass unix:/etc/nginx/fcgi/froxlor.panel-s1.domain.de-php-fpm.socket; } } Wenn ich nun die Rechte von /var/www/froxlor auf 750 setze, kommt ein 403 Error. Es wird also nicht einmal von fcgi ausgef?hrt 2014/07/06 11:52:08 [error] 9358#0: *142 "/var/www/froxlor/index.php" is forbidden (13: Permission denied), client: ip, server: s1.domain.de, request: "GET /froxlor/ HTTP/1.1", host: ip"
  15. Hallo werte Froxlorgemeinde! Meine Frage hat nicht direkt etwas mit Froxlor zu tun, aber ich hoffe hier trotzdem auf hilfreiche Tipps - besten Dank im Voraus. Ich habe aktuell unter Deian Wheezy (Froxlor 9.31) Apache (2.2.22) und PHP-FPM installiert. Die aktuelle stable von Debian ist PHP 5.4.4-14+deb7u9. Ich m?chte auch grunds?tzlich immer "aktuell" bleiben mit den jeweiligen PHP Paketen. Allerdings ben?tige ich f?r ein Projekt maximal PHP 5.3.x! Von daher meine Frage: Kann mir jemand ein Tutorial nennen, und/ oder Tipps geben, wie ich unter meiner Installation verschiedene PHP Versionen installieren kann und dann per Froxlor einem Kunden/ einer Domain eine bestimmte Version zuweisen kann? Gru? Gunther
  16. Hello This patch adds the ability to use custom php.ini files together with php-fpm. At first you have to apply the Apache 2.4 patch even if you use Nginx or Lighttpd. patch -p0 < froxlor-apache24.patch Apply the PHP-FPM patch: patch -p0 < froxlor-php-fpm.patch Configure php-fpm and PHP Configurations as usual. Be careful defined settings in PHP Configurations can't be overwritten in ".user.ini" files. http://php.net/manua...le.per-user.php Furthermore this method to configure PHP works for the CGI, FastCGI and FPM SAPI. So once support for PHP 5.2 in Froxlor is dropped this could be the default method to configure custom php.ini files. Patch for Froxlor 0.9.28-svn5: https://gist.github....smomill/4753944 Bye Rene
  17. Tomasz Czauderna

    nginx + php-fpm

    Hi all I just migrate from apache to nginx with foxlor panel and i have problem. If i create user and domain all files create successful but user for php-fpm dosen't create. And after reload nothing start up. And if i manual add user to system for php-fpm all start again. My distro is funtoo formaly (Gentoo). Someone have similar problem this is bug or bad my config somewere BestRegards
  18. Hello I added Apache 2.4 and mod_proxy_fcgi support to Froxlor. The good news are: -no more messing around with suphp, suexec or mod_fastcgi -libnss-mysql is not necessary anymore Drawback: -until unix socket support is build in mod_proxy_fcgi you have to apply a patch and compile Apache on your own mod_proxy_fcgi patch: https://gist.github....smomill/4693178 If you are not able to compile Apache on your own, try pkgsrc. http://www.netbsd.org/docs/pkgsrc/platforms.html#bootstrapping-pkgsrc http://wiki.netbsd.org/pkgsrc/how_to_use_pkgsrc_on_linux/ This pkgsrc package includes the above patch: https://github.com/cosmomill/pkgsrc Patch for Froxlor 0.9.28-svn5 https://gist.github....smomill/4753722 Apply the patch patch -p0 < froxlor-apache24.patch Configure Apache and php-fpm as usual. Bye Rene
  19. Hi all i'm creating new web server using debian 6 as os with nginx php-fpm and froxlor all works fine except joomla. if i try to install joomla, installation freeze during configuration check if i install joomla with aps, when i try to upload something with administrator interface, i get one error about file size.. this problems not occur if I change vhost's settings, from fastcgi_pass unix:/var/run/nginx/user-domain-php-fpm.socket; to fastcgi_pass 127.0.0.1:8888; this is not a good solution because all vhosts will work with same php-fpm instance and user is not the real website owner someone have any suggest? thanks all Bye
×