Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'dovecot'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 17 results

  1. Hi everyone, just a little problem here. I have severa domains registered on my froxlor installation and a different hostname of course. So let's say domain1.de is my hostname. The second domain, which is used by a customer is called domain2.de . When I view the mail.log I am not able to find my connection request. I do only see the bruteforce bots with example@domain1.de connecting. But any example@domain2.de request is not getting forwareded. I did configure the installation accordingdly with the provided templates. Best regards, thunfischbaum
  2. Hi everyone, I'm running a Debian 10 Buster Server with PHP7.3 installed. The PHP7.3 update is the new component in the system. since then, I can't find any Mailboxes. There are no folders in the var/customers/mail/[customer] directory. If you take look at the Screenshot, you see, that the E-Mail adress is existent in Froxlor. Mail Bounce Mail Log If I missed a log, please let me know, so I can attach it Best regards, thunfischbaum
  3. alex84

    Mailbox Quota

    Hallo, ich würde gerne Quotas für die Mailboxen nutzen. Dazu habe ich u.g. Funktion aktiviert und kann jetzt pro Mailbox Kontingente festlegen. Allerdings werden die weder in Thunderbird noch Roundcube angezeigt. Die Option oben besagt ja auch, das eine "spezielle Konfiguration" vorausgesetzt wird. Also nun meine Frage(n) Was muss ich noch anpassen oder installieren? Haben sich mit der Aktivierung dieser Option auch die Konfigurationstemplates geändert? (Auf dem ersten Blick würde ich sagen: Nein) Ich nutze das aktuelle Froxlor 0.9.40.1 (allerdings auf Debian 10 - Ich habe mich dabei an diese Anleitung gehalten, so weit es rein um Froxlor geht. Also ohne die "Partitionieren"-etc Abschnitte: https://lichtmetzger.de/2019/05/31/debian-10-buster-und-froxlor-0-9-auf-einem-hetzner-ex52-server-installieren/) Die Config-Templates (Postfix/Dovecot) habe ich soweit 1:1 übernommen, lediglich die SSL-Zertifikate und das message_size_limit angepasst. Danke schonmal, Alex
  4. Hi, erstmal eine gesundes neues Jahr! Ich habe gerade einen Mailaccount und die Mailbox dazu estellt. Dann habe ich diesen Mailaccount samt Mailbox gelöscht. Dann kommt die Meldung, das das etwas dauert.. Dann habe ich den Account neu erstellt, Geht. Mailbox dazu, dann kommt die Fehlermeldung Ein vorheriges Konto mit dem gleichen Namen (user@anstalt.org) wird aktuell noch gelöscht und kann daher derzeit nicht angelegt werden Wie wird man denn diesen Fehler los? Und wo muss man suchen. In der Datenbank habe ich alle Vorkommen von user@anstalt.org umbenannt in user1@anstalt.org, so dass Froxlor denkt, den account gibts nicht mehr. Aber Froxlor laääst sich offenbar nicht beschummeln.. Schade, denn es muss ja schnell gehen... (wie immer!) Auf etwas hilfe hoffend.. Jottschi
  5. Hallo Froxlor Team, wäre es möglich, dass ihr im nächsten Release auch die fullchain.pem von Let's Encrypt abspeichert? Somit könnte man diese auch ohne die Chainfiles direkt in Programme wie dovecot und postfix einbinden. Soweit ich weiß erlaubt dovecot sogar ausschließlich fullchains Vielen Dank
  6. i'm just in a the process of migrating a froxlor managed couriermail server to a new froxlor/debian9/postfix/dovecot mail server there are hundreds of gigabyte imapmap emails with hundreds of accounts. to make this a bit less painfully to move i started to created a small email migration script for the beginning https://github.com/veto64/sync_froxlor requirements: emails passwords must be plain latest docker remote access to the server
  7. Hallo zusammen! Ich habe eine Frage bzw. ein Problem zum Mailbox-Quota. Und zwar habe ich dieses aktiviert in den Einstellungen ("Nutze E-Mail-Kontingent für Kunden") und kann fröhlich Kontingente vergeben. Die Größe der jeweiligen Mailboxes werden auch bei Froxlor angezeigt, ich sehe also, was ich vergeben habe und was verwendet wird. Jedoch hat dies keinerlei Auswirkung auf den Account. Weder per Roundcube noch per Mail-Client wird die Größe der Mailbox angezeigt (unknown). Es läuft ein Debian 7.11 auf dem Server. Der Clou ist, dass per Froxlor eigentlich mal Courier als MDA ausgewählt wurde, als relay wird aber wohl weiterhin Dovecot verwendet - hierbei die Version 2.1.7. Die Config ist laut Froxlor-Configs angelegt. Witzigerweise ist mir hierbei aufgefallen, dass für die SQL-Befehle laut Dovecot-Wiki andere Texte angehängt werden als es Froxlor vorgibt. Es war bei mir jedoch egal, was ich verwendet habe, bisher führte nichts zum Erfolg. Leider steht im Webpanel auch nur "da dies eine spezielle Konfiguration voraussetzt", aber nicht, welche das sein soll. Anhand eines weiteren Forenbeitrags hier und einer weiteren Internetseite habe ich mir schon versucht, eine Lösung zu erarbeiten, was jedoch nicht glückte. Die SQL-Abfragen gehen durch, Ergebnisse sind da. Quota ist erkennbar, aktuelle Größe ebenso... ich weiß nicht mehr weiter. Hat jemand Ideen und kann mir weiterhelfen? Liebe Grüße!
  8. Hallo Froxlor-Community, Froxlor habe ich auf zwei getrennten Root Servern (Debian) bei Hetzner installiert. Beide Server sind unter einem FQDN (+ Reverse-IP) mit der selben Top-Level Domain example.com erreichbar: server1.example.com, server2.example.com. Nun hätte ich gerne beim Einrichten eines E-Mail Postfaches im Client (Outlook, Thunderbird, etc.) anstatt des Servernamens server1.example.com oder server2.example.com am liebsten (wie man es gewohnt ist) die Adressen mail.example.com oder smtp.example.com und pop3/imap.example.com angegeben. Im DNS kann ich die genannten Subdomains (mail, smtp, pop3, imap, etc.) hinterlegen und jeweils auf beide Server/IP Adressen verweisen. An dieser Stelle fehlt mir jedoch das technische Mailserver-Knowhow oder der Fachbegriff, wie man Postfix/Dovecot erzählt, wenn sich das Postfach nicht auf dem eingehenden Server z.B. server1.example.com befindet, leite es weiter auf server2.example.com. Genauso wenn sich der Client mit imap.example.com verbindet, dass der Client beim Verbindungsaufbau auf dem richtigen Server, worauf sich das Postfach befindet, landet/geroutet wird. Wie machen das die großen Provider? Bei GMX, Web.de etc. stehen sicherlich auch mehrere Server dahinter, aber man gibt im Client als Servernamen smtp.gmx.net / pop3.gmx.net als Mailserver an. Ist eine realistische Umsetzung mit Froxlor möglich? Wonach muss ich suchen (Schlagwort)? Danke u. schönen Gruß, Alex
  9. Hallo Froxlor Froum, kämpfe seit Tagen damit einen VServer mit Froxlor erfolgreich zum laufen zu bringen, allerdings fallen mir immer wieder Steine in den Weg. Nach dem kürzlich gelösten ProFTP Fehler habe ich nun das Problem das ich mich nicht mit meinem Mailserver verbinden kann. Habe bereits viel Im Internet nach Lösungen gesucht aber nichts gefunden. Wie schon oft gelesen habe ich mich auch wirklich penibel an die Konfigurationsschritte des Webinterfaces gehalten. Um es nur kurz anzumerken, dies ist meine zweite Froxlor Installation auf einem VServer. Die erste liefe ohne nennenswerte Probleme ab und ist auch immer noch in Betrieb. Mein aktuelles System läuft auf Ubuntu 14.04, Froxlor per apt installiert und anschließend Konfiguration durchgeführt. Standardmäßig Postfix mit Dovecot. Der Fehler sieht wie folgt aus: Ich versuche mich per Email-Client mit einer vom Dummy Kunden erstellten Email auf den Server einzuloggen. Ich erhalte lediglich die Meldung, das die Verbindung zum Server nicht hergestellt werden kann. Ping an besagten Server ist erfolgreich. Was mich stutzig macht ist das ein nmap auf auf port 143 auswirft das der Port 143 geschlossen ist. Die Logs sagen folgendes: mail.log postfix/master[811]: daemon started -- version 2.11.0, configuration /etc/postfix postfix/qmgr[816]: 4D08D3EB60620: from=<admin@[MEIN_HOSTNAME]>, size=1344, nrcpt=1 (queue active) dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. postfix/pipe[1262]: 4D08D3EB60620: to=<[KUNDENMAIL]@[KUNDEN_DOMAIN]>, relay=dovecot, delay=6105, delays=6105/0.01/0/0.18, dsn=4.3.0, status=deferred (temporary failure) mail.err dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. Kann nur nochmal betonen das ich alle Schritte genaustens nach Anweisung durch geführt habe. Kann mir jemand bei der Problemlösung helfen? MFG
  10. Hallo zusammen, ich betreibe schon seit längerem einen Mailserver via Dovecot und Postfix. Als Plattform setze ich Debian GNU/Linux 8 ein. Dovecot und Postfix habe ich via apt-get install installiert. Jetzt möchte ich zusätzlich Sieve ins Spiel bringen um die Mails automatisiert filtern zu lassen. So wie ich die Dokus verstanden habe benötige ich dafür aber das Plugin 'sieve'. "Geschrieben" habe ich die sieve-scripts mit roundcube und getestet mit sieve-test. Demnach funktioniert sieve bereits super, nur leider scheint postfix/dovecot sieve gar nicht erst zu involvieren bevor die Mail abgelegt wird. Meine dovecot.conf ist recht schlank: !include_try /usr/share/dovecot/protocols.d/*.protocol dict { } !include conf.d/*.conf !include_try local.conf mail_location = maildir:~/.maildir mail_debug = yes 10-mail.conf mail_location = mbox:~/mail:INBOX=/var/mail/%u namespace inbox { inbox = yes } mail_access_groups = mail-users 20-lmtp.conf protocol lmtp { mail_plugins = $mail_plugins sieve } 90-sieve.conf plugin { sieve = ~/.maildir/sieve sieve_dir = ~/.maildir/sieve sieve_before = /etc/dovecot/sieve/spam-global.sieve } protocol sieve { managesieve_max_line_length = 65536 managesieve_implementation_string = dovecot log_path = /var/log/dovecot-sieve-errors.log info_log_path = /var/log/dovecot-sieve.log } Da die Konfig-Files in vielen Ordnern/Scripten aufgeteilt ist weiß ich nicht so recht welche Configs ich hier noch reinschreiben könnte. /etc/postfix/main.cf smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) biff = no append_dot_mydomain = no readme_directory = no smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key smtpd_use_tls = no smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtpd_enforce_tls = no mydomain = hkgame.de alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases myorigin = /etc/mailname mydestination = $myhostname, /etc/postfix/virtual/domains virtual_maps = hash:/etc/postfix/virtual/addresses relayhost = mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 mailbox_size_limit = 0 recipient_delimiter = + inet_interfaces = all home_mailbox = .maildir/ local_destination_concurrency_limit = 2 default_destination_concurrency_limit = 10 smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem smtpd_tls_received_header = yes smtp_use_tls = no Was mache ich wohl falsch? Muss ich noch irgend ein Plugin aktivieren? Danke und Gruß ZIP
  11. Hallo liebe Community, ich habe mal eine Frage ich habe gerade Froxlor neuaufgesetzt und mir selber eine Testmail über einen MailAccount gesendet um meinen Mailserver zu testen, dann habe ich die Log überprüft weil die Mail nicht ankam und da kam diese Meldung Jan 29 17:10:17 server1 postfix/qmgr[17261]: 1DD13200AE3: from=<mail@hotmail.de>, size=1201, nrcpt=1 (queue active) Jan 29 17:10:17 server1 postfix/pipe[3297]: 1DD13200AE3: to=<support@mail.maill>, relay=dovecot, delay=550, delays=550/0.01/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: doveconf: Fatal: open(/etc/dovecot/dovecot.conf) failed: Permission denied ) Ich dachte die Datei hat nicht genug Rechte und habe dieser dann Rechte gegeben da sie wirklich keine hatte, jedoch bringt das garnichts. Ich habe auch schon gegooglet aber nichts gefunden. Habe auch schon Dovecot und Postfix neugestartet.(Die Mailadressen wurden ersetzt durch Examples)
  12. Hi all! First off all, thx a lot for this superior admin panel, i love it! The setup under Debian7 wheezy was straight forward and I am very happy to have gone for froxlor. There was only one problem: I wasn't able to receive E-Mail, sending did work. The /var/log/mail.log: Sep 23 19:12:28 hostname postfix/pipe[8552]: 692BX34A21W: to=<mail@address.tld>, relay=dovecot, delay=155993, delays=155993/0.02/0/0.08, dsn=4.3.0, status=deferred (temporary failure. Command output: doveconf: Fatal: open(/etc/dovecot/dovecot.conf) failed: Permission denied ) Like it says in the froxlor config i did: chmod 0640 "/etc/dovecot/dovecot.conf" chown root:root "/etc/dovecot/dovecot.conf" This wouldn't work and gives the posted fatal error. :-( My solution so far is: change the permission from 640 to 644 and leave the chown as it suggests in the config. Also i changed permission of all files in /etc/dovecot/conf.d/ to 644 as well, leaving the owner and group as it was. After restarting postfix and dovecot everything works here! :-) I am not sure if this is a good fix and would be glad to hear what you think about it. Have a nice day and all the best, hale-xp
  13. Hallo zusammen, ich habe ein Problem bei der Konfiguration von Dovecot auf meinem Server. Es ist ein frisches Debian 7 aufgespielt, per apt-get habe ich die folgenden Pakete installiert (sowie die Abh?ngigkeiten, die automatisch mitinstalliert wurden): mysql-server apache2 php5 php5-gd php5-mysql php5-curl Froxlor 0.9.33.2 habe ich heruntergeladen und eingerichtet. Im Anschluss habe ich mich an die Konfiguration gemacht. Als Mailserver (IMAP/POP3) m?chte ich Dovecot verwenden und habe alle Dovecot installiert sowie alle Dateien entsprechend der anleitung ge?ndert. Beim Neustart von Dovecot mit /etc/init.d/dovecot restart gibt es dann folgende Ausgabe: root@server:/var/www# /etc/init.d/dovecot restart [....] Restarting IMAP/POP3 mail server: dovecotFatal: service(auth) Group doesn't exist: Debian-exim (See service auth { unix_listener /var/run/dovecot/auth-client { group } } setting) failed! root@server:/var/www# Ich bin gerade ziemlich am Verzweifeln, weil ich auch durch Googlen keine L?sung gefunden habe :/. Kann mir jemand sagen, wo der Fehler liegt und wie ich Dovecot richtig konfiguriert bekomme? Vielen Dank im Voraus!
  14. Looking for any help/ can't config mail/ i was create email - admin@domain setup roundcube login send email to gmail mailbox and receive it but when replay from google i got from my server Mail Delivery System <MAILER-DAEMON@mail.domain> who can help me please i can post anything to resolve my problem/ //sorry for my English//
  15. Hallo liebe Froxie's, ich habe bei mir leider das Problem, dass ich keine Mails senden/empfangen kann! Ich benutze Postfix Dovecot und habe versucht ?ber Thunderbird meine Mails abzurufen. Das Konto l?sst sich bei Thunderbird nicht wirklich hinzuf?gen und falls, dann kann ich weder Mail's empfangen noch senden. Ich stelle mal einen Ausschnitt meiner Mail.log dazu. Vielleicht k?nnt ihr mir ja helfen! LG Jakob Mail.log Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: mysql:/etc/postfix/mysql-virtual_alias_maps.cf lookup error for "root@mail.BNFC" Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: B481D300343: virtual_alias_maps map lookup problem for root@mail.BNFC -- deferring delivery Jan 14 22:41:30 rs000023 postfix/pickup[13736]: warning: B4A3E300343: message has been queued for 3 days Jan 14 22:41:30 rs000023 postfix/pickup[13736]: B4A3E300343: uid=33 from=<admin@BNFC> Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: B4A3E300343: message-id=<8bebda524d379c6b230ab1ff09521d8c@89.163.227.23> Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: mysql:/etc/postfix/mysql-virtual_alias_maps.cf lookup error for "mail@BenderNetwork.de" Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: B4A3E300343: virtual_alias_maps map lookup problem for mail@BenderNetwork.de -- deferring delivery
  16. Hey, ich habe heute meinen vServer neu aufgesetzt und dabei speziell auf die Installation von Froxlor hingearbeitet. Nachdem ich alle anderen Probleme via Google beheben konnte, sto?e ich nun auf mein gr??tes Problem: Ich erhalte schlichtweg keine E-Mails. Ich habe die in Froxlor angegebenen Konfigurationen f?r Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix/Dovecot Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix MX-Access (anti spam) Debian 7.0 (Wheezy) ? Mailserver (IMAP/POP3) ? Dovecot durchgef?hrt und nachtr?glich mehrmals gepr?ft. Wenn ich nun eine E-Mail von meinem GMail Account an eine in Froxlor angelegte E-Mail Adresse schicke (welche ich wiederum ?ber GMail abrufe), kann ich dem /var/log/mail.log entnehmen, dass eine Verbindung zur froxlor Datenbank aufgebaut wird und die Mail anschlie?end nach 'INBOX' gespeichert wurde. Leider warte ich bei GMail anschlie?end vergebens darauf, dass die E-Mail ankommt. Auch auf Dateiebene unter /var/customers/mail/Kunde/Domain/mail/Maildir/* kann ich nichts von der E-Mail finden. Wenn ich das Prinzip der Ablage richtig verstanden habe, m?sste da ja irgendwo eine Datei mit Namen 'CAJF6H3nemCOW+L9xCU+2nB4iR55WV_QpHjBpf63e=bYG01PuFQ@mail.gmail.com' sein. Wenn ich danach suche, oder nur nach gmail, finde ich nichts. Ich habe auch die froxlor Datenbank durchsucht und keine Tabelle gefunden, in der E-Mails gespeichert sein k?nnten. Zur Info: Die Mails von Froxlor ?ber angelegte Accounts etc. kommen bei GMail an, also muss es meiner Meinung nach etwas mit der Ablage der Mails beim Empfang zu tun haben. Bin also auf Eure Hilfe angewiesen. Kann jemand helfen? Hat jemand einen Verdacht? Gern poste ich weitere Logfiles, jedoch bin ich bis jetzt nicht f?ndig geworden. Danke! Timmaeh
  17. Hallo zusammen, ich habe ab und an Probleme mit dem Abrufen von Mails ?ber Outlook, Thunderbird geht stets ohne Probleme. Ich nutze Postfix/Dovecot und die aktuelle Froxlor-Version. Kunden berichten, dass das Abrufen eine ganze Weile funktioniert, dann jedoch angehangener Fehler kommt. Outlook schaltet sich zudem "offline". Ich habe in der 20-imap.conf des Dovecot schon testweise auf mail_max_userip_connections = 50 gestellt, allerdings l?st das mein Problem nicht ganz. Hat jemand Anhaltspunkte f?r mich? Wenn gew?nscht kann ich auch gern erforderliche Configs posten. Apropos: habe die Configs von Froxlor soweit bebeihalten, lediglich auf SSL umgestellt. Danke vorab f?r die Hilfe.
×
×
  • Create New...