Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'dovecot'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 25 results

  1. Hallo Froxlor Team, wäre es möglich, dass ihr im nächsten Release auch die fullchain.pem von Let's Encrypt abspeichert? Somit könnte man diese auch ohne die Chainfiles direkt in Programme wie dovecot und postfix einbinden. Soweit ich weiß erlaubt dovecot sogar ausschließlich fullchains Vielen Dank
  2. i'm just in a the process of migrating a froxlor managed couriermail server to a new froxlor/debian9/postfix/dovecot mail server there are hundreds of gigabyte imapmap emails with hundreds of accounts. to make this a bit less painfully to move i started to created a small email migration script for the beginning https://github.com/veto64/sync_froxlor requirements: emails passwords must be plain latest docker remote access to the server
  3. JayDee2202

    Mailbox Quota / Mailbox-Kontingent

    Hallo zusammen! Ich habe eine Frage bzw. ein Problem zum Mailbox-Quota. Und zwar habe ich dieses aktiviert in den Einstellungen ("Nutze E-Mail-Kontingent für Kunden") und kann fröhlich Kontingente vergeben. Die Größe der jeweiligen Mailboxes werden auch bei Froxlor angezeigt, ich sehe also, was ich vergeben habe und was verwendet wird. Jedoch hat dies keinerlei Auswirkung auf den Account. Weder per Roundcube noch per Mail-Client wird die Größe der Mailbox angezeigt (unknown). Es läuft ein Debian 7.11 auf dem Server. Der Clou ist, dass per Froxlor eigentlich mal Courier als MDA ausgewählt wurde, als relay wird aber wohl weiterhin Dovecot verwendet - hierbei die Version 2.1.7. Die Config ist laut Froxlor-Configs angelegt. Witzigerweise ist mir hierbei aufgefallen, dass für die SQL-Befehle laut Dovecot-Wiki andere Texte angehängt werden als es Froxlor vorgibt. Es war bei mir jedoch egal, was ich verwendet habe, bisher führte nichts zum Erfolg. Leider steht im Webpanel auch nur "da dies eine spezielle Konfiguration voraussetzt", aber nicht, welche das sein soll. Anhand eines weiteren Forenbeitrags hier und einer weiteren Internetseite habe ich mir schon versucht, eine Lösung zu erarbeiten, was jedoch nicht glückte. Die SQL-Abfragen gehen durch, Ergebnisse sind da. Quota ist erkennbar, aktuelle Größe ebenso... ich weiß nicht mehr weiter. Hat jemand Ideen und kann mir weiterhelfen? Liebe Grüße!
  4. Hallo Froxlor-Community, Froxlor habe ich auf zwei getrennten Root Servern (Debian) bei Hetzner installiert. Beide Server sind unter einem FQDN (+ Reverse-IP) mit der selben Top-Level Domain example.com erreichbar: server1.example.com, server2.example.com. Nun hätte ich gerne beim Einrichten eines E-Mail Postfaches im Client (Outlook, Thunderbird, etc.) anstatt des Servernamens server1.example.com oder server2.example.com am liebsten (wie man es gewohnt ist) die Adressen mail.example.com oder smtp.example.com und pop3/imap.example.com angegeben. Im DNS kann ich die genannten Subdomains (mail, smtp, pop3, imap, etc.) hinterlegen und jeweils auf beide Server/IP Adressen verweisen. An dieser Stelle fehlt mir jedoch das technische Mailserver-Knowhow oder der Fachbegriff, wie man Postfix/Dovecot erzählt, wenn sich das Postfach nicht auf dem eingehenden Server z.B. server1.example.com befindet, leite es weiter auf server2.example.com. Genauso wenn sich der Client mit imap.example.com verbindet, dass der Client beim Verbindungsaufbau auf dem richtigen Server, worauf sich das Postfach befindet, landet/geroutet wird. Wie machen das die großen Provider? Bei GMX, Web.de etc. stehen sicherlich auch mehrere Server dahinter, aber man gibt im Client als Servernamen smtp.gmx.net / pop3.gmx.net als Mailserver an. Ist eine realistische Umsetzung mit Froxlor möglich? Wonach muss ich suchen (Schlagwort)? Danke u. schönen Gruß, Alex
  5. Hallo Froxlor Froum, kämpfe seit Tagen damit einen VServer mit Froxlor erfolgreich zum laufen zu bringen, allerdings fallen mir immer wieder Steine in den Weg. Nach dem kürzlich gelösten ProFTP Fehler habe ich nun das Problem das ich mich nicht mit meinem Mailserver verbinden kann. Habe bereits viel Im Internet nach Lösungen gesucht aber nichts gefunden. Wie schon oft gelesen habe ich mich auch wirklich penibel an die Konfigurationsschritte des Webinterfaces gehalten. Um es nur kurz anzumerken, dies ist meine zweite Froxlor Installation auf einem VServer. Die erste liefe ohne nennenswerte Probleme ab und ist auch immer noch in Betrieb. Mein aktuelles System läuft auf Ubuntu 14.04, Froxlor per apt installiert und anschließend Konfiguration durchgeführt. Standardmäßig Postfix mit Dovecot. Der Fehler sieht wie folgt aus: Ich versuche mich per Email-Client mit einer vom Dummy Kunden erstellten Email auf den Server einzuloggen. Ich erhalte lediglich die Meldung, das die Verbindung zum Server nicht hergestellt werden kann. Ping an besagten Server ist erfolgreich. Was mich stutzig macht ist das ein nmap auf auf port 143 auswirft das der Port 143 geschlossen ist. Die Logs sagen folgendes: mail.log postfix/master[811]: daemon started -- version 2.11.0, configuration /etc/postfix postfix/qmgr[816]: 4D08D3EB60620: from=<admin@[MEIN_HOSTNAME]>, size=1344, nrcpt=1 (queue active) dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. postfix/pipe[1262]: 4D08D3EB60620: to=<[KUNDENMAIL]@[KUNDEN_DOMAIN]>, relay=dovecot, delay=6105, delays=6105/0.01/0/0.18, dsn=4.3.0, status=deferred (temporary failure) mail.err dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. Kann nur nochmal betonen das ich alle Schritte genaustens nach Anweisung durch geführt habe. Kann mir jemand bei der Problemlösung helfen? MFG
  6. Hallo zusammen, ich betreibe schon seit längerem einen Mailserver via Dovecot und Postfix. Als Plattform setze ich Debian GNU/Linux 8 ein. Dovecot und Postfix habe ich via apt-get install installiert. Jetzt möchte ich zusätzlich Sieve ins Spiel bringen um die Mails automatisiert filtern zu lassen. So wie ich die Dokus verstanden habe benötige ich dafür aber das Plugin 'sieve'. "Geschrieben" habe ich die sieve-scripts mit roundcube und getestet mit sieve-test. Demnach funktioniert sieve bereits super, nur leider scheint postfix/dovecot sieve gar nicht erst zu involvieren bevor die Mail abgelegt wird. Meine dovecot.conf ist recht schlank: !include_try /usr/share/dovecot/protocols.d/*.protocol dict { } !include conf.d/*.conf !include_try local.conf mail_location = maildir:~/.maildir mail_debug = yes 10-mail.conf mail_location = mbox:~/mail:INBOX=/var/mail/%u namespace inbox { inbox = yes } mail_access_groups = mail-users 20-lmtp.conf protocol lmtp { mail_plugins = $mail_plugins sieve } 90-sieve.conf plugin { sieve = ~/.maildir/sieve sieve_dir = ~/.maildir/sieve sieve_before = /etc/dovecot/sieve/spam-global.sieve } protocol sieve { managesieve_max_line_length = 65536 managesieve_implementation_string = dovecot log_path = /var/log/dovecot-sieve-errors.log info_log_path = /var/log/dovecot-sieve.log } Da die Konfig-Files in vielen Ordnern/Scripten aufgeteilt ist weiß ich nicht so recht welche Configs ich hier noch reinschreiben könnte. /etc/postfix/main.cf smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) biff = no append_dot_mydomain = no readme_directory = no smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key smtpd_use_tls = no smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtpd_enforce_tls = no mydomain = hkgame.de alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases myorigin = /etc/mailname mydestination = $myhostname, /etc/postfix/virtual/domains virtual_maps = hash:/etc/postfix/virtual/addresses relayhost = mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 mailbox_size_limit = 0 recipient_delimiter = + inet_interfaces = all home_mailbox = .maildir/ local_destination_concurrency_limit = 2 default_destination_concurrency_limit = 10 smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem smtpd_tls_received_header = yes smtp_use_tls = no Was mache ich wohl falsch? Muss ich noch irgend ein Plugin aktivieren? Danke und Gruß ZIP
  7. thebornde

    Fehlermeldung durch Mailserver

    Hallo liebe Community, ich habe mal eine Frage ich habe gerade Froxlor neuaufgesetzt und mir selber eine Testmail über einen MailAccount gesendet um meinen Mailserver zu testen, dann habe ich die Log überprüft weil die Mail nicht ankam und da kam diese Meldung Jan 29 17:10:17 server1 postfix/qmgr[17261]: 1DD13200AE3: from=<mail@hotmail.de>, size=1201, nrcpt=1 (queue active) Jan 29 17:10:17 server1 postfix/pipe[3297]: 1DD13200AE3: to=<support@mail.maill>, relay=dovecot, delay=550, delays=550/0.01/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: doveconf: Fatal: open(/etc/dovecot/dovecot.conf) failed: Permission denied ) Ich dachte die Datei hat nicht genug Rechte und habe dieser dann Rechte gegeben da sie wirklich keine hatte, jedoch bringt das garnichts. Ich habe auch schon gegooglet aber nichts gefunden. Habe auch schon Dovecot und Postfix neugestartet.(Die Mailadressen wurden ersetzt durch Examples)
  8. Hi all! First off all, thx a lot for this superior admin panel, i love it! The setup under Debian7 wheezy was straight forward and I am very happy to have gone for froxlor. There was only one problem: I wasn't able to receive E-Mail, sending did work. The /var/log/mail.log: Sep 23 19:12:28 hostname postfix/pipe[8552]: 692BX34A21W: to=<mail@address.tld>, relay=dovecot, delay=155993, delays=155993/0.02/0/0.08, dsn=4.3.0, status=deferred (temporary failure. Command output: doveconf: Fatal: open(/etc/dovecot/dovecot.conf) failed: Permission denied ) Like it says in the froxlor config i did: chmod 0640 "/etc/dovecot/dovecot.conf" chown root:root "/etc/dovecot/dovecot.conf" This wouldn't work and gives the posted fatal error. :-( My solution so far is: change the permission from 640 to 644 and leave the chown as it suggests in the config. Also i changed permission of all files in /etc/dovecot/conf.d/ to 644 as well, leaving the owner and group as it was. After restarting postfix and dovecot everything works here! :-) I am not sure if this is a good fix and would be glad to hear what you think about it. Have a nice day and all the best, hale-xp
  9. Hallo zusammen, ich habe ein Problem bei der Konfiguration von Dovecot auf meinem Server. Es ist ein frisches Debian 7 aufgespielt, per apt-get habe ich die folgenden Pakete installiert (sowie die Abh?ngigkeiten, die automatisch mitinstalliert wurden): mysql-server apache2 php5 php5-gd php5-mysql php5-curl Froxlor 0.9.33.2 habe ich heruntergeladen und eingerichtet. Im Anschluss habe ich mich an die Konfiguration gemacht. Als Mailserver (IMAP/POP3) m?chte ich Dovecot verwenden und habe alle Dovecot installiert sowie alle Dateien entsprechend der anleitung ge?ndert. Beim Neustart von Dovecot mit /etc/init.d/dovecot restart gibt es dann folgende Ausgabe: root@server:/var/www# /etc/init.d/dovecot restart [....] Restarting IMAP/POP3 mail server: dovecotFatal: service(auth) Group doesn't exist: Debian-exim (See service auth { unix_listener /var/run/dovecot/auth-client { group } } setting) failed! root@server:/var/www# Ich bin gerade ziemlich am Verzweifeln, weil ich auch durch Googlen keine L?sung gefunden habe :/. Kann mir jemand sagen, wo der Fehler liegt und wie ich Dovecot richtig konfiguriert bekomme? Vielen Dank im Voraus!
  10. bigshusha

    Postfix/Dovecot unknown user

    Looking for any help/ can't config mail/ i was create email - admin@domain setup roundcube login send email to gmail mailbox and receive it but when replay from google i got from my server Mail Delivery System <MAILER-DAEMON@mail.domain> who can help me please i can post anything to resolve my problem/ //sorry for my English//
  11. Hallo liebe Froxie's, ich habe bei mir leider das Problem, dass ich keine Mails senden/empfangen kann! Ich benutze Postfix Dovecot und habe versucht ?ber Thunderbird meine Mails abzurufen. Das Konto l?sst sich bei Thunderbird nicht wirklich hinzuf?gen und falls, dann kann ich weder Mail's empfangen noch senden. Ich stelle mal einen Ausschnitt meiner Mail.log dazu. Vielleicht k?nnt ihr mir ja helfen! LG Jakob Mail.log Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: mysql:/etc/postfix/mysql-virtual_alias_maps.cf lookup error for "root@mail.BNFC" Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: B481D300343: virtual_alias_maps map lookup problem for root@mail.BNFC -- deferring delivery Jan 14 22:41:30 rs000023 postfix/pickup[13736]: warning: B4A3E300343: message has been queued for 3 days Jan 14 22:41:30 rs000023 postfix/pickup[13736]: B4A3E300343: uid=33 from=<admin@BNFC> Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: B4A3E300343: message-id=<8bebda524d379c6b230ab1ff09521d8c@89.163.227.23> Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: mysql:/etc/postfix/mysql-virtual_alias_maps.cf lookup error for "mail@BenderNetwork.de" Jan 14 22:41:30 rs000023 postfix/cleanup[18375]: warning: B4A3E300343: virtual_alias_maps map lookup problem for mail@BenderNetwork.de -- deferring delivery
  12. Timmaeh

    Ich erhalte keine E-Mails

    Hey, ich habe heute meinen vServer neu aufgesetzt und dabei speziell auf die Installation von Froxlor hingearbeitet. Nachdem ich alle anderen Probleme via Google beheben konnte, sto?e ich nun auf mein gr??tes Problem: Ich erhalte schlichtweg keine E-Mails. Ich habe die in Froxlor angegebenen Konfigurationen f?r Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix/Dovecot Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix MX-Access (anti spam) Debian 7.0 (Wheezy) ? Mailserver (IMAP/POP3) ? Dovecot durchgef?hrt und nachtr?glich mehrmals gepr?ft. Wenn ich nun eine E-Mail von meinem GMail Account an eine in Froxlor angelegte E-Mail Adresse schicke (welche ich wiederum ?ber GMail abrufe), kann ich dem /var/log/mail.log entnehmen, dass eine Verbindung zur froxlor Datenbank aufgebaut wird und die Mail anschlie?end nach 'INBOX' gespeichert wurde. Leider warte ich bei GMail anschlie?end vergebens darauf, dass die E-Mail ankommt. Auch auf Dateiebene unter /var/customers/mail/Kunde/Domain/mail/Maildir/* kann ich nichts von der E-Mail finden. Wenn ich das Prinzip der Ablage richtig verstanden habe, m?sste da ja irgendwo eine Datei mit Namen 'CAJF6H3nemCOW+L9xCU+2nB4iR55WV_QpHjBpf63e=bYG01PuFQ@mail.gmail.com' sein. Wenn ich danach suche, oder nur nach gmail, finde ich nichts. Ich habe auch die froxlor Datenbank durchsucht und keine Tabelle gefunden, in der E-Mails gespeichert sein k?nnten. Zur Info: Die Mails von Froxlor ?ber angelegte Accounts etc. kommen bei GMail an, also muss es meiner Meinung nach etwas mit der Ablage der Mails beim Empfang zu tun haben. Bin also auf Eure Hilfe angewiesen. Kann jemand helfen? Hat jemand einen Verdacht? Gern poste ich weitere Logfiles, jedoch bin ich bis jetzt nicht f?ndig geworden. Danke! Timmaeh
  13. jonnexen

    Tempor?re Outlook Probleme

    Hallo zusammen, ich habe ab und an Probleme mit dem Abrufen von Mails ?ber Outlook, Thunderbird geht stets ohne Probleme. Ich nutze Postfix/Dovecot und die aktuelle Froxlor-Version. Kunden berichten, dass das Abrufen eine ganze Weile funktioniert, dann jedoch angehangener Fehler kommt. Outlook schaltet sich zudem "offline". Ich habe in der 20-imap.conf des Dovecot schon testweise auf mail_max_userip_connections = 50 gestellt, allerdings l?st das mein Problem nicht ganz. Hat jemand Anhaltspunkte f?r mich? Wenn gew?nscht kann ich auch gern erforderliche Configs posten. Apropos: habe die Configs von Froxlor soweit bebeihalten, lediglich auf SSL umgestellt. Danke vorab f?r die Hilfe.
  14. Hello, I just set up a new installation of Froxlor + Ubuntu Server 14.04.1 again and this time dovecot simply do not start after applying the configs given by froxlor. On initial setup it worked fine but since restarting it the first time after adding the froxlo configs it says on next restart "Unknown instance.". There's no error in the log. Any idea what the error/missconfig could be? Thanks for your help.
  15. Hello, I'm currently experiencing some issues on my mailserver setup. It seems like there's a mistake in configuration but I can't figure out which part sucks. I get the following error message: Jul 22 14:58:15 server postfix/smtpd[16170]: warning: SASL: Connect to private/auth failed: No such file or directory Jul 22 14:58:15 server postfix/smtpd[16170]: fatal: no SASL authentication mechanisms Jul 22 14:58:16 server postfix/master[15928]: warning: process /usr/lib/postfix/smtpd pid 16170 exit status 1 Jul 22 14:58:16 server postfix/master[15928]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttlingHow to fix it? Thanks for your help.
  16. cronosdev

    Managesieve

    Guten Tag Gemeinde, ich habe gerade anhand dieses Howto versucht das Filtern von Emails zu erm?glichen. Allerdings komme ich nicht zu gew?nschten Ergebnis. Ich vermute, dass das Tutorial unter einer anderen Version von Dovecot geschrieben wurde und mir so nicht klar ist in welche Dateien ich die Codeschnippsel einf?gen soll. ?ber Unterst?tzung w?rde ich mich sehr freuen. MFG Cronosdev.
  17. Hallo Froxlor-Community, Leider funktioniert bei mir der Mailserver von Froxlor nicht. Wenn ich eine E-Mail an meine EMail-Adresse senden will, bekommt ich immer folgende Meldung zur?ck: This is the mail system at host mail.yourdomain.de. I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below. For further assistance, please send mail to postmaster. If you do so, please include this problem report. You can delete your own text from the attached returned message. The mail system <info@yourdomain.de>: unknown user: "info" Im Postfix log steht folgendes: Feb 22 11:28:15 debian-froxlor postfix/trivial-rewrite[25831]: warning: do not list domain yourdomain.de in BOTH mydestination and virtual_mailbox_domains Feb 22 11:28:15 debian-froxlor postfix/cleanup[25834]: C3D322C0A94: message-id=<DUB122-DS6975034C5B49B5C92E3E2D5840@phx.gbl> Feb 22 11:28:15 debian-froxlor postfix/qmgr[25812]: C3D322C0A94: from=<asdf@live.de>, size=2976, nrcpt=1 (queue active) Feb 22 11:28:15 debian-froxlor postfix/trivial-rewrite[25831]: warning: do not list domain yourdomain.de in BOTH mydestination and virtual_mailbox_domains Feb 22 11:28:15 debian-froxlor postfix/local[25836]: C3D322C0A94: to=<info@ yourdomain.de>, relay=local, delay=0.15, delays=0.14/0.01/0/0.01, dsn=5.1.1,status=bounced (unknown user: "info") leider wei? ich nicht was ich nun machen sollte. Ich hoffe ihr k?nnt mir weiterhelfen, Gr??e, foteteja (die Domain hab ich mit yourdomain.de ersetzt)
  18. Hallo zusammen! Bevor ich mir jetzt meine Installation "zerschie?e", wollte ich gerne mal nachfragen, ob mir jemand Tipps geben kann, bez?glich der Installation von 'dovecot-sieve' und 'dovecot-managesieved'? Folgende Umgebung/ Voraussetzungen: - Debian 7 (Wheezy) - Froxlor 0.9.31.1 (noch nicht auf 0.9.31.2 upgedated) - Postfix + Dovecot 2 + amavis + spamassassin Folgenden Thread habe ich dazu als einzigen hier im Forum gefunden: http://forum.froxlor.org/index.php/topic/926-solved-managesieve-mit-froxlor-dovecot-und-roundcube/ W?re sehr dankbar, wenn wir jemand sagen k?nnte, was ich ggf. an den vorhandenen Froxlor und/ oder anderen Konfigurationsdateien "anpassen" muss! Besten Dank im Voraus! Gru? Gunther
  19. Hallo liebe Froxlor'er, leider hat sich bei mir ein unbekannter Fehler eingeschlichen, und ich bin nicht in der Lage dovecot und Postfix zu konfigurieren. Der Fehler scheint irgendwo in der Config zu stecken, jedoch trotz mehrmaliger Kontrolle nun ueber die gesamte Nacht, ist der Fehler fuer mich nicht erkennbar. Im Error-Log tauchen nur die folgenden Zeilen immer wieder in /var/log/mail.err auf: Dec 29 09:11:54 localhost dovecot: lda(root): Error: user root: Initialization failed: Namespace '': stat(/root/.maildir) failed: Permission denied (euid=65534(nobody) egid=65534(nobody) missing +x perm: /root, dir owned by 0:0 mode=0700) Dec 29 09:11:54 localhost dovecot:lda(root): Fatal: Invalid user settings. Refer to server log for more information. in /var/log/mail.log taucht nur: Dec 29 09:16:54 localhost postfix/local[4464]: 1CA9B1003DFB08: to=<root@mail.domain.tld>, orig_to=<root>, relay=local, delay=1012, delays=1012/0.03/0/0.03, dsn=4.3.0, status deferred (temporary failure) auf zusammen mit obiger Meldung. Die Konfig selbst basiert auf der von froxlor in Version 0.9.31.2 fuer gentoo. Kann hier jemand mir evt helfen, wo ich in meinen Konfigs eventuell einen Fehler gemacht habe, oder was ich noch kontrollieren kann? Gruesse golodhrim
  20. Ich habe die Kombination Postfix/Dovecot ?ber Froxlor komplett eingerichtet und kann intern wunderbar mails schicken. Was nicht funktioniert istdas Mailen von und nach drau?en. Wenn ich eine Mail nach drau?en sende passiert folgendes: Nov 22 18:39:21 domain postfix/smtpd[15986]: connect from unknown[my,own,ip,addr] Nov 22 18:39:21 domain dovecot: auth-worker(16002): mysql(localhost): Connected to database froxlor Nov 22 18:39:22 domain postfix/smtpd[15986]: 0BEED6B2207E: client=unknown[my,own,ip,addr], sasl_method=PLAIN, sasl_username=admin@domain.tld Nov 22 18:39:22 domain postfix/cleanup[16005]: 0BEED6B2207E: message-id=<528F96EC.2080804@domain.tld> Nov 22 18:39:22 domain postfix/qmgr[15881]: 0BEED6B2207E: from=<admin@domain.tld>, size=528, nrcpt=1 (queue active) Nov 22 18:39:22 domain postfix/smtp[16007]: fatal: unknown service: smtp/tcp Nov 22 18:39:22 domain postfix/smtpd[15986]: disconnect from unknown[my,own,ip,addr] Nov 22 18:39:23 domain postfix/qmgr[15881]: warning: private/smtp socket: malformed response Nov 22 18:39:23 domain postfix/qmgr[15881]: warning: transport smtp failure -- see a previous warning/fatal/panic logfile record for the problem description Nov 22 18:39:23 domain postfix/master[15450]: warning: process /usr/lib/postfix/smtp pid 16007 exit status 1 Nov 22 18:39:23 domain postfix/master[15450]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling Nov 22 18:39:23 domain postfix/error[16008]: 0BEED6B2207E: to=<sebastian@other.tld>, relay=none, delay=1.3, delays=0.14/1/0/0.12, dsn=4.3.0, status=deferred (unknown mail trans port error) Wenn ich eine Mail von au?en bekomme das hier: Nov 22 18:43:44 slenz postfix/smtpd[16025]: connect from unknown[209.85.215.171] Nov 22 18:43:44 slenz postfix/smtpd[16025]: NOQUEUE: reject: RCPT from unknown[209.85.215.171]: 450 4.7.1 Client host rejected: cannot find your hostname, [209.85.215.171]; from=<xxx@gmail.com> to=<admin@domain.tld> proto=ESMTP helo=<mail-ea0-f171.google.com> Nov 22 18:43:44 slenz postfix/smtpd[16025]: disconnect from unknown[209.85.215.171] Hierbei l?sst sich der host ohne Probleme aufl?sen: $ dig -x 209.85.215.171 +short mail-ea0-f171.google.com. $ dig mail-ea0-f171.google.com +short 209.85.215.171 Was l?uft hier schief? Und was muss ich ?ndern, damit es funktioniert?
  21. Hi, since version 2.0 Dovecot supports LMTP and the dbox format is ready for production environment. Therefore, it's time to update Froxlor's configuration files for Postfix and Dovecot. Furthermore Dovecot's configuration syntax changed in 2.0. Dovecot is configured for multi-dbox storage. Postfix's final delivery is performed through Dovecot's LMTP server via unix socket. https://gist.github.com/4668341 I hope you like it and as usually all comments and suggestions are very welcomed. Bye Rene
  22. I have an issue with Froxlor on top of Debian. Email does not work, I get the following error mail_location not set and autodetection failed I looked at the dovecot-sql.conf thinking the queries must be wrong and returning errors rather than results. I have run both quirers manually and they results seem to be what you would expect. Currently both the dovecot.conf and the dovecot-sql.conf are exactly as per the setup instructions. Thank you in advance for any help you can give me.
  23. Hallo, ich habe von heute auf morgen das Problem, das Postfix/Dovecot Mails von virtuellen Nutzern nicht mehr zustellt. Bei regul?ren Nutzern klappt die Zustellung problemlos... Die Konfiguration l?uft mit Froxlor! ($DOMAIN wurde ersetzt...) Als Sender einer Mail bekomme ich folgenden Fehler zur?ck: <post@$DOMAIN>: user unknown Action: failed Status: 5.1.1 Diagnostic-Code: x-unix; user unknown Ich habe Dovecot und Postfix im Debug hochgestellt, habe aber keinerlei Anhaltspunkt. Es scheint mir so, als w?rde Postfix die zwei richtigen Empf?nger (a und b finden), reicht diese aber nicht an Dovecot weiter. postfix/smtpd[5270]: dict_mysql_lookup: retrieved 1 rows postfix/smtpd[5270]: maps_find: virtual_alias_maps: mysql:/etc/postfix/mysql-virtual_alias_maps.cf(0,lock|fold_fix): post@$DOMAIN = a@$DOMAIN b@$DOMAIN postfix/smtpd[5270]: mail_addr_find: post@$DOMAIN -> a@$DOMAIN b@$DOMAIN Bei Dovecot in der Log kommt folgendes an: deliver(post@$DOMAIN): Info: Loading modules from directory: /usr/lib/dovecot/modules/lda deliver(post@$DOMAIN): Info: Module loaded: /usr/lib/dovecot/modules/lda/lib10_quota_plugin.so deliver(post@$DOMAIN): Info: Module loaded: /usr/lib/dovecot/modules/lda/lib90_sieve_plugin.so auth(default): Info: master in: USER 1 post@$DOMAIN service=deliver auth(default): Info: prefetch(post@$DOMAIN): passdb didn't return userdb entries, trying the next userdb auth-worker(default): Info: sql(post@$DOMAIN): SELECT CONCAT(homedir, maildir) AS home, CONCAT('maildir:', homedir, maildir) AS mail, uid, gid, CONCAT('maildir:storage=', (quota*1024)) as quota FROM mail_users WHERE (username = 'post@$DOMAIN' OR email = 'post@$DOMAIN') auth-worker(default): Info: sql(post@$DOMAIN): Unknown user auth(default): Info: master out: NOTFOUND 1 Anschlie?end in den Postfix-Logs: postfix/pipe[5277]: 1922E110A6BB: to=<post@$DOMAIN>, relay=dovecot, delay=0.13, delays=0.11/0/0/0.02, dsn=5.1.1, status=bounced (user unknown) Der SQL-Error hat auch Sinn, da die virtuellen Nutzer in der SQL-Tabelle mail_virtual stehen und nicht in der mail_users. Dovecot hat gem?? den Konfigurationsdateien keinen Zugriff auf die mail_virtual, ausschlie?lich Posttifx, das hat die letzten Wochen aber immer geklappt. Kann jemand Hilfe beim Debugging leisten? Postfix: main.cf ## Dovecot Settings for deliver, SASL Auth and virtual transport smtpd_sasl_type = dovecot mailbox_command = /usr/lib/dovecot/deliver virtual_transport = dovecot dovecot_destination_recipient_limit = 1
  24. Hallo, ich betreibe seit einiger Zeit ein Debian System inkl. Froxlor und roundcube. Es funktioniert zwar alles aber einige Eintr?ge in meinen Logs gefallen mir einfach nicht. Problem 1: Ich bekomme immer wieder den Eintrag "Fatal: Namespace initialization failed"... in der mail.warn. Wie gesagt es geht alles, aber solcher Fehlerlogs m?ssen ja nicht sein Problem 2: Bekomme den Fehler "mail_location not set and autodetection failed: Mail storage autodetect failed with home=/home/musteruser". Wenn ich die dovecot.conf um "mail_location = /var/spool/mail/%u" erg?nze verschwindet zwar die erste Meldung aber ich bekommen dann "mail_location: Ambiguous mail location setting, don?t know what to do with it: /var/spool/mail/%u" Problem 3: Ich wei? nicht wirklich ob es sich dabei um einen Systemfehler handelt. Auf dem Server befinden sich auch ein paar php mailer... bisher ging wie gesagt immer alles. Nun ist es so das alle Mails welche zu externen anbietern gesendet werden (web.de, gmx.de, t-online.de) mit einer Bounce-Message abgelehnt werden. Mails welche manuell (mit webmailer oder E-Mail Client) versendet werden gehen aber. Reverse DNS-Mapping korrekt eingerichtet.. aber das sollte klar sein, da sonst auch die Mails wleche manuell versendet werden abgelehnt w?rden. Wurde diesbez?glich was an php/apache ge?ndert? Ich habe das Gef?hl das besagtes Problem erst seit dem neusten Update besteht. (es wurden ja Updates f?r Apache/php ausgeliefert) Problem Nummer 3 habe ich behoben, lag an einer Einstellung in der Main.cf von Postfix. Bleiben also nur noch 2 Probleme ?brig. Danke im Voraus f?r eure Hilfe
  25. Hallo, ich betreibe seit einiger Zeit ein Debian System inkl. Froxlor und roundcube. Es funktioniert zwar alles aber einige Eintr?ge in meinen Logs gefallen mir einfach nicht. Problem 1: Ich bekomme immer wieder den Eintrag "Fatal: Namespace initialization failed"... in der mail.warn. Wie gesagt es geht alles, aber solcher Fehlerlogs m?ssen ja nicht sein Problem 2: Bekomme den Fehler "mail_location not set and autodetection failed: Mail storage autodetect failed with home=/home/musteruser". Wenn ich die dovecot.conf um "mail_location = /var/spool/mail/%u" erg?nze verschwindet zwar die erste Meldung aber ich bekommen dann "mail_location: Ambiguous mail location setting, don?t know what to do with it: /var/spool/mail/%u" Problem 3: Ich wei? nicht wirklich ob es sich dabei um einen Systemfehler handelt. Auf dem Server befinden sich auch ein paar php mailer... bisher ging wie gesagt immer alles. Nun ist es so das alle Mails welche zu externen anbietern gesendet werden (web.de, gmx.de, t-online.de) mit einer Bounce-Message abgelehnt werden. Mails welche manuell (mit webmailer oder E-Mail Client) versendet werden gehen aber. Reverse DNS-Mapping korrekt eingerichtet.. aber das sollte klar sein, da sonst auch die Mails wleche manuell versendet werden abgelehnt w?rden. Wurde diesbez?glich was an php/apache ge?ndert? Ich habe das Gef?hl das besagtes Problem erst seit dem neusten Update besteht. (es wurden ja Updates f?r Apache/php ausgeliefert) Danke im Voraus f?r eure Hilfe
×