Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'PHP-FPM'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 13 results

  1. Warning, this is not an official guide!!! 1. sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list sudo nano /etc/apt/source.list 1b. insert (for Debian Stretch) 1.2B (for Ubuntu Cosmic) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server 2. MariaDB install Warning use sudo command für this install! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional) 3. nginx install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 4. PHP install sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. sudo service nginx restart sudo service php7.3-fpm restart Froxlor install There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master) Stable Version 1. cd /var/www/html/ 1a. sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or Git Version (Beta Version) sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory composer install --no-dev 1b. sudo chown -R www-data:www-data Froxlor/ Set up Froxlor 2. Open Your Browser 2a. http://your IP or Hostname/Froxlor Install Froxlor finish  3d. Move userdata (Optional) sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. sudo rm /etc/nginx/site-enable/default don't restart nginx! Froxlor Settings 1. Cronjob sudo nano /etc/cron.d/froxlor insert # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock 3. sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated:Change from NO to YES 3a. PHP-FPM versionsChange > php-fpm restart command: service php7.3-fpm restart and Configuration directory of php-fpm: > to /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate 1. sudo apt install certbot 1a. sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. sudo nano /etc/nginx/acme.conf insert location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfileinsert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > SettingsActivate > Enable Let's Encrypt Change Path to the acme.conf snippet to > /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings- Enable Let's Encrypt for the froxlor vhost- Enable SSL-redirect for the froxlor vhost- HTTP Strict Transport Security (HSTS)- Include HSTS for any subdomain 2d. Activated HTTP2 Support on > Settings > Nginx
  2. Wenn running "froxlor_master_cronjob.php -- tasks", it produces this error at the end: sh: 1: /etc/init.d/php-fpm: not found On Debian Stretch with PHP 7.2, this should be "/etc/init.d/php7.2-fpm". Is this a configuration setting? I can't find it.
  3. Good morning, after the restart of the vps I find the following problem: AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/10_froxlor_ipandport www1 apache2[2426]: Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration.
  4. Hi, because I had some issues with HTTP2 and php via fcgid under Apache I tried to switch to php_fpm. While I was at it, I noticed a problem that I couldn't pinpoint and decided to try nginx. The issue stayed the same, basically these log entries: nginx: connect() to unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: xx.xx.xx.xx, server: domainname.de, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket:", host: "domainname.de", referrer: "https://domainname.de/" Apache: (13)Permission denied: [client xx.xx.xx.xx:63318] FastCGI: failed to connect to server "/var/www/php-fpm/web2/domainname.de/ssl-fpm.external": connect() failed The way I understand this problem: By design, php-fpm sockets created by Froxlor have permissions which only allow the vhost user to connect. But neither Apache nor nginx are told anywhere under which identity to connect to the socket. The SuExecUserGroup line in the vhost config file for Apache which does this for fcgid vanished when switching to php-fpm. I currently solved the problem by changing the line "listen.owner" inside the php-fpm pools to "www-data". That should not lower security, because php-fpm in itself takes care that the php process runs as the vhost user. Can someone tell me where I misunderstood the whole concept?
  5. Hi all, is it possible to use a shared php-fpm pool for a domain and its subdomains? I have a domain with ~80 subdomains for the local branches of a political party. I can't use a wildcard domain because we're using Let's Encrypt certificates, and an alias domain seems to not work either for the same reason. However, having 80+ php-fpm pools is a little high on the memory side. Do you have any advice for me? Best regards
  6. Hello! I have this error HTTP Error: Missing header/body separator, in my web app when PHP-FPM is enabled. When I disabled PHP-FPM the web app works fine. Any idea or additional config to php-fpm?? Thank you, Regards.
  7. Hi There, Anyone kwons How to solve froxlor-user in the customer groups (for FCGID/php-fpm) -- FAIL? In the database validation. I click in Fix problems automatically, but after the next cronjob run. It FAIL again. Regards,
  8. Moin moin, ich bereite gerade einen Migrationspfad für einen veralteten Server vor und möchte nat. viele Altlasten damit bereinigen. Ich möchte gern PHP-FPM mit Apache 2.4 nutzen. PHP soll per default in der Version 5.6.x laufen. Dies funktioniert auch alles prima. Nun ist es allerdings so, das es auch ältere WebApps gibt die nur mit PHP 5.3/4 laufen und auch Kunden, welche immer wieder nach PHP 7 fragen. Grundsätzlich ist es ja möglich verschiedene Instanzen aufzusetzen, hab hier PHP 5.4/5.6/7 laufen, natürlich von Hand konfiguriert. Das möchte nat. niemand auf Dauer machen;) Nun wäre es schön wenn es möglich wäre, verschiedene FPM Instanzen zu hinterlegen, so wie dies schon in den Einstellungen gemacht wird aber eben von 1-n und diese dann den vhosts zugewiesen werden könnte. Ja ich weiss das es dies noch nicht gibt und Feature Requests sind immer nervig weil man ja immer was anderes zu tun hat. Ich hätte kein Problem damit mich selbst dafür einzubringen , es wäre halt schön wenn man ein paar Tips bekäme wo anzusetzen ist, Programmier Konventionen etc. pp, sozusagen eine Schnellbesohlung, dann könnt man mal forken und schaun obs geht und ggf. hier zur Verfügung stellen (wenn gewünscht). Meine Deadline ist ende Juni für den Server daher muss ich bis dahin eine adäquateLösung haben, im Zweifel halt wieder Apache 2.2 mit fcgid aber wer will schon alte Kamellen wenn man die Sache grad anpackt, soll ja wieder eine Weile laufen und den Anforderungen genügen. Würde mich über Feedback freuen. lg max
  9. so, die allseits beliebte Fehlermeldung hat mich wieder erwischt: [Mon Apr 25 14:16:00.645665 2016] [fastcgi:error] [pid 991:tid 140379730966272] (13)Permission denied: [client 79.205.198.74:60848] FastCGI: failed to connect to server "/var/www/php-fpm/PKMD/pkmd.de/fpm.external": connect() failed [Mon Apr 25 14:16:00.645742 2016] [fastcgi:error] [pid 991:tid 140379730966272] [client 79.205.198.74:60848] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/PKMD/pkmd.de/fpm.external" Den Dateinamen gibt es zwar nicht, aber den Socket schon: srw-rw---- 1 PKMD PKMD 0 Apr 25 14:22 pkmd-pkmd.de-php-fpm.socket in /etc/php5/fpm/pool.d/pkmd.de.conf findet sich [pkmd.de] listen = /var/lib/apache2/fastcgi/pkmd-pkmd.de-php-fpm.socket listen.owner = PKMD listen.group = PKMD listen.mode = 0660 user = PKMD group = PKMD und das Ganze wird auch in /etc/php5/fpm/php-fpm.conf eingebunden: include=/etc/php5/fpm/pool.d/*.conf Das Froxlor-Panel (0.9.35.1-1+wheezy1) geht auch noch. Auch wenn das Debian 8 ist. Und der Dienst scheint zu laufen: ● php5-fpm.service - LSB: starts php5-fpm Loaded: loaded (/etc/init.d/php5-fpm) Active: active (running) since Mon 2016-04-25 14:22:02 CEST; 20min ago Process: 2225 ExecStop=/etc/init.d/php5-fpm stop (code=exited, status=0/SUCCESS) Process: 2233 ExecStart=/etc/init.d/php5-fpm start (code=exited, status=0/SUCCESS) CGroup: /system.slice/php5-fpm.service └─2245 php-fpm: master process (/etc/php5/fpm/php-fpm.conf) Wo muß ich sonst noch gucken? danke schonmal
  10. Hallihallo liebes Forum, ich muss nach einer langen Recherche aufgeben und mal nachfragen. Und zwar geht es konkret darum Froxlor Kunden-Domains mit SSL-Zertifikaten zu best?cken. Wie schon erw?hnt, habe ich mich umgehend umgeschaut und kam nicht wirklich zu einer L?sung des Problems durch Suchen und Ausprobieren. Mal vorweg das Problem: nginx liefert dem Browser das SSL-Zertifikat, was unter "IP and Ports" hinterlegt wurde, also quasi sowas wie das "Server-Fallback-Zertifikat" statt dem SSL-Zertifikat, was der Kunde angelegt hat. Das ist so nat?rlich nicht praktikabel und daher kann da ja nur etwas nicht stimmen. Zu den technischen Details: Der Server ist ein Debian 3.2.65-1+deb7u2 x86_64 Es l?uft Froxlor 0.9.33.1-1 Es l?uft nginx 1.6.2 (SNI-Support) sowie php5-fpm PHP 5.4.36-0+deb7u3 Ich benutze aktuelle Browser mit SNI-Support Die Kunden k?nnen erfolgreich als "virtuelle" UNIX User gemappt werden (also f?r PHP-Socket-Zugriff etc.) Die nginx Vhost Dateien: IP und Port SSL-Vhost: http://nopaste.linux-dev.org/?450919 Kunden SSL-Vhost: http://nopaste.linux-dev.org/?450920 Wie ich das sehe, sieht das korrekt aus, oder? Das Problem ist nun, dass ich statt dem Kunden SSL Zertifikat das der IP bekomme, also das unter /pfad/zum/server/cert.crt. Was ich schon gemacht habe: s?mtliche Einstellungen der IP ge?ndert (alle Checkboxen mal durchprobiert), also diese Vhost-Container ja/nein, Servername ja/nein, ? Domains gel?scht/neu hinzugef?gt Zertifikate gel?scht/neu hinzugef?gt Configs neu geschrieben Services neu gestartet Was sonst noch so passiert: L?sche ich das der IP hinterlegte SSL-Zertifikat, sagt nginx bei einer Anfrage auf die SSL-Kunden-Domain, dass kein SSL-Zertifikat angegeben wurde Vielleicht habe ich einige Daten, Fakten und Dinge, die ich schon probiert habe, vergessen zu erw?hnen. Fragt doch bitte, wenn was fehlt oder unklar ist. ?ber Denkanst??e w?re ich sehr dankbar, ich bin noch recht neu um Umgang mir Froxlor und wollte jetzt mal die SSL-Implementation testen? Ich gehe mal davon aus, dass mein Fehler recht trivial sein d?rfte.
  11. Hi, OS: Ubuntu 15.04, Webserver: nginx, PHP-FPM aktiviert? Ja! Soweit funktioniert alles, Kunden werden angelegt und man kann problemlos auf deren Seite verbinden und sieht die index.html. Wenn ich jetzt aber die index.html in index.php umbenenne, erhalte ich einen 502 gateway timed out fehler. Errorlog vom Kunden: Das Gleiche passiert bei einem Reboot. Ein simples "service nginx reload" behebt den Fehler. Kunde ist in der Webservergruppe vorhanden. nscd etc. sind richtig konfiguriert, bin nach dem offiziellen Howto gegangen. Einstellungen sollten richtig sein: Die Sockets von PHP-FPM werden auch angelegt. vhost.conf vom Kunden: php-fpm.conf (/etc/php5/fpm): Den Fehler kann ich mit: "service nginx reload" wie erw?hnt beheben. Ein "chmod 666" auf den php-fpm.socket l?st das Problem nach dem Reboot ebenfalls, jedoch m?chte ich ungern an den Rechten rumschrauben. Ebenfalls wird das problem gel?st indem ich den Master-Cronjob ausf?hre. Wobei, wenn nginx restarted/reloaded wird, ?ndert der ja nichts an den Rechten vom php-fpm.socket - also kann es nicht die L?sung sein, die chmod-Rechte auf jeden socket zu erh?hen. Edit: Habe gerade mal das System neu gestartet und sehe in der syslog folgendes: Habe aber in der nscd in der Zeile bei required-start mysql eingetragen, also d?rfte es zu dem Fehler nicht kommen. Die Daten stimmen 100% ?berein, ein manuelles Einloggverfahren mit den gleichen Daten funktioniert problemlos.
  12. Ich versuche verzweifelt o.g. Konfiguration zum Laufen zu bringen, scheitere aber bereits bei der Installation an den ersten Schritten. Ich hoffe, Ihr k?nnte mir helfen. Bei der Installation halte ich mich an dieser Anleitung FPM - handbook - Froxlor. Bei der Ausf?hrung des Befehls ?apt-get install libnss-mysql-bg nscd libapache2-mod-fastcgi apache2-suexec php5-fpm? kommt die Meldung ?Package libapache2-mod-fastcgi is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libapache2-mod-fastcgi' has no installation candidate? Ich habe die Source-Listen wie folgt angepasst: ftp.es.debian.org/debian stable main contrib non-freedeb-src ftp.es.debian.org/debian stable main contrib non-freedeb ftp.debian.org/debian/ wheezy-updates main contrib non-freedeb-src ftp.debian.org/debian/ wheezy-updates main contrib non-freedeb security.debian.org/ wheezy/updates main contrib non-freedeb-src security.debian.org/ wheezy/updates main contrib non-free Nach 'apt-get update' funktioniert auch die Installation. W?hrend der Installation folgt dann die Frage, wie mit dem Konfiguration File ?/etc/apache2/apche2.conf? umgegangen werden soll. Hier bin mir unschl?ssig. Ich habe die ?Install the package maintrainer?s version? versucht. Dann funktioniert Froxlor nicht mehr. Ich habe es auch mit der Beibehaltung der aktuellen Version versucht. Dann l?sst sich aber Apache nicht mehr starten. (?apache2: Syntax error on line 265 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/conf.d/: No such file or directory?). Leider finde ich dazu keine Hinweise oder Anleitungen. Hat von Euch jemand eine Idee?
  13. Hallo, ich habe gerade einen neuen Server aufgesetzt. Ubuntu 14.04 LTS, Apache2, Froxlor 0.9.33 mit PHP-FPM Leider haben alle Benutzer die selbe php.ini. Loaded Configuration File /etc/php5/fpm/php.ini Sonst funktioniert das mit den Benutzern alles korrekt. Ich habe auch mal Dein Youtube Video geschaut. Aber da ist am ende der gleiche Pfad. Im Forum hattest Du 2014 geschrieben, dass das Problem behoben w?re. Was kann ich tun? http://shoplive.server31.skyweb.hosting/phpinfo.php https://gist.github.com/cosmomill/4753944 https://forum.froxlor.org/index.php/topic/11662-merged-add-custom-phpini-files-for-php-fpm/ Viele Gr??e Stefan
×
×
  • Create New...