Jump to content
Froxlor Forum

Balumir

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Balumir

  • Rank
    Newbie
  1. Kleiner technischer Workaround... In der Froxlor-DB in der Tabelle "domain_ssl_settings" das Zertifikat für die Domain identifizeiren und dann die Spalte "expirationdate" auf jetzt+1-Stunde setzen. Froxlor fängt dann mit der normalen Verlängerung an und hat im CSR die SAN neu aufgelistet und mein "www..." ist jetzt enthalten. Frage an die Entwickler: Gibt es für sowas einen Mechanismuss? Macht es evtl. sowas automatisch triggern zu lassen oder in der Seite "SSL Certificates" einen "renew" button mit einzubauen?
  2. Hallo, gibt es eine Möglichkeit ein LE-Zertifikat vor dem Ablaufdatum zu erneuern? Hintergrund ist, dass bei einem bereits ausgestellten Zertifikat für eine Domain der SAN für www.domain.tld hinzugefügt werden soll und ich nicht auf das Zertifikatsablaufdatum warten kann. Und bei einer Site mit bestehender http2https-Redirection das Cert löschen, um es neu generieren zu lassen, würde ja mindestens 2 Konfigzyklen ohne SSL bedeuten... viele Grüße Frank
  3. Hallo, ich habe einen Froxor-Server, der sich hinter einer Firewall befindet und mit privaten IPs installiert ist. Die Firewall leitet die Anfragen per NAT auf den Server weiter. Ohne SSL hat bisher alles sauber funktioniert. Die Lets-Encrypt funktion bekomme ich nicht ohne Workaround zum laufen. Die DNS-Auflösung weist auf den öffentiche IP der Firwall. Die Firwall kann allerdings den connect von innen auf die öffentlche NAT-IP nicht anständig behandelt so dass die Überprüfung des Challenge-Files nicht funktioniert. Mein Workaround ist daher, dass ich die Hostnamen der Lets-Encrypt Domains mit der privaten IP-Adresse in die /etc/hosts eintrage. Damit läuft der curl-Aufruf für die Validierung direkt auf die private IP und alles klappt. Das ist natürlich Fehleranfällig. Gibt es eine Möglichkeit, den Self-Check des Challenge-Files abzuschalten? Den Versuch, den Betreiber dieser sch... Firewall in die Pflicht zu nehmen, musste ich leider als gescheitert erklären. Angeblich geht das mit der Firewall nicht... Der Vollständigkeit halber... Der Check von den Lets-Encrypt Server funktioniert sauber, da der ja von extern auf die NAT-IP geht. viele Grüße Frank Nachtrag: Version: Git cf4f15a83c4769347ee3175c6a5d1dc399df89dc (19.12.17)
  4. Ich habe folgende Einstellungen gemacht: Enable PHP-FPM for the Froxlor vHost = ja Local user to use for PHP-FPM (Froxlor vHost) = froxlorlocal Local group to use for PHP-FPM (Froxlor vHost) = froxlorlocal Der ganze Bereich "Enable FCGID for the Froxlor vHost" ist dementsprechend deaktiviert. Aber ich hab sicherheitshalber jetzt nochmal einen weiteren Customer angelegt. Den ersten Customer habe ich wohl angelegt, als die Installation noch nicht auf php-fpm umgestellt war. Beim Speichern eines existierenden Customers fasst er die members scheinbar nicht mehr an. Beim Neuanlegen habe ich jetzt auch froxlorlocal in den members und ich kann FTP-User anlegen, ohne das es die PHP-Exception gibt. Muss ich mir gleich mal ins Kochbuch schreiben. Testkunden erst anlegen, wenn alle anderen Konfigurationen fertig sind. Danke für die Tips.
  5. Den www-data User hat er in die Gruppe mit aufgenommen. Aber beim froxlorlocal ist das nicht erfolgt: # id -a www-data uid=33(www-data) gid=33(www-data) groups=33(www-data),9999(froxlorlocal),10000(fae) # id -a froxlorlocal uid=9999(froxlorlocal) gid=9999(froxlorlocal) groups=9999(froxlorlocal),33(www-data) Das Ganze ist aber auch imho unabhängig von der libnss-mysql.cfg, weil die Infos schon nicht in der DB stehen: select * from ftp_groups; +----+-----------+-------+--------------+------------+ | id | groupname | gid | members | customerid | +----+-----------+-------+--------------+------------+ | 1 | fae | 10000 | fae,www-data | 1 | +----+-----------+-------+--------------+------------+ ...die Debian-Spezialität hab ich noch separat am Wickel. Bei mir funktioniert die Rückgabe des memsbygid nicht, weil die libnss-mysql-bg das scheinbar nicht als CSV sondern als mehrere Rows erwartet und daher abschmiert. Ich hab im github schon die Ansätze des libnss-extrausers gesehen. Das steht bei mir als nächstes auf der Testliste...
  6. Moin, Ich habe ein Froxlor 0.9.38.7 auf Debian Jessie mit Apache 2.4 und PHP-FPM installiert. Der Froxlor VHost läuft als User froxlorlocal:froxlorlocal und der Webserver mit www-data:www-data. Beim Anlegen der DocumentRoots werden scheinbar seit einiger Zeit nur noch Rechte für User und Gruppe gesetzt. Beim Editorieren oder neu Anlegen von FTP-Benutzer durch den Customer bekomme ich jetzt eine weiße Seite und im Log bekomme ich: stderr: PHP message: PHP Fatal error: Uncaught UnexpectedValueException: RecursiveDirectoryIterator::__construct(/srv/customers/webs/fae/): failed to open dir: Permission denied in /var/www/html/froxlor/lib/functions/filedir/function.findDirs.php:67 Ich habe in den Einstellungen nichts gesehen, dass ich hierzu noch extra Settings machen muss. Kann mir jemand sagen, wie ich entweder dem Froxlor den Versuch abgewöhne, auf die VHost DocumentRoots zugreifen zu wollen, oder wie ich das zum laufen bekomme? viele Grüße Frank
×
×
  • Create New...