Jump to content
Froxlor Forum

plusterkopp

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About plusterkopp

  • Rank
    Newbie
  1. Hmm, also ich habe dem Froxlor an anderer Stelle gesagt, daß ich einen Apache 2.4 habe. Und ich habe ihn auch seitdem schon ein paar mal die Konfigs neu schreiben lassen. Natürlich habe ich kein Problem damit, hier auch mal Konfigs selbst zu schreiben bzw zu verändern, aber dann sollte das idealerweise irgendwo stehen oder die Fehlermeldungen sollten irgendwie ein bißchen helfen, die Stelle zu finden, wo was falsch ist. Bis zu meinem letzten Neustart heute Mittag ging das nämlich und davor (eine Woche etwa) hatte ich nur den Froxlor mal aktualisiert, der seitdem in der neuen Version lief. Der 2.4er Apache lief schon seit Monaten so, seit ich auf Deb 8 umgestiegen bin. Aber wenn ich das richtig sehe, scheint das kein Froxlor-Problem zu sein, denn die mod_fastcgi Konfig wird ja nicht dort gemacht. Und Asche-auf-mein-Haupt: die Konfig-Anleitungen habe ich mir nie angesehen, weil ich immer dachte, da wird gleich alles übergebügelt, wenn ich was anclicke. Der Tag hat sich gelohnt, vielen Dank
  2. da steht: # http://redmine.froxlor.org/projects/froxlor/wiki/FPM_-_handbook <IfModule mod_fastcgi.c> AddHandler fastcgi-script .fcgi # FastCgiWrapper /usr/lib/apache2/suexec FastCgiIpcDir /var/lib/apache2/fastcgi <Location "/fastcgiphp"> Order Deny,Allow Deny from All # Prevent accessing this path directly Allow from env=REDIRECT_STATUS </Location> </IfModule>
  3. </VirtualHost> LoadModule ssl_module /usr/lib/apache2/modules/mod_ssl.so Listen 443 <VirtualHost 37.120.161.140:443> ServerName pkmd.de ServerAlias www.pkmd.de ServerAdmin bummer@gmx.net DocumentRoot "/var/customers/webs/PKMD/" <Directory "/var/customers/webs/PKMD/"> <FilesMatch "\.php$"> SetHandler php5-fastcgi Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> Order allow,deny allow from all </Directory> Alias /fastcgiphp /var/www/php-fpm/PKMD/pkmd.de/fpm.external Alias /webalizer "/var/customers/webs/PKMD/webalizer/pkmd.de" ErrorLog "/var/customers/logs/PKMD-pkmd.de-error.log" CustomLog "/var/customers/logs/PKMD-pkmd.de-access.log" combined SSL...
  4. so, die allseits beliebte Fehlermeldung hat mich wieder erwischt: [Mon Apr 25 14:16:00.645665 2016] [fastcgi:error] [pid 991:tid 140379730966272] (13)Permission denied: [client 79.205.198.74:60848] FastCGI: failed to connect to server "/var/www/php-fpm/PKMD/pkmd.de/fpm.external": connect() failed [Mon Apr 25 14:16:00.645742 2016] [fastcgi:error] [pid 991:tid 140379730966272] [client 79.205.198.74:60848] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/PKMD/pkmd.de/fpm.external" Den Dateinamen gibt es zwar nicht, aber den Socket schon: srw-rw---- 1 PKMD PKMD 0 Apr 25 14:22 pkmd-pkmd.de-php-fpm.socket in /etc/php5/fpm/pool.d/pkmd.de.conf findet sich [pkmd.de] listen = /var/lib/apache2/fastcgi/pkmd-pkmd.de-php-fpm.socket listen.owner = PKMD listen.group = PKMD listen.mode = 0660 user = PKMD group = PKMD und das Ganze wird auch in /etc/php5/fpm/php-fpm.conf eingebunden: include=/etc/php5/fpm/pool.d/*.conf Das Froxlor-Panel (0.9.35.1-1+wheezy1) geht auch noch. Auch wenn das Debian 8 ist. Und der Dienst scheint zu laufen: ● php5-fpm.service - LSB: starts php5-fpm Loaded: loaded (/etc/init.d/php5-fpm) Active: active (running) since Mon 2016-04-25 14:22:02 CEST; 20min ago Process: 2225 ExecStop=/etc/init.d/php5-fpm stop (code=exited, status=0/SUCCESS) Process: 2233 ExecStart=/etc/init.d/php5-fpm start (code=exited, status=0/SUCCESS) CGroup: /system.slice/php5-fpm.service └─2245 php-fpm: master process (/etc/php5/fpm/php-fpm.conf) Wo muß ich sonst noch gucken? danke schonmal
×
×
  • Create New...