Jump to content
Froxlor Forum

caroman

Members
  • Content Count

    28
  • Joined

  • Last visited

Posts posted by caroman


  1. Hallo,

    In der Beseitigung der Fehlermeldungen aus der Syslog wurde ein LogIn-Fehler unter Verweis auf die "/etc/dovecot/dovecot-sql.conf.ext" angezeigt. Den Fehler konnte ich dadurch beseitigen, in dem ich das Passwort mit Gäsefüßchen versah.

    Jetzt kommt noch der Fehler

    "Nov 16 11:47:50 webmail dovecot: auth-worker(28600): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 5 seconds before retry"

    den ich nicht wegbekomme: Der Fehler weist expliziet auf DOVECOT hin. In der Diagnose ging ich in die Einstellungen zu Dovecot und habe nur die "dovecot-sql.conf.ext" ausgemacht, in welcher das Datanbankpasswort definiert ist. Hab ich eine Stelle übersehen?

    Angenommen, ich müsste das Passwort der Datenbank hinsichtlich Sonderzeichen etwas entschlacken, in welcher Froxlor-Datei muss bitte das Datenbankpasswort angepasst werden? Dabei meine ich NICHT die Configurationsfiles, sondern die Datei, damit Froxlor die Adminnistartionsoberfläche laden kann.

    Danke für den Tip im Voraus !!!


  2. Jup, extrausers kommt zum Einsatz. Hab mal nachgesehen, wie es auf dem BusterServer mit den Datein

    /var/lib/extrausers/passwd
    /var/lib/extrausers/group
    /var/lib/extrausers/shadow


    ausssieht. Die waren leer, wie am Anfang, erkllärt alles. Hab dann einen DemoKunden und hierfür eine Domain angelegt, plötzlich waren alle Einträge da, auch nach dem Extrahieren der Customers stimmten die Owner.

    Was ich außen vor ließ ist, dass neue Passwörter für MySQL root, MySQL froxlor uns das Admin-Passwort vergeben wurden, das dürfte jedoch nicht ursächlich sein. Natürlich ist klar, dass die Anpassung in den Configurationsdateien erfolgen muss, soweit erforderlich.


  3. Hallo,

    verabschiede mich gerade von Strech und stelle um auf Buster. Auf Stretch habe ich das Update auf die letzte Version durchgeführt, ohne Probleme.

    Die Froxlor Datenbank habe ich gesichert und auf den BusterServer kopiert.

    Die Froxlor Installation auf dem BusterServer iss sauber durchgelaufen, hab die mit der Installation angelegte Datenbank gesichert und dann die Datenbank aus Stretch zurück kopiert.

    Auch das zurück kopieren der Datenbank klappte auch ohne Probleme, alles wird angezeigt. Muss danach noch schnell die IP's ändern, alles kein Problem.

    Wer ahnt's, es zwickt an einer anderen Stelle: Die User müssten aus der Froxlor Datenbank dem System bekannt gemacht werden, das scheint noch nicht zu klappen:

    Wenn ich die webs aus der tgz extrahiere, werden die owner in Zahlen ausgegeben.

    Außerdem jammert der Apache herum:  "bad user name ImmoService" könnte sein, dass das mit den ownern zusammenhängt, das Log-File gibt noch nichts sinnvolles her. Da muss ich noch forschen.

    Ist bekannt, dass ein einfaches kopieren des customers-Verzeichnis von mit seinen UnterverzeichnissenStretch nach Buster nicht reicht?

    Danke für die Antwort schon mal im Voraus !!!! und danke für die super Software in den vergangenen Monaten !!!!!!


  4. Ahhh, hab Froxlor auch gleich aktualisiert, danke für den Hinweis.

    Den Mailserver habe ich auch gleich anstelle des localhost definiert und beim testen rausgefunden, dass wenn die Bestätigungsmail (aus welchen Gründen auch immer) beim Eröffnen eines Postfachs nicht zugestellt werden kann, ich sodann auf "zurück" klicke, einen leeren Screen bekomme.

    Bei weiteren Tests habe ich festgestellt, dass es bei der Verwendung von Zertifikaten absolut keine Probleme gibt, wenn Hostname für den Webserver und Host des MailServers identisch sind. Weichen diese voneinander ab, so kann die Bestätigungsmail wegen der Verwendung verschiedener Zertifikate nicht zugestellt werden. Gibt es eine von mir noch nicht entdeckte Möglichkeit, die Zertifikate alleine für den MailServer zu definieren?


  5. Fürchte über einen kleinen Bug berichten zu müssen: Auf meinem neu installierten und mit Altdaten zurückgesicherten Server klappt 'fast' alles super. Eine Kleinigkeit ist mir heute aufgefallen:

    Das Anlegen eines Postfachs dauerte ewig lang. Nach ein paar Minuten kam eine Fehlermeldung, dass das Versenden einer Nachricht an die betreffende Mailadresse fehlschlug.
    In den Einstellungen hatte ich bei der Froxlor Installation den Port 465 eingetragen. Die Fehlermeldung legte zunächst den Verdacht nahe, dass die Portadresse ursächlich sein könnte, ergo anderte ich die Adrese zurück, auf 25, speicherte ab und legte erneut ein Postfach an. Dann kam nach Sekunden die im Titel bezeichnete Fehlermeldung. Versenden der Begrüßungsmail hat trotzdem nicht geklappt, der Ursache werde ich weiter nachgehen.

    Das Froxlor habe ich am 22.12.2017 vom Github geholt, dürfte somit die letzte Version sein.

    2018-01-03_081015.jpg


  6. Der Apache 2.4 in der neuen Debian Stretch Version bringt leider Änderungen mit sich, die in der vhost nachvollzogen werden müssen. Die beiden  'alten' Standardeinträge unter dem Tag   </FilesMatch> führen dazu, dass meine Rechte zur Darstellung der Webseite nicht mehr ausreichen, vgl. https://httpd.apache.org/docs/current/upgrading.html.

    Da muss statt dessen ein 'Require all granted' rein. Wie ich Änderungen in Gestalt der Ergänzung des vhost files vornehme ist klar, nur, wie kann ich das Default-Template abändern, so dass die Änderung innerhalb des  <Directory "/var/customers/webs/007/meinedomain/">... </Directory> erfolgt?

    Vielen Dank für die Antwort im Voraus ....

     

    # 29_froxlor_normal_vhost_www.007.conf
    # Created 12.12.2017 10:55
    # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

    # Domain ID: 87 - CustomerID: 7 - CustomerLogin: 007
    <VirtualHost xx.xxx.xx.40:80>
      ServerName www.domain.de
      ServerAlias *.www.meinedomain.de
      ServerAdmin mail@meinedomain.de
      DocumentRoot "/var/customers/webs/007/meinedomain/"
      FcgidIdleTimeout 30
      SuexecUserGroup "007" "007"
      <Directory "/var/customers/webs/007/meinedomain/">
        <FilesMatch "\.(php)$">
          SetHandler fcgid-script
          FcgidWrapper /var/www/php-fcgi-scripts/007/www.meinedomain.de/php-fcgi-starter .php
          Options +ExecCGI
        </FilesMatch>
        Order allow,deny
        allow from all

      </Directory>
      Alias /awstats "/var/customers/webs/007/awstats/www.meinedomain.de"
      Alias /awstats-icon "/usr/share/awstats/icon/"
      ErrorLog "/var/customers/logs/007-error.log"
      CustomLog "/var/customers/logs/007-access.log" combined
    </VirtualHost>


  7. Moin moin, bin gerade mal ein paar logs durchgegangen, nachdem ich in den vergangenen Tagen Froxlor auf stretch installiert habe.

    Dabei bin ich auf den Eintrag gestoßen:  /usr/bin/nice: '/usr/bin/php5': No such file or directory

    Ursache ist, dass auf meinem DebianServer nicht mehr php5, sondern php7.0 installiert ist. sämtliche Froxlor CronJobs rufen php5 auf. Im der Froxlor-Datei unter /ect.cron.d steht, dass die Datei von Zeit zu Zeit neu generiert wird diese Datei nicht verändert werden sollte. Ergo möchte ich die Anpassung im php-script von Froxlor vornehmen, in dem die Datei generiert wird. Stellt sich die Frage, in welchem Script die Datei generiert wird? Bei meiner Suche im Forum wurde ich nicht fündig.

    Vielen Dank für eine kurze Info im Voraus ...

     


  8. 9 hours ago, d00p said:

    Wenn froxlor wieder korrekt eingerichtet ist (und auch die Dienste, wie z.B. libnss-mysql) sollte eine Owner-Zuordnung problemlos sein, es sei denn die Daten wurden ohne Owner-Info übertragen (sinnvoll hier z.B. rsync mit archiv-parameter, der erhält owner und permissions).
     

    In der Froxlor-Datenbank

    Hab zwar noch nicht kappiert, wie das mit den ownern aus der Datenbank funktioniert (macht nix), aber der Tipp hat weitergeholfen, vielen Dank!

     


  9. Hallo,

    muss leider auf dem ThemaBackup/Restore herumreiten. Hatte in den vergangenen Tagen einen Serverwechsel, dazu brav die Froxlor MySQL Datenbank exportiert und im neuen Server importiert, zuvor allerdings meine Konfiguration durchgezogen. Hat super geklappt.

    Auf dem alten Server habe ich das customers Verzeichnis gepackt und auf dem neuen Server entpackt. Probleme bereiten dabei die Owner. Muss ich die wirklich manuell für jedes Verzeichis neu setzen oder geht das auch irgendwie automatisch?

    Eine Zweite Frage habe ich zu den Ownern selbst, leider NewBiiii: mir ist bekannt, dass ich Dateien einem Benutzer/Gruppe zuweisen kann, die in den bekannten Dateien im /etc stehen. Wo stehen die owner aus Froxlor? selbst wenn ich die owner zufuß zuweisen wollte, könnte ich das nicht, weil diese nicht in der shadow/group zu finden sind. Im Forum habe ich -offensichtlich mangels der richtigen Stichworte- nichts passendes gefunden. Hat jemand einen hilfreichen Tipp für mich?

    Vielen Dank im Voraus ....


  10. Hallo,

     

    habe meine super gut laufende Froxlor Installation auf den Stand gebracht.

    Nach meiner Erinnerung war nach dem Login ein Häkchen zu setzen, wenn die Konfiguartionsdateien angepasst waren.

    Das waren sie bei mir nicht, deshalb habe ich das Häkchen bei der Aktivierung von lets encrypt rausgenommen und bin weiter gegangen.

     

    Jetzt, wo ich die Konfigurationsdateien anpassen und die Aktivierung vornehmen möchte, finde ich nix. In der Konfiguration des Apachen wird die nano /etc/apache2/conf.d/acme.conf nicht angezeigt.

     

    Ich vermute dass das damit zusammenhängt, dass lets encrypt nicht aktiviert ist. Die Aktivierung suchte ich vergebens, In den Einstellungen und den Einstellungen zum Apachen.

     

    Wo ist die Aktivierung von lets encrypt bitte versteckt?

     

    Vielen Dank für die Antwort im Voraus und vielen Dank für das Froxlor Update !!!!


  11. Hallo,

     

    heute habe ich die Systemlog gel?scht, vergangene Woche eine subdomain hinzugef?gt, aber eigentlich bekomme ich den Fehler schon l?nger:

     

    PHP Notice: Undefined variable: domain in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 321

     

    Keine Ahnung, was ich angestellt habe, um auf diesen Bug zu kommen, den ich per Mail zugesandt bekomme. aber nur einmal nach jeder aktion, z.B, dem Hinzuf?gen einer Subdomain.

     

    Ist der Bug bekannt, vielleicht auch, was ich dagegen unternehmen kann? In der Content Suche bin ich leider nicht f?ndig geworden.

     

    Im ?brigen l?uft froxlor auf meinem Server super stabil, nur zu empfehlen !!!


  12. Danke f?r den Hinweis, bin zuf?llig auf den Thread

     

    https://forum.froxlor.org/index.php/topic/13119-geotrust-ev-ssl-installieren/

     

    gesto?en und habe die Links durchgearbeitet, was letztlich die Erleuchtung brachte. Ich ging urspr?nglich davon aus, dass es h?tte reichen sollen, in den SSL-Einstellungen die Felder mit den Pfaden zum Zertifikat auszuf?llen. Wichtig ist jedoch, IP und Port  f?r die SSL-?bertragung gesondert zu erfassen.

     

    Jetzt gehts bei mir auch, auch ohne meinen vHost und wie der Admin in meinen oben zitierten Link geschrieben hat, l??t die Konfiguration wirklich keine W?nsche offen.


  13. Lass doch also bitte froxlor seinen eigenen vhost erstellen .... lautet der Tenor des Admins

     

    https://forum.froxlor.org/index.php/topic/13128-bug-beim-zur%C3%BCcksetzen-des-passworts/

     

    und brachte mich auf die Idee, dass Froxlor tats?chlich einen solchen eigenst?ndig anlegen k?nnte, was ich zuvor nicht gepr?ft hatte. Nur habe ich das gleiche Problem wie der Collega vor mir. Ich ging in die Einstellungen zu SSL, habe mein Zertifikat in die Felder zu den Pfadangaben eingetragen und den von mir angelegten vhost rausgeworfen.

     

    Nischt iss, es findet sich ein vhost '10_froxlor_ipandport_84.200.52.242.80.conf', der, wie der Name schon sagt, keine Eintragungen mit den Zertifikaten enth?lt.

    Obwohl ich schon viel probiert habe, kann ich 'derzeit' eine SSL-Anbindung nur MIT eigenem vHost vornehmen. Stellt sich die Frage, wie der vhost denn heissen 

    soll, den Froxlor selbst erstellt, vor allem, wann Froxlor diesen, wo erstellt?

     

    Habe h?chst vorsorglich SSL in den Froxlor Einstellungen gel?scht und neu eingetragen, dazwischen lief der Cron, brachte aber keine ?nderungen :-(


  14. Muss leider einen Bug beim Zur?cksetzen es Passworts in der aktuellen Version von Froxlor melden:

    Angegeben habe ich Benutzernamen und Passwort des Kunden. Froxlor hat den Link zum Zur?cksetzen des Passworts geschickt.

     

    Der sieht schon mal so aus:

    https://froxlor.asw-hosting.de/froxlor/index.php?action=resetpwd&resetcode=3661499f89b918b1442863760013356915026f044dba26f053

     

    Was ich dann bekomme ist nicht eine Seite zum Zur?cksetzen des Passworts, sondern eine leere Seite 404.

     

    Das ApacheLog, bei mir froxlor-access.log sagt dazu:

    46.24.55.243 - - [21/Sep/2015:21:29:40 +0200] "GET /froxlor/index.php?action=resetpwd&resetcode=3661499f89b918b1442863760013356915026f044dba26f053 HTTP/1.1" 404 187

     

    Die froxlor-error.log des Apachen sagt:

    [Mon Sep 21 21:29:40 2015] [error] [client 46.24.55.243] File does not exist: /var/www/froxlor/froxlor

     

    Eine Idee, was ich ?ndern muss, damit dat funktioniert?

     

    Danke f?r den Hinweis im Voraus ....


  15. Erstmal Danke f?r den Hinweis, wie durch die erste eMail das Konto angelegt wird.

     

    Um herauszufinden, wie Dovecot unter Nutzung des IMAP Protokol Ordner selbst?ndig anlegt, habe ich ?brigens keine 15 Sekunden gebraucht ;-)

     

    Wunsch meiner Konfiguration war aber nicht, wie ich Folders nach einem IMAP Zugriff auf das Konto automatisch anlege, sondern wie die Ordner 'mit Anlegen des Postfachs' automatisch angelegt werden k?nnen, und das scheint unter der Version 1.2 des Dovecot nicht ganz so einfach, jedenfalls habe ich auch nach l?ngerer Suche nix dazu gefunden.

     

    Grund weshalb ich die Ordner mit Anlegen des Postfachs automatisch einrichten will ist, dass es noch genug User gibt, die ihre Nachrichten nicht auf dem Server halten wollen und folglich POP3 nutzen. Ich werde noch ein wenig experimentieren, vielleicht finde ich auch f?r letzteres einen Weg.

     

    Trotzdem Danke f?r die Antwort ....


  16. Hallo,

     

    Froxlor legt nach dem Anlegen eines Mailpostfaches die Folder der Inbox an (nur diesen).

    In meiner Konfiguration m?chte ich sogleich die Folder der gesendeten Objekte, Draft und Spam anlegen.

     

    In Netz habe ich ein Beispiel (Spam) gefunden, in welchem erkl?rt wird, dass der Namespace Inbox der Datei /etc/docecot/conf.d/10-mail.conf zu erweitern ist:

    namespace inbox {
      inbox = yes
            mailbox Spam {
            auto = create
            special_use = \Junk
            }
    }

     

    Problem ist nur, dass der Spamordner nach obiger Konfiguration gerade nicht automatisch erstellt wird.

     

    Meine Frage ist, ob Froxlor beim Anlegen des Postfachs auf Dovecot zur?ckgreift, oder ob Froxlor die Anlage des Postfachs durch eigene Routinen vornimmt? Im Falle, dass Froxlor dies selbst erledigt, stellte sich die Frage, ob ich eine Anpassung dahin vornehmen kann, dass weitere Folder angelegt werden, ggf, wo?

     

    Sollte (wie ich eher vermute), Dovecot die Anlage des Postfachs vornehmen, stellt sich die Frage, wo der Fehler in meinem obigen Beispiel ist?

    K?nnte ich hierzu bitte einen Tipp bekommen?

     

    Vielen Dank f?r die Antwort in Voraus !!!!

×
×
  • Create New...