mrwonka

Members
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mrwonka

  • Rank
    Newbie
  1. https://github.com/cooperaj/froxlor_contrib_commands It only does the one thing at the moment but it should be easily expandable to do more as and when I need to.
  2. This appears to not just affect Apache but also Nginx. I was getting a 403 forbidden error on my new domain until I restarted Nginx. I also restarted nscd but I don't know if this did anything. It certainly didn't on its own.
  3. Thanks for your help
  4. Ok. That makes sense. I have not found any instructions for the installation of webalizer (under any distribution) in the Configuration section. Is it just a case of installing it and it works or is some config required? Sorry, I realise this is more a support issue now, it should be in the other forum.
  5. I've noticed that there is no setting in the UI to disable the webalizer functionality. In the database there appears to be a "webalizer_enabled" field set to 1 though. I've done a search of the codebase and this configuration setting isn't used anywhere. Is it possible to disable it at all? If not should it be?
  6. I'm working on getting my froxlor instance setup with PHP5-FPM and Nginx and was encountering an issue whereupon reboot the PHP functionality would be broken. Looking in syslog would give me about 30 lines of PHP5-FPM failing to start and then giving up. Looking in php5-fpm.log would tell me nothing useful other then the configtest passed. I eventually found a helpful message in the /var/log/upstart/php5-fpm.log file: [14-May-2015 09:21:54] ERROR: unable to bind listening socket for address '/var/run/nginx/username-domain.com-php-fpm.socket': No such file or directory (2) True enough the /var/run/nginx folder did not exist. I could not figure out where it was going. After hair pulling research I found that the /var/run mount point is run as tmpfs and so is deleted on reboot. In order to fix this I had to ensure the directory was recreated before PHP5-FPM started. It turns out this if fairly easy with upstart. I added this stanza: pre-start ... other stuff ... [ -d /var/run/nginx ] || mkdir -p /var/run/nginx end script to the /etc/init/nginx.conf file to have the folder created on boot. Problem solved.