Jump to content
Froxlor Forum

Gamerboy59

Members
  • Posts

    113
  • Joined

  • Last visited

Posts posted by Gamerboy59

  1. 2 hours ago, d00p said:

    Du scheinst offenbar nicht zu wissen wie php-fpm funktioniert...

    Und nein, natürlich reicht das reine Anlegen der Version nicht daß bestimmte Seiten diese php- Version nutzen, du weist Domains entsprechend angelegte PHP-Konfigurationen zu bei denen du wiederum die FPM-Version wählen kannst. Schau dir doch bitte einfach die entsprechenden Einstellungen und Ansichten dazu an...

    Ja, das mit dem Template zuweise ist klar, wie php-fpm funktioniert ist mir scheinbar dann doch nicht so klar.. Ich habe jetzt eine neue Config erstellt und das unterstrichene im Vergleich zum ersten Screenshot geändert. Wenn ich die php-config einer Domain zuweise, reicht das, damit sie unter php7.4 läuft?

    n2.thumb.JPG.017f8c163867cb8e0686f8e5b29602bb.JPG

  2. 13 minutes ago, d00p said:

    Na wenn du eine weitere php-version installierst, solltest DU ja wissen, wie das Kommando zum Neustarten des fpm-dienstes und der Pfad zur entsprechenden pool-config-directory lautet...

    Ja, die Daten weiß ich, die Frage war nur, ob das reicht, damit die .php-Dateien auch von der php-Version ausgeführt werden. Also das keine weitere Angabe zur php-executable notwendig ist?

  3. 21 minutes ago, d00p said:

    why is there an @ sign in the username? Can you please give more detailed information about your settings (ftp-user login or weird usernames?) The double path might also be an issue because i do not have that anywhere for any user....also please state which froxlor version etc.

    I don't know. Removing the @ and the double path make it working again. I recently updated to the latest git version but a downgrade didn't help either.

  4. 36 minutes ago, d00p said:

    hm, no, looks the same on my system and works just fine, sorry, no idea

    Or is maybe something wrong with the generation of the passwd file? The path in 'space' appears to be set twice:

    maxm@:x:10000:10000:Max Mustermann:/var/customers/webs/maxm/var/customers/webs/maxm/:/bin/false

     

    Edit: If I search the usernumber ("id 10000") I can find the corresponding user but when I search the username ("id maxm") it says no user found.

  5. Ok, I reinstalled my server but same issue.

     

    Here's my nsswitch.conf

    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat extrausers
    group:          compat extrausers
    shadow:         compat extrausers
    gshadow:        files
    
    hosts:          files dns
    networks:       files dns
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    netmasks:       files
    netgroup:       files
    bootparams:     files
    
    automount:      files
    aliases:        files
    

    /var/lib/extrausers/passwd and These files contain the correct user Information, just the system can't find them. Did I miss something?

  6. 52 minutes ago, d00p said:

    it's all settings. per default it's /var/customers/ for webs, mail, logs and tmp

    did you go through the configuration steps for libnss-extrausers? 

    Yh, fixed the directory in the settings and created a symlink for just in case.

    I went thru all installations steps (which aren't that many). I guess the extrausers setup is working as the users are shown in the files. The nsswitch file was completely copy&pasted so should be working too. I'm on Debian 10 but that shouldn't cause any trouble here. Nscd is no more required to have extrausers working, is it?

     

    I guess I'll do a reinstall anyways. Maybe it'll be fixed then.

     

    btw: is the request to approve configuration just a hint or is there any further setting related to it?

  7. Ok, just noticed froxlor created two different folders /var/customer and /var/customer

    The latter one did have the logs directory.

    Additionally, it appears that no users are passed through extrausers. I can find an user entry in /var/lib/extrausers/passwd but that's not found with "id <user>".

  8. Hello,

    I set up froxlor using nginx and fpm. So far so good and everything is smooth but when I create a customer, the following error appears:

    root@de3:~# php /var/www/html/scripts/froxlor_master_cronjob.php --force --debug
    [information] TasksCron: Searching for tasks to do
    [information] TasksCron: Task2 started - create new home
    [notice] Running: mkdir -p '/var/customers/webs/<user>/webalizer'
    [notice] Running: mkdir -p '/var/customers/mail/<user>/'
    [notice] Running: cp -a /var/www/html//templates/misc/standardcustomer/* '/var/customers/webs/<user>/'
    [notice] Running: chown -R 10002:10002 '/var/customers/webs/<user>/'
    [notice] Running: chown -R 2000:2000 '/var/customers/mail/<user>/'
    [notice] Creating passwd file
    [notice] Writing 1 entries to passwd file
    [notice] Succesfully wrote passwd file
    [notice] Creating group file
    [notice] Writing 1 entries to group file
    [notice] Succesfully wrote group file
    [notice] Creating shadow file
    [notice] Writing 1 entries to shadow file
    [notice] Succesfully wrote shadow file
    [information] Creating new FTP-home
    [information] Running Let's Encrypt cronjob prior to regenerating webserver config files
    [information] Requesting/renewing Let's Encrypt certificates
    [information] No new certificates or certificates due for renewal found
    [information] nginx::createIpPort: creating ip/port settings for  123.456.789.012:80
    [information] nginx::createIpPort: creating ip/port settings for  123.456.789.012:443
    PHP Warning:  touch(): Unable to create file /var/customers/logs/<user>-error.log because No such file or directory in /var/www/html/lib/Froxlor/Cron/Http/Nginx.php on line 1048
    PHP Warning:  chown(): No such file or directory in /var/www/html/lib/Froxlor/Cron/Http/Nginx.php on line 1049
    PHP Warning:  chgrp(): No such file or directory in /var/www/html/lib/Froxlor/Cron/Http/Nginx.php on line 1050
    PHP Warning:  touch(): Unable to create file /var/customers/logs/<user>-access.log because No such file or directory in /var/www/html/lib/Froxlor/Cron/Http/Nginx.php on line 1058
    PHP Warning:  chown(): No such file or directory in /var/www/html/lib/Froxlor/Cron/Http/Nginx.php on line 1059
    PHP Warning:  chgrp(): No such file or directory in /var/www/html/lib/Froxlor/Cron/Http/Nginx.php on line 1060
    [information] nginx::writeConfigs: rebuilding /etc/nginx/sites-enabled/
    [information] Froxlor\Cron\Http\NginxFcgi::reload: running service php7.3-fpm restart
    Job for php7.3-fpm.service failed because the control process exited with error code.
    See "systemctl status php7.3-fpm.service" and "journalctl -xe" for details.
    [information] Froxlor\Cron\Http\NginxFcgi::reload: reloading Froxlor\Cron\Http\NginxFcgi
    [information] Task4 started - Rebuilding froxlor_bind.conf
    [information] Cleaning dns zone files from /etc/bind/domains/
    [information] No domains found for nameserver-config, skipping...
    [notice] Creating passwd file
    [notice] Writing 1 entries to passwd file
    [notice] Succesfully wrote passwd file
    [notice] Creating group file
    [notice] Writing 1 entries to group file
    [notice] Succesfully wrote group file
    [notice] Creating shadow file
    [notice] Writing 1 entries to shadow file
    [notice] Succesfully wrote shadow file
    [notice] Checking system's last guid

     

    Additionally, but not very important though, is that at the end of the URL there is always a 2nd "/". Guess that is nginx redirect config..

     

    However, always when I create a new customer the error appears and the system crashs.

    Thanks for your kind help.

  9. 7 hours ago, MKEurope said:

    Kann mir mal da keiner helfen, wenn ich ihm einen Temporären Adminzugang anlege ?

     

    Gruß

    Michael

     

     

    Der Admin-Zugang für Froxlor alleine reicht da nicht, wenn dann bräuchte man root/sudo-Zugang um die Configs zu erstellen, aber ich kann dir auf keinen Fall empfehlen den so rauszugeben.

  10. Ok thanks, but this goes well?
     

    1. IPs and Ports -> Add -> Same IP as HTTP, Port 443, enable SSL-Port and supply certificate details. Additional settings according to your configuration.
    2. Domains -> Edit Domain -> Tick the newly created SSL-IP
    3. Customer Portal -> Domain, Setting -> SSL-Domain Settings

  11. Thanks. However, the config for port 80 doesn't include the word 'SSL', so I don't know what's going wrong there.

    I tried adding SSL-support like this:

    • IPs and Ports -> Add -> Same IP as HTTP, Port 443, enable SSL-Port and supply certificate details. Additional settings according to your configuration.
    • Domains -> Edit Domain -> Tick the newly created SSL-IP
    • Customer Portal -> Domain, Setting -> SSL-Domain Settings
    Edit: Maybe this is connected with the use of CGI-FCGI?
  12. I don't think so, where to check?

     

    This is my ports.conf:

    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default.conf
    
    Listen 80
    
    <IfModule ssl_module>
    	Listen 443
    </IfModule>
    
    <IfModule mod_gnutls.c>
    	Listen 443
    </IfModule>
    
    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
    
×
×
  • Create New...