Jump to content
Froxlor Forum

glampe

Members
  • Content Count

    9
  • Joined

  • Last visited

Posts posted by glampe


  1. When I try to access Froxlor on my server I am now receiving a 500 error.

     

    A few days before this, I upgraded php and a few other items through apt-get but did not see an issue immediately.  All the hosted sites are running fine.  The only problem I have is with the Froxlor interface.

     

    This is the message in the browser.

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

     

    The error.log shows

     

    No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/froxlor.panel/hostname.com/8dfd.fpm.external": connect() failed

     

    FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/froxlor.panel/hosting.com/8dfd.fpm.external

     

    Anyone have any ideas on how to fix this or what might have changed?  It seems like it is trying to use php-fpm.  I know the other sites use it, but does the Froxlor admin?

     

    Thanks for any help anyone can give.

     


  2. I'm using Debian Weezy, Apache2 and mod_php (I haven't installed fcgif or php-fpm).

     

    Apache is running under www-data.

     

    The directory is set drwxr-xr-x 10001 10001

     

    System details Serversoftware: Apache/2.2.22 (Debian) PHP-Version: 5.4.4-14+deb7u7 MySQL server version: 5.5.33-0+wheezy1 Webserver interface: APACHE2HANDLER System load: 0.07 / 0.06 / 0.05 Kernel: 3.2.0-4-amd64 (x86_64)

  3. I finished setting up Froxlor and my test site worked!  Now, I've tried to setup a second site.  I installed Wordpress and setup the database.  The site runs, but Wordpress can't write to the directory or create files.  Should this work "out of the box" or do I need to change permissions?  This usually works fine on most hosts, so I would prefer to not have to set permissions on each install.  Did I miss something in the setup?  If I have to set permissions, what is the best way?

×
×
  • Create New...