Jump to content
Froxlor Forum

pbaasch

Members
  • Posts

    3
  • Joined

  • Last visited

pbaasch's Achievements

Newbie

Newbie (1/14)

  • Week One Done
  • First Post
  • Conversation Starter

Recent Badges

0

Reputation

  1. Unfortunately this doesn't help as the session is IP based in the database table which it shouldn't be and still would force me to login again and again.
  2. There is nothing in the error logs but I was able to figure out the issue. I'm using Cloudflare as DNS as well as a the SSL Proxy layer to provide SSL to protect the real IP address of my servers. Unfortunately this means that the client IP address may change every request. This has never been a problem with other control panels and shouldn't be an issue at all but Froxlor doesn't allow this due to the following line in the code which is a ancient way of security: https://github.com/Froxlor/Froxlor/blob/4750dad9e2ced4efb188e6659512bd49892ee762/lib/init.php#L236-236 Removing the above part of "AND `s`.`ipaddress` = :ipaddr" as well as the parameter in line 243 will fix this. I'll create a pull request later when I have time.
  3. Hi, I have a new machine running Debian 11 with nginx and php fpm but if I login to the admin interface I get logged out after 30 seconds. I used the manual installation method as well as tried the automatic one with no luck. Any suggestions would be great.
×
×
  • Create New...