Jump to content
Froxlor Forum

carl

Members
  • Posts

    3
  • Joined

  • Last visited

carl's Achievements

Newbie

Newbie (1/14)

  • Week One Done
  • First Post
  • Conversation Starter

Recent Badges

0

Reputation

  1. ich k├Ânnte schw├Âren, ich hab irgendwo php-cgi gelesen ­čÖł. Danke f├╝r den Wink! PS: D.h. die CGI Versionen niemals ├╝ber Console ausf├╝hren? PPS: Wenn ich Froxlor auch mit CGI / FCGID ausf├╝hren will, ├Ąndert sich daran auch nichts?
  2. Moin, nach ein bisschen Server-Pflege inkl. Froxlor-Update habe festgestellt, dass der CronJob offenbar nicht mehr ausgef├╝hrt wird. Meine manuellen Versuche ├╝ber CLI: /usr/bin/php-cgi /var/www/froxlor/scripts/froxlor_master_cronjob.php --debug --force (PHP 8.1) /usr/bin/php-cgi7.2 /var/www/froxlor/scripts/froxlor_master_cronjob.php --debug --force /usr/bin/php-cgi7.4 /var/www/froxlor/scripts/froxlor_master_cronjob.php --debug --force Ich bekomme immer den gleichen Fehler PHP Notice: Undefined variable: argv in /var/www/froxlor/scripts/froxlor_master_cronjob.php on line 25 PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php on line 49 Darum bin ich in die PHP Konfiguration rein und habe jeweils in den php.ini Settings register_argc_argv = On gesetzt. Da die neuen PHP Einstellungen vom CronJob nicht durchgef├╝hrt werden k├Ânnen wegen des Fehlers, habe ich den CronJob darum so ausgef├╝hrt /usr/bin/php-cgi7.4 -dregister_argc_argv=On /var/www/froxlor/scripts/froxlor_master_cronjob.php --debug --force womit der Job auch wieder durchl├Ąuft. Das Problem ist allerdings, dass register_argc_argv=On scheinbar trotzdem nicht in der .ini landet, denn auch hinterher bleibt es bei Off: /usr/bin/php-cgi7.4 -i | grep register_argc_argv <tr><td class="e">register_argc_argv</td><td class="v">Off</td><td class="v">Off</td></tr> Ich habe auch schon versucht, den Wert direkt in der php.ini zu setzen, aber auch das scheint nichts am CGI PHP zu ├Ąndern (die FPM-Version zeigt register_argc_argv = On). Nun komm ich nicht weiter, kann jemand aushelfen?
×
×
  • Create New...