Jump to content
Froxlor Forum

Lud3r

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Lud3r

  • Rank
    Newbie
  1. Gibt es eine Möglichkeit die Froxlor-Standardeinstellungen wieder herzustellen ? Quasi so als wenn noch keine domain eingetragen ist.
  2. Ich habe in Froxlor alles versucht auf den Ausgangszustand zu setzen, indem ich SSL deaktiviert habe, bei den Ports/IP´s denn 443 gelöscht habe, die Zertifikate per froxlor und acme.sh. gelöscht habe. Das einzige was ich mal kopiert hatte war als ich ein Tutorial befolgte und der den pfad /etc/ssl/private nutzte und die Zertifikate dort ablegte und den Pfad in Froxlor angab. Ich fragte nach dem Pfad, weil acme mir einen komplett anderen Pfad angegeben hatte für die Zertifikate. Ich muss in dsa Feld ja eintragen wo die Zertifikate liegen und froxlor schiebt die ja meines Wisens nach in /etc/ssl/froxlor-custom wenn sie erstellt sind. Daher wollte ich den dann auch in den Einstellungen so eintragen. Ich werde das nochmal gründlich von vorne beginnen, wobei ich mir recht sicher bin, dass ich das so gemacht und befolgt habe wie belesen. Nur steckt der Teufel im Detail. Ich werde das hier wieder posten und gespannt wie die Rückmeldung ist.
  3. Ich habe eben alles mal deaktiviert mit SSL und dann zeigte mir die homepage die Fehlermeldung an : SSL_ERROR_RX_RECORD_TOO_LONG Wenn ich nun alle Zertifikate lösche und neu anlege, soll ich dann den Pfad in den Einstellungen /etc/ssl/froxlor-custom angeben oder leer lassen, weil froxlor das mittlerweile selbst organisiert.
  4. - Auf v2 ungestellt php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug ergibt : [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for MeineIP:80 [notice] MeineIP:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] MeineIP:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for MeineIP:443 [debug] MeineIP:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 4, customer Lud3r [information] apache::createVirtualHosts: creating vhost container for domain 1, customer Lud3r [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\Apache::reload: reloading Froxlor\Cron\Http\Apache [information] Task4 started - Rebuilding froxlor_bind.conf [information] Cleaning dns zone files from /etc/bind/domains/ [debug] domId domain ismainbutsubto parent domain list of child domain ids [debug] 4 meinedomain.de 0 - [information] `/etc/bind/domains/meinedomain.zone` written [debug] Generating dns config for meinedomain.de [information] froxlor_bind.conf written [information] Bind daemon reloaded [information] Task4 finished [notice] Checking system's last guid php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug ergibt : [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [notice] Checking system's last guid Evtl noch andere log´s auslesen ? Die Seite ist weiterhin nicht ereichbar.
  5. Zuerst vielen dank für die schnelle Antwort. Es ist mir gerade etwas unerklärlich, jedoch ist es gerade so, dass der webserver mit aktivierter conf läuft. Edit : Die Webseite ist doch nicht mehr erreichbar. Sie sieht aus als wenn sie angepingt wird und der Browser ständig versucht die Seite neu aufzubauen. Als wenn sich irgendetwas aktualisiert hat auf dem Server. Froxlor bzw apache weiterhin verfügbar. Froxlorversion ist 0.10.1 und Acme v1. Ich habe das Forum hier hoch und runtergelesen sowie google ausgiebig genutzt. Ich habe auch bereits viel selbst probiert. Es erscheint mir so, als wenn eine grundlegende Einstellung nicht richtig ist. Ist es normal, dass ich diese ganzen .conf´s habe, owbohl ich nur eine domain in froxlor habe ? 000-default.conf 03_froxlor_ocsp_cache.conf 05_froxlor_dirfix_nofcgid.conf 10_froxlor_ipandport_MeineIP.443.conf 10_froxlor_ipandport_MeineIP.80.conf 28_froxlor_normal_vhost_Lud3r.XXXXXXXXXXXXX.supersrv.de.conf 35_froxlor_normal_vhost_MeineDomain.de.conf 35_froxlor_ssl_vhost_MeineDomain.de.conf 40_froxlor_diroption_80b71ad9c736c1f70523296fe1d98507.conf wordpress.conf Leider muss ich fragen, wie ich die manuellen Cronjobs bzw Debug abfrage bzw einsehe 😞 Ich habe hier nochmal die Einstellungen der IPS´s und Ports. Ist natürlich nur für diese eine/gleiche IP. Ist das denn so richtig, dass beide kein Listen aktiviert haben und beide einen vHost.
  6. Hallo zusammen, für meinen VServer (Debian Jessi 8.11 mit Apache 2.4) versuche ich das lets encrpyt Zertifikat einzubinden. Vorgegangen bin ich wie folgt : SSL aktiviert Pfade festegelt für .crt und .key festgelegt (etc/ssl/private/) IP und Port (SSL Port aktiviert, Pfad zum Zertifikat und Private key wie oben festgelegt) Wie unter "System Konfiguation" angegeben die Dinge per ssh ausgeführt. (es kamen dort nur kleinere perl-Störungen --> wichtig?) Die acme.conf konfiguriert In den Webserver Einstellungen die IP mit Port 443 ausgewählt und Zertifikat erstellen lassen Dann mittels " php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug " und " php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug " das ganze fertig gestellt. Die Zertifikate/Keys in den Ordner /etc/ssl/private kopiert. Neustart des Apache. Nun kam die Fehlermeldung SSL_ERROR_RX_RECORD_TOO_LONG als ich die Seite aufrief. Daraufhin habe ich für den Apache Zertifikate erzeugt mittels openssl req -new -newkey rsa:4096 -nodes -sha256 -out apache2.csr -keyout apache2.key und openssl x509 -req -days 365 -in apache2.csr -signkey apache2.key -out apache2.pem Das half noch nicht weiter, denn ich habe dann unter "IP´s und Port´s" das Listen deaktiviert. Wenn ich nun den Apache neugetsartet habe, zeigte mir der Apache jedoch wieder folgendes an : apache2(98)Address already in use: AH00072: make_sock: could not bind to address "Meine IP":443 Ich muss dann die 10_froxlor_ipandport_"MeienIP".443.conf umbenennen, damit der Apache wieder startet. In der ports.conf steht folgendes : Listen 80 <IfModule ssl_module> Listen 443 </IfModule> <IfModule mod_gnutls.c> Listen 443 </IfModule> LG
×
×
  • Create New...