Jump to content
Froxlor Forum

neomatt

Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About neomatt

  • Rank
    Froxie
  1. Es war ein Update von 0.9, wird ja dann in Zukunft geprüft. Dann schaue ich mal, ob ich das installiere und konfiguriere, wahrscheinlich eher nicht. Danke!
  2. Nach kleineren Problemen beim Update auf 0.10.5 frage ich mich: 1. Ich habe das Update über den Froxlor-Update-Link im System automatisch ausführen lassen. Leider ohne vorher die Update-Doku zu lesen. Leider fehlten mir die Update-Voraussetzungen (zu kleine mysql- und php-fpm-Versionen, letztendlich ein veraltetes Ubuntu14LTS). Ist es möglich, dass das Update-Skript Systemvoraussetzungen prüft und auf die Notwendigkeit zur Aktualisierung hinweist? 2. Der Link zum phpMyAdmin in den Cutomer-Bereichen funktioniert nicht. Er möchte den Link domain/pma öffnen, der nicht existiert. Wo wird dieser konfiguriert und wie sind die Voraussetzungen dafür.
  3. Warum alle Werte in den Einstellungen deaktiviert waren, ist mir nicht klar. Verloren gegangen ist aber natürlich nichts. Die pageKit-Installation für den Kunden ist die einzige mit sqlite-DB. Letztendlich fehlte nur noch das Paket php7.0-sqlite3. Danach ging wieder alles.
  4. Einstellungen verloren gegangen meint, dass unter Einstellungen des Kunden (admin_customers.php) in diesem Bereich alles auf "0" stand. Beim Kunden waren dann entsprechende Menüpunkte nicht vorhanden. Nach Korrektur der Einstellungen sind alle Menüpunkte verfügbar, es sind aber keine DB-Verbindungen konfiguriert. Hier vermute ich einen Zusammenhang mit dem 500er Fehler, da im nginx ein Fehler wegen der fehlenden Verbindungsdaten auftritt, obwohl ich eigentlich dachte, dass froxlor beim php-serven nicht involviert ist.
  5. Hallo, nach kleineren Problemen beim Upgrade auf 0.10.5, die gelöst wurden, sind in einem Customer-Bereich (von ca. 10) die DB- und andere Einstellungen verloren gegangen. Hier wurde vor dem Update eine Webseite mit pageKit und sqllite installiert. Bei den anderen Webs mit ähnlichen Installationen sind die Daten unter "Datenbanken" vorhanden. Bei diesem einem Kunden sind sie leer. Wie kann ich das Problem lösen? Viele Grüße Dirk
  6. Danke, korrekt mit php7.0-fpm geht es!
  7. Danke, jep, nach apt-get install php5.6-xml ist dieser Fehler weg. Jetzt komme ich auf die Einstellungen aber noch nicht auf die Kundenseiten. Hier ist im Log gemeldet: [error] 8887#8887: *14733 FastCGI sent in stderr: "PHP message: PHP Parse error: syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 254" Fehlt noch eine Extension?
  8. Hallo, wir haben das gleiche Problem nach Update auf 0.10.5 (DB: 201910200): 500 auf Kundenseiten und bei https://<froxlor-domain>/admin_configfiles.php?page=configfiles&s=aa80269d00316587be71157a3ce8e023 Im nginx-ErrorLog steht: 2019/11/07 10:31:32 [error] 8890#8890: *14496 FastCGI sent in stderr: "PHP message: PHP Fatal error: Call to undefined function Froxlor\Config\simplexml_load_file() in /var/www/froxlor/lib/Froxlor/Config/ConfigParser.php on line 106" while reading response header from upstream, client: 178.9.101.160, server: <froxlor-domain>, request: "GET /admin_configfiles.php?page=configfiles&s=aa80269d00316587be71157a3ce8e023 HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php-fpm/1-froxlor.panel-<froxlor-domain>-php-fpm.socket:", host: "<froxlor-domain>", referrer: "https://<froxlor-domain>/admin_index.php?s=aa80269d00316587be71157a3ce8e023" Hinweis: <froxlor-domain> ist jeweils unser froxlor-domain-Name. Nach Update musste mysql aktualisiert werden, es erfolgte ein Server-Update auf Ubuntu 16, danach konnte das Update ohne Fehlermeldung abgeschlossen werden. System ist mit nginx und php-fpm ohne apache2 konfiguriert. Grüße auch Dirk
  9. Danke, habe gerade das nginx error.log gecheckt und gesehen: Klar, froxlor ist jetzt unter domain und nicht mehr unter domain/froxlor erreichbar! Fazit: Das Problem an meiner Konfiguration waren die fehlenden Einstellungen unter Froxlor VirtualHost Einstellungen. Nun sollte ich alleine weiterkommen! Vielen Dank für die tolle Unterstützung!
  10. Yes führt dazu, dass eine <ip>.443.conf geschrieben wird, die bei nginx -t zu dem o. g. Fehler führt und mir bei "nginx restart" alle Domains unerreichbar macht. Also no. ? Habe jetzt gesehen, dass unter Einstellungen -> Froxlor vHost nichts eingetragen war. Habe das jetzt gemacht (3 Checkboxen: vHost verwenden, ssl mit LE, ssl-Weiterleitung). Leider ist nun froxlor nicht mehr unter der IP und auch nicht unter der Domain erreichbar. Ich bin aktuell ausgesperrt...
  11. Mit der Einstellung "vHost-Container=nein" in IP/Port habe ich kein Problem mehr. Ich hatte mich nur zurückgemeldet, weil ich Du sagtest, diese Einstellung wäre nicht richtig. Ich wünsche mir Froxlor unter SSL und mit einer Domain zu nutzen, was aktuell nicht geht, da ich froxlor nur unter <ip> erreiche und nicht unter <domain>. Unter <ip> kann ich, wenn ich Dich richtig verstanden habe, auch kein Zertifikat verwenden. Was ist bei meiner Konfig falsch, dass ich nicht https://domain/froxlor nutzen kann? Vielen Dank für die Hilfe!
  12. Bilder der Konfig sind unten angehängt. Die 10_*-Dateien (eine für 80 und eine für 443) sehen so aus wie in beschrieben, doch die Checkbox "create listen" habe ich nicht unter der ip/port Konfiguration.
  13. > das ist ja nicht sinn der sache... Die Checkbox ist bei IP/Port Konfiguration für die IP deaktiviert. Aktiviere ich sie, dann steht in der nginx conf: <ip>:443 default host. Dann bekomme ich die Fehlermeldung: 'no "ssl_certificate" is defined in server listening on SSL port while SSL handshaking' und die domains mit dns Verweis auf <ip> sind nicht erreichbar. Was ist die Alternative zum Deaktivieren des vHost-Containers für die IP-Adresse? Zu 1. : Ich erreiche froxlor nie unter einer Domain, auch wenn der vHost-Container (wie gesagt in der IP/Port Konfig) aktiviert ist. Zu 2. : Das scheint damit ein Folgeproblem von 1. zu sein, keine Domain, kein richtiges Zertifikat. Übrigens habe ich auch für die mail-Server-Subdomain zunächst immer das gleiche falsche Zertifikat erhalten. Ich vermute das Problem darin, dass bei den Froxlor-Einstellungen unter Host eine Subdomain eingetragen wurde (das ist schon etwas her). Der Grund war wohl, dass froxlor die Domain die unter Host eingetragen ist nicht wie die anderen Domains verwalten kann.
  14. Vielen Dank für die Antwort! Ja, die Domains funktionierten bis gestern auch. Ich habe gerade die Checkbox "Erstelle vHost-Container" deaktiviert. Jetzt ist die <ip>.443.conf 'leer' und es funktioniert wieder. Zwei Fragen habe ich noch (erstelle auch gerne eigene Einträge): 1. froxlor selbst ist unter http://ip/froxlor zu erreichen und nicht unter http://domain/froxlor. Warum ist das so? 2. Mit https://ip/froxlor wird ein Zertifikat einer konfigurierten Domain mitgesandt. Es ist immer das Gleiche, nur kann ich nicht sehen, warum dieses gewählt wird.
  15. Unter ssl ist meine Haupt-Domain (Haupt-IP) nur noch erreichbar, wenn ich die <ip>.443.conf aus /etc/nginx/sites-enabled entferne. Ansonsten sagt nginx im error.log: no "ssl_certificate" is defined in server listening on SSL port while SSL handshaking Ich hatte schon gelesen, dass in den IP/Port-Einstellungen "create listen" deaktiviert werden muss. Ich sehe diese Einstellungsmöglichkeit jedoch nicht. Was ist falsch an meiner Konfiguration?
×
×
  • Create New...