Jump to content
Froxlor Forum

rObbi

Members
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

0 Neutral

About rObbi

  • Rank
    Froxie
  1. Schade. Aber vielen, vielen Dank für deine Mühe!
  2. Jetzt schon. Du hast PN.
  3. Mist, jetzt läuft gerade ein länger dauerndes (Test-)Skript im Terminal ... Muss ich jetzt leider erst abwarten.
  4. Für den Server-Vhost hatte ich es ja schon mal gepostet. Dachte, du wolltest noch einen anderen sehen. Sorry. Im Server-Vhost steht ja das serverselbstzertifizierte Zertifikat drin und kein Letsencrypt-Zertifikat.
  5. Beispiel: # 35_froxlor_ssl_vhost_[domain].de.conf # Created 18.03.2019 15:00 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 28 (SSL) - CustomerID: 1 - CustomerLogin: c11 <VirtualHost 89.200.xxx.xx:443> ServerName [domain].de ServerAlias www.[domain].de ServerAdmin [name]@[anderedomain].de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDHE-RSA-AES128-GCM-SHA256**************[alles Mögliche ...]********************+S:!RC4:!MD5:!PSK SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/[domain].de.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/[domain].de.key SSLCACertificateFile /etc/ssl/froxlor-custom/[domain].de_CA.pem SSLCertificateChainFile /etc/ssl/froxlor-custom/[domain].de_chain.pem <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/c11/[domain].de/htdocs/" FcgidIdleTimeout 30 SuexecUserGroup "c11" "c11" <Directory "/var/customers/webs/c11/[domain].de/htdocs/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/c11/[domain].de/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> Alias /webalizer "/var/customers/webs/c11/webalizer/[domain].de" ErrorLog "/var/customers/logs/c11-[domain].de-error.log" CustomLog "/var/customers/logs/c11-[domain].de-access.log" combined </VirtualHost> ----------------EOF----------------------- Kann man da etwas (problemrelevantes) herauslesen?
  6. Ja, ich könnte mir schon denken, wofür. Aber bei mir scheint es ja ungenutzt zu bleiben bzw. das servereigene Zertifikat wird bevorzugt ... Oder sehe ich da was falsch?
  7. Was ich mich frage: Wozu dient eigentlich das von Froxlor angelegte Letsencrypt-Zertifikat für [Servername].[Hostername].de?
  8. Das Problem ist, dass ich selber wirklich nur wenig gemacht habe und die Froxlorinstallation auf dem Server 1 damals von meiner Hostingfirma eingerichtet wurde. Ich hab jahrelang nur als normaler "Reseller" und User damit gearbeitet. Aber seit ich meinen Herumprobierserver 2 habe, traue ich mir auch ein wenig mehr zu. Allerdings habe ich an den Configs von Server 1 nie etwas verändert. Lediglich die SSL-Umstellungen habe ich nun aktuell (endlich) gemacht.
  9. Ja, ein wenig. Und ja, die Domain muss ja einem Kunden (c11) gehören, weil der Admin ja offenbar keine eigenen Domains haben kann.
  10. Zitat: "[servername].[hostername].de ist dein FROXLOR / Server hostname...damit greifst du auf froxlor zu. " Ja, ich selber sowieso, weil ich längst mein servereigenes Zertifikat am PC durchgewunken habe. Wenn https://[servername].[hostername].de funktionieren würde, dann wäre auch für die Kunden alles ausreichend und prima. Tut's aber nicht ... Daher die Idee mit der Subdomain ...
  11. Nein, IPv6 ist gar nicht aktiviert.
  12. [root@server1 ~]# a2dissite default ERROR: Site default does not exist! [root@server1 ~]# a2dissite 000-default Site 000-default already disabled
  13. Vielleicht sollte ich noch einmal die Subdomain neu anlegen? Probiere ich nachher mal aus. Dabei hat sich bisher noch nichts geändert: Wenn ich die Server-URL [servername].[hostername].de aufrufe, dann wird nur ein selbstsigniertes Zertifikat verwendet, das zugehörige Letsencrypt-Zertifikat (in Froxlor angezeigt) wird offenbar ignoriert.
  14. Oh ja, da fehlten Zeilen ... # 10_froxlor_ipandport_89.200.xxx.xx.80.conf # Created 16.03.2019 13:27 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. <VirtualHost 89.200.169.69:80> DocumentRoot "/var/www/froxlor/" ServerName [servername].[hostername].de FcgidIdleTimeout 30 SuexecUserGroup "froxlorlocal" "froxlorlocal" <Directory "/var/www/froxlor/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/froxlor.panel/[servername].[hostername].de/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> </VirtualHost> Da gab's offenbar wieder ein Problem beim Abschicken des ursprünglichen Posts. Da waren plötzlich Leerzeilen drin, die ich nachträglich dann entfernte ...
×
×
  • Create New...