Jump to content
Froxlor Forum

Kieron Boswell

Members
  • Content Count

    17
  • Joined

  • Last visited

Posts posted by Kieron Boswell


  1. Just now, d00p said:

    well, did the cronjob run? what exactly do you mean by "not working"? 

     

    Sorry, I mean the old froxlor subdomain is still online, but the new subdomain is not yet. 

    There are currently no outstanding tasks for Froxlor

     

     


  2. 8 minutes ago, d00p said:

    Yes it's all good when you change that, except when you've not specified a specific Standard Subdomain and already have customers with a standard subdomain, these won't be updated

    Ah I don't have many customers yet, I am still transferring, so these I can just go and change manually after? Thanks d00p!


  3. 22 minutes ago, d00p said:

    You may also go through all that again of course but remember to set the mysql password at the top 

    Ok this looks different in log now:

     

    
    Feb 10 18:46:33 web01 dovecot: master: Dovecot v2.2.27 (c0f36b0) starting up for imap, sieve, pop3 (core dumps disabled)
    Feb 10 18:47:13 web01 dovecot: imap-login: Aborted login (no auth attempts in 1 secs): user=<>, rip=[IP address], lip=[IP address], session=<CTY5yI2B8qhttDj1>
    Feb 10 18:47:18 web01 dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=[IP address], lip=[IP address], session=<tLGGyI2B9qhttDj1>
    Feb 10 18:47:35 web01 postfix/qmgr[1102]: 3C5C52015BF: from=<hello@my.domain>, size=1274, nrcpt=1 (queue active)
    Feb 10 18:47:35 web01 dovecot: lda(hello@customer.domain): msgid=<c91463d3618a00cd262c7a98b51de2da@web01.my.domain>: saved mail to INBOX
    Feb 10 18:47:35 web01 postfix/pipe[24232]: 3C5C52015BF: to=<hello@customer.domain>, relay=dovecot, delay=494, delays=494/0.06/0/0.08, dsn=2.0.0, status=sent (delivered via dovecot service)
    Feb 10 18:47:35 web01 postfix/qmgr[1102]: 3C5C52015BF: removed
    Feb 10 18:47:39 web01 postfix/smtpd[24174]: warning: hostname durigq.ga does not resolve to address [IP Address]: Name or service not known
    Feb 10 18:47:39 web01 postfix/smtpd[24174]: connect from unknown[IP Address]
    Feb 10 18:47:42 web01 postfix/smtpd[24174]: warning: unknown[IP Address]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Feb 10 18:47:42 web01 postfix/smtpd[24174]: disconnect from unknown[IP Address] ehlo=1 auth=0/1 quit=1 commands=2/3
    Feb 10 18:49:20 web01 postfix/smtpd[24174]: warning: unknown[IP Address]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Feb 10 18:49:20 web01 postfix/smtpd[24174]: disconnect from unknown[IP Address] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    
    

    Better than before!

     

    I am guessing now i am just authenticating incorrectly, would you suggest a particular address/port ?


  4. 1 minute ago, d00p said:

    SERVER logs, not client.... /var/log/mail.log...

    no

    this happens for example if no email has been received by the address yet - when adding a new address, froxlor sends an email to it to create the maildir, maybe that failed? Please ensure that in the settings there is a valid email address and the admin of that customer has a valid email address

    Thank you.

     

    Lots of this one!

    Feb 10 18:21:25 web01 dovecot: auth-worker(23757): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 125 seconds before retry

    I have obviously missed one password somewhere!


  5. 15 minutes ago, d00p said:

    Server Error Log? Don't just say "it's not working" - that does not really help in finding where the problem may be

    Only thing I can see in Froxlor System log is this; 

        cronjob    maildir /var/customers/mail/myuser/mycustomer/hello/Maildir/ does not exist

    Unfortunately, the end clients just say Error connecting, no real error message. 

     

    Does Webmail need to be installed? I don't have that yet.


  6. On 2/9/2019 at 9:01 AM, d00p said:

    what settings do you want to set?

    sure, but if you use SSL this will throw a warning that the certificate is not valid for the given domain but basically you can use anything that points to the servers-ip, even the IP itself

    what exactly do you want to make default? dont get what you mean

    same as mail-domain, you can use anything that points to the server when not using SSL and if the users domain has a wildcard-entry in its dns zone then the customer can use whateverhewants.domain.tld to connect to the ftp server. no need for a specific dns-entry

    Hey again d00p, I had a couple questions, I recently have got mail setup, but not able to connect with anything, SMTP has been configured via Froxlor instructions, same with IMAP/POP3 via Froxlor instructions, the test email works when I use the SMTP test in Froxlor, but in apps/phone/webmail's I just can't connect.


  7. 9 minutes ago, d00p said:

    Settings -> account settings -> last at the bottom: enable backup for customers, then edit customer and allow backup for the specific customer

    Ah that's it, great thank you! So looking at it, its best to find some external backup system, if I am looking for total autonomy? :)


  8. 13 minutes ago, d00p said:

    Support here is not given by amount of donations....so don't worry ;)

    Well you enable backup per customer. Rest is done as customer. Keep in mind that it's more like a "get all my data" feature than a full backup/restore solution. It's not done regularly, only when the customer triggers a backup to be made.

     

    Haha great! 🙂

     

    Ok, I am obviously missing it, ive clicked onto customers, then clicked edit on a customer, should it be here?

     

    Thanks! :) 


  9. 1 hour ago, d00p said:

    ah, okay, got it. Yes, you are right, these infos are not being displayed. most people setup up auto-confguration / auto-discover (see https://developer.mozilla.org/de/docs/Mozilla/Thunderbird/Autoconfiguration and/or https://technet.microsoft.com/en-us/library/cc511507.aspx)

    when SSL is used, if not (port 143 for imap, 110 pop3, 25 smtp) there won't be any warnings of course. Safest way is to use the "mydomain" value from the postfix/main.cf config file as email server

    in case you are using froxlor's DNS (most people dont as they do not maintain their own domain zones) there is an option to automatically add mail-A records to the zone. but as said, if the domain has a wildcard entry pointing to the server's ip, you can use any subdomain imaginable :)

    Thank you d00p, I will have a go at the mail soon. 


  10. 27 minutes ago, d00p said:

    what settings do you want to set?

    7

    Sorry if I wasn't clear, I mean when you are finished making an account in other panels I have used, you either see all the required mail settings for adding your account to a client, or you are emailed those settings. Again I'm not comparing Froxlor to anything and saying you should do it like this, but rather asking, where can I find the mail settings, if anywhere? :)

    Quote

    sure, but if you use SSL this will throw a warning that the certificate is not valid for the given domain but basically you can use anything that points to the servers-ip, even the IP itself

    1

    Ah, interesting, so to have no errors on mail the only true way is to use the primary domain I access the panel by?

    Quote

    what exactly do you want to make default? dont get what you mean

    1

    Here I was asking if by default, mail.domain.tld is a record when the domains are added to Froxlor, so that I can consistently tell clients to use mail.domain, only because its easy to remember.

    Quote

    same as mail-domain, you can use anything that points to the server when not using SSL and if the users domain has a wildcard-entry in its dns zone then the customer can use whateverhewants.domain.tld to connect to the ftp server. no need for a specific dns-entry

    Ok cool, I will try this one now, thanks.


  11. Hi guys, have just got froxlor set-up and looking around it getting it ready to move all my clients into, one or two things I haven't been able to see yet.

    • Mail settings, I'm used to being spoon-fed mail settings when I create an account, generally are these fixed so I can make a note? And is there a way to use mail.domain.tld rather than using the primary server domain for example? I'd really like something like that to be the default when I create a new website/email etc if possible.
    • Ftp, is it possible to set ftp.domain.tld as a record that works for FTP automatically when an account is made under a customer?

    Many thanks, enjoying froxlor so far :-)

×
×
  • Create New...