Jump to content
Froxlor Forum

docho

Members
  • Posts

    7
  • Joined

  • Last visited

Everything posted by docho

  1. Hmm, no, you were right. The file was empty. I checked the database and libnss-extrausers was disabled. I set it to 1 and then ran the cron-job twice. The first time, php-fpm didn't come up, as the /var/lib/extrausers/-files were written as the last step, in the second run php-fpm came up. It looks like I am now really in a "regular" state again. Thank you for your help!
  2. The only error there was: Job for php7.0-fpm.service failed because the control process exited with error code. See "systemctl status php7.0-fpm.service" and "journalctl -xe" for details. And as I have posted above, that gives me the the error with the missing uid. libnss-extrausers is installed, nsswitch.conf has the following content: passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns protocols: db files services: db files ethers: db files rpc: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files and the files - /var/lib/extrausers/passwd - /var/lib/extrausers/group - /var/lib/extrausers/shadow exist. nscd-service was restarted. Anything missing?
  3. Aaand there we go again -> Error 503 ? The only thing I did, was creating a new customer. No further steps. I now ran the cronjob again, but that didn't help. The fpm-service fails to start, but I don't know why, yet. Hmm - the customer-folder in /var/customers/webs/ belongs to a non-existing uid and gid 10000 and the fpm-service tells me " ERROR: [pool mycustomer.mydomain] cannot get uid for user 'mycustomer'" So I guess there has to be something more, I was missing.
  4. Thanks again, it seems that this was really the final missing thing. froxlor.panel belonged to root. I chowned it to froxlorlocal, now the errors are gone ?
  5. Thank you, d00p. As far as I understand the code, this would have been only visible, had I already set "enabled_ownvhost" by the time, the frontend was working. But as I told you in an earlier post, I added this after I couldn't access Froxlor anymore, directly in the database. So for me, it was indeed missing. I checked the database - use_mod_proxy is already set to 1, the same goes for vhost_container in ipsandports. You pointed me in the right direction however, as ne next step in the guide (also only visible after "enabled_vhost" was set) was the one missing for me -> a2dismod php7.0 After I did this, restarted apache and reran the cronjob, the missing php-fpm socket was created and I could access Froxlor again ? What's left are some errors, that appeared after logging in. They seem to be a permission problem in the course of session handling: On the top (after logging in) PHP warning/error #2 session_start(): open(/var/customers/tmp/froxlor.panel//sess_8ca3f6ea8d0350843a5351b4530f0eb0, O_RDWR) failed: Permission denied (13) /lib/init.php:216 On the bottom PHP warning/error #2 Unknown: open(/var/customers/tmp/froxlor.panel//sess_8ca3f6ea8d0350843a5351b4530f0eb0, O_RDWR) failed: Permission denied (13) Unknown:0 PHP warning/error #2 Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/customers/tmp/froxlor.panel/) Unknown:0 So, any (hopefully) final clue?
  6. I thought there was none, but I checked again: chown: invalid user: 'froxlorlocal:froxlorlocal' So the user froxlorlocal was missing. I added it now according to the fpm wiki entry, as that step seems to be missing from the guide within froxlor under configuration. Maybe there are more steps missing? I can't follow the wiki entry, as that refers to the old mod_fastcgi. As for the container - I don't remember any setting with 'container' in it, and didn't find the word container in panel_settings either. For an easier analysis find following the sql output for everything with fcgi and fpm in it: froxlor_panel_settings.txt
  7. Hi d00p, as I ran into the same problem (same errror in apache error log) - how can i fix it? I'm pretty sure I also forgot to activate it for the froxlor vhost. But as the web interface is not reachable anymore - how can i change the configuration? I searched the database (in panel_settings), but was not sure which entries I have to change... some more info: I'm running Debian 9 with Apache 2.4, PHP7 with fpm and MariaDB 10.1 the php-fpm service lists entries for all customer domains but not for the froxlor domain I guess I could copy one of the existing entries in /etc/php/7.0/fpm/pool.d/ but as they have all some specifics that are meant for customer domains, I'm not sure what would be needed there, either. So I guess, if I get the settings right in the DB, I could use the cron-job with --force flag to create it with the correct syntax. Am I right? I already tried it by setting 'enabled_ownvhost' to 1 and then ran the cronjob, but that didn't help. Regards, docho
×
×
  • Create New...