Jump to content
Froxlor Forum

nickchs

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About nickchs

  • Rank
    Froxie
  1. ok. Entweder oder. Hatte ich mir fast gedacht... Deren Outlook365 verlangt ein zusätzliche Absicherung via Oauth2. Mal sehen ob die Outlook365 Admins das abgeschaltet bekommen...
  2. Moin, Ich hab eine Froxlor-Installation mit Web- und Mailserver am laufen. Auf dem Server sind unterschiedliche Domains mit unterschiedlichen Mail-Adressen konfiguriert. Für eine dieser Domains wird ein externer Mail-Server verwendet. Dies ist auch alles in der DNS hinterlegt und funktioniert. Vor einiger Zeit kam es bei einer Software zu einer Umstellung welche mich dazu zwang Mails von der Webseite auf dieser Domain nur noch via SMTP zu verschicken. Deswegen habe ich die Domain auf E-Mail-Domain umgestellt und eine E-Mail-Adresse eingerichtet. Jetzt kann ich zwar
  3. ok, ich mach mir mal meinen reim drauf. Ich hab unter -> Einstellungen -> Mailserver-Einstellungen den Dovecot als MDA. Ich hab via Extrausers unter /var/lib/extrausers die Kunden im System. Die haben einen Shell-Zugang. Für all diese User würde der Dovecot jetzt gerne Zugang zu /var/mail haben um dort deren lokales Mailkonto einzurichten bzw. abzurufen. Da hat er aber keinen Zugang zu. Lösung wäre #mail_location = mbox:~/mail:INBOX=/var/mail/%u mail_location = maildir:~/Maildir Dann erhält man z.B. /var/customers/webs/customer1/Maildir weil /var/customers/webs/customer1 ist
  4. Die Datenbanktabelle sieht gut aus. Die IDs passen alle zusammen. Die durch Froxlor-Kunden erstellte E-Mail-Adressen sind auch nicht betroffen, sondern die Kunden-Konten selbst. Für alle Kunden / Benutzer welche durch Extrauser im System verfügbar sind möchte Dovecot gerne die Mailbox in /var/mail anlegen bzw sucht dort danach. wenn ich mir die /etc/dovecot/conf.d/ steht dort mail_location = mbox:~/mail:INBOX=/var/mail/%u das entspricht der Vorgabe der Froxlor-Konfiguration für Debian 9
  5. Jan 16 12:28:02 ghost dovecot: lda(web1): Debug: Loading modules from directory: /usr/lib/dovecot/modules Jan 16 12:28:02 ghost dovecot: lda(web1): Debug: Module loaded: /usr/lib/dovecot/modules/lib10_quota_plugin.so Jan 16 12:28:02 ghost dovecot: lda(web1): Debug: Module loaded: /usr/lib/dovecot/modules/lib90_sieve_plugin.so Jan 16 12:28:02 ghost dovecot: lda(web1): Debug: Effective uid=10002, gid=10002, home=/var/customers/webs/web1/ Jan 16 12:28:02 ghost dovecot: lda(web1): Debug: quota: No quota setting - plugin disabled Jan 16 12:28:02 ghost dovecot: lda(web1): Debug: Namespace inbox: typ
  6. Dovecot möchte in /var/mail Zugriff auf die Inbox für die in -> Kunden angelegten Kunden. Jan 16 09:16:17 ghost dovecot: lda(web1): msgid=<20190115192201.CE0DE176463@mail.domain.com>: save failed to open mailbox INBOX: Internal error occurred. Refer to server log for more information. [2019-01-16 09:16:17] Jan 16 09:16:17 ghost postfix/local[11068]: CE0DE176463: to=<web1@mail.domain.com>, orig_to=<web1>, relay=local, delay=46456, delays=46456/0.33/0/0.01, dsn=4.3.0, status=deferred (temporary failure) In Einstellungen -> Mail-Server-Einstellungen steht /var/cust
  7. korrekt, das wars unter Einstellungen -> Froxlor Vhost Einstellung den Benutzer umgesetzt und läuft! Danke!
  8. nein web1 ist nicht froxlor-lokal In der Datenbank-Tablle ftp_groups sieht es so aus wie in den /extrausers/group web1 10000 web1,www-data web2 10002 web2,www-data,web1 web3 10005 web3,www-data,web1
  9. /var/lib/extrauser/group sieht wie folgt aus: web1:x:10000:web1,www-data web2:x:10002:web2,www-data,web1 web3:x:10005:web3,www-data,web1 mir ist nicht ganz klar wieso web2 und web3 die web1 angefügt wird. web1 und web3 haben ssh-Zugang. Ich kann dadurch problemlos als web1 in /var/customers/webs/web3 hinein...
  10. Moin, ich schlag mich nach einem Umzug nach Debian 9 mit Let's encrypt rum welches mir kein Zertifikat liefert. Der Fehler besagt das der Token nicht via der URL erreichbar ist. Der Token wird zwar generiert aber ist halt nicht aufrubar. Die acme.conf welche unter conf.d abgelegt wurde stimmt. In einer Ubuntu-Dokumentation bin ich drauf gestoßen das alle Dateien die früher unter conf.d lagen nun in conf-available abgelegt werden müssen. Das conf.d-Verzeichnis wird anscheinend nicht mehr ausgelesen. In conf-available abgelegt und mit a2enconf aktiviert, Apache2 neu gestestartet, läuft alle
×
×
  • Create New...