Jump to content
Froxlor Forum
  • 0

Lets's encrypt renewal and additions failing



I'm running Froxlor V2 and added a new domains to my resources with a Let's Encrypt certificate. When rebuilding the config files, the cert never gets generated. I ran the froxlor-cli froxlor:cron -d -f and get the follwing information:

[error] Could not find file 'DOMAIN.com.cer' in '/root/.acme.sh/DOMAIN.com/'
[error] Could not find file 'ca.cer' in '/root/.acme.sh/DOMAIN.com/'
[error] Could not find file 'fullchain.cer' in '/root/.acme.sh/DOMAIN.com/'
[error] Could not get Let's Encrypt certificate for DOMAIN.com:

If I run certbot and renew the certificates by force, it works fine until the froxlor cron job runs again and overwrites the apache configs to point the certs back to the /root/.acme.sh/DOMAIN directory. Then the error becomes that the signing request doesn't match?

I have a dozen domains on the server and I'm only having issue with about 3 domains...

If I try to force renew though froxlor with /root/.acme.sh/acme.sh --renew --force -d DOMAIN.com I receive a 404 error like so: Invalid response from https://DOMAIN.com/.well-known/acme-challenge/br1Vv8R8osLylM9TcRlSb9Q-3Bro3PH76jykk0FrnPA: 404
Despite having validated the web roots with bin/froxlor-cli froxlor:validate-acme-webroot -A

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...