Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'vhost'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 16 results

  1. Warning, this is not an official guide!!! 1. sudo nano /etc/apt/source.list 1a. Delete all Text in to the File and Paste new Source list 1b. ###### Debian Main Repos deb http://ftp.de.debian.org/debian/ stable main contrib non-free deb-src http://ftp.de.debian.org/debian/ stable main contrib non-free deb http://ftp.de.debian.org/debian/ stable-updates main contrib non-free deb-src http://ftp.de.debian.org/debian/ stable-updates main contrib non-free deb http://security.debian.org/ stable/updates main deb-src http://security.debian.org/ stable/updates main deb http://ftp.debian.org/debian stretch-backports main deb-src http://ftp.debian.org/debian stretch-backports main ###### Extra Repos ###Debian Multimedia deb [arch=i386,amd64] http://www.deb-multimedia.org stretch main non-free ###nginx deb [arch=amd64,i386] http://nginx.org/packages/debian/ stretch nginx deb-src [arch=amd64,i386] http://nginx.org/packages/debian/ stretch nginx ###php7.X | curl https://packages.sury.org/php/apt.gpg | apt-key add - deb https://packages.sury.org/php/ $(lsb_release -sc) main ### MariaDB 10.3 ### http://downloads.mariadb.org/mariadb/repositories/ deb [arch=amd64,i386,ppc64el] http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/debian stretch main deb-src http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/debian stretch main 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server 2. MariaDB install Warning use sudo command für this install! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional) 3. nginx install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 4. PHP install sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. sudo service nginx restart sudo service php7.3-fpm restart For Ubuntu (Cosmic) 1. sudo nano /etc/apt/source.list 1a. Delete all Text in to the File and Paste new Source list 1b. ###### Ubuntu Main Repos deb http://de.archive.ubuntu.com/ubuntu/ cosmic main restricted universe multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic main restricted universe multiverse ###### Ubuntu Update Repos deb http://de.archive.ubuntu.com/ubuntu/ cosmic-security main restricted universe multiverse deb http://de.archive.ubuntu.com/ubuntu/ cosmic-updates main restricted universe multiverse deb http://de.archive.ubuntu.com/ubuntu/ cosmic-proposed main restricted universe multiverse deb http://de.archive.ubuntu.com/ubuntu/ cosmic-backports main restricted universe multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-security main restricted universe multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-updates main restricted universe multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-proposed main restricted universe multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-backports main restricted universe multiverse # MariaDB 10.3 repository list - created 2019-01-25 21:01 UTC # http://downloads.mariadb.org/mariadb/repositories/ deb [arch=amd64] http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/ubuntu cosmic main deb-src http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/ubuntu cosmic main 1c. Key install sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987) sudo add-apt-repository ppa:nginx/development sudo add-apt-repository ppa:ondrej/php 1e. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2. MariaDB install Warning use sudo command für this install! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional) 3. nginx install sudo apt install nginx Froxlor install There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master) Stable Version 1. cd /var/www/html/ 1a. sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or Git Version (Beta Version) sudo git clone https://github.com/Froxlor/Froxlor.git If you're using the git version, you still need to load the composer > Composer.phar and Read this for install Do not run Composer with root/super user 1a(2). Composer install in your Froxlor directory composer install --no-dev 1b. sudo chown -R www-data:www-data Froxlor/ Set up Froxlor 2. Open Your Browser 2a. http://your IP or Hostname/Froxlor Install Froxlor finish  3d. Move userdata (Optional) sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. sudo rm /etc/nginx/site-enable/default don't restart nginx! Froxlor Settings 1. Cronjob sudo nano /etc/cron.d/froxlor insert # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock 3. sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated:Change from NO to YES 3a. PHP-FPM versionsChange > php-fpm restart command: service php7.3-fpm restart and Configuration directory of php-fpm: > to /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate 1. sudo apt install certbot 1a. sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. sudo nano /etc/nginx/acme.conf insert location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfileinsert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > SettingsActivate > Enable Let's Encrypt Change Path to the acme.conf snippet to > /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings- Enable Let's Encrypt for the froxlor vhost- Enable SSL-redirect for the froxlor vhost- HTTP Strict Transport Security (HSTS)- Include HSTS for any subdomain 2d. Activated HTTP2 Support on > Settings > Nginx
  2. Folgende Situation: Ich betreibe einen vServer mit Froxlor als Hostingpanel Der docroot von meinedomain.tld liegt unter /var/customers/webs/meinAccount Eine SSL Weiterleitung wurde auf meinedomain.tld eingerichtet Kunden verwenden ein paar vorinstallierte tools (Webmailer, DB Frontend, Froxlor Panel) über toolname.meinedomain.tld Die Tools liegen nicht im docroot von meinedomain.tld sondern unter /var/www/toolname Folgendes Problem: Die SSL Weiterleitung von http auf https bei der Hauptdomain meinedomain.tld funktioniert nicht, es sei denn, man verwendet eine der Subdomains für die Tools Für meinedomain.tld wird anstatt /var/customers/webs/meinAccount der docroot /var/www verwendet Vorübergehende Lösung: Die Prüfung, ob mod_rewrite in der NN_froxlor_normal_vhost_meinedomain.tld.conf aktiv ist, entfernen <IfModule !mod_rewrite.c> Redirect 301 / https://meinedomain.tld/ </IfModule> Dann findet IMMER ein Redirect auf HTTPS statt, wobei hier auch der richtige docroot geladen wird. Nachteil: Sobald die Configs neu geschrieben werden, ist die Änderung weg. Fragen: Kann man die mod_rewrite prüfung für die SSL Weiterleitung irgendwo dauerhaft deaktivieren? Warum verwendet der vHost Container für http keinen bzw. den falschen docroot? Wie kann ich persistente Änderungen an den .conf Dateien für einen vHost vornehmen?
  3. Hallo zusammen, habe das Problem: "Unknown Error (not in option): system_phpfpm_defaultini_ownvhost" wenn ich in Froxlor die Froxlor-VHOST Settings ändern will. Server ist mit FCGI konfiguriert und läuft seit einigen Jahren. Habe heute auf Let's Encrypt umgestellt und wollte den FROXLOR Vhost auf auf Let's Encrypt umstellen - leider geht es aufgrund des Fehlers nicht. Wenn weitere Infos benötigt werden, einfach melden. Nachtrag: habe in der mysql datenbank im backend die entsprechenden flags von hand gesetzt und den master cron aufgerufen -> dann ging zumindest die erstellung der zertis etc. Fazit: Hier scheint lediglich was im GUI nicht zu stimmen (merkwürdig: Fehlermeldung spricht von FPM - ich habe allerdings auf FCGI konfiguriert...".
  4. Hallo ich hoffe, mir kann jemand helfen. Ich habe eine Subdomain erstellt (phpmyadmin.example.ltd). Dort funktioniert PHP ohne probleme. Auf meiner anderen Subdomain (wi.example.ltd) funktioniert PHP überhaupt nicht und er zeigt mir bei der index.php nur den text an, der in der Datei drin steht. In Der vHost.conf steht, dass php disabled ist. Weiss jemand, wo man das aktivieren kann? Ich finde in der Konfiguration von der Subdomain den Eintrag nicht. Vielen Dank schonmal in vorraus. Mit freundlichen Grüßen UncleSnycs
  5. Hello folks, I'm experiencing the following issue: I have create a separate customer account for myself. When I add a subdomain, PHP is disabled in the resulting vHost config. I traced the way down: The customer is PHP enabled, the TLD domain is PHP enabled. I discovered, if I just open and re-save the TLD settings page for the specific domain from the admins account after creating the subdomain in the customer account, the "phpenabled" flag gets updated correctly in the database. Which setting am I missing to realise the behaviour without this workaround?
  6. Hi, ich hätte mal eine simple Frage zum Thema Redirects. Wir möchten gerne folgende Redirects für eine Domain einrichten (siehe Screenshot für korrektest Beispiel aus dem Internet): http://www.domain.de (301) -> https://domain.de https://www.domain.de (301) -> https://domain.de http://domain.de (301) -> https://domain.de https://domain.de (301) -> kein redirect Könnten wir dies im Froxlor Panel einstellen oder ist es hierzu erforderlich das wir die vHosts Configs der einzelnen Domains/Subdomains mit einer manuellen Config erweitern die die gewünschten Redirects aufweist ? Manuell würde ja bedeuten, dass Froxlor die Config nach 15min überschreibt. Können wir dies permanent hinzufügen oder gar im Panel ? Ich denke im worse Case dann über .htaccess oder ? Gerne würde ich natürlich im vHost anfangen statt in der unteren Ebene (.htaccess). Vielen Dank schon mal im Voraus.
  7. Hallo liebes Froxlor Team, ich nutze Froxlor sehr gerne und finde es super, aber wieso gibt es 2017 noch nicht die Möglichkeit mehrere Domains mit einer IP Adresse zu nutzen? Das ist ja wirklich nicht so schwer. Ich habe jetzt halt provisorisch in jeder Domain einen Custom vhost eintrag hinzugefügt aber das ist eigentlich keine richtige Lösung. Es sollte wirklich nicht viel Aufwand sein, diese Option dem Panel hinzuzufügen... Gruß,
  8. Andreas

    Handshake failure vhost

    Hallo zusammen, ich habe Probleme mit diversen SEO-/Webseiten-Anlayse-Tools, die beim Crawlen der Domain einen SSL Handshake Failure bekommen. Wir haben den Verdacht, dass diese Tools eventuell SNI nicht beherrschen und haben daher testweise eine Domain mit eigener IP auf einem vHost mit entsprechendem SSL-Zertifikat installiert. Die Domains laufen über den Browser fehlerfrei, die Tools machen allerdings Probleme. Ein SSL-Test via https://www.ssllabs.com/ssltest/ hat nun ergeben, dass auf dem vHost neben dem Domainzertifikat auch noch das Serverzertifikat ausgegeben wird. Wie kann ich die Domain bzw. den vHost in Froxlor so konfigurieren, so dass auf dem vHost nur das Zertifkat des entsprechenden vHosts ausgegeben wird? Danke schonmal für euere Hilfe.
  9. Gibt es eine Möglichkeit einen domainspezifischen vHost Eintrag über das Froxlor Backend zu setzten? Soweit ich das sehe, werden alle Eintrage sowohl für den normalen Eintrag (*.80) als auch den SSL Port (*.443) der Domain gesetzt. Im Speziellen möchte ich für eine Pfad ein redirect setzten: Redirect permanent /secure/ https://domain.ltd/secure/ Das macht aber nur Sinn wenn das lediglich für die normale http Verbindung passiert. Alternativ müsste ich es sonst via .htaccess machen.
  10. naumix

    nginx vHost Server-Block

    Hy, mache ich irgend etwas falsch oder ist es so gewollt, dass ich bei der Domainerstellung im Abschnitt "Eigene vHost-Einstellungen" keinen Server-Block erstellen kann? Im aktuellen Fall versuche ich eine Domain "domain.tld" zu erstellen ohne Alias und über einen separaten Server-Block wollte ich "*.domain.tld" auf "domain.tld" umleiten. Dazu bietet sich ja der Abschnitt super an. Da die dort erstellten Einträge ja direkt vor dem Ende des eigentlichen Server-Blockes eingetragen werden habe ich zu diesem "Trick" gegriffen und erst den alten Server-Block geschlossen und meinen nicht geschlossen: ############################## # Eigene vHost-Einstellungen # ############################## } server { server_name *.{DOMAIN}; return 301 $scheme://{DOMAIN}$request_uri; leider ohne Erfolg. jetzt gibt es zwar den schmutzigen weg, von dem aber auch die Jungs von nginx selbst abraten mittels IF: ############################## # Eigene vHost-Einstellungen # ############################## if ($http_host != {DOMAIN}) { return 301 $scheme://{DOMAIN}$request_uri; } Die Frage ist halt ist es Absicht, dass Server-Blöcke im Bereich "Eigene vHost-Einstellungen" ignoriert werden? Danke
  11. Hi there! If have a question regarding vHosts. I'm using the up to date debian installer package of froxlor with apache2 and am missing an option to change a vhosts default value. In /etc/apache2/sites-enabled/...something...conf it say to not change the file since froxlor will recreate it. I assume it will override it with its' standard config settings but am not sure about this. How can I modify individual vhosts? I saw some froxlor screenshots showing changable vhost templates but I'm missing this in the newest froxlor package for debian. I cant just delete the Domain in froxlor since I would like to use it for E-Mail as well. Any help is very welcome! Thx! hale-xp
  12. Hallo Ich setzte gerade meinen ersten Server mit froxlor auf. Leider schaffe ich es nicht mit froxlor eine vhost zu erstellen, damit der Apache mit dem Domainnamen eine bestimmte Seite angezeigt wird. Zu Info: Habe derzeit von Hand eine Vhost Datei erstellt, die auch funktioniert. Aber ich moechte gerne froxlor verstehen. 1. Wie erstelle ich mit froxlor eine VHost? Leider finde ich im froxlor keinen Punkt dazu... 2. Wie stelle ich froxler um, damit er mit folgender URL aufgerufen werden kann z..b: froxler.xxxxxxx.de Danke f?r jeden Tip!
  13. Hallo bin ganz neu bei Froxlor. :-) Gefallen hat mir das simple und ?bersichtliche User-Interface. Gut f?r die Kunden! Im Moment teste ich es auf einem vServer, vielleicht setzen wir es ja dann produktiv ein... Die Installation klappte schon mal super. Die Basis ist ein Debian Wheezy. Bin danach alle Konfigurationsschritte durchgegangen. Der FTP-Server funktioniert, konnte auch einen Kunden anlegen, sogar eine Best?tigungsmail wurde verschickt, mySQL funktioniert auch... Das was ich aber nicht hinbekomme, ist das Routing einer Domain auf den richtigen Ordner. Der Ordner wurde von Froxlor aber korrekt angelegt (mit index.html). Die conf-Datei im Ordner /etc/apache2/sites-enabled existiert auch. Meines Wissens werden die ja automatisch eingebunden? <VirtualHost 31.47.252.201:80> ServerName test.v0296.vps.configcenter.info ServerAdmin carsten.tornow@hummelundmors.com DocumentRoot "/var/customers/webs/hummelmors/test/" php_admin_value open_basedir "/var/customers/webs/hummelmors:/tmp" Alias /webalizer "/var/customers/webs/hummelmors/webalizer" ErrorLog "/var/customers/logs/hummelmors-error.log" CustomLog "/var/customers/logs/hummelmors-access.log" combined </VirtualHost> Wie gesagt, was einfach funktionieren will, das nicht der in der Config-Datei korrekt angegebende Ordner aufgerufen wird. Hat jemand ein ?hnliches Problem? Vielen Dank Carsten
  14. Hi, I just installed Froxlor and it works like a charm. But one question, I've got left. When I create a customer or a domain ( even if it's just a customer without domain), after the cronjob, my virtual host changes the doument root from: NameVirtualHost 12.34.56.78:80 <VirtualHost 12.34.56.78:80> DocumentRoot "/var/www" ServerName myfroxlordomain.de </VirtualHost> to NameVirtualHost 12.34.56.78:80 <VirtualHost 12.34.56.78:80> DocumentRoot "/var/" ServerName myfroxlordomain.de </VirtualHost> This is making it unable for me to connect to the myfroxlordomain.de web login. I just the the Directory Index and if I add myfroxlordomain.de/www I'm back in my dashboard. Anyone an idea why I got this error ? I controlled my cronjob settings and that looks just fine. It like everytime I do a change, the Documentroot of the virtual host gets editet to /var instead of /var/www. But why ???
  15. Hallo, ich habe grade meinen vServer frisch augesetzt. Diesmal hatte ich keine lust Froxlor manuell zu installieren und habe das Froxolor image von meinem Hoster ausgew?hlt. Ob ihr's glaubt oder nicht, alles war richtig eingerichtet(was man auf den ersten blick sehen konnte). Als ich dann allerdings den ersten Kunden ins WI eingetragen habe, wollte der Apache-Server nicht auf Anfragen der Standart Sub-domain reagieren. Forefox lieferte immer :"Der Server braucht zu lange um eine Antwort zu senden.". Der DNS-Record ist richtig gesetzt und liefert auch die richtige IP-Adresse und ein trace-route liefert mir auch den richtigen Ziel-Server. Deswegen gehe ich davon aus, dass Apache nicht will. Hier mal meine Apache-Configs: httpd.config (sehr voll ) ServerName enter-game.de vhost.config # 20_froxlor_normal_vhost_ftp1.enter-game.de.conf # Created 29.02.2012 16:57 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 2 - CustomerID: 2 - CustomerLogin: ftp1 <VirtualHost 62.108.44.35:80> ServerName ftp1.enter-game.de ServerAlias *.ftp1.enter-game.de ServerAdmin bla@mail.com DocumentRoot "/var/customers/webs/ftp1/" php_admin_value open_basedir "/var/customers/webs/ftp1/:/tmp/" php_admin_flag safe_mode On ErrorLog "/var/customers/logs/ftp1-error.log" CustomLog "/var/customers/logs/ftp1-access.log" combined </VirtualHost> Weder die allgemeinen access-logs von Apache noch die Custom Access-logs zeigen irgendwelche Anfragen. Hat jemand eine Ahnung woran das liegen k?nnte ? Gr??e, Mansi EDIT: Eine andere Frage habe ich noch: Brauch man zum Traffic z?hlen zwangsm??ig awstats oder geht das auch mit webalizer ?
  16. girlhunter

    [solved] PHP/FCGID Problem

    Hallo zusammen, ich habe nun seit gestern das ganze Forum durchsucht und alle bisherigen Probleml?sungen zu dem Thema ausprobiert, allerdings alle ohne Erfolg. Zum Problem: Nach dem Umstellen auf FCGDI (strikt nach Anleitung http://redmine.froxl...CGID_-_Handbuch) bekomme ich bei Aufruf des Froxlor-Panels nur die Meldung "You have to make the file "./lib/userdata.inc.php" readable for the http-process!". Die Rechte sind f?r den User und Gruppe froxlorlocal allerdings vergeben (chown -R froxlorlocal:froxlorlocal /var/www/froxlor). Infos zum System: Froxlor Version 0.9.26-1; Debian Squeeze Vielen Dank f?r eure Hilfe. Beste Gr??e David
×