Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'ubuntu'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 9 results

  1. I have been in the process of installing Froxlor in a Google Cloud Instance. All the errors I have encountered I was able to fix them by searching on the web, but this one I couldn't find a solution for the past two hours. Simply I need help solving this error.😓
  2. Debian (9) Stretch 1. sudo apt install curl wget apt-transport-https dirmngr git 1a. Keys install wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && curl https://packages.sury.org/php/apt.gpg | apt-key add - 1b. Source List ( nano /etc/apt/source.list ) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2. MariaDB Install use sudo command for install MariaDB! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 3. nginx Install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 3c. service nginx restart 4. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 4a. service nginx restart service php7.1-fpm restart Ubuntu 17.10 (Artful) 1. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common python-software-properties 1b. Source List ( nano /etc/apt/source.list ) 1c. Key Install sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987) sudo add-apt-repository ppa:ondrej/nginx-mainline sudo add-apt-repository ppa:ondrej/php 2. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 3. MariaDB Install sudo apt install mariadb-server mariadb-client 3a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 4. nginx Install sudo apt install nginx 4a. nano /etc/nginx/nginx.conf 4b. service nginx restart 5. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 5a. service nginx restart service php7.1-fpm restart Froxlor Install Git version 1. vhost nano /etc/nginx/sites-enabled/frox 1a. service nginx restart 2. Change dir cd /usr/share/nginx/ 2a. Froxlor git Load sudo git clone https://github.com/Froxlor/Froxlor.git 2a. Folder Rename mv /usr/share/nginx/Froxlor /usr/share/nginx/your Folder Name 2b. User/Group Change for Froxlor Folder sudo chown -HR www-data:www-data Your Froxlor Folder 3. Browser Open http://your-SubDomain/your-Frolxor-Folder 3c. Change Your DB/User Name for Froxlor Install Froxlor finish 3d. Move userdata (Optional) mv /tmp/userdata.inc.php /usr/share/nginx/Your Froxlor Folder/lib/ 4. vhost delete rm /etc/nginx/site-enable/frox don't restart nginx! Froxlor Settings 1. cronjob nano /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /usr/share/nginx/your Froxlor Folder/scripts/froxlor_master_cronjob.php chmod 0640 "/etc/cron.d/froxlor" chown root:0 "/etc/cron.d/froxlor" service cron restart Froxlor Panel 1. Change your PHP-Backend Settings Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.1-fpm.sock 2. Make Folder and Change chmod mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /home/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp service nginx restart 2a. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home 2. libnss-extrausers install sudo apt install install nscd libnss-extrausers mkdir -p /var/lib/extrausers touch /var/lib/extrausers/{passwd,group,shadow} mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated: Change from NO to YES 3a. Settings > PHP-FPM > Settings Change > Configuration directory of php-fpm to /etc/php/7.1/fpm/pool.d/ Change > php-fpm restart command to /etc/init.d/php7.1-fpm restart or service php7.1-fpm restart 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. When you 502 error on Nginx have, use this command (Optional) (Thanks lino16 for this Note) sudo usermod -a -G www-data froxlorlocal SSL / Let's Encrypt activate 1. Create Folder on nginx mkdir /etc/nginx/ssl cd /etc/nginx/ssl 1a. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1b. create acme.conf nano /etc/nginx/acme.conf location /.well-known/acme-challenge { alias /usr/share/nginx/Your Froxlor Folder/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile insert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings Activate > Enable Let's Encrypt 2c. Activate on Settings > Froxlor VirtualHost settings - Enable Let's Encrypt for the froxlor vhost - Enable SSL-redirect for the froxlor vhost - HTTP Strict Transport Security (HSTS) - Include HSTS for any subdomain
  3. Rupert Dobiasch

    Maildir Pfad

    Maildir wird autom. bei Erstellung von Mailadresse angelegt, aber Pfad ist falsch, siehe /var/customers/mail/var/customers/mail/[CUSTOMER]/[DOMAIN.TLD]/[MAILBOX] "var/customers/mail" ist doppelt. Bitte um Info welcher Prozess dieses Verzeichnis anlegt, bzw. wo der Fehler liegt.
  4. Hallo, ich bin jetzt ein frischer" Anwender" und habe gestern auch schon mal eine Weile durch das Forum gestöbert. Aber eine Grundfrage ist mir noch nicht so richtig klar geworden. Ich möchte einen neuen VServer aufsetzen und überlege ob ich Debian 8.5 oder Ubuntu 16.04 nehmen soll. Gibt es für froxlor eine Präferenz? Ich selber kenne mich seit Jahren mit Ubuntu aus, aber mit Debian würde ich bestimmt genau so gut klar kommen. Bisher habe ich als Admin Panel Plex und Vesta-CP genutzt, aber bei letzterem komme ich mit dem Support nicht klar. Grüße aus Südhessen Jochen
  5. Hallo zusammen, ich habe eine frische Froxlor Installation unter Ubuntu 16.04 aufgesetzt. Wenn ich einen User anlege kann ich mich auch problemlos per FTP connecten - und Daten hochladen. Das Aufrufen der Seite funktioniert auch soweit. Nur wenn die Seite dann etwas schreiben möchte klappt dies nicht. CHMODS wurden testweise auf 755, 775 und 777 gesetzt - leider ohne Erfolg. ID www-data zeigt mir an, dass der Owner der Dateien auch in der Gruppe ist (10002). Eine Idee woran das liegen kann ? Habe schon gesucht und Verweise auf libness mysql gefunden, was ich aber konfiguriert habe. Vielen Dank vorab.
  6. Hi all, I have set up a server with the configuration from the title. web root: /var/www/ froxlor: /var/www/froxlor I have set an A record of my domain to the servers IP. When I open the domain in the browser, it always goes to the web root. Froxlor seems to be ignored. I run through the froxlor system confuguration (system/configuration) and added the domain via the panel. So, I have basically two questions: Is my configuration even possible with froxlor? How could I troubleshoot my issue? Thank you very much!
  7. DYNASTIE

    502 bei Kunden nach Reboot

    Hi, OS: Ubuntu 15.04, Webserver: nginx, PHP-FPM aktiviert? Ja! Soweit funktioniert alles, Kunden werden angelegt und man kann problemlos auf deren Seite verbinden und sieht die index.html. Wenn ich jetzt aber die index.html in index.php umbenenne, erhalte ich einen 502 gateway timed out fehler. Errorlog vom Kunden: Das Gleiche passiert bei einem Reboot. Ein simples "service nginx reload" behebt den Fehler. Kunde ist in der Webservergruppe vorhanden. nscd etc. sind richtig konfiguriert, bin nach dem offiziellen Howto gegangen. Einstellungen sollten richtig sein: Die Sockets von PHP-FPM werden auch angelegt. vhost.conf vom Kunden: php-fpm.conf (/etc/php5/fpm): Den Fehler kann ich mit: "service nginx reload" wie erw?hnt beheben. Ein "chmod 666" auf den php-fpm.socket l?st das Problem nach dem Reboot ebenfalls, jedoch m?chte ich ungern an den Rechten rumschrauben. Ebenfalls wird das problem gel?st indem ich den Master-Cronjob ausf?hre. Wobei, wenn nginx restarted/reloaded wird, ?ndert der ja nichts an den Rechten vom php-fpm.socket - also kann es nicht die L?sung sein, die chmod-Rechte auf jeden socket zu erh?hen. Edit: Habe gerade mal das System neu gestartet und sehe in der syslog folgendes: Habe aber in der nscd in der Zeile bei required-start mysql eingetragen, also d?rfte es zu dem Fehler nicht kommen. Die Daten stimmen 100% ?berein, ein manuelles Einloggverfahren mit den gleichen Daten funktioniert problemlos.
  8. Hi, I'm a bit new to Ubuntu and Froxlor... What I'm wondering is this: is there a way to set new Froxlor user accounts as new users on the hosting Ubuntu server? At present, all new Froxlor user profiles are created in var/customers/webs. But what if I wanted to create new users on the Ubuntu server via the Froxlor panel, which would also serve as Froxlor customer accounts? Thanks in advance for any help.
  9. Hi Guys, i'm running a Ubuntu 11.10 Server, currently with ISPConfig (and im very unhappy with this piece of s***), i'm really looking forward to install FROXLOR. Is it supported and possible to install Froxlor on Ubuntu 11.10 without any problems? I have also postfix, apache, mysql and some more stuff running, connected with ispconfig, would it be possible to use the extisting settings from these services and integrate it with froxlor then? thanks Markus
×