Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'subdomain'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 9 results

  1. Hallöchen zusammen, ich hätte mal eine Frage bezüglich Froxlor und Cloudflare. Da einige die Froxlor benutzen, bestimmt auch bei cloudflare ihre domain eingetragen haben, stellt sich mir die Frage ob man dies nicht gleich auch mit cloudflare verbinden kann um so seine subdomains / Domains miteinzurichten, ohne sich immer zusätzlich bei cloudflare anzumelden. Cloudflare bringt ja von Haus aus eine API mit womit man sich auch über Scripte und einen Authentifikations Key extern anmelden kann. Cloudflare API: https://api.cloudflare.com/ Ich für meinen Teil würde es Prima finden wenn zum Beispiel Kunden ihren Login Key eintragen, und damit bequem auch bei erstellung von subdomains gleichzeitig (sofern sie ihre Domain beim Cloudflare registriert haben) alles in einem abwickeltn können. Was haltet ihr von der Idee und könnte man es überhaubt verwirklichen für Froxlor? lg H4nSolo
  2. Hallo, ich bin schon wieder am verzweifeln, vielleicht kann mir jemand helfen... Ich habe eine Domain mit Letsencrypt angelegt und die läuft auch wunderbar. Nun will ich dazu eine Wildcard Subdomain OHNE SSL (Letsencrypt) anlegen, es wird ein vhost für SSL angelegt und erzeugt beim Apache-Server einen Konfigurationsfehler... Läßt sich sowas realisieren oder ist das ein Fehler bei Froxlor ? Die Domain mit https://meine-domain.de und http://*.meine-domain.de angelegt, der Ordner wo die -> http://*.meine-domain.de hinverweist wird angelegt, aber die Sub-Domains laufen in den Root des Servers, also 404 Not Found.
  3. Ich glaube ich brauche für heute noch mal einen kleinen Denkanstoß um den berühmten Hacken zu finden. Folgendes ist eingestellt: IPs und Ports (Meiner einziger IP) -> Benutzerdefinierter Docroot -> /var/www/ Einstellungen -> Hostname -> v22018xxx.luckysrv.de Einstellungen -> Froxlor VirtualHost Einstellungen -> Froxlor direkt über den Hostnamen erreichbar machen [X] Ziel ist es das Froxlor Admin Panel über v22018xxx.luckysrv.de erreichbar zu machen, aber bei jeder anderen URL oder meiner IP das Standard Verzeichnis /var/www/ anzuzeigen Leider wird der Hostname nicht auf den richtigen Ordner /var/www/froxlor eingestellt. Nur wenn ich den IPs und Ports (Meiner einziger IP) -> Benutzerdefinierter Docroot rausnehme.
  4. Einen wunderschönen guten Abend, Ich habe ein kleines Problem mit Subdomains auf meinem Webserver. Ich habe für diesen Froxlor mit LetsEncrypt eingestellt und bereits RainLoop als Webmailer eingerichtet. Das hat wunderbar funktioniert über meinedomain.de/webmailordner. Nun wollte ich allerdings eine Subdomain anlegen (webmail.meinedomain.de) das will aber nicht funktionieren. Die Subdomain bekommt korrekt ein SSL Zertifikat zugewiesen, allerdings wird die in dem Verzeichnis liegende PHP Datei nicht ausgeführt sondern einfach nur der Inhalt angezeigt. Somit ist das Aufrufen des Webmailers nicht möglich. Rufe ich den Webmailer wieder über "meinedomain.de/webmailordner" auf funktioniert alles ganz normal. Ebenfalls wollte ich das Verzeichnis von meinedomain.de ändern, sobald ich das allerdings mache bekomme ich nur noch den Fehler 403 forbidden unter der Domain. Sobald ich den Pfad wieder in den Kundenroot ändere funktioniert es wieder. Allerdings sollen auf den Server doch diverse Domains für verschiedene Dienste umgezogen werden und die aktuelle Domain ist nur für einen Dienst gedacht soll also auf einen Unterordner verweisen, wo ist hier das Problem? Vielen Dank für eure Hilfe! In den angehängten Screenshot ist die Konfiguration in Froxlor zu sehen, falls noch etwas benötigt wird reiche ich das natürlich sofort nach.
  5. Why my froxlor doesn't have "create subdomain" button? I tried to create another customers, but the button still missing. Anyone met the same situation?
  6. Moin, anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log: root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? 🤔
  7. Hi all, is it possible to use a shared php-fpm pool for a domain and its subdomains? I have a domain with ~80 subdomains for the local branches of a political party. I can't use a wildcard domain because we're using Let's Encrypt certificates, and an alias domain seems to not work either for the same reason. However, having 80+ php-fpm pools is a little high on the memory side. Do you have any advice for me? Best regards
  8. I've installed froxlor about 5 times in the past 36 hours (all on same machine) and still don't quite understand this part. I want to be able to manage my own root domain from froxlor, this is the domain that froxlor is being used on. So i have a domain like so thisismydomain.com When I setup froxlor on the first setup screen, if i enter this as my FQDN then i can not add it as a domain in Froxlor so have to manage it outside of Froxlor. I want to manage this domain, which is also the domain Froxlor is installed on from within Froxlor. So i have experiemented with just making up a random subdomain and entering this on the Froxlor setup screen, like this: - Server name (FQDN, no ip-address): anything.thisismydomain.com When I do this I can add a customer when i log into Froxlor and then add my actual domain (thisismydomain.com) which is what I was looking to do. My questions are: 1) Is this the correct way to setup Froxlor so I can add my own domain in froxlor and have it managed inside froxlor? 2) can i just make up a subdomain, and enter it, and this will work ok? Or do i need to add this to my webserver config files myself somehow also? - i'm using NginX 3) I discovered froxlor because I'm working on a server, that someone else setup and they had installed froxlor, so it's all pretty new to me. I'm building a test server to get to grips with it, hence all my recent questions. In the server that is already setup and functioning, there is only one domain visible when you click on domains and it is the root domain, e.g. thisismydomain.com ; there are no other domains in there... how do I achieve this same effect? Whenever I setup froxlor like I have explained above, i get a thisismydomain.com domain entry (after I have added it through froxlor) - but i also get a anything.thisismydomain.com domain entry - which is added when I create the customer - however there is no delete option next to this domain ; and I don't understand how the person that setup the froxlor I'm working with on another server, how they managed to get just the domain listed in the domains entry inside the control panel. One thing i have noticed is that on this, they have used a subdomain it would appear as froxlor is accessed by typing - something.thedomain.com ; and if you go to the domain.com/froxlor nothing is there ; but I'm confused about how they've achieved this also because in the nginx config there are no rewrites to forward traffic from something.thedomain.com to thedomain.com/froxlor - also i've checked the config through the froxlor panel on this server and the 'access froxlor through a hostname option' is not ticked. If you could answer this as detailed as possible, it would be appreciated, as I've been grappling with this question myself for the past few days, Many thanks - and kudos on a great product, and service for the community.
  9. Because otherwise he's not able to change the open_basedir-settings for the default subdomain. As an admin you can only turn it on/off, but not choose between document root and customers home dir.
×
×
  • Create New...