Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'seo'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Found 2 results

  1. Hi, ich hätte mal eine simple Frage zum Thema Redirects. Wir möchten gerne folgende Redirects für eine Domain einrichten (siehe Screenshot für korrektest Beispiel aus dem Internet): http://www.domain.de (301) -> https://domain.de https://www.domain.de (301) -> https://domain.de http://domain.de (301) -> https://domain.de https://domain.de (301) -> kein redirect Könnten wir dies im Froxlor Panel einstellen oder ist es hierzu erforderlich das wir die vHosts Configs der einzelnen Domains/Subdomains mit einer manuellen Config erweitern die die gewünschten Redirects aufweist ? Manuell würde ja bedeuten, dass Froxlor die Config nach 15min überschreibt. Können wir dies permanent hinzufügen oder gar im Panel ? Ich denke im worse Case dann über .htaccess oder ? Gerne würde ich natürlich im vHost anfangen statt in der unteren Ebene (.htaccess). Vielen Dank schon mal im Voraus.
  2. Hallo zusammen, erstmal meine Konfiguration: Debian wheezy, nginx, Froxlor, php-fpm und als CMS probiere ich gerade GetSimple. Get Simple hat eine Funktion, die da heisst: "Nutze freundliche URLs - Erfordert 'mod_rewrite' auf Ihrem Server" Wie man schon erkennen kann ist Get Simple eigentlich auf Apache ausgelegt. Die sonstigen URLs sehen folgenderma?en aus: $URL/index.php?=eine_unterseite Die SEO-Funktion von Get Simple soll folgendes machen: $URL/eine_unterseite/ Es gibt eigentlich auch schon Vieles dazu im Netz, aber scheinbar funktioniert das entweder nicht mit der Froxlor-Konfiguration zusammen oder hakt einfach an meinem Unverst?ndnis Meine erste Idee dazu war folgende als "Eigene VHOST-Einstellungen" in Froxlor einzutragen: location / { try_files $uri $uri/ /index.php?=$uri&$args; } Unter sites_enabled sehe ich dann nach Aktivierung folgendes Konstrukt: server { listen IP:80; server_name example.com *.example.com mail.example.com *.mail.example.com; access_log /var/customers/logs/example.com-access.log combined; error_log /var/customers/logs/example.com-error.log error; root /var/customers/webs/test/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; try_files $uri $uri/ /index.php?=$uri&$args; } location @rewrites { rewrite ^ /index.php last; } location /awstats { alias /var/customers/webs/test/awstats/example.com/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/2-sd7f67sd6f76sd87.htpasswd; } location ~ ^/awstats-icon/(.*)$ { alias /usr/share/awstats/icon/$1; } location ~ \.php$ { try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass unix:/var/run/nginx/example.com-php-fpm.socket; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include /etc/nginx/fastcgi_params; } } Ich habe auch schon etwas an dem try files Konstrukt geschraubt, aber bekomme st?ndig einen 404 Hat jemand zuf?llig den richtigen Riecher und kann mir einen Tipp geben? Danke schon mal.
×