Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'php5-fpm'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. I'm working on getting my froxlor instance setup with PHP5-FPM and Nginx and was encountering an issue whereupon reboot the PHP functionality would be broken. Looking in syslog would give me about 30 lines of PHP5-FPM failing to start and then giving up. Looking in php5-fpm.log would tell me nothing useful other then the configtest passed. I eventually found a helpful message in the /var/log/upstart/php5-fpm.log file: [14-May-2015 09:21:54] ERROR: unable to bind listening socket for address '/var/run/nginx/username-domain.com-php-fpm.socket': No such file or directory (2) True enough the /var/run/nginx folder did not exist. I could not figure out where it was going. After hair pulling research I found that the /var/run mount point is run as tmpfs and so is deleted on reboot. In order to fix this I had to ensure the directory was recreated before PHP5-FPM started. It turns out this if fairly easy with upstart. I added this stanza: pre-start ... other stuff ... [ -d /var/run/nginx ] || mkdir -p /var/run/nginx end script to the /etc/init/nginx.conf file to have the folder created on boot. Problem solved.
  2. Hi, I?m using Froxlor with Apache2 and Php5-fpm on a Debian Wheezy server. I installed Oncloud using debians packetmanager so that Owncloud is installed in /var/www/owncloud and is owned by user www-data and group www-data. The problem is, if I create a new domain using froxlor and set the DocumentRoot to /var/www/owncloud the php process cant write the config files because it runs as myuserinfroxlor. I tried to set the listen.owner and listen.group or user and group directives in my php pool configuration but without any luck. How do I deal with this in general? Kind Regards Floh1111
  3. Hey, ich habe heute meinen vServer neu aufgesetzt und dabei speziell auf die Installation von Froxlor hingearbeitet. Nachdem ich alle anderen Probleme via Google beheben konnte, sto?e ich nun auf mein gr??tes Problem: Ich erhalte schlichtweg keine E-Mails. Ich habe die in Froxlor angegebenen Konfigurationen f?r Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix/Dovecot Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix MX-Access (anti spam) Debian 7.0 (Wheezy) ? Mailserver (IMAP/POP3) ? Dovecot durchgef?hrt und nachtr?glich mehrmals gepr?ft. Wenn ich nun eine E-Mail von meinem GMail Account an eine in Froxlor angelegte E-Mail Adresse schicke (welche ich wiederum ?ber GMail abrufe), kann ich dem /var/log/mail.log entnehmen, dass eine Verbindung zur froxlor Datenbank aufgebaut wird und die Mail anschlie?end nach 'INBOX' gespeichert wurde. Leider warte ich bei GMail anschlie?end vergebens darauf, dass die E-Mail ankommt. Auch auf Dateiebene unter /var/customers/mail/Kunde/Domain/mail/Maildir/* kann ich nichts von der E-Mail finden. Wenn ich das Prinzip der Ablage richtig verstanden habe, m?sste da ja irgendwo eine Datei mit Namen 'CAJF6H3nemCOW+L9xCU+2nB4iR55WV_QpHjBpf63e=bYG01PuFQ@mail.gmail.com' sein. Wenn ich danach suche, oder nur nach gmail, finde ich nichts. Ich habe auch die froxlor Datenbank durchsucht und keine Tabelle gefunden, in der E-Mails gespeichert sein k?nnten. Zur Info: Die Mails von Froxlor ?ber angelegte Accounts etc. kommen bei GMail an, also muss es meiner Meinung nach etwas mit der Ablage der Mails beim Empfang zu tun haben. Bin also auf Eure Hilfe angewiesen. Kann jemand helfen? Hat jemand einen Verdacht? Gern poste ich weitere Logfiles, jedoch bin ich bis jetzt nicht f?ndig geworden. Danke! Timmaeh
×
×
  • Create New...