Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'php http header authorization'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. In the default configuration the http-header "Authorization" is not passed to the fastcgi server. You could see this behavior in the mod_fastcgi documentation of the apache webserver. The REST-API of an installation of the Magento webstore software uses oauth. To fullfil the authorization steps they use the "Authorization" header. But this header isn't passed to the php process. So we've to append '-pass-header Authorization' to the FastCgiExternalServer configuration line to obtain a line like this: FastCgiExternalServer .../fpm.external -socket ../customer-php-fpm.socket -idle-timeout 180 -pass-header Authorization But I'm not sure if authorization-header passing is enabled we get some security constraints too. What do you think? Maybe we could open a feature/bug ticket for this case?
×
×
  • Create New...