Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'permissions'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 5 results

  1. Guten Tag, ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000. Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen. Liebe Grüße tmuecksch
  2. Hi, I just set up Froxlor to work with php-fpm. I'm using pretty much the standard configuration. Debian Jessie Froxlor ver 0.9.35.1-1 PHP 5.6 My pool-config lies in /etc/php5/fpm/pool.d since I'm using Debian Jessie, all other configuration values are set to default. Therefore the configuration alias-directory of php-fpm is set to /var/www/php-fpm/ My Problem is, that froxlor creates/changes the subdirectories (e.g. /var/www/php-fpm/username) on every master cronjob to owner root:root with permissions 750. This way I get this error on access in the users custom error log from apache stating (13)Permission denied: [client 77.181.66.50:49690] AH00035: access to /fastcgiphp/index.php denied (filesystem path '/var/www/php-fpm/username/domain.com') because search permissions are missing on a component of the path, referer: http://domain.com/ Right now I fixed it by adding a chmod o+x /var/www/php-fpm/* to the webserver restart script, that I have configured. Is this due to a misconfiguration or a bug? Regards jBOKA
  3. Hallo, ich habe bereits flei?ig im Forum gesucht, allerdings gibt es scheinbar keine konkrete Antwort darauf: Wo verbirgt sich in Froxlor die Einstellung, mit der ich setzen kann, dass alle Kunden-Webs-Verzeichnisse, die erstellt werden, mit der Berechtigung +x erstellt werden? Gerade landen alle Aufrufe nach dem Neuanlegen erst einmal in einem 403 permission denied. Ich nutze Ngninx unter Debian 7. Wei? jemand, wo diese Einstellung gesetzt wird? Danke!
  4. Hi, I?m using Froxlor with Apache2 and Php5-fpm on a Debian Wheezy server. I installed Oncloud using debians packetmanager so that Owncloud is installed in /var/www/owncloud and is owned by user www-data and group www-data. The problem is, if I create a new domain using froxlor and set the DocumentRoot to /var/www/owncloud the php process cant write the config files because it runs as myuserinfroxlor. I tried to set the listen.owner and listen.group or user and group directives in my php pool configuration but without any luck. How do I deal with this in general? Kind Regards Floh1111
  5. Hallo Leute, ich habe die Suchfunktion benutzt und es gibt haufenweise threads dazu, trotzdem bin ich der L?sung nicht n?her gekommen. Meine aktuelle Situation ist folgende: Ich habe einen vserver mit vorinstalliertem froxlor gehabt und wollte die sicherheit erh?hen, weil ich 2-3 kleine getrennte domains hosten m?chte. Aus negativen Erfahrungen der Vergangenheit bin ich auf die L?sung gesto?en apache mit jeweiligen Rechten laufen zu lassen, sodass nur das eigene www-verzeichnis gelesen und geschrieben werden kann. Also in froxlor mal fcgid angeschalten und alles nach der offiziellen Anleitung installiert, aber Pustekuchen... Die Situation ist folgende, ich habe Permission probleme bei den Kundenwebs und ps faux (siehe anleitung) zeigt mir f?r alle apache2 prozesse den user www-data. Ist das so richtig? Ich vermute mal nicht. K?nnt ihr mir bitte weiterhelfen? Ich habe suexec custom probiert und bin damit auch nicht weiter gekommen, weshalb ich wieder das "normale" installiert habe. Mod_php ist nicht deaktiviert, weil ich sonst den php quellcode sehe, obwohl ich mit a2enable fcgi aktiviert habe. ?ber eine L?sung oder Idee w?re ich sehr Dankbar. EDIT: Es handelt sich nicht um 403, sondern Internal Server Error, suexec.log sagt: [2015-01-08 16:39:22]: uid: (10000/schneider) gid: (10000/schneider) cmd: php-fcgi-starter [2015-01-08 16:39:22]: cannot get docroot information (/var/www)
×
×
  • Create New...