Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'perl'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I've installed Debian 8.2 amd64 with apache, mysql and php to run as a webserver. What I want is retrieving the $_SERVER['REMOTE_USER'] when my clients, using Windows XP and Windows 7, visit the intranet installed on the Debian server. Modules that are enabled in apache: alias auth_basic auth_kerb authn_core authn_file authz_core authz_host authz_user autoindex cgi deflate dir env filter mime mpm_prefork negotiation perl php5 setenvif status httpd.conf DirectoryIndex index.php index.html index.htm KeepAlive on HostnameLookups on <Location /test> PerlAuthenHandler "Apache2::AuthenNTLM" AuthType ntlm,basic AuthName "NTLM Authentication" require valid-user PerlAddVar ntdomain "MYDOMAIN 10.52.43.220" PerlSetVar defaultdomain "MYDOMAIN" PerlSetVar splitdomainprefix 1 PerlSetVar ntlmdebug 0 PerlSetVar ntlmauthorative off PerlSetVar ntlmsemkey 0 PerlSetVar ntlmsemtimeout 1 </Location> apache2.conf is a default file without any changes. Because it doesn't work I tried putting an .htaccess in /var/www/test <Location /test> AuthType NTLM NTLMAuth on NTLMAuthoritative on NTLMDomain MYDOMAIN NTLMServer 10.52.43.220 require valid-user </Location> But it doesn't work either. /var/log/apache2/error.log displays this: [Thu Oct 08 11:34:23.786879 2015] [mpm_prefork:notice] [pid 2287] AH00163: Apache/2.4.10 (Debian) mod_auth_kerb/5.4 mod_perl/2.0.9dev Perl/v5.20.2 configured -- resuming normal operations [Thu Oct 08 11:34:23.786922 2015] [core:notice] [pid 2287] AH00094: Command line: '/usr/sbin/apache2' [Thu Oct 08 11:35:39.656529 2015] [:error] [pid 2293] [client 10.52.43.14:49784] PHP Notice: Undefined index: REMOTE_USER in /var/www/html/test/ntlm.php on line 2, referer: http://10.52.43.71/test/ What am I doing wrong and how can I fix it?
×
×
  • Create New...