Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'nginx'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 32 results

  1. Hallo, ich habe Debian Strecht und nginx mit MariaDB installiert und möchte gern PHP 7 mit FPM ans laufen bekommen. Das erste Problem, dass ich habe ist, dass die Ausgabe von ls /var/customers/webs nicht die User sondern nur die ID ausgibt. drwxr-xr-x 5 10000 10000 4096 Nov 10 15:26 web1 Habe alles wie in der Anleitung beschrieben installiert und erhalte auch hier die User: cat /var/lib/extrausers/passwd web1:x:10000:10000:Froxlor User:/var/customers/webs/web1/:/bin/false Nun läuft der Webserver auch trotzdem und ich kann per FTP Dateien hochladen. Allerdings wird der PHP Socket nicht erstellt. In der vHost steht z.B. fastcgi_pass unix:/var/run/php/web1-meinedomain.de-php-fpm.socket; Im Ordner /var/run/php existieren aber nur php7.0-fpm.pid und php7.0-fpm.sock. Im Froxlor Backend habe ich " Verwende libnss-extrausers anstatt libnss-mysql" aktiviert. Cronjobs sind auch eingerichtet. Ich hatte auch mal in der /etc/php/7.0/fpm/pool.d/www.conf folgende Zeile eingefügt "include=/etc/php-fpm.d/*.conf". Ob das richtig ist weiß ich leider nicht. Aber wenn ich dann fpm neustarte erhalte ich folgende Fehler: ERROR: [pool meinedomain.de] cannot get uid for user 'web1' Ich vermute es hat mit libnss zu tun. Habt Ihr vielleicht eine Idee?
  2. Evren

    Let's Encrypt with nginx

    Hi, I wonder if there is anyone who able to properly set up Let's Encrypt feature with nginx? I followed suggested steps but I couldn't make it happen. - activate Let's Encrypt in the settings - as admin, goto Configuration -> select your distro -> select Webserver -> select your software - copy'n'paste the acme.conf part of the configration template - restart/reload webserver Then I run the cron php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid But, when I try to enable Let's Encrypt for a domain, the system automatically uncheck this option after I save. Any idea? Thanks
  3. Debian (9) Stretch 1. sudo apt install curl wget apt-transport-https dirmngr git 1a. Keys install wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && curl https://packages.sury.org/php/apt.gpg | apt-key add - 1b. Source List ( nano /etc/apt/source.list ) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2. MariaDB Install use sudo command for install MariaDB! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 3. nginx Install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 3c. service nginx restart 4. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 4a. service nginx restart service php7.1-fpm restart Ubuntu 17.10 (Artful) 1. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common python-software-properties 1b. Source List ( nano /etc/apt/source.list ) 1c. Key Install sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987) sudo add-apt-repository ppa:ondrej/nginx-mainline sudo add-apt-repository ppa:ondrej/php 2. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 3. MariaDB Install sudo apt install mariadb-server mariadb-client 3a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 4. nginx Install sudo apt install nginx 4a. nano /etc/nginx/nginx.conf 4b. service nginx restart 5. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 5a. service nginx restart service php7.1-fpm restart Froxlor Install Git version 1. vhost nano /etc/nginx/sites-enabled/frox 1a. service nginx restart 2. Change dir cd /usr/share/nginx/ 2a. Froxlor git Load sudo git clone https://github.com/Froxlor/Froxlor.git 2a. Folder Rename mv /usr/share/nginx/Froxlor /usr/share/nginx/your Folder Name 2b. User/Group Change for Froxlor Folder sudo chown -HR www-data:www-data Your Froxlor Folder 3. Browser Open http://your-SubDomain/your-Frolxor-Folder 3c. Change Your DB/User Name for Froxlor Install Froxlor finish 3d. Move userdata (Optional) mv /tmp/userdata.inc.php /usr/share/nginx/Your Froxlor Folder/lib/ 4. vhost delete rm /etc/nginx/site-enable/frox don't restart nginx! Froxlor Settings 1. cronjob nano /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /usr/share/nginx/your Froxlor Folder/scripts/froxlor_master_cronjob.php chmod 0640 "/etc/cron.d/froxlor" chown root:0 "/etc/cron.d/froxlor" service cron restart Froxlor Panel 1. Change your PHP-Backend Settings Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.1-fpm.sock 2. Make Folder and Change chmod mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /home/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp service nginx restart 2a. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home 2. libnss-extrausers install sudo apt install install nscd libnss-extrausers mkdir -p /var/lib/extrausers touch /var/lib/extrausers/{passwd,group,shadow} mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated: Change from NO to YES 3a. Settings > PHP-FPM > Settings Change > Configuration directory of php-fpm to /etc/php/7.1/fpm/pool.d/ Change > php-fpm restart command to /etc/init.d/php7.1-fpm restart or service php7.1-fpm restart 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. When you 502 error on Nginx have, use this command (Optional) (Thanks lino16 for this Note) sudo usermod -a -G www-data froxlorlocal SSL / Let's Encrypt activate 1. Create Folder on nginx mkdir /etc/nginx/ssl cd /etc/nginx/ssl 1a. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1b. create acme.conf nano /etc/nginx/acme.conf location /.well-known/acme-challenge { alias /usr/share/nginx/Your Froxlor Folder/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile insert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings Activate > Enable Let's Encrypt 2c. Activate on Settings > Froxlor VirtualHost settings - Enable Let's Encrypt for the froxlor vhost - Enable SSL-redirect for the froxlor vhost - HTTP Strict Transport Security (HSTS) - Include HSTS for any subdomain
  4. Moin, ich habe da mal eine Frage zum Browser Caching. Man kann das Browser Caching in den conf Dateien unter /etc/nginx/sites-available/ mit folgenden Befehl aktivieren. location ~* \.(jpg|jpeg|png|gif|ico|css|js)$ { expires 365d; } Das funktioniert wunderbar. Leider werden die conf Dateien durch den Cronjob wieder überschrieben. Gibt es eine Möglichkeit das irgendwo fest zu hinterlegen, damit es automatisch in die neu generierten Dateien eingetragen wird? NGINX 1.3.1 PHP5 0.9.38.7-1+wheezy1 Ich freue mich auf eure Antworten! Silvio
  5. OliverRahner

    overriding nginx try_files setting

    And the next issue on my way to nginx'iness. I want to run Seafile on one vhost. I added all the settings Seafile told me to in their manual (https://manual.seafile.com/deploy/deploy_with_nginx.html). Didn't work at first (got 404'ed after the initial redirect), but once I commented out either the "try_files" in "location /" or in "location @php" it started working. It seems that the =404 which is default in "location @php" is the issue. Even after reading through the source code's "mergeVhostCustom" magic I couldn't find a way to override the default try_files statement without patching my Froxlor installation... Any hints?
  6. Tomasz Czauderna

    SPDY in froxlor

    Hi I don't do this but i have plan setup up domain with spdy can I set this in Froxlor of any method ?? BestRegards
  7. Ein weiteres Problem, welches ich bei der Konfiguration von Nginx mit Froxlor habe wäre: Wie leite ich direkt bei Aufruf der domain bspw. www.hochzeitsfotografie-pajo.de auf https um? Soweit ich es ergoogelt habe müsste ich weitere "server" blöcke einbauen, dass geht über die vHost Einstellungen in Froxlor jedoch nicht. Eine Verschachtelung ist ebenfalls nicht möglich. Was wäre hier also der richtige Ansatz? Das gefundene Snippet wäre wie folgt: server { listen 80; listen [::]:80; server_name www.example.com; return 301 https://$server_name$request_uri; } server { listen 443 default_server ssl; server_name www.example.com; ssl_certificate /path/to/my/cert; ssl_certificate_key /path/to/my/key; } Ideen und Vorschläge sind sehr willkommen
  8. Hi, because I had some issues with HTTP2 and php via fcgid under Apache I tried to switch to php_fpm. While I was at it, I noticed a problem that I couldn't pinpoint and decided to try nginx. The issue stayed the same, basically these log entries: nginx: connect() to unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: xx.xx.xx.xx, server: domainname.de, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket:", host: "domainname.de", referrer: "https://domainname.de/" Apache: (13)Permission denied: [client xx.xx.xx.xx:63318] FastCGI: failed to connect to server "/var/www/php-fpm/web2/domainname.de/ssl-fpm.external": connect() failed The way I understand this problem: By design, php-fpm sockets created by Froxlor have permissions which only allow the vhost user to connect. But neither Apache nor nginx are told anywhere under which identity to connect to the socket. The SuExecUserGroup line in the vhost config file for Apache which does this for fcgid vanished when switching to php-fpm. I currently solved the problem by changing the line "listen.owner" inside the php-fpm pools to "www-data". That should not lower security, because php-fpm in itself takes care that the php process runs as the vhost user. Can someone tell me where I misunderstood the whole concept?
  9. Schutzgeist

    NGINX redmine HOW-TOs

    Hallo! Besteht nach dem Crash die Möglichkeit an die WIKIS heranzukommen ? http://redmine.froxlor.org/projects/froxlor/wiki/FPM_-_nginx_-_howto ist derzeit nicht aktiv. Ich nutze Debian 8/jessie + nginx 1.12 + php7.0-fpm und php7.0-mysql Mit hat er leider auch apache2 php5 usw installiert. Durch schlampige remove-purge* Ausführungen hab ich mir andere Konfigs erneut versaut . Auf Grund von Zeitdruck und Schlafmangel möchte ich mir weitere selbstverschuldete Fehler ersparen Gibt es eine apt-get-Paket-Installationsvariante ohne Apache2/php-Zwangs-Installation ? Finde leider meine alten Tutorials nicht mehr. Im Zweifel werde ich die tar manuell entpacken und alles so aufsetzen. Danke
  10. Hi all, I have set up a server with the configuration from the title. web root: /var/www/ froxlor: /var/www/froxlor I have set an A record of my domain to the servers IP. When I open the domain in the browser, it always goes to the web root. Froxlor seems to be ignored. I run through the froxlor system confuguration (system/configuration) and added the domain via the panel. So, I have basically two questions: Is my configuration even possible with froxlor? How could I troubleshoot my issue? Thank you very much!
  11. naumix

    nginx vHost Server-Block

    Hy, mache ich irgend etwas falsch oder ist es so gewollt, dass ich bei der Domainerstellung im Abschnitt "Eigene vHost-Einstellungen" keinen Server-Block erstellen kann? Im aktuellen Fall versuche ich eine Domain "domain.tld" zu erstellen ohne Alias und über einen separaten Server-Block wollte ich "*.domain.tld" auf "domain.tld" umleiten. Dazu bietet sich ja der Abschnitt super an. Da die dort erstellten Einträge ja direkt vor dem Ende des eigentlichen Server-Blockes eingetragen werden habe ich zu diesem "Trick" gegriffen und erst den alten Server-Block geschlossen und meinen nicht geschlossen: ############################## # Eigene vHost-Einstellungen # ############################## } server { server_name *.{DOMAIN}; return 301 $scheme://{DOMAIN}$request_uri; leider ohne Erfolg. jetzt gibt es zwar den schmutzigen weg, von dem aber auch die Jungs von nginx selbst abraten mittels IF: ############################## # Eigene vHost-Einstellungen # ############################## if ($http_host != {DOMAIN}) { return 301 $scheme://{DOMAIN}$request_uri; } Die Frage ist halt ist es Absicht, dass Server-Blöcke im Bereich "Eigene vHost-Einstellungen" ignoriert werden? Danke
  12. Hallihallo liebes Forum, ich muss nach einer langen Recherche aufgeben und mal nachfragen. Und zwar geht es konkret darum Froxlor Kunden-Domains mit SSL-Zertifikaten zu best?cken. Wie schon erw?hnt, habe ich mich umgehend umgeschaut und kam nicht wirklich zu einer L?sung des Problems durch Suchen und Ausprobieren. Mal vorweg das Problem: nginx liefert dem Browser das SSL-Zertifikat, was unter "IP and Ports" hinterlegt wurde, also quasi sowas wie das "Server-Fallback-Zertifikat" statt dem SSL-Zertifikat, was der Kunde angelegt hat. Das ist so nat?rlich nicht praktikabel und daher kann da ja nur etwas nicht stimmen. Zu den technischen Details: Der Server ist ein Debian 3.2.65-1+deb7u2 x86_64 Es l?uft Froxlor 0.9.33.1-1 Es l?uft nginx 1.6.2 (SNI-Support) sowie php5-fpm PHP 5.4.36-0+deb7u3 Ich benutze aktuelle Browser mit SNI-Support Die Kunden k?nnen erfolgreich als "virtuelle" UNIX User gemappt werden (also f?r PHP-Socket-Zugriff etc.) Die nginx Vhost Dateien: IP und Port SSL-Vhost: http://nopaste.linux-dev.org/?450919 Kunden SSL-Vhost: http://nopaste.linux-dev.org/?450920 Wie ich das sehe, sieht das korrekt aus, oder? Das Problem ist nun, dass ich statt dem Kunden SSL Zertifikat das der IP bekomme, also das unter /pfad/zum/server/cert.crt. Was ich schon gemacht habe: s?mtliche Einstellungen der IP ge?ndert (alle Checkboxen mal durchprobiert), also diese Vhost-Container ja/nein, Servername ja/nein, ? Domains gel?scht/neu hinzugef?gt Zertifikate gel?scht/neu hinzugef?gt Configs neu geschrieben Services neu gestartet Was sonst noch so passiert: L?sche ich das der IP hinterlegte SSL-Zertifikat, sagt nginx bei einer Anfrage auf die SSL-Kunden-Domain, dass kein SSL-Zertifikat angegeben wurde Vielleicht habe ich einige Daten, Fakten und Dinge, die ich schon probiert habe, vergessen zu erw?hnen. Fragt doch bitte, wenn was fehlt oder unklar ist. ?ber Denkanst??e w?re ich sehr dankbar, ich bin noch recht neu um Umgang mir Froxlor und wollte jetzt mal die SSL-Implementation testen? Ich gehe mal davon aus, dass mein Fehler recht trivial sein d?rfte.
  13. DYNASTIE

    502 bei Kunden nach Reboot

    Hi, OS: Ubuntu 15.04, Webserver: nginx, PHP-FPM aktiviert? Ja! Soweit funktioniert alles, Kunden werden angelegt und man kann problemlos auf deren Seite verbinden und sieht die index.html. Wenn ich jetzt aber die index.html in index.php umbenenne, erhalte ich einen 502 gateway timed out fehler. Errorlog vom Kunden: Das Gleiche passiert bei einem Reboot. Ein simples "service nginx reload" behebt den Fehler. Kunde ist in der Webservergruppe vorhanden. nscd etc. sind richtig konfiguriert, bin nach dem offiziellen Howto gegangen. Einstellungen sollten richtig sein: Die Sockets von PHP-FPM werden auch angelegt. vhost.conf vom Kunden: php-fpm.conf (/etc/php5/fpm): Den Fehler kann ich mit: "service nginx reload" wie erw?hnt beheben. Ein "chmod 666" auf den php-fpm.socket l?st das Problem nach dem Reboot ebenfalls, jedoch m?chte ich ungern an den Rechten rumschrauben. Ebenfalls wird das problem gel?st indem ich den Master-Cronjob ausf?hre. Wobei, wenn nginx restarted/reloaded wird, ?ndert der ja nichts an den Rechten vom php-fpm.socket - also kann es nicht die L?sung sein, die chmod-Rechte auf jeden socket zu erh?hen. Edit: Habe gerade mal das System neu gestartet und sehe in der syslog folgendes: Habe aber in der nscd in der Zeile bei required-start mysql eingetragen, also d?rfte es zu dem Fehler nicht kommen. Die Daten stimmen 100% ?berein, ein manuelles Einloggverfahren mit den gleichen Daten funktioniert problemlos.
  14. I'm working on getting my froxlor instance setup with PHP5-FPM and Nginx and was encountering an issue whereupon reboot the PHP functionality would be broken. Looking in syslog would give me about 30 lines of PHP5-FPM failing to start and then giving up. Looking in php5-fpm.log would tell me nothing useful other then the configtest passed. I eventually found a helpful message in the /var/log/upstart/php5-fpm.log file: [14-May-2015 09:21:54] ERROR: unable to bind listening socket for address '/var/run/nginx/username-domain.com-php-fpm.socket': No such file or directory (2) True enough the /var/run/nginx folder did not exist. I could not figure out where it was going. After hair pulling research I found that the /var/run mount point is run as tmpfs and so is deleted on reboot. In order to fix this I had to ensure the directory was recreated before PHP5-FPM started. It turns out this if fairly easy with upstart. I added this stanza: pre-start ... other stuff ... [ -d /var/run/nginx ] || mkdir -p /var/run/nginx end script to the /etc/init/nginx.conf file to have the folder created on boot. Problem solved.
  15. I want redirect non-www domain to www with nginx. Example: test.com -> www.test.com Is possible to have two server declaration for one domain in nginx config? Example: server { listen 80; server_name test.com; return 301 http://www.test.com$request_uri; } server { listen 80; server_name www.test.com; ... }
  16. Davlyin Lafitte

    rm /etc/nginx/sites-enabled/default ?

    Hello, I'm currently trying to configure Froxlor on a Debian Nginx configured server, I'm currently using the default configuration file, I'm aware that removing this file will make the control panel and anything related to Nginx disappear from the web; But is keeping it as it is has any impact on the full functionality of Froxlor ? server { listen 80; root /www/; index index.php index.html index.htm; server_name ontweerp.com; location / { try_files $uri $uri/ /index.html; } error_page 404 /404.html; error_page 500 502 503 504 /50x.html; location = /50x.html { root /www/; } # pass the PHP scripts to FastCGI server listening on /var/run/php5-fpm.sock location ~ \.php$ { try_files $uri =404; fastcgi_pass unix:/var/run/php5-fpm.sock; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; } } Warm wishes, Davlyin.
  17. Hallo, ich habe bereits flei?ig im Forum gesucht, allerdings gibt es scheinbar keine konkrete Antwort darauf: Wo verbirgt sich in Froxlor die Einstellung, mit der ich setzen kann, dass alle Kunden-Webs-Verzeichnisse, die erstellt werden, mit der Berechtigung +x erstellt werden? Gerade landen alle Aufrufe nach dem Neuanlegen erst einmal in einem 403 permission denied. Ich nutze Ngninx unter Debian 7. Wei? jemand, wo diese Einstellung gesetzt wird? Danke!
  18. Hallo zusammen, Kunde hat auf ner Maschine nen neuen Benutzer erstellt. Erst bekam ich nen 404 beim Zugriff, dann nachdem ich die Verz. Berechtigungen korrigiert habe wurde daraus ein 502... dann hab ich die Logs gepr?ft: access.log 176.x.xx.199 - - [05/Jan/2015:20:19:34 +0100] "GET / HTTP/1.1" 200 4833 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" error.log 2015/01/05 19:44:04 [crit] 32282#0: *422 connect() to unix:/var/run/nginx/clientname-sub.domain.de-php-fpm.socket failed (13: Permission denied) while con necting to upstream, client: 176.x.xx.199, server: sub.domain.de, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/clientname-sub.domain.de-php-fpm.socket:", host: "sub.domain.de" Dann hab ich die Gruppenzugeh?rigkeit von www-data angeschaut: groups www-data www-data : www-data froxlorlocal ONE EDL NJ Und die Gruppe "clientname" ist nicht dabei... Also hab ich nscd neu gestartet, das hat aber nichts gebracht also hab ich dem *.socket ein "chmod 666" verpasst. Aber das kann ja keine Dauerl?sung sein, bin gespannt wie das ganze nach dem reboot aussieht...
  19. Hi hi, hab eine neue Domain erstellt, sagen wir mal ssb.de. Die *conf dazu sieht wie folgt aus: # 22_froxlor_normal_vhost_ssb.de.conf # Created 05.01.2015 19:09 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen xxx.xxx.xx.x:80; server_name ssb.de www.ssb.de; access_log /var/customers/logs/ssb-ssb.de-access.log combined; error_log /var/customers/logs/ssb-ssb.de-error.log error; root /var/customers/webs/ssb/altewebsite/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/ssb/webalizer/ssb.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/26-2b820aeb81697a87606fc0207fdbb11c.htpasswd; } location ~ \.php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_pass unix:/var/run/nginx/ssb-ssb.de-php-fpm.socket; fastcgi_index index.php; } } Soweit straight forward... Allerdings bleiben die logs leer und die /var/log/nginx/error.log f?llt sich so: 2015/01/07 18:45:06 [error] 23055#0: *6955 directory index of "/var/www/" is forbidden, client: yyy.yyy.yy.yy, server: websrv01.foo.de, request: "GET / HTTP/1.1", host: "www.ssb.de" Ich bin daher gerade ratlos... OS is Debian Wheezy, Nginx is v1.6.1
  20. Seit dem Update Anfang der Woche kann ich mich nicht mehr an PHPmyAdmin anmelden. Genauer gesagt wird das Passwort schon noch akzeptiert, aber danach bekomm ich nur eine Wei?e Seite. Google hat mir nur das gezeigt: http://stackoverflow.com/questions/27334512/nginx-phpmyadmin-stuck-after-login-page-all-blank-and-token-in-the-url Hier die verwendete Nginx Config: location /phpmyadmin { root /usr/share/; index index.php; location ~ ^/phpmyadmin/(.+\.php)$ { try_files $uri =404; root /usr/share/; fastcgi_pass 127.0.0.1:9000; fastcgi_param HTTPS on; fastcgi_index index.php; include /etc/nginx/fastcgi_params; } location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ { root /usr/share/; } } location /phpMyAdmin { rewrite ^/* /phpmyadmin last; } Die Datei wird in 10_froxlor_ipandport_x.x.x.x:xx:conf included, darin wird logging wie folgt aktiviert: access_log /var/log/nginx/froxlor.panel.access.log; error_log /var/log/nginx/froxlor.panel.error.log error; hier ein Ausschnitt aus dem ...access.log 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793 HTTP/1.1" 200 1123 "https://websrv.yyy.de/phpmyadmin/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/js/jquery/jquery-1.4.4.js?ts=1344778698 HTTP/1.1" 304 0 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/js/update-location.js?ts=1344778698 HTTP/1.1" 304 0 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/js/common.js?ts=1344778698 HTTP/1.1" 304 0 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/navigation.php?token=1b0aca9e7b0ca79433e7de65db0fe793 HTTP/1.1" 200 1968 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/main.php?token=1b0aca9e7b0ca79433e7de65db0fe793 HTTP/1.1" 200 8727 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:17 +0100] "-" 400 0 "-" "-" error.log wird erzeugt, bleibt aber leer... /var/log/php5-fpm/www.access.log 127.0.0.1 - 17/Dec/2014:15:39:01 +0100 "GET /phpmyadmin/index.php" 200 127.0.0.1 - 17/Dec/2014:15:39:01 +0100 "GET /phpmyadmin/navigation.php" 200 127.0.0.1 - 17/Dec/2014:15:39:01 +0100 "GET /phpmyadmin/main.php" 200 auch hier kein error.log, hier wird es aber noch nicht mal erzeugt, obwohl es hier definiert ist: /etc/php5/fpm/pool.d/www.conf Hab jetzt gerade noch zus?tzlich in /etc/php5/fpm/php5-fpm.conf 'log_level = debug' gesetzt, aber auch dann ist in /var/log/php5-fpm.log nichts nennenswertes: [17-Dec-2014 16:20:22.938365] DEBUG: pid 11568, fpm_children_make(), line 421: [pool test.xxx.de] child 11716 started [17-Dec-2014 16:20:22.939227] DEBUG: pid 11568, fpm_children_make(), line 421: [pool www] child 11717 started [17-Dec-2014 16:20:22.965938] DEBUG: pid 11568, fpm_children_make(), line 421: [pool www] child 11718 started [17-Dec-2014 16:20:22.966023] DEBUG: pid 11568, fpm_event_loop(), line 366: 196056 bytes have been reserved in SHM [17-Dec-2014 16:20:22.966034] NOTICE: pid 11568, fpm_event_loop(), line 367: ready to handle connections [17-Dec-2014 16:20:23.967267] DEBUG: pid 11568, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 2 spare children, 2 running children. Spawning rate 1 [17-Dec-2014 16:20:24.968204] DEBUG: pid 11568, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 2 spare children, 2 running children. Spawning rate 1 Ich bin ratlos!
  21. Hallo zusammen, am Montag hab ich Froxlor von 0.9.32 auf ne GIT Installation umgestellt, also 0.9.33dev3. Mein Server ist ein Wheezy und als Webserver nutze ich Nginx v1.2.1 Seitdem hab ich ein paar Probleme, zum einen liefert Contao wei?e inPage iFrame popups, EmonCMS stellt keine Graphen dar und PHPmyadmin bleibt nach der Anmeldung komplett wei?... Aber das wichtigste ist der 502 nach "service php5-fpm restart", der momentane Kompromiss ist ein "chmod 666 /var/run/nginx/*" Das log einer Domain sieht wie folgt aus: 2014/12/17 08:23:29 [crit] 23825#0: *18878 connect() to unix:/var/run/nginx/CLIENT-xxx.de-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: 176.198.171.171, server: xxx.de, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/CLIENT-xxx.de-php-fpm.socket:", host: "www.xxx.de" hier die /etc/php5/fpm/php-fpm.conf: root@websrv:~# grep -v '^;' /etc/php5/fpm/php-fpm.conf include=/etc/php5-fpm.d/*.conf include=/etc/php5/fpm/pool.d/*.conf [global] pid = /var/run/php5-fpm.pid error_log = /var/log/php5-fpm.log NSS hab ich gem?? dieser Doku installiert. Das tut auch wie erwartet: root@websrv01:/etc/nginx# ll /var/run/nginx/CLIENT-xxx.de-php-fpm.socket srw-rw-rw- 1 CLIENT CLIENT 0 Dez 17 08:22 /var/run/nginx/CLIENT-xxx.de-php-fpm.socket root@websrv01:/etc/nginx# ll /var/customers/webs/|grep CLIENT drwxr-xr-x 6 CLIENT CLIENT 4,0K Dez 14 11:59 CLIENT Ich bezweifle zwar das diese config's urs?chlich sein k?nnen, aber der Vollst?ndigkeit halber: /etc/php5-fpm.d/xxx.de.conf und noch /etc/nginx/sites-enabled/22_froxlor_normal_vhost_xxx.de.conf Danke vorab...
  22. Hallo zusammen, erstmal meine Konfiguration: Debian wheezy, nginx, Froxlor, php-fpm und als CMS probiere ich gerade GetSimple. Get Simple hat eine Funktion, die da heisst: "Nutze freundliche URLs - Erfordert 'mod_rewrite' auf Ihrem Server" Wie man schon erkennen kann ist Get Simple eigentlich auf Apache ausgelegt. Die sonstigen URLs sehen folgenderma?en aus: $URL/index.php?=eine_unterseite Die SEO-Funktion von Get Simple soll folgendes machen: $URL/eine_unterseite/ Es gibt eigentlich auch schon Vieles dazu im Netz, aber scheinbar funktioniert das entweder nicht mit der Froxlor-Konfiguration zusammen oder hakt einfach an meinem Unverst?ndnis Meine erste Idee dazu war folgende als "Eigene VHOST-Einstellungen" in Froxlor einzutragen: location / { try_files $uri $uri/ /index.php?=$uri&$args; } Unter sites_enabled sehe ich dann nach Aktivierung folgendes Konstrukt: server { listen IP:80; server_name example.com *.example.com mail.example.com *.mail.example.com; access_log /var/customers/logs/example.com-access.log combined; error_log /var/customers/logs/example.com-error.log error; root /var/customers/webs/test/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; try_files $uri $uri/ /index.php?=$uri&$args; } location @rewrites { rewrite ^ /index.php last; } location /awstats { alias /var/customers/webs/test/awstats/example.com/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/2-sd7f67sd6f76sd87.htpasswd; } location ~ ^/awstats-icon/(.*)$ { alias /usr/share/awstats/icon/$1; } location ~ \.php$ { try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass unix:/var/run/nginx/example.com-php-fpm.socket; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include /etc/nginx/fastcgi_params; } } Ich habe auch schon etwas an dem try files Konstrukt geschraubt, aber bekomme st?ndig einen 404 Hat jemand zuf?llig den richtigen Riecher und kann mir einen Tipp geben? Danke schon mal.
  23. iamkingsleyf

    Froxlor with nginx set up

    Hello, Please i need help in setting up froxlor with nginx as the webserver on Ubuntu or centos, i have been searching for days now an i could not find any and no official tutorial on this
  24. Timmaeh

    Ich erhalte keine E-Mails

    Hey, ich habe heute meinen vServer neu aufgesetzt und dabei speziell auf die Installation von Froxlor hingearbeitet. Nachdem ich alle anderen Probleme via Google beheben konnte, sto?e ich nun auf mein gr??tes Problem: Ich erhalte schlichtweg keine E-Mails. Ich habe die in Froxlor angegebenen Konfigurationen f?r Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix/Dovecot Debian 7.0 (Wheezy) ? Mailserver (SMTP) ? Postfix MX-Access (anti spam) Debian 7.0 (Wheezy) ? Mailserver (IMAP/POP3) ? Dovecot durchgef?hrt und nachtr?glich mehrmals gepr?ft. Wenn ich nun eine E-Mail von meinem GMail Account an eine in Froxlor angelegte E-Mail Adresse schicke (welche ich wiederum ?ber GMail abrufe), kann ich dem /var/log/mail.log entnehmen, dass eine Verbindung zur froxlor Datenbank aufgebaut wird und die Mail anschlie?end nach 'INBOX' gespeichert wurde. Leider warte ich bei GMail anschlie?end vergebens darauf, dass die E-Mail ankommt. Auch auf Dateiebene unter /var/customers/mail/Kunde/Domain/mail/Maildir/* kann ich nichts von der E-Mail finden. Wenn ich das Prinzip der Ablage richtig verstanden habe, m?sste da ja irgendwo eine Datei mit Namen 'CAJF6H3nemCOW+L9xCU+2nB4iR55WV_QpHjBpf63e=bYG01PuFQ@mail.gmail.com' sein. Wenn ich danach suche, oder nur nach gmail, finde ich nichts. Ich habe auch die froxlor Datenbank durchsucht und keine Tabelle gefunden, in der E-Mails gespeichert sein k?nnten. Zur Info: Die Mails von Froxlor ?ber angelegte Accounts etc. kommen bei GMail an, also muss es meiner Meinung nach etwas mit der Ablage der Mails beim Empfang zu tun haben. Bin also auf Eure Hilfe angewiesen. Kann jemand helfen? Hat jemand einen Verdacht? Gern poste ich weitere Logfiles, jedoch bin ich bis jetzt nicht f?ndig geworden. Danke! Timmaeh
  25. Hi all, I searched in the forum, but the answers weren't to clear to me(since one says Yes, and other No), and SysCP worked with different versions from php(yes, using fcgid). My question is quite simple: Can I use PHP 5.4 for customer A, and PHP 5.5 for customer B? I have to upload the php.ini, but how? And if just keeps compatibility with fcgi, where can I find a Howto with that? Environment: Nginx 1.6 PHP 5.4.14 with FPM(which runs Froxlor) PHP 5.4.30 with FPM PHP 5.5.14 with FPM Yes: http://forum.froxlor.org/index.php/topic/11662-merged-add-custom-phpini-files-for-php-fpm/ No: http://forum.froxlor.org/index.php/topic/12610-erledigt-php-fpm-verschiedene-php-versionen/ And if I should do another question in the same topic, is there a way to set ssh login to all users without mysql every time with new user added? I mean, setting different shells(just /bin/false, or /bin/bash)? Or should I patch it? TIA Best Regards, Gabriel
×