Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'Apache'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 18 results

  1. Hallo alle miteinander, ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe: SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt Kommen wir zur Frage: Wie bekomme ich hin, dass ich folgende Einstellung setzen kann: Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik. Beste Grüße
  2. I looked around and like my last question the directory on Centos 7 is different then the configuration in RHEL / CentOS (7) » Webserver (HTTP) » Apache 2.4 I see that ofcourse my apache 2 is installed in httpd and I am searching, but no /etc/apache2/conf-enabled/acme.conf. I did see the first command created the var folders fine for customers, but the others all failed: [root@s128426 ~]# nano /etc/httpd/conf/httpd.conf [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/ chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/ chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/ chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/ chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory When I search httpd these directories do not exist within it. Is there a separate install for apache for Froxlor or something I am missing? I am really thinking about going to debian, but my dedicated host does not offer debian stretch at the moment so went centos being I knew it was the most up to date right now in their list.
  3. wwl

    http/2

    Hallo, ich hab heute noch eine 2. Frage: Ich hab vor einiger Zeit http/2 auf meinem Apachen eingerichtet. Jetzt habe die Beobachtung gemacht das seit dem aktivieren der http/2 Version auf meinem Apache nur sehr wehnige Anfrage auch in http2 abgearbeitet werden. Wenn ich am Firefox nachschaue (Addon http2 indicator) wird für eine webseite auf meinem Server http2 erkannt. Aber im Log steht das er trotzdem http/1.1 verwendet. Muss ich den Webseiten (TYPO3,WP,Joomla) noch sagen das sie auch über http/2 abgerufen werden können? Im apache2.conf File Protocols h2 h2c http/1.1 H2Push on H2PushPriority * after H2PushPriority text/css before H2PushPriority image/jpeg after 32 H2PushPriority image/png after 32 H2PushPriority application/javascript interleaved Besten Dank für Tipps Christian
  4. Hallo zusammen, ich habe ein Problem mit Froxlor, bzw. dessen Erreichbarkeit. Ich habe auf meinem Root-Server Debian 8.9 (Jessie) laufen und dort Froxlor installiert. Froxlor liegt in /var/www/froxlor/. Problem ist nun, dass diese Adresse von meinem Apache anscheinend nie abgerufen wird. Der Server-Name domain1.de und noch eine weitere Domain domain2.de die beide ihre eigenen Customers in /var/customers/webs/ haben funktionieren problemlos. Als Workaround habe ich versucht /var/www/froxlor in das webs Verzeichnis eines Customers zu symlinken, dann bekomme ich allerdings folgenden php-Error: [Wed Nov 29 10:47:43.392017 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: open_basedir restriction in effect. File(/var/www/froxlor/index.php) is not within the allowed path(s): (/var/customers/webs/johannes:/tmp) in Unknown on line 0 [Wed Nov 29 10:47:43.392110 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0 [Wed Nov 29 10:47:43.392127 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Fatal error: Unknown: Failed opening required '/var/customers/webs/johannes/froxlor/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0 Ich habe außerdem festgestellt, dass die beiden vhosts 10_froxlor_ipandport_x.x.x.x.433.conf und 10_froxlor_ipandport_x.x.x.x.80.conf komplett leer von froxlor erzeugt werden. Nur der Header ist drin: # 10_froxlor_ipandport_x.x.x.x.443.conf # Created 28.11.2017 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Also kann mir jedemand hier helfen, wie ich froxlor wieder erreichbar machen kann? Viele Grüße und schonmal vielen Dank, Johannes
  5. Hallo Community und Staff, bezüglich eines Serverwechsel stande nun auch eine Änderung des Control Panels an, da unser bisher genutztes einfach zu wenig geupdatet wurde und Fehler selbst gefixt werden mussten. Es blieb eigentlich nur Froxlor übrig. Allerdings haben wir nun feststellen müssen, dass man bei Froxlor nicht die Möglichkeit hat den Datenbanknamen und Nutzer frei zu wählen, was viele als hohes Sicherheitsrisiko werten. Warum ist dies so gewählt? Und gibt es bereits jetzt schon eine Möglichkeit das zu aktivieren? Zum anderen Problem: Froxlor scheint magisch alles abzufangen. Bislang hatte ich Apache so konfiguriert, dass alle nicht vorhanden Vhosts ins 403-Forbidden Nirvana gesendet werden. Gleiche Konfiguration habe ich nun auch mit Froxlor versucht und mein Abfangen als 01-beginnende Apache config hinterlegt. Dies fängt auch direkte Aufrufe der IP ab, allerdings funktioniert dies weder mit der IP noch mit nicht angelegten (Sub)-Domains. Es wird immer automatisch auf den FQDN des Panels umgeleitet, was eigentlich gar nicht möglich sein sollte. Vielen Dank schon mal für die Antworten
  6. Moin, anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log: root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? 🤔
  7. Hi, because I had some issues with HTTP2 and php via fcgid under Apache I tried to switch to php_fpm. While I was at it, I noticed a problem that I couldn't pinpoint and decided to try nginx. The issue stayed the same, basically these log entries: nginx: connect() to unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: xx.xx.xx.xx, server: domainname.de, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/domainname.de-php-fpm.socket:", host: "domainname.de", referrer: "https://domainname.de/" Apache: (13)Permission denied: [client xx.xx.xx.xx:63318] FastCGI: failed to connect to server "/var/www/php-fpm/web2/domainname.de/ssl-fpm.external": connect() failed The way I understand this problem: By design, php-fpm sockets created by Froxlor have permissions which only allow the vhost user to connect. But neither Apache nor nginx are told anywhere under which identity to connect to the socket. The SuExecUserGroup line in the vhost config file for Apache which does this for fcgid vanished when switching to php-fpm. I currently solved the problem by changing the line "listen.owner" inside the php-fpm pools to "www-data". That should not lower security, because php-fpm in itself takes care that the php process runs as the vhost user. Can someone tell me where I misunderstood the whole concept?
  8. Hallo. Ich habe gerade gesehen, dass es hier das Forum auch in Deutsch gibt Habe die Frage zwar im englischen schon gestellt, aber in Deutsch wär mi das ganze doch lieber (Admin du kannst gerne meine Post im EN Forum löschen). Ich habe seit dem Update auf Debian 8 das Problem, dass ich einen 404 Error erhalte. Ich habe (wie in Froxlor beschrieben) die acme.conf erstellt und den Dienst "apache2" neugestartet. Weiters habe ich auch noch Could not get Let's Encrypt certificate for cloudservice.DOMAIN.com: Verification ended with error: {"identifier":{"type":"dns","value":"cloudservice.DOMAIN.com"},"status":"invalid","expires":"2017-06-07T20:05:14Z","challenges":[{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196287","token":"IRK9FHJuWGV9l3qnCnoHuh7XGudY4bWd5Sx1JerSkSU"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196288","token":"ufnSkvFtYYIXOWhqBGuv1QZF_iaOkrZ5USKYE0U52QM"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8: \"<html>\r\n<head><title>404 Not Found<\/title><\/head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404 Not Found<\/h1><\/center>\r\n<hr><center>\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196289","token":"KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8","keyAuthorization":"KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8.smiCkvGETnwE6QlOocMBuKikIIKHHcPhTBjXZgHYBt4","validationRecord":[{"url":"http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8","hostname":"cloudservice.DOMAIN.com","port":"80","addressesResolved":["188.68.55.173","2001:1a50:11:0:5f:8f:acfa:7c"],"addressUsed":"2001:1a50:11:0:5f:8f:acfa:7c","addressesTried":[]}]}],"combinations":[[2],[0],[1]]} nano /etc/apache2/conf-enabled/acme.conf Alias "/.well-known/acme-challenge" "/var/www/froxlor/.well-known/acme-challenge" <Directory "/var/www/froxlor/.well-known/acme-challenge"> Require all granted </Directory> Weiters habe ich mir dann noch gedacht ich checke die apache Einstellungen die Floxlor angeben hat. mkdir -p /etc/apache2/sites-enabled/ chown root:0 /etc/apache2/sites-enabled/ chmod 0600 /etc/apache2/sites-enabled/ mkdir -p /etc/apache2/sites-enabled/ chown root:0 /etc/apache2/sites-enabled/ chmod 0600 /etc/apache2/sites-enabled/ mkdir -p /var/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp a2dismod userdir a2enmod headers apt-get install libapache2-mod-fastcgi Ich habe alles außer mkdir nochmals durchgeführt. Da die Folder sind ja schon vorhanden. Kann ich sonst noch irgendwo was einstellen oder kontrollieren? Liebe Grüße Matthias
  9. Hallo Froxlor Gemeinde, ich versuche gerade auf unserem Server Seiten via letsencrypt zu verschlüsseln. Mit den Froxlor eigenen Tools hatte ich leider keinen Erfolg. Das kann an unserem Setup liegen oder an meiner Unfähigkeit (Achtung Serveradmin-Noob!). (Der Fehler den ich bekomme ist folgender) Could not get Let's Encrypt certificate for mysite.com: Please check http://mysite/.well-known/acme-challenge/YI6nQJMglYzLJoOf-2u_MRZMivqlD5w29wovISnRJpA - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/mysite\/.well-known\/acme-challenge\/YI6nQJMglYzLJoOf-2u_MRZMivqlD5w29wovISnRJpA): failed to open stream: HTTP request failed! HTTP\/1.1 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":171} Wenn jemand dafür eine Lösung hat immer her damit. Was jedoch funktioniert hat ist direkt mit dem letsencrypt Kommandozeilen Tool ein Zertifikat zu erstellen. Nun habe ich das Problem, dass letsencrypt die ssl_vhost_xx.conf angepasst hat. Diese wird von froxlor jedoch bei einer Änderung an der Domain neu generiert. Meine Fragen: Wo sollte ich die Einstellungen der Domain anpassen, damit sich froxlor und letsencrypt nicht in die Quere kommen? (Geschätz unter "Eigene vHost-Einstellungen:" der Domain) Welchen Teil aus der .conf muss ich übernehmen? Welcher Teil der .conf verändert sich bei einem erneuern des Zertifikats durch letsencrypt? Vielen Dank vorab Fabian
  10. Gibt es eine Möglichkeit einen domainspezifischen vHost Eintrag über das Froxlor Backend zu setzten? Soweit ich das sehe, werden alle Eintrage sowohl für den normalen Eintrag (*.80) als auch den SSL Port (*.443) der Domain gesetzt. Im Speziellen möchte ich für eine Pfad ein redirect setzten: Redirect permanent /secure/ https://domain.ltd/secure/ Das macht aber nur Sinn wenn das lediglich für die normale http Verbindung passiert. Alternativ müsste ich es sonst via .htaccess machen.
  11. Hallo, unter Apache 2.4 mit Jessie bei aktiviertem LE (auch die acme.conf ist aktiviert und funktioniert), habe ich in den Logs folgende Fehler: Could not get Let's Encrypt certificate for DOMAIN: No challenges received for . Whole response: {"type":"urn:acme:error:malformed","detail":"Error unmarshaling JSON","status":400} error Could not get Let's Encrypt certificate for DOMAIN: Please check http://DOMAIN/.well-known/acme-challenge/1234567abcdwefgh - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/DOMAIN\/.well-known\/acme-challenge\/1234567abcdwefgh): failed to open stream: Connection timed out","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":154} Dabei schlägt das Generieren eines Zertifikates natürlich fehl. Habt ihr Ideen?
  12. Hallo, Ich wei?, dass dieses Thema hier schon 100x aufgeriffen wurde, jedoch habe ich bisher in keiner der Topics eine L?sung gefunden. Folgendes Problem, nach dem erstellen eines neuen Kunden und einem ausf?hren des Cronjobs bekomme ich folgende Meldung: AH00543: apache2: bad user name "Kunde" Auf dem Server l?uft FCGID unter Debian 8. Libnss ist selbstverst?ndlich nach Konifgurationshinweisen aus dem Panel eingerichtet. Sowohl Apache, MySQL als auch NSCD laufen und wurden auch in der richtigen Reihenfolge gestartet: MySQL> NSCD > Apache Der Log von sagt nichts. Eine Idee? Danke und Gr??e
  13. Hi there! If have a question regarding vHosts. I'm using the up to date debian installer package of froxlor with apache2 and am missing an option to change a vhosts default value. In /etc/apache2/sites-enabled/...something...conf it say to not change the file since froxlor will recreate it. I assume it will override it with its' standard config settings but am not sure about this. How can I modify individual vhosts? I saw some froxlor screenshots showing changable vhost templates but I'm missing this in the newest froxlor package for debian. I cant just delete the Domain in froxlor since I would like to use it for E-Mail as well. Any help is very welcome! Thx! hale-xp
  14. I've installed Debian 8.2 amd64 with apache, mysql and php to run as a webserver. What I want is retrieving the $_SERVER['REMOTE_USER'] when my clients, using Windows XP and Windows 7, visit the intranet installed on the Debian server. Modules that are enabled in apache: alias auth_basic auth_kerb authn_core authn_file authz_core authz_host authz_user autoindex cgi deflate dir env filter mime mpm_prefork negotiation perl php5 setenvif status httpd.conf DirectoryIndex index.php index.html index.htm KeepAlive on HostnameLookups on <Location /test> PerlAuthenHandler "Apache2::AuthenNTLM" AuthType ntlm,basic AuthName "NTLM Authentication" require valid-user PerlAddVar ntdomain "MYDOMAIN 10.52.43.220" PerlSetVar defaultdomain "MYDOMAIN" PerlSetVar splitdomainprefix 1 PerlSetVar ntlmdebug 0 PerlSetVar ntlmauthorative off PerlSetVar ntlmsemkey 0 PerlSetVar ntlmsemtimeout 1 </Location> apache2.conf is a default file without any changes. Because it doesn't work I tried putting an .htaccess in /var/www/test <Location /test> AuthType NTLM NTLMAuth on NTLMAuthoritative on NTLMDomain MYDOMAIN NTLMServer 10.52.43.220 require valid-user </Location> But it doesn't work either. /var/log/apache2/error.log displays this: [Thu Oct 08 11:34:23.786879 2015] [mpm_prefork:notice] [pid 2287] AH00163: Apache/2.4.10 (Debian) mod_auth_kerb/5.4 mod_perl/2.0.9dev Perl/v5.20.2 configured -- resuming normal operations [Thu Oct 08 11:34:23.786922 2015] [core:notice] [pid 2287] AH00094: Command line: '/usr/sbin/apache2' [Thu Oct 08 11:35:39.656529 2015] [:error] [pid 2293] [client 10.52.43.14:49784] PHP Notice: Undefined index: REMOTE_USER in /var/www/html/test/ntlm.php on line 2, referer: http://10.52.43.71/test/ What am I doing wrong and how can I fix it?
  15. Hallo, Ich habe zurzeit Apache 2.2.22 und FCGID auf meinem "Froxlor Host" installiert. Aufgrund einiger Fehler unter Apache 2.2 m?chte ich auf die Version 2.4 updaten. Ist denn das m?glich, oder muss ich dabei etwas beachten, abgesehen davon, Apache 2.4 in den Froxlor Einstellungen zu aktivieren. Vielen Dank
  16. Hallo, Ich habe Apache auf meinem Server von der Version 2.2 auf die Version 2.4 upgegradet. Danach wollte ich Apache restarten, doch dabei habe ich folgende Ausgabe bekommen. F?r eure Hilfe w?re ich wirklich dankbar. Vielen Dank und einen sch?nen Abend! Ps: Wie weit ist Froxlor eigentlich mit Debian 8 kompatibel? root@vps:/var/www# service apache2 restart [FAIL] Restarting web server: apache2 failed! [warn] The apache2 configtest failed. ... (warning). Output of config test was: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/10_froxlor_ipandport_xx.xxx.xx.xx.conf:5 AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/20_froxlor_normal_vhost_test.srv.meinedomain.de.conf: Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed. The Apache error log may have more information. root@vps:/var/www#
  17. Hallo, ich habe meinen Server auf Debian Jessie aktualisiert. Seit dem ist ?ber den Apache keine SSL Verbindung mehr m?glich. Im Browser bekomm ich die Fehlermeldung "ssl_error_rx_record_too_long". Ein Test der SSL-Verbindung auf z. B. sslshopper.com, gibt folgende Fehlermeldung: "No SSL certificates were found on domain1.de. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server's firewall." Die Domain zeigt auf den korrekten Server und die korrekte IP. Die Firewall wurde deaktiviert und alle Einstellungen in Froxlor entsprechend gesetzt. Im Error-Log des Apache oder der Domain kommt dazu kein Fehler an, da scheinbar erst gar keine korrekt SSL Verbindung aufgebaut werden kann. In Froxlor ist Apache 2.4 aktiviert. Zertifikate sind alle g?ltig bis 2016 und die Checksum von crt und key sind identisch. Als vHosts hab ich folgende: lrwxrwxrwx 1 root root 35 Mai 5 09:29 000-default.conf -> ../sites-available/000-default.conf lrwxrwxrwx 1 root root 35 Mai 5 10:51 000-default-ssl -> ../sites-available/default-ssl.conf -rw-r--r-- 1 root root 818 Mai 4 16:57 10_froxlor_ipandport_IP.443.conf -rw-r--r-- 1 root root 807 Mai 4 16:57 10_froxlor_ipandport_IP.80.conf -rw-r--r-- 1 root root 1,4K Mai 4 16:57 22_froxlor_normal_vhost_domain2.de.conf -rw-r--r-- 1 root root 1,4K Mai 4 16:57 22_froxlor_normal_vhost_domain1.de.conf -rw-r--r-- 1 root root 1,8K Mai 4 16:57 22_froxlor_ssl_vhost_domain2.de.conf -rw-r--r-- 1 root root 1,8K Mai 4 16:57 22_froxlor_ssl_vhost_domain1.de.conf lrwxrwxrwx 1 root root 35 Mai 5 09:29 default-ssl.conf -> ../sites-available/default-ssl.conf Benenne ich z. B. 22_froxlor_ssl_vhost_domain1.de.conf in 00_froxlor_ssl_vhost_domain1.de.conf um, ist die SSL-Verbindung zu dieser Domain korrekt m?glich. Mache ich dies weider r?ckg?ngig, ist keine SSL-Verbindung mehr m?glich. Ich seh allerdings nicht den Fehler bzw. die Ursache, die den Fehler verursacht. Scheinbar erfolgt kein korrektes "Durchreichen" der Verbindung zu dem SSL vhost. Ich hab jetzt schon vieles gepr?ft, komme aber nicht weiter. Hat vielleicht jemand einen Tipp f?r mich? Mit Wheezy und Apache 2.2 lief alles mit den gleichen Einstellungen korrekt. 10_froxlor_ipandport_IP.80.conf # 10_froxlor_ipandport_IP.80.conf # Created 05.05.2015 08:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. <VirtualHost IP:80> DocumentRoot "/var/www/froxlor/" ServerName www.froxlordomain.de FastCgiExternalServer /var/www/php-fpm/froxlor.panel/www.froxlordomain.de/e23b.fpm.external -socket /var/lib/apache2/fastcgi/froxlor.panel-www.froxlordomain.de-php-fpm.socket -idle-timeout 180 <Directory "/var/www/froxlor/"> <FilesMatch "\.(php)$"> AddHandler php5-fastcgi .php Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> Require all granted </Directory> Alias /fastcgiphp /var/www/php-fpm/froxlor.panel/www.froxlordomain.de/e23b.fpm.external </VirtualHost> 10_froxlor_ipandport_IP.443.conf # 10_froxlor_ipandport_IP.443.conf # Created 05.05.2015 09:43 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. <VirtualHost IP:443> DocumentRoot "/var/www/froxlor/" ServerName www.froxlordomain.de FastCgiExternalServer /var/www/php-fpm/froxlor.panel/www.froxlordomain.de/8afc.ssl-fpm.external -socket /var/lib/apache2/fastcgi/froxlor.panel-www.froxlordomain.de-php-fpm.socket -idle-timeout 180 <Directory "/var/www/froxlor/"> <FilesMatch "\.(php)$"> AddHandler php5-fastcgi .php Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> Require all granted </Directory> Alias /fastcgiphp /var/www/php-fpm/froxlor.panel/www.froxlordomain.de/8afc.ssl-fpm.external </VirtualHost> 22_froxlor_normal_vhost_domain1.de.conf # 22_froxlor_normal_vhost_domain1.de.conf # Created 05.05.2015 09:43 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 1 - CustomerID: 1 - CustomerLogin: domain1 <VirtualHost IP:80> ServerName domain1.de ServerAlias www.domain1.de ServerAdmin test@domain1.de <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{HTTPS} off RewriteRule ^/(.*) https://domain1.de/$1'>https://domain1.de/$1 </IfModule> Redirect / https://domain1.de/ </VirtualHost> 22_froxlor_ssl_vhost_domain1.de.conf # 22_froxlor_ssl_vhost_domain1.de.conf # Created 05.05.2015 09:43 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 1 (SSL) - CustomerID: 1 - CustomerLogin: x-dast <VirtualHost IP:443> ServerName domain1.de ServerAlias www.domain1.de ServerAdmin test@domain1.de SSLEngine On SSLProtocol ALL -SSLv2 -SSLv3 SSLHonorCipherOrder On SSLCipherSuite AES256+EECDH:AES256+EDH SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/domain1.de.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/domain1.de.key SSLCACertificateFile /etc/ssl/froxlor-custom/domain1.de_CA.pem SSLCertificateChainFile /etc/ssl/froxlor-custom/domain1.de_chain.pem DocumentRoot "/var/customers/webs/x-dast/websites/main/" SuexecUserGroup "x-dast" "x-dast" FastCgiExternalServer /var/www/php-fpm/x-dast/domain1.de/ssl-fpm.external -socket /var/lib/apache2/fastcgi/x-dast-domain1.de-php-fpm.socket -idle-timeout 180 <Directory "/var/customers/webs/x-dast/websites/main/"> <FilesMatch "\.php$"> SetHandler php5-fastcgi Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> Require all granted </Directory> Alias /fastcgiphp /var/www/php-fpm/x-dast/domain1.de/ssl-fpm.external Alias /webalizer "/var/customers/webs/x-dast/webalizer" ErrorLog "/var/customers/logs/x-dast-error.log" CustomLog "/var/customers/logs/x-dast-access.log" combined </VirtualHost> mods-enabled: lrwxrwxrwx 1 root root 36 Mai 5 09:29 access_compat.load -> ../mods-available/access_compat.load lrwxrwxrwx 1 root root 30 M?r 31 10:03 actions.conf -> ../mods-available/actions.conf lrwxrwxrwx 1 root root 30 M?r 31 10:03 actions.load -> ../mods-available/actions.load lrwxrwxrwx 1 root root 28 M?r 5 18:52 alias.conf -> ../mods-available/alias.conf lrwxrwxrwx 1 root root 28 M?r 5 18:52 alias.load -> ../mods-available/alias.load lrwxrwxrwx 1 root root 33 M?r 5 18:52 auth_basic.load -> ../mods-available/auth_basic.load lrwxrwxrwx 1 root root 33 Mai 5 09:29 authn_core.load -> ../mods-available/authn_core.load lrwxrwxrwx 1 root root 33 M?r 5 18:52 authn_file.load -> ../mods-available/authn_file.load lrwxrwxrwx 1 root root 33 Mai 5 09:29 authz_core.load -> ../mods-available/authz_core.load lrwxrwxrwx 1 root root 38 M?r 5 18:52 authz_groupfile.load -> ../mods-available/authz_groupfile.load lrwxrwxrwx 1 root root 33 M?r 5 18:52 authz_host.load -> ../mods-available/authz_host.load lrwxrwxrwx 1 root root 33 M?r 5 18:52 authz_user.load -> ../mods-available/authz_user.load lrwxrwxrwx 1 root root 32 M?r 5 18:52 autoindex.conf -> ../mods-available/autoindex.conf lrwxrwxrwx 1 root root 32 M?r 5 18:52 autoindex.load -> ../mods-available/autoindex.load lrwxrwxrwx 1 root root 27 M?r 31 10:14 cgid.conf -> ../mods-available/cgid.conf lrwxrwxrwx 1 root root 27 M?r 31 10:14 cgid.load -> ../mods-available/cgid.load lrwxrwxrwx 1 root root 26 M?r 5 18:52 cgi.load -> ../mods-available/cgi.load lrwxrwxrwx 1 root root 30 M?r 5 18:52 deflate.conf -> ../mods-available/deflate.conf lrwxrwxrwx 1 root root 30 M?r 5 18:52 deflate.load -> ../mods-available/deflate.load lrwxrwxrwx 1 root root 26 M?r 5 18:52 dir.conf -> ../mods-available/dir.conf lrwxrwxrwx 1 root root 26 M?r 5 18:52 dir.load -> ../mods-available/dir.load lrwxrwxrwx 1 root root 26 M?r 5 18:52 env.load -> ../mods-available/env.load lrwxrwxrwx 1 root root 30 M?r 31 10:03 fastcgi.conf -> ../mods-available/fastcgi.conf lrwxrwxrwx 1 root root 30 M?r 31 10:03 fastcgi.load -> ../mods-available/fastcgi.load lrwxrwxrwx 1 root root 29 Mai 5 09:29 filter.load -> ../mods-available/filter.load lrwxrwxrwx 1 root root 30 Apr 23 14:03 headers.load -> ../mods-available/headers.load lrwxrwxrwx 1 root root 27 M?r 5 18:52 mime.conf -> ../mods-available/mime.conf lrwxrwxrwx 1 root root 27 M?r 5 18:52 mime.load -> ../mods-available/mime.load lrwxrwxrwx 1 root root 33 Mai 5 09:29 mpm_worker.conf -> ../mods-available/mpm_worker.conf lrwxrwxrwx 1 root root 33 Mai 5 09:29 mpm_worker.load -> ../mods-available/mpm_worker.load lrwxrwxrwx 1 root root 34 M?r 5 18:52 negotiation.conf -> ../mods-available/negotiation.conf lrwxrwxrwx 1 root root 34 M?r 5 18:52 negotiation.load -> ../mods-available/negotiation.load lrwxrwxrwx 1 root root 33 M?r 5 18:52 reqtimeout.conf -> ../mods-available/reqtimeout.conf lrwxrwxrwx 1 root root 33 M?r 5 18:52 reqtimeout.load -> ../mods-available/reqtimeout.load lrwxrwxrwx 1 root root 30 M?r 25 04:39 rewrite.load -> ../mods-available/rewrite.load lrwxrwxrwx 1 root root 31 M?r 5 18:52 setenvif.conf -> ../mods-available/setenvif.conf lrwxrwxrwx 1 root root 31 M?r 5 18:52 setenvif.load -> ../mods-available/setenvif.load lrwxrwxrwx 1 root root 36 Mai 5 09:29 socache_shmcb.load -> ../mods-available/socache_shmcb.load lrwxrwxrwx 1 root root 26 M?r 6 14:24 ssl.conf -> ../mods-available/ssl.conf lrwxrwxrwx 1 root root 26 M?r 6 14:24 ssl.load -> ../mods-available/ssl.load lrwxrwxrwx 1 root root 29 M?r 5 18:52 status.conf -> ../mods-available/status.conf lrwxrwxrwx 1 root root 29 M?r 5 18:52 status.load -> ../mods-available/status.load lrwxrwxrwx 1 root root 29 M?r 5 19:18 suexec.load -> ../mods-available/suexec.load conf-enabled: lrwxrwxrwx 1 root root 30 Mai 5 09:29 charset.conf -> ../conf-available/charset.conf lrwxrwxrwx 1 root root 44 Mai 5 09:29 localized-error-pages.conf -> ../conf-available/localized-error-pages.conf lrwxrwxrwx 1 root root 46 Mai 5 09:29 other-vhosts-access-log.conf -> ../conf-available/other-vhosts-access-log.conf lrwxrwxrwx 1 root root 31 Mai 5 09:29 security.conf -> ../conf-available/security.conf lrwxrwxrwx 1 root root 36 Mai 5 09:29 serve-cgi-bin.conf -> ../conf-available/serve-cgi-bin.conf apache2.conf # This is the main Apache server configuration file. It contains the # configuration directives that give the server its instructions. # See http://httpd.apache.org/docs/2.4/ for detailed information about # the directives and /usr/share/doc/apache2/README.Debian about Debian specific # hints. # # # Summary of how the Apache 2 configuration works in Debian: # The Apache 2 web server configuration in Debian is quite different to # upstream's suggested way to configure the web server. This is because Debian's # default Apache2 installation attempts to make adding and removing modules, # virtual hosts, and extra configuration directives as flexible as possible, in # order to make automating the changes and administering the server as easy as # possible. # It is split into several files forming the configuration hierarchy outlined # below, all located in the /etc/apache2/ directory: # # /etc/apache2/ # |-- apache2.conf # | `-- ports.conf # |-- mods-enabled # | |-- *.load # | `-- *.conf # |-- conf-enabled # | `-- *.conf # `-- sites-enabled # `-- *.conf # # # * apache2.conf is the main configuration file (this file). It puts the pieces # together by including all remaining configuration files when starting up the # web server. # # * ports.conf is always included from the main configuration file. It is # supposed to determine listening ports for incoming connections which can be # customized anytime. # # * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/ # directories contain particular configuration snippets which manage modules, # global configuration fragments, or virtual host configurations, # respectively. # # They are activated by symlinking available configuration files from their # respective *-available/ counterparts. These should be managed by using our # helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See # their respective man pages for detailed information. # # * The binary is called apache2. Due to the use of environment variables, in # the default configuration, apache2 needs to be started/stopped with # /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not # work with the default configuration. # Global configuration # # # ServerRoot: The top of the directory tree under which the server's # configuration, error, and log files are kept. # # NOTE! If you intend to place this on an NFS (or otherwise network) # mounted filesystem then please read the Mutex documentation (available # at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>); # you will save yourself a lot of trouble. # # Do NOT add a slash at the end of the directory path. # #ServerRoot "/etc/apache2" # # The accept serialization lock file MUST BE STORED ON A LOCAL DISK. # Mutex file:${APACHE_LOCK_DIR} default # # PidFile: The file in which the server should record its process # identification number when it starts. # This needs to be set in /etc/apache2/envvars # PidFile ${APACHE_PID_FILE} # # Timeout: The number of seconds before receives and sends time out. # Timeout 300 # # KeepAlive: Whether or not to allow persistent connections (more than # one request per connection). Set to "Off" to deactivate. # KeepAlive On # # MaxKeepAliveRequests: The maximum number of requests to allow # during a persistent connection. Set to 0 to allow an unlimited amount. # We recommend you leave this number high, for maximum performance. # MaxKeepAliveRequests 100 # # KeepAliveTimeout: Number of seconds to wait for the next request from the # same client on the same connection. # KeepAliveTimeout 5 # These need to be set in /etc/apache2/envvars User ${APACHE_RUN_USER} Group ${APACHE_RUN_GROUP} # # HostnameLookups: Log the names of clients or just their IP addresses # e.g., www.apache.org (on) or 204.62.129.132 (off). # The default is off because it'd be overall better for the net if people # had to knowingly turn this feature on, since enabling it means that # each client request will result in AT LEAST one lookup request to the # nameserver. # HostnameLookups Off # ErrorLog: The location of the error log file. # If you do not specify an ErrorLog directive within a <VirtualHost> # container, error messages relating to that virtual host will be # logged here. If you *do* define an error logfile for a <VirtualHost> # container, that host's errors will be logged there and not here. # ErrorLog ${APACHE_LOG_DIR}/error.log # # LogLevel: Control the severity of messages logged to the error_log. # Available values: trace8, ..., trace1, debug, info, notice, warn, # error, crit, alert, emerg. # It is also possible to configure the log level for particular modules, e.g. # "LogLevel info ssl:warn" # LogLevel warn # Include module configuration: IncludeOptional mods-enabled/*.load IncludeOptional mods-enabled/*.conf # Include list of ports to listen on Include ports.conf # Sets the default security model of the Apache2 HTTPD server. It does # not allow access to the root filesystem outside of /usr/share and /var/www. # The former is used by web applications packaged in Debian, # the latter may be used for local directories served by the web server. If # your system is serving content from a sub-directory in /srv you must allow # access here, or in any related virtual host. <Directory /> Options FollowSymLinks AllowOverride None Require all denied </Directory> <Directory /usr/share> AllowOverride None Require all granted </Directory> <Directory /var/www/> Options Indexes FollowSymLinks AllowOverride None Require all granted </Directory> #<Directory /srv/> # Options Indexes FollowSymLinks # AllowOverride None # Require all granted #</Directory> # AccessFileName: The name of the file to look for in each directory # for additional configuration directives. See also the AllowOverride # directive. # AccessFileName .htaccess # # The following lines prevent .htaccess and .htpasswd files from being # viewed by Web clients. # <FilesMatch "^\.ht"> Require all denied </FilesMatch> # # The following directives define some format nicknames for use with # a CustomLog directive. # # These deviate from the Common Log Format definitions in that they use %O # (the actual bytes sent including headers) instead of %b (the size of the # requested file), because the latter makes it impossible to detect partial # requests. # # Note that the use of %{X-Forwarded-For}i instead of %h is not recommended. # Use mod_remoteip instead. # LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined LogFormat "%h %l %u %t \"%r\" %>s %O" common LogFormat "%{Referer}i -> %U" referer LogFormat "%{User-agent}i" agent # Include of directories ignores editors' and dpkg's backup files, # see README.Debian for details. # Include generic snippets of statements IncludeOptional conf-enabled/*.conf # Include the virtual host configurations: IncludeOptional sites-enabled/*.conf # vim: syntax=apache ts=4 sw=4 sts=4 sr noet ssl.conf <IfModule mod_ssl.c> # Pseudo Random Number Generator (PRNG): # Configure one or more sources to seed the PRNG of the SSL library. # The seed data should be of good random quality. # WARNING! On some platforms /dev/random blocks if not enough entropy # is available. This means you then cannot use the /dev/random device # because it would lead to very long connection times (as long as # it requires to make more entropy available). But usually those # platforms additionally provide a /dev/urandom device which doesn't # block. So, if available, use this one instead. Read the mod_ssl User # Manual for more details. # SSLRandomSeed startup builtin SSLRandomSeed startup file:/dev/urandom 512 SSLRandomSeed connect builtin SSLRandomSeed connect file:/dev/urandom 512 ## ## SSL Global Context ## ## All SSL configuration in this context applies both to ## the main server and all SSL-enabled virtual hosts. ## # # Some MIME-types for downloading Certificates and CRLs # AddType application/x-x509-ca-cert .crt AddType application/x-pkcs7-crl .crl # Pass Phrase Dialog: # Configure the pass phrase gathering process. # The filtering dialog program (`builtin' is a internal # terminal dialog) has to provide the pass phrase on stdout. SSLPassPhraseDialog exec:/usr/share/apache2/ask-for-passphrase # Inter-Process Session Cache: # Configure the SSL Session Cache: First the mechanism # to use and second the expiring timeout (in seconds). # (The mechanism dbm has known memory leaks and should not be used). #SSLSessionCache dbm:${APACHE_RUN_DIR}/ssl_scache SSLSessionCache shmcb:${APACHE_RUN_DIR}/ssl_scache(512000) SSLSessionCacheTimeout 300 # Semaphore: # Configure the path to the mutual exclusion semaphore the # SSL engine uses internally for inter-process synchronization. # (Disabled by default, the global Mutex directive consolidates by default # this) #Mutex file:${APACHE_LOCK_DIR}/ssl_mutex ssl-cache # SSL Cipher Suite: # List the ciphers that the client is permitted to negotiate. See the # ciphers(1) man page from the openssl package for list of all available # options. # Enable only secure ciphers: SSLCipherSuite HIGH:!aNULL # SSL server cipher order preference: # Use server priorities for cipher algorithm choice. # Clients may prefer lower grade encryption. You should enable this # option if you want to enforce stronger encryption, and can afford # the CPU cost, and did not override SSLCipherSuite in a way that puts # insecure ciphers first. # Default: Off #SSLHonorCipherOrder on # The protocols to enable. # Available values: all, SSLv3, TLSv1, TLSv1.1, TLSv1.2 # SSL v2 is no longer supported SSLProtocol all -SSLv3 # Allow insecure renegotiation with clients which do not yet support the # secure renegotiation protocol. Default: Off #SSLInsecureRenegotiation on # Whether to forbid non-SNI clients to access name based virtual hosts. # Default: Off #SSLStrictSNIVHostCheck On </IfModule> # vim: syntax=apache ts=4 sw=4 sts=4 sr noet ports.conf # If you just change the port or add more ports here, you will likely also # have to change the VirtualHost statement in # /etc/apache2/sites-enabled/000-default.conf Listen 80 <IfModule ssl_module> Listen 443 </IfModule> <IfModule mod_gnutls.c> Listen 443 </IfModule> # vim: syntax=apache ts=4 sw=4 sts=4 sr noet apache2ctl -S [10:58:28 root /etc/apache2/mods-available]> apache2ctl -S VirtualHost configuration: IP:80 is a NameVirtualHost default server www.froxlordomain.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_IP.80.conf:5) port 80 namevhost www.froxlordomain.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_IP.80.conf:5) port 80 namevhost domain2.de (/etc/apache2/sites-enabled/22_froxlor_normal_vhost_domain2.de.conf:6) alias www.domain2.de port 80 namevhost domain1.de (/etc/apache2/sites-enabled/22_froxlor_normal_vhost_domain1.de.conf:6) alias www.domain1.de IP:443 is a NameVirtualHost default server www.froxlordomain.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_IP.443.conf:5) port 443 namevhost www.froxlordomain.de (/etc/apache2/sites-enabled/10_froxlor_ipandport_IP.443.conf:5) port 443 namevhost domain2.de (/etc/apache2/sites-enabled/22_froxlor_ssl_vhost_domain2.de.conf:6) alias www.domain2.de port 443 namevhost domain1.de (/etc/apache2/sites-enabled/22_froxlor_ssl_vhost_domain1.de.conf:6) alias www.domain1.de port 443 namevhost froxlordomain.de (/etc/apache2/sites-enabled/default-ssl.conf:2) *:80 froxlordomain.de (/etc/apache2/sites-enabled/000-default.conf:1) ServerRoot: "/etc/apache2" Main DocumentRoot: "/var/www/html" Main ErrorLog: "/var/log/apache2/error.log" Mutex ssl-stapling: using_defaults Mutex ssl-cache: using_defaults Mutex default: dir="/var/lock/apache2" mechanism=fcntl Mutex mpm-accept: using_defaults Mutex watchdog-callback: using_defaults Mutex rewrite-map: using_defaults PidFile: "/var/run/apache2/apache2.pid" Define: DUMP_VHOSTS Define: DUMP_RUN_CFG Define: ENABLE_USR_LIB_CGI_BIN User: name="www-data" id=33 Group: name="www-data" id=33 openssl s_client -connect domain1.de:443 -state -debug CONNECTED(00000003) SSL_connect:before/connect initialization write to 0x1e00420 [0x1e00d90] (295 bytes => 295 (0x127)) 0000 - 16 03 01 01 22 01 00 01-1e 03 03 6e 57 de c5 87 ...."......nW... 0010 - 15 a8 72 75 8d 24 f0 d4-3f 4d b3 0f 5c 81 e7 5a ..ru.$..?M..\..Z 0020 - 18 3d 13 66 bf 8e e3 e7-fc 6c fb 00 00 88 c0 30 .=.f.....l.....0 0030 - c0 2c c0 28 c0 24 c0 14-c0 0a 00 a3 00 9f 00 6b .,.(.$.........k 0040 - 00 6a 00 39 00 38 00 88-00 87 c0 32 c0 2e c0 2a .j.9.8.....2...* 0050 - c0 26 c0 0f c0 05 00 9d-00 3d 00 35 00 84 c0 2f .&.......=.5.../ 0060 - c0 2b c0 27 c0 23 c0 13-c0 09 00 a2 00 9e 00 67 .+.'.#.........g 0070 - 00 40 00 33 00 32 00 9a-00 99 00 45 00 44 c0 31 .@.3.2.....E.D.1 0080 - c0 2d c0 29 c0 25 c0 0e-c0 04 00 9c 00 3c 00 2f .-.).%.......<./ 0090 - 00 96 00 41 c0 11 c0 07-c0 0c c0 02 00 05 00 04 ...A............ 00a0 - c0 12 c0 08 00 16 00 13-c0 0d c0 03 00 0a 00 15 ................ 00b0 - 00 12 00 09 00 ff 01 00-00 6d 00 0b 00 04 03 00 .........m...... 00c0 - 01 02 00 0a 00 34 00 32-00 0e 00 0d 00 19 00 0b .....4.2........ 00d0 - 00 0c 00 18 00 09 00 0a-00 16 00 17 00 08 00 06 ................ 00e0 - 00 07 00 14 00 15 00 04-00 05 00 12 00 13 00 01 ................ 00f0 - 00 02 00 03 00 0f 00 10-00 11 00 23 00 00 00 0d ...........#.... 0100 - 00 20 00 1e 06 01 06 02-06 03 05 01 05 02 05 03 . .............. 0110 - 04 01 04 02 04 03 03 01-03 02 03 03 02 01 02 02 ................ 0120 - 02 03 00 0f 00 01 01 ....... SSL_connect:SSLv2/v3 write client hello A read from 0x1e00420 [0x1e062f0] (7 bytes => 7 (0x7)) 0000 - 48 54 54 50 2f 31 2e HTTP/1. SSL_connect:error in SSLv2/v3 read server hello A 139646614730384:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:795: --- no peer certificate available --- No client certificate CA names sent --- SSL handshake has read 7 bytes and written 295 bytes --- New, (NONE), Cipher is (NONE) Secure Renegotiation IS NOT supported Compression: NONE Expansion: NONE --- Gru? x-dast
  18. Hallo, ich habe heute meinen Server neuinstalliert und Froxlor gleich mit installiert. Soweit war ich sehr zufrieden dennd ie Installation hat ohne Probleme funktioniert. Nachdem ich Froxlor vollst?ndig Installiert/Konfuuriert hatte begann ich mit der Konfiguartion von den Diensten wie es empfohlen ist. Nachdem ich mit allem fertig war habe ich zum testen zwei Kunden angelegt auch dies hatte problemlos funktioniert. Ich war begeistert von Froxlor! Als ich dann aber festgestellt habe, dass Froxlor zwar den Kunden im Webinterface angelegt hatte aber kein /var/customer/webXX/ erstellt hatte also kein Verzeichnis f?r den Benutzer und auch kein FTP Account hatte sich die Begeisterung schnell gelegt. Hier die Fehlermeldung von Proftpd: [ERROR] Home directory not available ? aborting Danach habe ich es mit Pureftpd versucht wo es ledeglich hie?, dass der Login incorrect ist. Dass das Verzichnis bei FTP nicht da ist ist ja klar, da es nicht erstellt wurde doch warum ? Bin f?r jede Hilfe dankbar! Hier noch die Fakten: - Debian 7.0 64bit minimal - AMD Prozessor - Software Raid Logs kann ich gerne Posten habe allerdings schon alle durchgeschaut es steht nichts hilfreiches dabei. Sollte noch etwas fehlen bitte Bescheit sagen. Gr??e Cmfrank
×
×
  • Create New...