Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'fpm'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL







Found 8 results

  1. Hello there. After updating to PHP 7.1 with FPM my customer sites work perfectly, however I cannot access the Froxlor backend (as well as phpmyadmin) anymore, I get an error 503. Froxlor is supposed to also run with FPM. I am running on Debian8, Apache 2.4, PHP 7.1, PHP 7.1-FPM The apache error log reads: [Tue Jun 06 21:56:28.394119 2017] [proxy:error] [pid 6572] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.1-fpm.sock (*) failed [Tue Jun 06 21:56:28.394177 2017] [proxy_fcgi:error] [pid 6572] [client x.x.x.x:35356] AH0107
  2. Hallo, vielleicht kann mir jemand hier ja einen kleinen Tipp geben. Es ist mehr eine nginx-Konfiguration. PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden. Mein 'Froxlor-Standardvhost sieht wie folgt aus Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. Anstatt die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da die Abfrage hier als erstes ausgeführt wird. Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. Teilwe
  3. Warning, this is not an official guide!!! 1. sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list sudo nano /etc/apt/source.list 1b. insert (for Debian Stretch) 1.2B (for Ubuntu Cosmic) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server 2. MariaDB install Warning use sudo command für this install! sudo apt in
  4. Hi, after fresh froxlor install on debian9 and php-fpm I have 503 error : Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. In /var/log/apache2/error.log I found: [proxy:error] [pid 997] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.com-php-fpm.socket (*) failed [proxy_fcgi:error] [pid 997] [client] AH01079: failed to make connection to backend: httpd-UDS I have not created an
  5. Greetings, I have Froxlor installed with PHP7.2 and need to install/enable PHP7.2-fpm. I've reviewed the wiki, The Froxlor YouTube video on the subject, and reviewed/completed the instructions within the Panel > Configuration > DB Jessie > Other > FPM and am having difficulties getting the panel to work with FPM. All available instructions are written for PHP5 and when I complete the instructions and substitute PHP7.2, when the panel generates configurations there are syntax errors and the websites go down. Does anyone have any pointers or updated instructio
  6. Hello again, hope you don't mind me coming up with another issue (including proposal for solution obviously). I had another issue using PHP-FPM, where I cannot get my .XML files parsed by the PHP interpreter even though I have this in my .htaccess: <FilesMatch "\.(xml)$"> SetHandler php5-fastcgi Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> It turns out that there is a limit imposed by the security.limit_extensions setting which defaults to .php only. My .XML files are used in order to automatically return the correct autodiscover/autoconfig setti
  7. I have some sites that make use of HTTP authorization headers inside of PHP (so not using htaccess/htpasswd, but an internal user database). For the moment I have simply added the required "-pass-header Authorization" to scripts/jobs/cron_tasks.inc.http.15.apache_fcgid.php @ 63 right after the "-socket" setting. But it would be nice if this was either always on by default or selectable as a switch in the GUI (could either be a global FCGI/FPM setting, but would be nicer if it was on a level with "PHP Configurations", since it's rarely needed). Thanks Günther
  8. Hi, I just set up Froxlor to work with php-fpm. I'm using pretty much the standard configuration. Debian Jessie Froxlor ver PHP 5.6 My pool-config lies in /etc/php5/fpm/pool.d since I'm using Debian Jessie, all other configuration values are set to default. Therefore the configuration alias-directory of php-fpm is set to /var/www/php-fpm/ My Problem is, that froxlor creates/changes the subdirectories (e.g. /var/www/php-fpm/username) on every master cronjob to owner root:root with permissions 750. This way I get this error on access in the users custom error l
  • Create New...