Jump to content
Froxlor Forum

rashantha

Members
  • Posts

    39
  • Joined

  • Last visited

Posts posted by rashantha

  1. I understand running an open source project is not easy. That said, poor documentation is a huge detriment to any project. I have read a lot of the post on the forums and find the answers harsh, to say the least. Hopefully, this is taken as constructive criticism and not an attack.

     Also, there seems to be only 1 person answering the forums which can be taxing.

    I was lucky to be able to move to Cpanel because of the huge support provided by them for the education market. $30 only for the product.

    I was working on some refreshed guides to install froxlor... I might post these. It might help others that want to test and not have to invest wasted hours imho. I did get http and sftp working on debian.

    All the best... Froxlor looks like a great project.

    Maybe focus on debian and remove support for Centos till others can help. not sure. And also to acknowledge mistakes so that it helps others.

    my 2 cents.

  2. I ran the config a second time.

    Here's the error in the logs.

     mod_sql/4.3: unrec              overable backend error: (1045) Access denied for user 'froxlor'@'localhost' (using password: YES)
     

  3. Thanks.

    Others are having similar issues. Just a suggestion since it works for you everytime. A step by step guide would make things so helpful and will help with the growth of the project as well.

    At least we would have a stepping stone for testing and adjusting...

    A pov from the other side.

  4. also tried this.

    root@dev:/var/www/froxlor/scripts# telnet localhost 21
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    220 ProFTPD 1.3.5b Server (dev.school.org FTP Server) [::1]
    USER councilftp1
    331 Password required for councilftp1
    PASS iahgjzpYMr
    Connection closed by foreign host.
     

  5. How do you engage the debuging?

    I have the same errors.

    Wishing there was better documentation on the project.

    Tried FTP, SFTP, tried a new ftp account.

    I have checked the ports. 21,22,25,53,80,110,143 all open

    web, subdomains all work.

     

  6. Still have cron issues I believe.

    I went thru all the setting and did the configuration and ran all the commands. I didn't run mail sever because I don't need a mail server on this yet.

    Trying to get SFTP and Web working.

    Is this normal?

    I did see where you posted how to run cron from terminal but I can not find that post. Can you please help on this?

    image.png.1a9144f691f2abcafd88a44a818c6e21.png

  7. I don't get it. Wasn't Apache 2.4 selected when running the install?

    What other settings need to be changed?

    Why is there no change to cron... is there a command I can run in terminal to manually run the cron jobs.

  8.  Okay so I gave up on Centos7 and tried Debian Stretch. Followed everything from your script... and get this. Am I just having bad luck. I did a minimal install. At the end I edited /etc/apache2/sites-enabled/000-default.conf and changed DocumentRoot

    image.png.db840bf62416da5c1ea53f8eb2273587.png

  9. Has anyone successfully installed froxlor on Centos7

    Having a heck of a time. Tried about 6 ways now.

    I can run install but can not run any configurations. From what I read in the forums others have had similar issues.

    Maybe I am just banging my head on the wrong door.

    Is everyone using Ubuntu?

    Froxlor is looking so promising but I am at a dead end.

  10. 19 hours ago, rashantha said:
     

    So am I getting these errors because I tried to run configuration after creating the user.


    systemctl reload-or-restart httpd.servicechown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
    chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# chown root:0 /etc/apache2/sites-enabled/
    chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
    chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# mkdir -p /var/customers/webs/
    [root@dev lib]# mkdir -p /var/customers/logs/
    [root@dev lib]# mkdir -p /var/customers/tmp
    [root@dev lib]# chmod 1777 /var/customers/tmp
    [root@dev lib]# systemctl reload-or-restart httpd.service
     

     

    1

     

  11. Here's a silly question do I have to run this first...

    image.png.c1fc6d2841c3fc50843211d62810646f.png

    [root@dev lib]# chown root:0 /etc/apache2/sites-enabled/
    chmod 0600 /etc/apache2/sites-enabled/
    mkdir -p /var/customers/webs/
    mkdir -p /var/customers/logs/
    mkdir -p /var/customers/tmp
    chmod 1777 /var/customers/tmp
    systemctl reload-or-restart httpd.servicechown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
    chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# chown root:0 /etc/apache2/sites-enabled/
    chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# chmod 0600 /etc/apache2/sites-enabled/
    chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
    [root@dev lib]# mkdir -p /var/customers/webs/
    [root@dev lib]# mkdir -p /var/customers/logs/
    [root@dev lib]# mkdir -p /var/customers/tmp
    [root@dev lib]# chmod 1777 /var/customers/tmp
    [root@dev lib]# systemctl reload-or-restart httpd.service
     

     

  12. 28 minutes ago, d00p said:
     

    The default standard-subdomain is [username].[froxlor-system-hostname], you can adjust the domain-part in the settings so it becomes [username].[std-subdomain-domain-from-settings]

     

    i tried all 3 council.dev.school.org, dev.school.org, council.school.org

    Forbidden

    You don't have permission to access / on this server.

  13. So here is what I did. hostname dev.school.org

    1. Created 1st User - council

    2. Created domain school.org assigned it to council

    3. Created subdomain council under user council. didn't change any paths

    4. Created ftp account under council - can not login via council@dev.school.org or council@council.school.org (authentication failed)

    5. index.html is in /var/customers/webs/council but if you go to council.school.org you get a 403 forbidden

    ports to dev.school.org open 22, 80

    what is the path to check vhost file? I didn't change any settings. maybe it will give me a clue.

    dev.school.org/froxlor works, i can log in as admin as well as user council

×
×
  • Create New...