Jump to content
Froxlor Forum

MGmeiner

Members
  • Posts

    29
  • Joined

  • Last visited

Posts posted by MGmeiner

  1. Hatte nochmals Zeit um mir die Log anzusehen. Denke es hat doch etwas mit dem eingeloggt Theme zu tun?

    Am 9.4.2018 um 17:27 schrieb d00p:

    unsere standard configerlaubt nur das senden wenn du eingeloggt bist.

    Jul 10 11:14:44 v22018xxxxx postfix/smtpd[29566]: connect from unknown[103.100.0.000]
    Jul 10 11:14:47 v22018xxxxx postfix/smtpd[29566]: warning: unknown[103.100.0.000]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Jul 10 11:14:47 v22018xxxxx postfix/smtpd[29566]: disconnect from unknown[103.100.0.0]
    Jul 10 11:14:52 v22018xxxxx postfix/pickup[29106]: 06B3F60313: uid=10000 from=<my@mail.com>
    Jul 10 11:14:52 v22018xxxxx postfix/cleanup[29578]: 06B3F60313: message-id=<20180710091452.06B3F60313@myserver.de>
    Jul 10 11:14:52 v22018xxxxx postfix/qmgr[1129]: 06B3F60313: from=<my@mail.com>, size=425, nrcpt=1 (queue active)
    Jul 10 11:14:52 v22018xxxxx dovecot: lda(my@mail.com): msgid=<20180710091452.06B3F60313@v22018025830361712.happysrv.de>: saved mail to INBOX
    Jul 10 11:14:52 v22018xxxxx postfix/pipe[29582]: 06B3F60313: to=<my@myil.com>, relay=dovecot, delay=0.1, delays=0.07/0.01/0/0.03, dsn=2.0.0, status=sent (delivered via dovecot service)
    Jul 10 11:14:52 v22018xxxxx postfix/qmgr[1129]: 06B3F60313: removed

    Wie und wo wird das genau definiert? Oder welche Werte sollte ich kontrollieren?

  2. Hallo das könnte ich noch versuchen, wollte nur ausschließen, dass ich etwas bei den Settings falsch gemacht habe :) Habe es auf einem anderen Server genau gleich und hier klappt es.
    Dachte es sei etwas mit den Einstellungen, wenn ich über das Terminal keine Mail senden kann oder von Apticron keine durchkommen. 
    Wo sollte den der Versand von Apticron gelogt werden? Oder wie kann ich am besten einen Mail Versand über das Terminal testen mit am besten wäre dann ein -trail damit ich genau verfolgen kann.

  3.  

    Hallo.

    Ich habe meinen Server soweit wie in den Configs beschrieben eingerichtet.
    Wenn ich jetzt über eine Webseite, ein Kontaktformular versende kommt nichts an.

    Auch über das Terminal erhalte ich keine Mails.

    echo testing | mail -s foobar meine@mailadresse.com

    /var/log/mail.log

    Apr  9 15:18:43 v22018025830361712 postfix/master[25543]: reload -- version 2.11.3, configuration /etc/postfix
    Apr  9 15:19:13 v22018025830361712 postfix/pickup[25982]: 69CD46040A: uid=10000 from=<MAIL@DOMAIN.com>
    Apr  9 15:19:13 v22018025830361712 postfix/cleanup[25990]: 69CD46040A: message-id=<316cdfdd2d34482988c3cad2dea22d33@www.DOMAIN.com>
    Apr  9 15:19:13 v22018025830361712 postfix/qmgr[25983]: 69CD46040A: from=<MAIL@DOMAIN.com>, size=715, nrcpt=1 (queue active)
    Apr  9 15:19:13 v22018025830361712 dovecot: lda(MAIL@DOMAIN.com): msgid=<316cdfdd2d34482988c3cad2dea22d33@www.DOMAIN.com>: saved mail to INBOX
    Apr  9 15:19:13 v22018025830361712 postfix/pipe[25994]: 69CD46040A: to=<MAIL@DOMAIN.com>, relay=dovecot, delay=0.08, delays=0.03/0.01/0/0.05, dsn=2.0.0, status=sent (delivered via dovecot service)
    Apr  9 15:19:13 v22018025830361712 postfix/qmgr[25983]: 69CD46040A: removed

    /var/log/mail.err 

    Ist leer.

    /var/customers/logs/KUNDE-error.log

    Ist leer.

     

  4. Nein, diese wird in der NextCloud unter Einstellungen angezeigt.
    Aber sobald ich es direkt in der /etc/php/7.1/fpm/php.ini eintrage kommt die Fehlermeldung nicht mehr.

    Und wenn ich es über Froxlor eintrage hat es keine Auswirkungen.

    Habe schon apache2 + php-fpm neu gestartet.

    Bildschirmfoto 2018-03-28 um 17.04.43.png

  5. Also in der /etc/php/7.1/fpm/pool.d/DOMAIN.com.conf 

    Steht es so drinnen

    php_admin_flag[opcache.enable] = 1
    php_admin_value[opcache.interned_strings_buffer] = 8
    php_admin_value[opcache.max_accelerated_files] = 10000
    php_admin_value[opcache.memory_consumption] = 128
    php_admin_flag[opcache.save_comments] = 1
    php_admin_value[opcache.revalidate_freq] = 1
    

     

  6. Hallo.

    Wenn ich direkt über Froxlor Admin in meine die PHP-Konfig (php.ini) folgendes definiere

    opcache.enable=1
    opcache.enable_cli=1
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=10000
    opcache.memory_consumption=128
    opcache.save_comments=1
    opcache.revalidate_freq=1

    und fpm neustarte.

    service php7.1-fpm restart

    Bekomme ich in meiner Cloud folgende Fehler.

    Der PHP-OPcache ist nicht richtig konfiguriert. Für eine bessere Leistung empfiehlt es sich folgende Einstellungen in der php.ini vorzunehmen: opcache.enable=1 opcache.enable_cli=1 opcache.interned_strings_buffer=8 opcache.max_accelerated_files=10000 opcache.memory_consumption=128 opcache.save_comments=1 opcache.revalidate_freq=1 Bitte überprüfen Sie noch einmal die Installationsanleitungen ↗ und kontrollieren Sie das Protokoll auf mögliche Fehler oder Warnungen.

    Wenn ich das ganze aber in /etc/php/7.1/fpm/php.ini  eintrage funktioniert es.

    Anbei noch meine ganze php.ini

    allow_call_time_pass_reference = Off
    allow_url_fopen = On
    asp_tags = Off
    disable_classes =
    disable_functions = curl_multi_exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system
    display_errors = Off
    display_startup_errors = Off
    enable_dl = Off
    error_reporting = E_ALL & ~E_NOTICE
    expose_php = Off
    file_uploads = On
    cgi.force_redirect = 1
    gpc_order = "GPC"
    html_errors = Off
    ignore_repeated_errors = Off
    ignore_repeated_source = Off
    include_path = ".:{PEAR_DIR}"
    log_errors = On
    log_errors_max_len = 1024
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    max_execution_time = 3600
    max_input_time = 3600
    memory_limit = 1024M
    {OPEN_BASEDIR_C}open_basedir = {OPEN_BASEDIR}:/dev/urandom
    output_buffering = Off
    post_max_size = 16400M
    precision = 14
    register_argc_argv = Off
    register_globals = Off
    report_memleaks = On
    sendmail_path = "/usr/sbin/sendmail -t -i -f {CUSTOMER_EMAIL}"
    session.auto_start = 0
    session.bug_compat_42 = 0
    session.bug_compat_warn = 1
    session.cache_expire = 180
    session.cache_limiter = nocache
    session.cookie_domain =
    session.cookie_lifetime = 0
    session.cookie_path = /
    session.entropy_file = /dev/urandom
    session.entropy_length = 16
    session.gc_divisor = 1000
    session.gc_maxlifetime = 1440
    session.gc_probability = 1
    session.name = PHPSESSID
    session.referer_check =
    session.save_handler = files
    session.save_path = "{TMP_DIR}"
    session.serialize_handler = php
    session.use_cookies = 1
    session.use_trans_sid = 0
    short_open_tag = On
    suhosin.mail.protect = 1
    suhosin.simulation = Off
    track_errors = Off
    upload_max_filesize = 16G
    upload_tmp_dir = "{TMP_DIR}"
    variables_order = "GPCS"
    ;mail.add_x_header = On
    ;mail.log = "/var/log/phpmail.log"
    
    opcache.restrict_api = "{DOCUMENT_ROOT}"
    
    extension = apc.so
    
    opcache.enable=1
    opcache.enable_cli=1
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=10000
    opcache.memory_consumption=128
    opcache.save_comments=1
    opcache.revalidate_freq=1



    Mache ich das was falsch? :D:)

  7. Hallo ich habe als Admin 3 FPM am laufen.

    1. Froxlor Vhost Config - PHP 5
    2. Default - Config  - PHP 7.1 
    3. PHP 7.2 - Config - PHP 7.2

    Als Kunde kann ich bei der Domain / Subdomain nur auf die Default - Config zugreifen.
    Gibt es eine Möglichkeit, Config's auch dem Kunden zur Verfügung zustellen? 
    Sonst müsste ich die Subdomain als Domain anlegen und die  Config zuweisen.

    Liebe Grüße

    Matthias

  8. Hallo.

    Ich habe eine Domain / Subdomain auf einen anderen Server "übernommen" / umgeleitet.
    Nun habe ich für alle neuen Sudomains über letsencrypt Zertifikate erstellen lassen. Das klappt.
    Nur eine Subdomain hatte bereits ein Zertifikat auf dem anderen Server und ich erhalte beim erstellen folgende Meldung.

    [error] Could not get Let's Encrypt certificate for subdomain.domain.com: Curl error: SSL: no alternative certificate subject name matches target host name ' subdomain.domain.com'
    

    Ich habe beim alten Server das Zertifikat über Foxlor schon gelöscht :/

    Kann ich das erneuern irgendwie erzwingen?

    Liebe Grüße
    Matthias

  9. Ich habe lange gegooglet :D aber immer in zusammenhang mit SSL, weil davor ging alles.
    Ich habe zu keinem anderen Webserver gewechselt Apache läuft seit Anfang an.

    Wenn ich systemctl enable apache2 eingebe erhalte ich

    Synchronizing state for apache2.service with sysvinit using update-rc.d...
    Executing /usr/sbin/update-rc.d apache2 defaults
    Executing /usr/sbin/update-rc.d apache2 enable

    Mit dem gleichen Ergebnis wie Oben.

     

    lg

  10. Hallo.

    Ich habe mir gerade einen neuen Root-Server gegönnt :)
    und habe nun ein Problem, ich habe SSL aktiviert und habe wie bei meinem anderen Server die Einstellungen gewählt.

    Nun kann ich auf keine Seite (Froxlor oder Testseite / Kunde) zugreifen.

     /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug
    [information] cron_tasks: Searching for tasks to do
    [information] apache::createIpPort: creating ip/port settings for  188.XX.XX.XX:80
    [notice] 188.XX.XX.XX:80 :: namevirtualhost-statement no longer needed for apache-2.4
    [debug] 188.XX.XX.XX:80 :: inserted vhostcontainer
    [information] apache::createIpPort: creating ip/port settings for  188.XX.XX.XX:443
    [debug] 188.XX.XX.XX:443 :: inserted listen-statement
    [debug] 188.XX.XX.XX:443 :: inserted vhostcontainer
    [information] apache::createVirtualHosts: creating vhost container for domain 2, customer MGmeiner
    [information] apache::createVirtualHosts: creating vhost container for domain 1, customer MGmeiner
    [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
    [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
    [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
    [information] apache::reload: running service php7.2-fpm restart
    [information] apache::reload: fpm config directory "/etc/php5/fpm/pool.d/" is empty. Creating dummy.
    [information] apache::reload: running /etc/init.d/php5-fpm restart
    [information] apache::reload: reloading apache
    Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
    [notice] Checking system's last guid

    Wenn ich dann 

    journalctl -xn
    Feb 23 09:26:25 SERVERNAME systemd[1]: Stopping The PHP 7.2 FastCGI Process Manager...
    -- Subject: Unit php7.2-fpm.service has begun shutting down
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit php7.2-fpm.service has begun shutting down.
    Feb 23 09:26:25 SERVERNAME systemd[1]: Starting The PHP 7.2 FastCGI Process Manager...
    -- Subject: Unit php7.2-fpm.service has begun with start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit php7.2-fpm.service has begun starting up.
    Feb 23 09:26:25 SERVERNAME systemd[1]: Started The PHP 7.2 FastCGI Process Manager.
    -- Subject: Unit php7.2-fpm.service has finished start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit php7.2-fpm.service has finished starting up.
    -- 
    -- The start-up result is done.
    Feb 23 09:26:25 SERVERNAME systemd[1]: Stopping The PHP FastCGI Process Manager...
    -- Subject: Unit php5-fpm.service has begun shutting down
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit php5-fpm.service has begun shutting down.
    Feb 23 09:26:25 SERVERNAME systemd[1]: Starting The PHP FastCGI Process Manager...
    -- Subject: Unit php5-fpm.service has begun with start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit php5-fpm.service has begun starting up.
    Feb 23 09:26:25 SERVERNAME systemd[1]: Started The PHP FastCGI Process Manager.
    -- Subject: Unit php5-fpm.service has finished start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    -- 
    -- Unit php5-fpm.service has finished starting up.
    -- 
    -- The start-up result is done.
    
    Feb 23 09:26:25 SERVERNAME systemd[1]: Unit apache2.service cannot be reloaded because it is inactive.
    

    Wo finde ich heraus wo es hängt? Oder übersehe ich hier etwas?

    In der Apache Log steht

    /var/log/apache2/error.log 

    [Fri Feb 23 09:12:12.313874 2018] [suexec:notice] [pid 22182] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Feb 23 09:12:12.335296 2018] [:notice] [pid 22186] FastCGI: process manager initialized (pid 22186)
    [Fri Feb 23 09:12:12.368974 2018] [mpm_prefork:notice] [pid 22183] AH00163: Apache/2.4.10 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 OpenSSL/1.0.1t configured -- resuming normal operations
    [Fri Feb 23 09:12:12.369028 2018] [core:notice] [pid 22183] AH00094: Command line: '/usr/sbin/apache2'
    [Fri Feb 23 09:12:38.965355 2018] [mpm_prefork:notice] [pid 22183] AH00171: Graceful restart requested, doing restart
    (98)Address already in use: AH00072: make_sock: could not bind to address 188.XX.XX.XX:443
    [Fri Feb 23 09:12:39.075757 2018] [mpm_prefork:alert] [pid 22183] no listening sockets available, shutting down
    [Fri Feb 23 09:12:39.075767 2018] [:emerg] [pid 22183] AH00019: Unable to open logs, exiting

    lg Matthias

  11. @d00p Ich komme hier leider vorab nicht weiter. Ich habe mit 

    watch -n .1 "ls -al"

    kontrollierte, das im "/.well-known/acme-challenge" Ordern so passiert wenn ich den Cron starte.
    Es wird die Datei erstellt mit root als Besitzer und danach wird sie gelöscht, leider erhalte ich trotzdem ein 404 Fehler.
    Dann habe ich im Script das Löschen auskommentiert, danach bleibt die Datei und ich kann sie auch direkt ansurfen.
    Trotzdem erhalte ich einen 404 Fehler über den Cron-Job. 

    Bietest du deine Dienst auch gegen eine Spende für euere Projekt an?
    Bin leider am Ende meiner Ideen :)

    Liebe Grüße
    Matthias

  12. Ich habe dir Gestern ein PN mit der IP gesendet :)

    Die vhost der Domain

    # 35_froxlor_normal_vhost_cloudservice.DOMAIN.com.conf
    # Created 01.06.2017 14:10
    # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
    
    # Domain ID: 22 - CustomerID: 4 - CustomerLogin: owncloud
    <VirtualHost 188.68.55.XXX:80>
      ServerName cloudservice.DOMAIN.com
      ServerAdmin mail@DOMAIN.com
      DocumentRoot "/var/customers/webs/owncloud/"
      FastCgiExternalServer /var/www/php-fpm/owncloud/cloudservice.DOMAIN.com/fpm.external -socket /var/lib/apache2/fastcgi/owncloud-cloudservice.DOMAIN.com-php-fpm.socket -idle-timeout 30
      <Directory "/var/customers/webs/owncloud/">
        <FilesMatch "\.php$">
          SetHandler php5-fastcgi
          Action php5-fastcgi /fastcgiphp
          Options +ExecCGI
        </FilesMatch>
        Require all granted
        AllowOverride All
      </Directory>
      Alias /fastcgiphp /var/www/php-fpm/owncloud/cloudservice.DOMAIN.com/fpm.external
      ErrorLog "/var/customers/logs/owncloud-error.log"
      CustomLog "/var/customers/logs/owncloud-access.log" combined
    </VirtualHost>

    Die  SSL vhost der Domain

    # 35_froxlor_ssl_vhost_cloudservice.DOMAIN.com.conf
    # Created 01.06.2017 14:10
    # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.
    
    # Domain ID: 22 (SSL) - CustomerID: 4 - CustomerLogin: owncloud
    # no ssl-certificate was specified for this domain, therefore no explicit vhost is being generated

    Und hier nochmals /etc/host (nur die letzen 3 Zeichen ersetzt)

     

    
    127.0.0.1       localhost
    127.0.1.1       kvmimageinstall.yourvserver.net kvmimageinstall
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    188.68.55.XXX   SERVERNAME.happysrv.de  SERVERNAME

     

  13. Hallo.

    Die Domain habe ich via AAA und A weitergeleitet. Ansurfen kann ich die Seite ja auch, komme dann auch auf die richtigen Daten die im FTP Verzeichnis liegen.

    /etc/host steht
     

    
    127.0.0.1       localhost
    127.0.1.1       kvmimageinstall.yourvserver.net kvmimageinstall
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    1XX.XX.XX.XXX   XXXXX.happysrv.de  XXXXX
    
    

    Ich schick dir mal die IP und die Domain in einer PN.
    Lg Matthias

×
×
  • Create New...