Jump to content
Froxlor Forum

wwl

Members
  • Content Count

    95
  • Joined

  • Last visited

Posts posted by wwl

  1. Wenn ich wüste was ich fragen müsste 😉
    In panel_customers sind alle documentroot felder richtig eingetragen /home/httpd/customerX/

    In panel_domains sind auch alle documentroot eingertragen /home/httpd/customerX/domain.de/

    Liegt die Fehlermeldung an irgenwelchen Sonderzeichen? In der alten Version haben die Pfade ja auch gestimmt.
    Alle 130 Domains können doch jetzt nicht falsch sein. An den Verzeichnisrechten hab ich ja auch nichts geändert. Alle haben die richtigen Nutzerrechte
    Die 0.95er Version hat nach /etc/apache/sites-enabled schreiben können, die 0.10 gibt Fehler aus.

    Kann es sein das ich irgendein Limit überschritten habe?

     

  2. Jetzt hab ich in der aktuellen Version mal den Cron per shell aufgerufen. Es läuft alles saber durch nur am schluss kommen diese Meldungen:

    [information] apache::createVirtualHosts: creating vhost container for domain 460, customer desumed
    [information] apache::createVirtualHosts: creating vhost container for domain 40, customer desumed
    [information] apache::createVirtualHosts: creating vhost container for domain 77, customer leicht
    [information] apache::createVirtualHosts: creating vhost container for domain 485, customer beyond
    [information] apache::createVirtualHosts: creating vhost container for domain 427, customer beyond
    chown: der Eigentümer von „/var/www/php-fcgi-scripts/beyond/www.beyond-history.com/php-fcgi-starter“ wird geändert: Die                                    Operation ist nicht erlaubt
    [information] apache::createVirtualHosts: creating vhost container for domain 428, customer beyond
    [information] apache::createVirtualHosts: creating vhost container for domain 417, customer leicht
    [information] apache::createVirtualHosts: creating vhost container for domain 41, customer beubl
    [information] apache::createVirtualHosts: creating vhost container for domain 266, customer stimmelmayer
    [information] apache::createVirtualHosts: creating vhost container for domain 44, customer heindl
    chown: der Eigentümer von „/var/www/php-fcgi-scripts/heindl/bianca-heindl.de/php-fcgi-starter“ wird geändert: Die Operat                                   ion ist nicht erlaubt
    [information] apache::createVirtualHosts: creating vhost container for domain 158, customer chrisleblanc
    chmod: Beim Setzen der Zugriffsrechte für „/var/www/php-fcgi-scripts/chrisleblanc/christophweis.com/php-fcgi-starter“: D                                   ie Operation ist nicht erlaubt
    chown: der Eigentümer von „/var/www/php-fcgi-scripts/chrisleblanc/christophweis.com/php-fcgi-starter“ wird geändert: Die                                    Operation ist nicht erlaubt
    [information] apache::createVirtualHosts: creating vhost container for domain 159, customer chrisleblanc
    [information] apache::createVirtualHosts: creating vhost container for domain 161, customer chrisleblanc
    [information] apache::createVirtualHosts: creating vhost container for domain 212, customer karmaloft
    chown: der Eigentümer von „/var/www/php-fcgi-scripts/karmaloft/florianluettich.de/php-fcgi-starter“ wird geändert: Die O                                   peration ist nicht erlaubt
    [information] apache::createVirtualHosts: creating vhost container for domain 214, customer karmaloft
    PHP Fatal error:  Uncaught Exception: Cannot validate directory in makeCorrectDir which is very dangerous. in /var/www/f                                   roxlor/lib/Froxlor/FileDir.php:289
    Stack trace:
    #0 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(660): Froxlor\FileDir::makeCorrectDir()
    #1 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1073): Froxlor\Cron\Http\Apache->getWebroot()
    #2 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1122): Froxlor\Cron\Http\Apache->getVhostContent()
    #3 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(152): Froxlor\Cron\Http\Apache->createVirtualHosts()
    #4 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(52): Froxlor\Cron\System\TasksCron::rebuildWebserverConfigs()
    #5 /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php(111): Froxlor\Cron\System\TasksCron::run()
    #6 /var/www/froxlor/scripts/froxlor_master_cronjob.php(26): Froxlor\Cron\MasterCron::run()
    #7 {main}
      thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 289

     

  3. Aktuelles Upgrade:

     

    Updating from 0.9.39.5 to 0.9.40
    Updating from 0.9.40 to 0.9.40.1
    Updating from 0.9.40.1 to 0.10.0-rc1
    Adding new api keys table[OK]
    Adding new api settings[OK]
    Adding new default-ssl-ip setting[OK]
    Altering admin ip's field to allow multiple ip addresses[OK]
    Adding dhparams-file setting[OK]
    Adding new settings for 2FA[OK]
    Adding new fields to admin-table for 2FA[OK]
    Adding new fields to customer-table for 2FA[OK]
    Adding new logview-flag to customers[OK]
    Adding new is_configured-flag[OK]
    Adding fields writeaccesslog and writeerrorlog for domains[OK]
    Updating cronjob table[OK]
    Removing ticketsystem[OK]
    Updating nameserver settings[OK]
    Adding new webserver error-log-level setting[OK]
    Adding new ECC / ECDSA setting for Let's Encrypt[OK]
    Removing current Let's Encrypt certificates due to new implementation of acme.sh[OK]
    Inserting job to regenerate configfiles[OK]
    Adding new froxlor vhost domain alias setting[OK]
    Converting all MyISAM tables to InnoDB[OK]
    Updating from 0.10.0-rc1 to 0.10.0-rc2
    Adding new settings for CAA[OK]
    Cleaning up old files[OK]
    Updating from 0.10.0-rc2 to 0.10.0 final
    Adding TLSv1.3-cipherlist setting[OK]
    Adding field api_allowed to admins and customers[OK]
    Updating from 0.10.0 to 0.10.1 final
    Adjusting Let's Encrypt API setting[OK]
    Adding new settings for ssl-vhost default content[OK]
    Adding new fields to ips and ports-table[OK]
    Adding new fields to domains-table[OK]
    Adjusting IP/port settings for downward compatibility[OK]
    Adjusting domain settings for downward compatibility[OK]
    Updating from 0.10.1 to 0.10.2
    Adding new TLS options to domains-table[OK]
    Updating from 0.10.2 to 0.10.3
    Updating from 0.10.3 to 0.10.4
    Updating from 0.10.4 to 0.10.5
    Optimizing customer and admin table for size[OK]
    Updating from 0.10.5 to 0.10.6
    Adding new settings for domain edit form default values[OK]
    Updating from 0.10.6 to 0.10.7
    Updating from 0.10.7 to 0.10.8
    Updating from 0.10.8 to 0.10.9
    Adding enhanced SSL control over domains[OK]
    Updating from 0.10.9 to 0.10.10
    Adding option to disable SSL sessiontickets for older systems[OK]
    Adding custom phpfpm pool configuration field[OK]
    Updating from 0.10.10 to 0.10.11
    Migrate logfiles_format setting[OK]
    Adding option change awstats LogFormat[OK]
    Updating from 0.10.11 to 0.10.12
    Updating from 0.10.12 to 0.10.13
    Adding new field to domains table[OK]
    Updating domain entries[OK]
    Updating from 0.10.13 to 0.10.14
    Updating from 0.10.14 to 0.10.15
    Adding new setting to validate DNS when using Let's Encrypt[OK]
    Updating from 0.10.15 to 0.10.16
    Adding unique key on domainid field in domain ssl table[OK]
    Updating from 0.10.16 to 0.10.17
    Updating from 0.10.17 to 0.10.18
    Updating from 0.10.18 to 0.10.19
    Checking database integrity[Monkeys ate the integrity]
    Trying to remove monkeys, feeding bananas[Integrity restored]

  4. DAs Hauptproblem scheint aber folgendes zu sein:

     

    PHP Fatal error:  Uncaught Exception: Cannot validate directory in makeCorrectDir which is very dangerous. in /var/www/froxlor/lib/Froxlor/FileDir.php:289
    Stack trace:
    #0 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(660): Froxlor\FileDir::makeCorrectDir()
    #1 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1073): Froxlor\Cron\Http\Apache->getWebroot()
    #2 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1122): Froxlor\Cron\Http\Apache->getVhostContent()
    #3 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(152): Froxlor\Cron\Http\Apache->createVirtualHosts()
    #4 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(52): Froxlor\Cron\System\TasksCron::rebuildWebserverConfigs()
    #5 /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php(111): Froxlor\Cron\System\TasksCron::run()
    #6 /var/www/froxlor/scripts/froxlor_master_cronjob.php(26): Froxlor\Cron\MasterCron::run()
    #7 {main}
      thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 289

    Deswegen werden keine Dateien angelegt. Der Cron wird angestoßen, aber nicht abgeschlossen.

     

  5. Hmm, war komisch habe die alte Version komplett aus dem Verzeichnis gelöscht und die neue reinkopiert. Dann die userdata.inc.php kopiert und das Backend aufgerufen. Da wurde eine  Update durchgeführt und danach lief alles mit der neuen Version. Unten Rechts in Froxlor Details wurde auch die Neue Version angezeigt. Soweit alles gut. Nur die Cron Scripte wurden nicht abgearbeitet. Dann hab ich cron über die shell gestartet und bekam die Meldung: Version of file doesn't match version of database. Exiting...

    Jetzt hab ich nochmal alles runtergelöscht und nochmal in das Verzeichnis alle Neuen Daten kopiert und die userdata.inc.php platziert. Im Backend alles ok, ohne Updateroutine. - Jetzt geht auch die cron aufrufen über die shell. Die Dateien werden aber nicht erzeugt.

    In Froxlor unter Froxlor Detail wird mir immer angezeigt das Cron Aufgaben ausstehen:

    • Neuerstellung der Webserver-Konfiguration
    • Neuerstellung der Bind-Konfiguration
    • Lösche SSL Dateien von Domain BlaBla******.de

    Aber die Aufgaben wurden bereits abgearbeitet. Z.B. steht für Let´s Encrypt 30 Minuten in der Cron, aber es wird alle 5 Minuten ausgeführt. Auch Konfigurationsdateien werden laut Froxlor Details erstellt, liegen aber nicht im Verzeichnis.

    Irgendwas stimmt mit den cron Jobs nicht. Die Konfigurationsdateien für Apache wurden immer unter /etc/apache2/sites-enabled abgelegt. Hat sich das nach dem Update geändert. Steht zumindest immer noch so unter den Froxlor Einstellungen drin. Jetzt tauchen sie nicht mehr auf.

    Was ist das schiefgelaufen?

     

    Hab noch was gefunden:


    PHP Fatal error:  Uncaught Exception: Cannot validate directory in makeCorrectDir which is very dangerous. in /var/www/froxlor/lib/Froxlor/FileDir.php:289
    Stack trace:
    #0 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(660): Froxlor\FileDir::makeCorrectDir()
    #1 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1073): Froxlor\Cron\Http\Apache->getWebroot()
    #2 /var/www/froxlor/lib/Froxlor/Cron/Http/Apache.php(1122): Froxlor\Cron\Http\Apache->getVhostContent()
    #3 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(152): Froxlor\Cron\Http\Apache->createVirtualHosts()
    #4 /var/www/froxlor/lib/Froxlor/Cron/System/TasksCron.php(52): Froxlor\Cron\System\TasksCron::rebuildWebserverConfigs()
    #5 /var/www/froxlor/lib/Froxlor/Cron/MasterCron.php(111): Froxlor\Cron\System\TasksCron::run()
    #6 /var/www/froxlor/scripts/froxlor_master_cronjob.php(26): Froxlor\Cron\MasterCron::run()
    #7 {main}
      thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 289

     

  6. Hallo ich hab von einer 0.95 Version auf die aktuelle 0.10.19   DB 20200515 upgedatet.

    Jetzt funktioniert der cron nicht mehr. Wenn ich ihn per Hand aufrufe kommt diese Meldung:

    root@mail:/var/www/froxlor/scripts# php -q froxlor_master_cronjob.php
    Version of file doesn't match version of database. Exiting...

    Possible reason: Froxlor update
    Information: Current version in database: 0.10.19 (DB: 202005150) - version of Froxlor files: 0.9.39.5 (DB: 201809280)
    Solution: Please visit your Foxlor admin interface for further information.

    Was ist das schiefgelaufen? Anscheinend wurde die Datenbank nicht upgegradet. Das wurde mir aber nicht angezeigt. Ich habe was von DNS und Let´s Encrypt update gelesen und durchgeführt. Das Backend zeigt mir aber keinen weiteren Fehler an.
    Besten Dank für einen Tipp

    OS: Debian 8

     

     

  7. Hallo, ich hab heute noch eine 2. Frage:

    Ich hab vor einiger Zeit http/2 auf meinem Apachen eingerichtet. Jetzt habe die Beobachtung gemacht das seit dem aktivieren der http/2 Version auf meinem Apache nur sehr wehnige Anfrage auch in http2 abgearbeitet werden. Wenn ich am Firefox nachschaue (Addon http2 indicator) wird für eine webseite auf meinem Server http2 erkannt. Aber im Log steht das er trotzdem http/1.1 verwendet. Muss ich den Webseiten (TYPO3,WP,Joomla) noch sagen das sie auch über http/2 abgerufen werden können?

    Im apache2.conf File

    Protocols h2 h2c http/1.1
    H2Push          on
    H2PushPriority  *                       after
    H2PushPriority  text/css                before
    H2PushPriority  image/jpeg              after   32
    H2PushPriority  image/png               after   32
    H2PushPriority  application/javascript  interleaved


    Besten Dank für Tipps
    Christian

  8. Aber ich hab keine Afragen verlohren, oder?

    Den MX Server betrifft es nicht, oder?

    OK dann hab ich das Wochenende noch Arbeit. Ist eh Sau kalt

     

    PS: Das letzte Update mit der PHP auswahl für Kunden ist Klasse :-)

  9. Hallo zusammen, hab Ihr bei euren Servern IPv6 aktiv? Ich hab damit keine Erfahrung und stelle jetzt nach installation von Netdata auf meiner Mühle fest das viele IPv6 Zugriffe erkennbar sind. Jetzt habe ich das aber nicht eingerichtet und Frage mich ob ich Anfragen gar nicht annehme. Kann Froxlor damit umgehen? Oder muss ich gar nicht damit Umgehen?

    Besten Dank für Tipps

    Christian

  10. Ja nur Verbindungen von Froxlor:

     

    mysql> show processlist;
    +--------+-----------------+-------------------------------------+---------------+---------+------+-----------------------------+------------------+
    | Id     | User            | Host                                | db            | Command | Time | State                       | Info             |
    +--------+-----------------+-------------------------------------+---------------+---------+------+-----------------------------+------------------+
    |      1 | event_scheduler | localhost                           | NULL          | Daemon  |  542 | Waiting for next activation | NULL             |
    |    103 | wwl             | localhost:55668                     | froxlor       | Sleep   |   75 |                             | NULL             |
    | 166150 | wwl             | wwl8.leicht.info:33942              | assp          | Sleep   |   84 |                             | NULL             |
    | 166158 | wwl             | wwl8.leicht.info:33944              | assp          | Sleep   |   18 |                             | NULL             |
    | 166168 | wwl             | wwl8.leicht.info:33946              | assp          | Sleep   |   47 |                             | NULL             |
    | 166178 | wwl             | wwl8.leicht.info:33948              | assp          | Sleep   |  152 |                             | NULL             |
    | 166190 | wwl             | wwl8.leicht.info:33950              | assp          | Sleep   |   87 |                             | NULL             |
    | 166200 | wwl             | wwl8.leicht.info:33952              | assp          | Sleep   |   95 |                             | NULL             |
    | 166212 | wwl             | wwl8.leicht.info:33954              | assp          | Sleep   |   28 |                             | NULL             |
    | 166229 | wwl             | wwl8.leicht.info:33970              | assp          | Sleep   |    1 |                             | NULL             |
    | 274593 | wwl             | wwl8.leicht.info:48346              | assp          | Sleep   |   18 |                             | NULL             |
    | 274624 | wwl             | wwl8.leicht.info:48376              | assp          | Sleep   |   47 |                             | NULL             |
    | 275513 | wwl             | localhost                           | transfer      | Sleep   | 7195 |                             | NULL             |
    | 275933 | wwl             | localhost                           | ipobserver    | Sleep   |  750 |                             | NULL             |
    | 276124 | wwl             | localhost                           | cacti         | Sleep   |   76 |                             | NULL             |
    | 277855 | wwl             | localhost:37588                     | froxlor       | Sleep   |   23 |                             | NULL             |
    | 278933 | wwl             | localhost                           | transfer      | Sleep   |  443 |                             | NULL             |
    | 278939 | wwl             | localhost                           | transfer      | Sleep   |  437 |                             | NULL             |
    | 292037 | wwl             | p57B6E9E8.dip0.t-ipconnect.de:54944 | wwlmailer     | Sleep   |   94 |                             | NULL             |
    | 292361 | wwl             | localhost:41518                     | froxlor       | Sleep   |   35 |                             | NULL             |
    | 292467 | wwl             | localhost:41698                     | froxlor       | Sleep   |   37 |                             | NULL             |
    | 292606 | wwl             | localhost:41862                     | froxlor       | Sleep   |   35 |                             | NULL             |
    | 292607 | wwl             | localhost:41864                     | froxlor       | Sleep   |   35 |                             | NULL             |
    | 292693 | wwl             | localhost:42048                     | froxlor       | Sleep   |   32 |                             | NULL             |
    | 292694 | wwl             | localhost:42050                     | froxlor       | Sleep   |   32 |                             | NULL             |
    | 292696 | wwl             | localhost:42058                     | froxlor       | Sleep   |   47 |                             | NULL             |
    | 292701 | wwl             | localhost:42068                     | froxlor       | Sleep   |   49 |                             | NULL             |
    | 292706 | wwl             | localhost:42080                     | froxlor       | Sleep   |   32 |                             | NULL             |
    | 292709 | wwl             | localhost                           | NULL          | Query   |    0 | starting                    | show processlist |
    | 292785 | wwl             | localhost:42270                     | froxlor       | Sleep   |   37 |                             | NULL             |
    | 292790 | wwl             | localhost                           | rss-tiny-tiny | Sleep   |   30 |                             | NULL             |
    +--------+-----------------+-------------------------------------+---------------+---------+------+-----------------------------+------------------+
    31 rows in set (0,00 sec)

     

  11. Hallo, ich stelle fest das Froxlor ständig um die 10 Datenbankverbindungen aufrecht erhält. Normalerweise sollte doch nur eine Verbindung in Verwendung sein, der vom Cron gebraucht wird. Ok, wenn gerade viel konfiguriert wird, kann es auch mal mehr sein. Aber ständig 10 Connections ist sehr viel weil auch InnoDB Datenbanken viel Speicher brauchen.

    Gibts da eine Lösung?

    Christian

  12. Hallo, ich habe mir die ganze Sache noch mal angeschaut und komme nicht drauf was da nicht passt.

     

    Ich habe jetzt Froxlor noch mal als Source installiert und nicht aus den .deb Paket. Soweit läuft das ganze jetzt und ich hatte Zeitweise auch schon mal im Dashboard die FCGID Meldung. Aber nur kurzzeitig bis das nächste cron durchläuft und die Config Dateien wieder neu schreibt.

     

    Kurz noch mal meine Aufgabenstellung:

    Ich brauche 2 PHP Versionen die ich bestimmten Domain zuweisen kann (PHP 5.6 und 7). Das ganze läuft auf einem Debian 8.5 mit Apache2.4, MySQL 5.7 und Postfix mit Dovecot (managedsieve)

     

    Also ich liege doch richtig wenn ich sage:

     

    Ich brauche dazu Froxlor das auf apache mit fcgid läuft.

    fcgid bedeutet das ich nur php_cgi installiere und nicht libapache2-mod-php?

    Dann kann ich "Verwende FCGID im Froxlor-Vhost" aktivieren damit Froxlor auch über php_cgi abgearbeitet wird. Aber wenn ich das tue wird PHP nicht verarbeitet und ich sehe den html Quellcode beim aufrufen von Froxlor. Also funktioniert das mit FCGID nicht.

     

    Sollte ich das ganze mit php-fpm machen? Kann ich damit auch PHP Versionen den Domains zuweisen?

     

    Was mache ich da noch falsch?

    Besten Dank für Hilfe und Tipps

     

    Christian

     

×
×
  • Create New...