Jump to content
Froxlor Forum

All Activity

This stream auto-updates     

  1. Today
  2. Ein neuer Server den ich installiert habe. Nein eben nicht keinerlei Anpassungen in der VHost oder in der .htaccess. Alles unberührt, das habe ich schon geprüft, daher verstehe ich das ja nicht und hab hier die frage gestellt ob jemand eine Idee hat wo man noch schauen könnte.
  3. Der neuesten Version von was? Froxlor macht da nichts anders. Hast du vllt irgendwas in der Richtung in die eigenen vhost settings eingetragen oder sowas?
  4. Ja, denn das hatte ich auch noch nie, nur bei der neusten Installation ist der Header gesetzt und ich weiß nicht wie das sein kann.
  5. This should also not be necessary. As i do not know your set up or what settings you've set and not, it's hard to reproduce, especially when you've messed with ownerships manually. I just say, normally, this works smoothly out of the box
  6. Froxlor setzt das nicht für Kunden-Domains. Nur für sich selbst.
  7. I set up libnss-mysql so that It seemed to work. The directory was owned by the user that I created and he was in the ftp-users table. I didn't chown the folder I chgrp'd the folder and the php-fpm socket. My nginx is running as www-data:www-data. I guess that there is something that I am missing. It looks like from the sites-enabled/* files that php-fpm is just for the php files. How does nginx see the static files or the php-fpm socket if they aren't in the www-data group?
  8. Yesterday
  9. Sorry das habe ich wirklich missverständlich kommuniziert. Ich möchte das für andere Domains deaktivieren, finde aber nirgends etwas warum es überhaupt aktiv ist.
  10. Hi, ja - der Haken ist nicht gesetzt und dennoch wird versucht die Mail intern zuzustellen. LG Flo
  11. You are using php-fpm, so did you set up libnss-mysql or libnss-extrausers accordingly? It should NEVER be necessary to chown a customers directory to www-data!
  12. d00p

    FCGID Timeout

    Generell, ja Ja, in den "eigene vhost Einstellungen" pro Domain kannst du natürlich die Option einfach angeben, z.B. FcgidIOTimeout 1200 Der Cronjob schreibt dir das dann in den entsprechenden Vhost
  13. Heißt aber, dass die Option in froxlor nicht konfigurierbar ist, sondern ich in die fcgid.conf anpassen muss? Oder kann ich die Option irgendwie auch für bestimmte vhosts erstellt werden?
  14. d00p

    FCGID Timeout

    Bei read data timeout sollte FcgidIOTimeout die entsprechende konfiguration sein ja
  15. Hallo, ich habe ein Problem mit FCGID Timeout. Ich nutze froxlor in der neusten Version (0.9.40.1-1). Außerdem haben wir einen Apache2 mit FCGID im Einsatz. Nun habe ich ein Script, das länger als 10 Minuten benötigt. Ich bekomme jedoch in meiner Log-Datei von vhost immer folgenden Fehler: [Wed Jun 19 10:17:34.467769 2019] [fcgid:warn] [pid 22291] [client 87.167.97.19:54254] mod_fcgid: read data timeout in 600 seconds, referer: https://example.de/ [Wed Jun 19 10:17:34.467852 2019] [core:error] [pid 22291] [client 87.167.97.19:54254] End of script output before headers: sync_zast.php, referer: https://example.de/ In den Einstellungen für den Apache gibt es nichts bezüglich des Timeouts. In den Einstellungen des vhosts habe ich die max_execution_time erhöht. Hat jedoch keine Auswirkungen. In den Einstellungen des FCGID habe ich dann die Einstellung "Idle-Timeout - Timeout-Einstellung für mod_FastCGI." gefunden. Dies stand jedoch auf 60 Sekunden, damit war die Verwirrung perfekt. In der Datei /etc/apache2/mods-available/fcgid.conf finde ich jedoch die Zeile "FcgidIOTimeout 600". Ist das nochmal ein anderer Timeout? kommen sich hier verschiedene Timeouts in die Quere? Ich komme nicht mit und bin mir nicht sicher, ob ich irgendetwas nicht richtig verstehe, oder die Einstellung von froxlor nicht richtig übernommen wird. Danke für die Hilfe!
  16. Last week
  17. When I create a user the default subdomain 29_froxlor_normal_vhost_breakthroug.rhlab.io.conf for instance is created like this: server { listen 172.31.24.34:80; server_name breakthroug.rhlab.io *.breakthroug.rhlab.io; I would like it to listen on port 443. I have a wildcard certificate and http://* is set to redirect to https:// on my domain. Is there a setting for this somewhere that I am missing??? ... a little later ... Now I have it creating a 29_froxlor_ssl_vhost_breakthroug.rhlab.io.conf file. It was missing the ssl_certificate_key so I put it in. When I try to surf to the site I get an error: 2019/06/18 01:01:46 [error] 28498#28498: *15 "/var/customers/webs/breakthroug/index.php" is forbidden (13: Permission denied), client: 108.162.242.14, server: breakthroug.rhlab.io, request: "GET / HTTP/1.1", host: "breakthroug.rhlab.io". There is no index.php, only an index.html. When I try to get /index.html I get: 2019/06/18 01:38:06 [crit] 28496#28496: *38 stat() "/var/customers/webs/breakthroug/index.html" failed (13: Permission denied), client: 108.162.242.14, server: breakthroug.rhlab.io, request: "GET /index.html HTTP/1.1", host: "breakthroug.rhlab.io" I feel like maybe I am close. ... a little bit more later .... I did `chgrp -R www-data /var/customers/webs/breakthroug` and now I see the index.html file. Then with a `chgrp www-data /var/run/1-breakthroug-breakthroug.rhlab.io-php-fpm.socket` I could also see a phpinfo.php file that I created in the same folder as the index.html. My question remains. Are there config options in froxlor that would let me create a file in the sites-enabled folder with the ssl_certificate_key, a socket and root folder with the www-data group?
  18. Hallo, danke für die Anleitung. Da Debian 10 zeitnah veröffentlicht wird und ich gerade einen neuen Server konfiguriere ... Gibt es bei Froxlor unter Debian 10 bereits bekannte/unbekannte Probleme ? Oder etwas zu beachten. Laut Release habe ich dort keine negativen Überschneidungen "gelesen". Anleitung müsste so zu übernehmen sein. Kann man deb http://debian.froxlor.org buster main bereits eintragen ? Finde gerade nur die "Install"-Anleitung. Wie übernehme ich am besten eine entfernte Froxlor-Installation. Reichen die SQL-Backups für die Konfigübernahme ? Danke Gruß
  19. Hallo, kurze Frage: hast du bei diesen beiden Domains in den Einstellungen unter "Mailserver-Einstellungen" den Haken bei "E-Mail-Domain" entfernt? Solange der Haken gesetzt ist versucht das System (meines Wissens) eine E-Mail-Adresse auf dem lokalen System zu finden. Gruss Cardman
  20. Hi zusammen, ich verwalte mit froxlor einige Domains auf meinem root-Server. 2 dieser Domains haben jedoch keine eigenen Postfächer, sondern werden über über entsprechende MX-Records direkt bei Google verwendet - funktioniert auch alles super. Leider bekomme ich mein postfix / dovecot / froxlor nicht so konfiguriert, dass auch von E-Mail Adressen vom selben Server eine Mail an die entsprechenden G-Suite Mails geschickt werden können. Ich bekomme dann immer den Fehler "5.1.1 <xyz> Recipient address rejected: User unknown in virtual mailbox table". Ich reime es mir so zusammen, dass er merkt, dass es eine "lokale" Domain ist und dann versucht, die Mail direkt intern zuzustellen, also am MX-Record vorbei. Dort findet er dann natürlich keine passende Mailbox. Habt ihr eine andere Idee woran es liegen könnte oder wie kann ich Froxlor / postfix sagen, dass er bestimmte Domains immer über "extern" verschicken soll?! Vielen Dank im Voraus für jegliche Hilfe! Beste Grüße, Flo
  21. Wenn ich im Froxlor einen Kunden anlege und dann Domains, legt er die im Froxlor an und alles geht. Sobald ich aber den Apache neu starte bringt er mir httpd: bad user name ..... mit ID USERNAME finde ich den dann auch nicht auf der Konsole. Wenn ich nun mit adduser USERNAME den User per Hand anlege, erscheint der User und auch die Gruppe, und ich kann den Apache wieder starten. Auf einem anderen Server unter Debian habe ich diesbezüglich keine Probleme der legt die mit der UID auch im System an und nicht nur im Froxlor Mysql Danke im Voraus
  22. OR: you can use an of statement if possible, see http://httpd.apache.org/docs/2.4/mod/core.html#if
  23. Hm, not domain specific, you can add different custom configs for each domain in the corresponding IP/port settings. But then it's for all domains
  24. Hi, I was wondering if it possible to specify different custom configurations for HTTP and HTTPS traffic. I have a couple of sites that would need to keep HTTP traffic active. Basically what I would like to do is the following: for HTTP: ProxyPreserveHost On ProxyRequests off ### HTTP Proxy AllowCONNECT 443 563 ProxyPass / http://localhost:16080/ ProxyPassReverse / http://localhost:16080/ for HTTPS: ###SSL Proxy ProxyPreserveHost On ProxyRequests off SSLProxyEngine on SSLProxyVerify none SSLProxyCheckPeerCN off SSLProxyCheckPeerName off SSLProxyCheckPeerExpire off ProxyPass / https://localhost:16443/ ProxyPassReverse / https://localhost:16433/ is this possible?
  25. Danke - Zertifikate sind da und funktionieren wieder
  1. Load more activity




×
×
  • Create New...