May 15, 201115 yr Hallo, Ich benutze f?r den Backup den FTP Server. Ich m?chte die Backups auf einen anderen Server unterbringen damit diese dort sicher sind falls etwas mit dem Server Passieren k?nnte. Leider bekomme ich aber diesen Fehler: PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 PHP Warning: ftp_put(): Requested action not taken: internal server error in /opt/srv/froxlor/scripts/jobs/cron_backup.php on line 126 Der Externe FTP-Server ist ein vServer mit einer 25 Gigabyte Festplatte. FTP-Clienten wie u.a FileZilla funktionieren einwandfrei und ich kann auf dem FTP Server Dateien Hochladen, L?schen etc. Wei? einer was das ausl?sen k?nnte?
May 17, 201115 yr Wie in der Fehlermeldung bereits gesagt, steht in Zeile 126 der FTP-Put-Befehl: 126 $ftp_upload = ftp_put($ftp_con, $ftp_file, $row['documentroot'] . $settings['system']['backup_dir'] . "/" . $ftp_file, FTP_BINARY); Davor wird einmal der Passive Mode eingeschaltet und die ?bertragung wird per Binary vorgenommen. Das sind die einzigen beiden Fehlerquellen, die mir im Moment einfallen. Evtl. magst du testweise mal in Zeile 125 den Passive Mode abschalten, um zu schauen, ob es am Passive Mode liegt? 125 ftp_pasv($ftp_con, false);
May 17, 201115 yr Author Danke, daran lag es. Vielleicht k?nnte man beim N?chsten Update ein CheckPoint machen wo dies Abgefragt wird. Also ob man Passive oder Aktives FTP Benutzt.
May 17, 201115 yr Die Ursache f?r den Fehler liegt mit einer ziemlichen Sicherheit in einer Fehlkonfiguration des vServers, aber das l?st ja das Problem nicht. Insofern ist der Gedanke einer solchen Checkbox gar nicht so verkehrt. Ich mache mal ein Ticket auf. Edit: http://redmine.froxlor.org/issues/785
Archived
This topic is now archived and is closed to further replies.